Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: partities verdwijnen steeds...  (gelezen 2104 keer)

pieterjan

  • Gast
partities verdwijnen steeds...
« Gepost op: 2008/03/16, 10:21:52 »
Hallo,
ik heb Ubuntu naast Windows XP geïnstalleerd met nog een FAT32 partitie waar mijn gezamenlijke documenten (foto's, muziek...) op staan. Nu moet ik telkens bij het opstarten van Ubuntu naar Locaties>Computer gaan, die partitie aanklikken, en dan  pas verschijnt hij ook op mijn bureaublad... Is er een manier waardoor ik kan zorgen dat die partitie al direct op mijn bureaublad staat? Heeft dat misschien iets met permissies te maken ofzo?

Alvast bedankt!

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #1 Gepost op: 2008/03/16, 11:29:00 »
misschien dat het volgende werkt. Kijk in fstab of die betreffende partitie aanwezig is:
$ gedit /etc/fstab
(of een editor naar keuze natuurlijk)
als je die partitie niet ziet, doe dan
$ blkid
(staat voor block identifier geloof ik)
en plaats de gegevens van je partitie (UUID=, mount point etc) in fstab, als root.
bewaren en herstarten.

Mocht dit niet werken, dan heb je waarschijnlijk een ander probleem! -:)

Groet, Paul.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #2 Gepost op: 2008/03/16, 11:38:54 »
Citaat van: paul_matthijsse
misschien dat het volgende werkt. Kijk in fstab of die betreffende partitie aanwezig is:
$ gedit /etc/fstab
(of een editor naar keuze natuurlijk)
als je die partitie niet ziet, doe dan
$ blkid
(staat voor block identifier geloof ik)
en plaats de gegevens van je partitie (UUID=, mount point etc) in fstab, als root.
bewaren en herstarten.

Mocht dit niet werken, dan heb je waarschijnlijk een ander probleem! -:)

Groet, Paul.
Bedankt voor je reactie! Maar ik heb het nog niet helemaal opgelost... Als ik die eerste command uitvoer (gedit /etc/fstab), dan staat hij er inderdaad niet tussen.
Als ik daarna "blkid" typ in de terminal, krijg ik een soort lijst met alle partities en aangesloten schijven, denk ik. Het ziet er zo uit:

/dev/sda1: UUID="8C20A68F20A67FB6" TYPE="ntfs"
/dev/sda2: LABEL="DOCUMENTEN" UUID="6868-AC0A" TYPE="vfat"
/dev/sda3: UUID="25582e00-8294-4b8d-a533-14aa24108487" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: UUID="7408aa42-f811-42a8-85e3-ce5e45057d16" TYPE="swap"
/dev/sdb1: LABEL="EFI" UUID="3F3C-1AF6" TYPE="vfat"


het is de partitie "DOCUMENTEN" waarop mijn bestanden staan. Wat moet ik nu doen?

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #3 Gepost op: 2008/03/16, 11:57:21 »
kijk eerst waar je /dev/sda2 is aangekoppeld, dit kun je zien met het commando
§ mount -l
(de letter EL)

voeg nu aan fstab de volgende regel toe:

# /dev/sda2
UUID=6868-AC0A     [boven gevonden mount point]     vfat    defaults     0    2

bewaren en herstarten, werkt het nu?
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #4 Gepost op: 2008/03/16, 12:22:47 »
Bedankt! Het is inderdaad opgelost!
Pieterjan

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #5 Gepost op: 2008/03/16, 13:41:31 »
cool!

Groet, Paul.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #6 Gepost op: 2008/03/16, 15:43:00 »
Toch nog een probleem: ik kan nu niet meer de bestanden op die partitie wijzigen, "omdat de eigenaar ervan 'root' is"
Is er iets dat ik verkeerd heb gedaan? In mijn fstab staat het volgende:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=25582e00-8294-4b8d-a533-14aa24108487 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=7408aa42-f811-42a8-85e3-ce5e45057d16 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0
# /dev/sda2
UUID=6868-AC0A     /media/DOCUMENTEN     vfat    defaults     0    2

Is hier iets verkeerd misschien?
Alvast bedankt, Pieterjan

Offline vanadium

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #7 Gepost op: 2008/03/16, 16:55:06 »
Maak jezelf tot eigenaar van het mount point:

sudo chown $USER:$USER /media/DOCUMENTEN

(je mag dat als dusdanig intypen: $USER wordt vervangen door de login van de huidige gebruiker).

Misschien best eens "hermounten" om zeker te zijn dat alles nu goed gaat:

sudo mount -a

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #8 Gepost op: 2008/03/16, 20:48:31 »
Citaat van: vanadium
Maak jezelf tot eigenaar van het mount point:

sudo chown $USER:$USER /media/DOCUMENTEN

(je mag dat als dusdanig intypen: $USER wordt vervangen door de login van de huidige gebruiker).

Misschien best eens "hermounten" om zeker te zijn dat alles nu goed gaat:

sudo mount -a
moet ik dan dus 2x de gebruikersnaam in typen, in mijn geval:

sudo chown pieterjan:pieterjan /media/DOCUMENTEN

Dat lukt alleszins niet, bij komt er dan:

chown: bezig met het veranderen van de eigenaar van ‘/media/DOCUMENTEN’: Bewerking niet toegestaan

Heb ik iets verkeerd getypt of zo?
Alvast bedankt! Pieterjan

Offline vanadium

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #9 Gepost op: 2008/03/17, 09:39:44 »
Dan moet je wellicht toch eerst je schijf unmounten: had er aan gedacht, maar was er dan toch vanuit gegaan dat het niet nodig zou zijn:

sudo umount /media/DOCUMENTEN
sudo chown pieterjan:pieterjan /media/DOCUMENTEN
sudo mount -a
zou het dan moeten doen (met het laatste commando koppel je alles weer aan).

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #10 Gepost op: 2008/03/17, 13:28:22 »
Citaat van: vanadium
Dan moet je wellicht toch eerst je schijf unmounten: had er aan gedacht, maar was er dan toch vanuit gegaan dat het niet nodig zou zijn:

sudo umount /media/DOCUMENTEN
sudo chown pieterjan:pieterjan /media/DOCUMENTEN
sudo mount -a
zou het dan moeten doen (met het laatste commando koppel je alles weer aan).
Help! Die partitie unmounten is geen probleem, maar als ik die tweede command typ, komt er:

chown: kan geen toegang krijgen tot ‘/media/DOCUMENTEN’: Bestand of map bestaat niet

Ook kan ik de partitie niet meer openen via Locaties>Computer (Kan schijf niet aankoppelen - alleen root kan dev/sda2 aankoppelen aan /media/DOCUMENTEN

Wat moet ik nu doen?
Alvast bedankt, Pieterjan

Offline vanadium

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #11 Gepost op: 2008/03/17, 14:19:35 »
Nu heb ik geen controle of jij je commandos wel juist typt. Als je kan mounten en unmounten op /media/DOCUMENTEN dan bestaat die directory.

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #12 Gepost op: 2008/03/18, 18:53:35 »
Citaat van: vanadium
Nu heb ik geen controle of jij je commandos wel juist typt. Als je kan mounten en unmounten op /media/DOCUMENTEN dan bestaat die directory.
Normaal gezien typ ik alles correct in, ik doe gewoon Copy-Paste :)
Maar het probleem is, ik kon /media/DOCUMENTEN wel unmounten, maar ik kan hem niet meer opnieuw mounten! Nochtans heb ik niets aan die partitie veranderd...
Pieterjan

Offline vanadium

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #13 Gepost op: 2008/03/18, 20:25:54 »
Kan je eens de output posten van volgende commando's

ls -l /media
sudo mount -a

pieterjan

  • Gast
partities verdwijnen steeds...
« Reactie #14 Gepost op: 2008/03/19, 09:24:01 »
Citaat van: vanadium
Kan je eens de output posten van volgende commando's

ls -l /media
sudo mount -a
Het eerste:

totaal 6
lrwxrwxrwx  1 root       root          6 2008-03-09 15:44 cdrom -> cdrom0
dr-xr-xr-x 10 4294967295 4294967295 1220 2006-09-25 20:06 cdrom0
lrwxrwxrwx  1 root       root          7 2008-03-09 15:44 floppy -> floppy0
drwxr-xr-x  2 root       root       4096 2008-03-09 15:44 floppy0

Het tweede geeft geen outpost, waarschijnlijk omdat ik /media/DOCUMENTEN uit mijn /etc/fstab heb verwijderd, en dat geeft dus nu geen problemen meer.
Pieterjan

Offline vanadium

  • Lid
  • Steunpunt: Nee
partities verdwijnen steeds...
« Reactie #15 Gepost op: 2008/03/19, 18:29:53 »
Ik zie dus enkel dat je koppelpunt niet meer bestaat. Logisch dat je het dan ook niet van eigenaar kan veranderen. Om je aangekoppelde schijf ook als gebruiker te kunnen beschrijven, moet je met chown (of grafisch met "gksudo nautilus") de eigenaar van het koppelpunt veranderen van "root" naar jezelf.