Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Running local boot scripts  (gelezen 2392 keer)

Joeppy

  • Gast
Running local boot scripts
« Gepost op: 2008/03/12, 17:15:26 »
Hoi,

Ik heb Ubuntu eerder al eens als dual boot op mijn PC gehad en dit werkte vrij aardig.

Nu heb ik onlangs een laptop gekocht met Vista er al ingebakken. Ik wou naast Vista ook graag Ubuntu op deze laptop hebben. Nu had ik 7.10 gedownload en 8.04 alpha 6.

Alleen als ik wil starten houd de PC ermee op bij de regel 'running local boot scripts', ik kan dan op enter duwen zoveel als ik wil ik krijg geen GUI.

Ik heb al verscheidene fora gelezen en heb ook al gegoogled. De volgende dingen heb ik al geprobeerd:

1. Ctrl+C intypen --> Geen effect

2. Ctrl+Alt+F2 --> Kom ik in de terminal --> sudo dpkg-reconfigure xserver-xorg --> alle default instellingen --> xstart --> nog geen resultaat --> Misschien een interressante: ik krijg een Fatal server error: no screens found.

3. Verder heb ik nog gelezen dat het gebruiken van de alternate CD een optie is. Maar hiermee moet je Ubuntu direct installeren (meen ik gelezen te hebben) en dat wil ik liever niet, ik wil eerst kijken hoe Ubuntu loopt op de laptop en of hij compatible is met alle hardware etc.

Ik hoop dat ik snel een reactie kan verwachten :)

Voor nu alvast bedankt daarvoor

Mvg,
Joep

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Running local boot scripts
« Reactie #1 Gepost op: 2008/03/12, 18:13:32 »
Zou je eens de inhoud van je xorg.conf kunnen posten?

Deze is te vinden onder /etc/X11/xorg.conf
Live to win, dare to lose
http://www.robmaas.eu

Joeppy

  • Gast
Running local boot scripts
« Reactie #2 Gepost op: 2008/03/13, 12:42:02 »
Ik lees net je post..
Ik ga dat nu even doen..

Moet ik dat helemaal overtikken, of is er ook een snelle manier om dat te kopieeren? Het is namelijk een nogal lang bestand en de helft valt buiten het scherm. Ik ben nog niet zo geweldig in de terminal dus is er een mogelijkheid op het bestand naar een Stick te kopieeren?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Running local boot scripts
« Reactie #3 Gepost op: 2008/03/13, 22:57:22 »
Als je er een stick inpropt, dan wordt-ie waarschijnlijk al automatisch gemount. Laten we zeggen dat dat onder /media/usb is. Dan kan je als commando gebruiken:

cp /etc/X11/xorg.conf /media/usb

That's it!
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Running local boot scripts
« Reactie #4 Gepost op: 2008/03/13, 23:10:08 »
Citaat van: tukcedo
Als je er een stick inpropt, dan wordt-ie waarschijnlijk al automatisch gemount. Laten we zeggen dat dat onder /media/usb is. Dan kan je als commando gebruiken:

cp /etc/X11/xorg.conf /media/usb

That's it!
Ik denk dat die bedoeld de tekst te kopiëren, niet het binaire bestand. Dit kan heel gemakkelijk met bijv. gedit alles selecteren -> kopiëren.

sudo gedit /etc/X11/xorg.conf
Live to win, dare to lose
http://www.robmaas.eu

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #5 Gepost op: 2008/03/14, 07:59:18 »
Lief van jullie dat je Joeppy wilt helpen maar lees zijn post nou eens goed ???

( stick ?? , xorg.onf ?? )

Volgens mij krijgt hij de live cd niet aan de gang dus is dit niet van toepassing.

hij moet eerst die liver cd aan de gang hebben om te kijken of zijn hardware compatible is !

hmmz
OK Joeppy, hij wil dus niet booten en blijft hangen bij die scripts ??
Is dit wanneer je klikt op Install Ubuntu ? wanneer net de cd gestart is ??

Of wil je de cd helemaal niet opstarten zodat je het menu te zien krijgt ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Running local boot scripts
« Reactie #6 Gepost op: 2008/03/14, 08:25:37 »
Citaat van: Gandyman
Lief van jullie dat je Joeppy wilt helpen maar lees zijn post nou eens goed ???

( stick ?? , xorg.onf ?? )

Volgens mij krijgt hij de live cd niet aan de gang dus is dit niet van toepassing.

hij moet eerst die liver cd aan de gang hebben om te kijken of zijn hardware compatible is !

hmmz
OK Joeppy, hij wil dus niet booten en blijft hangen bij die scripts ??
Is dit wanneer je klikt op Install Ubuntu ? wanneer net de cd gestart is ??

Of wil je de cd helemaal niet opstarten zodat je het menu te zien krijgt ??
Hij kan we in een "kale" terminal komen met CTRL+Alt+F2, dus naar mij idee zou het best met zijn X server te maken kunenn hebben. Of het dan xorg.conf is laat ik er even buiten.
Live to win, dare to lose
http://www.robmaas.eu

Joeppy

  • Gast
Running local boot scripts
« Reactie #7 Gepost op: 2008/03/14, 10:25:12 »
Ik kies de eerste optie als ik van de CD boot (dus starten vanaf CD) en ik krijg dan geen GUI. Hij stopt bij running local bootscripts met [OK] erachter.

Ik kan dan in de terminal komen inderdaad. Ik zocht inderdaad iets van copy naar usb stick, dat ga ik denk ik eens proberen.

Maare, hoe weet ik zeker dat hij onder /usb mount?

EDIT:
Stel ik krijg hem aan de gang.. Kan ik dan beter 8.04 installeren of 7.10?

Offline lizardman

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #8 Gepost op: 2008/03/14, 10:40:10 »
8.04 is nog in ontwikkeling en komt als alles volgens plan verloopt in april uit. Maar je zult dan waarschijnlijk wel meer kans maken dat het allemaal uit de doos gaat werken met 8.04.
Misschien is het een idee om eens alvast een 'voorschotje' te nemen en eens de alfa 6 Live-cd van 8.04 te downloaden en te kijken of die wel in een keer wil booten? Let wel dat 8.04 nog in de alfa fase is.

Als je in een terminal kunt komen dan kun je, nadat je de usb-stick hebt ingestoken met het commando mount zien of hij ook gemount is. Als het een FAT geformatteerde stick is dan zoek je in de uitkomst van het commando mount naar de regel(s) waar vfat in staat.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Joeppy

  • Gast
Running local boot scripts
« Reactie #9 Gepost op: 2008/03/14, 10:51:14 »
Ik heb zowel 8.04 alpha 6 als 7.10 en die hebben beide hetzelfde probleem.

Ik heb mount geprobeerd, maar zie geen vfat er tussen staan.

Als ik de stick erin doe krijg ik het volgende bericht (misschien nuttig):

[ 1152.050046 ] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 1152.053165 ] sd 6:0:0:0: [sdb] Assuming drive cache: write through

Is dat 'sdb' dan misschien de naam waar hij gemount is?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Running local boot scripts
« Reactie #10 Gepost op: 2008/03/14, 22:21:12 »
Zou best wel es kunnen, je commando wordt dan:

sudo mkdir /media/usb
sudo mount /dev/sdb1 /media/usb

Dan het cp commando als in mijn vorige post.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #11 Gepost op: 2008/03/14, 23:52:40 »
Omdat hij dus wel doorstart maar blijkbaar vastloopt bij detectie van je monitor is het misschien te proberen dat je handmatig daar iets invoert ??

Citaat
2. Ctrl+Alt+F2 --> Kom ik in de terminal --> sudo dpkg-reconfigure xserver-xorg --> alle default instellingen --> xstart --> nog geen resultaat --> Misschien een interressante: ik krijg een Fatal server error: no screens found.
Wanneer je die wizard doorloopt en bij je monitor aankomt probeer dan jouw type erin te krijgen, of een vergelijkend type zodat dit er hard instaat.

uuuuh tis toch geen phillips monitor he ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Joeppy

  • Gast
Running local boot scripts
« Reactie #12 Gepost op: 2008/03/15, 01:37:48 »
Haha, het is een laptop.. Dus welke monitor het is zou ik niet weten.

Dat mounten... met mkdir, waar maakt hij die dir dan aan? Ik neem aan in het geheugen en niet op de HD?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #13 Gepost op: 2008/03/15, 03:38:57 »
Doe nogmaals
Ctrl+Alt+F1 -->
sudo dpkg-reconfigure xserver-xorg -plow

Kies voor vga kaart vesa
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Joeppy

  • Gast
Running local boot scripts
« Reactie #14 Gepost op: 2008/03/15, 16:52:09 »
Dat -plow erachter heeft hetzelfde effect als zonder -plow erachter. Ik krijg geen vraag welke VGA kaart ik wil. De vragen die ik krijg zijn:

Gebruik maken van de framebuffer-interface in de kernel?

Toetsenbord indeling automatisch laten dedecteren?

Toetsenbordindeling:

Te gebruiken XKB-regelset:

Toetsenbordmodel:

Toetsenbordvariant:

Toetsenbordopties: >

Klaar...

En dan doe ik startx

fatal server error:
no screens found

waiting for X server to begin accepting connections
giving up.
xinit: connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): server error.

En dan zijn we weer terug bij af.

Joeppy

  • Gast
Running local boot scripts
« Reactie #15 Gepost op: 2008/03/15, 17:53:51 »
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/192107

Ik denk dat dit mijn probleem is.

Het is een notebook met 1280x800 en heeft een ATI 1250 express en Intel Duo Core Processor

Dus ik ga hier eens meer over zoeken.

EDIT:
En dit is de echte bug (boven was een tweede van deze):
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-vesa/+bug/174434

Vreemde is, dat in de laatste posts staat dat er een nieuwe ati-driver uit is die het probleem verhelpt.
Ze gebruiken een dailybuild, die voor alpha 6 is uitgekomen. Dus dat is vreemd, want ik heb alpha 6 en die heeft het probleem nog steeds.

Hoe zou ik de nieuwe ati driver kunnen verkrijgen?

Offline lizardman

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #16 Gepost op: 2008/03/15, 18:10:46 »
De laatste daily build staat hier: http://cdimage.ubuntu.com/daily-live/20080315/
Ik zie alleen dat ie net iets groter dan 700 MB is.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Joeppy

  • Gast
Running local boot scripts
« Reactie #17 Gepost op: 2008/03/15, 18:33:27 »
Haha, volgens mij is iedereen hem aan het downloaden. Heb een snelheid van 3 kb/s :P. Nog 51 uur resterend..

Offline Nassara

  • Lid
  • Steunpunt: Nee
Running local boot scripts
« Reactie #18 Gepost op: 2008/03/23, 10:10:49 »
Ik heb net hetzelfde probleem bij poging tot installatie: blokkeert bij "running local boot scritps". Voordien vraagt-ie aan te geven welke monitor en grafische kaart ik bezit, enne... Ik heb wel een Phillips-monitor (flatscreen) (Gandyman schreef "Uh, ´t Is toch geen Phillips-monitor, he?) De grafische kaart is een Asus.

Blijkbaar een probleem bij het starten van de XWindow of zoiets. Hoe kan ik verder?

Joeppy

  • Gast
Running local boot scripts
« Reactie #19 Gepost op: 2008/04/04, 16:39:09 »
Ik het probleem ook nog steeds, maar ik wacht denk ik tot 8.04 echt uit is.. Dat duurt toch nog maar 20 dagen..