Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid met Audigy 2 ZS  (gelezen 1190 keer)

Razenko

  • Gast
Geen geluid met Audigy 2 ZS
« Gepost op: 2008/03/11, 15:06:44 »
Hallo,

Ik had gisteren Ubuntu 7.10 geinstalleerd, nu werkt bijna alles prima.
Alleen het geluid doet het nog niet goed, er zit een Audigy 2 ZS geluidskaart in dat systeem.
Ubuntu herkent de geluidskaart ook wel, maar verder heb ik gewoon geen geluid.
Ik heb nog bij de volume mixer als apparaat Audigy 2 ZS ingesteld, en ook heb ik de digitale uitgang switch uitgevinkt.
Maar dus zonder resultaat.

Verder had ik zo net ook nog wat problemen met internet, tijdens het gebruiken van Ubuntu had ik even geen internet, het systeem herstart en tijdens het booten kwam er iets van een usb-error langs (ik gebruik een Edimax USB WLAN stick om te verbinden, gebruikt Ralink chip), het kwam te snel voorbij om te kunnen noteren, toen mijn syteem weer was opgestart had ik dus geen internet, toen had ik de wlan stick er weer in en uit gedaan en het systeem herstart, nu heb ik dus wel weer verbinding, nu weet ik niet of dit random is, of dit een driver probleem is.

Verder is Ubuntu & Linux nog redelijk onbekend voor me, dus veel verstand ervan heb ik nog niet :).

Razenko

  • Gast
Geen geluid met Audigy 2 ZS
« Reactie #1 Gepost op: 2008/03/11, 17:14:14 »
Het probleem met het geluid heb ik inmiddels al opgelost, blijkbaar had Ubuntu nog een geluidskaart toegevoegd, waarschijnlijk mijn onboard geluidschip (het was een via82xx geluidskaart volgens Ubuntu), deze onboard chip staat in het bios wel uitgeschakeld maar Ubuntu heeft hem denk ik toch toegevoegd.
Het probleem was dus dat de Viachip als eerste geluidskaart ingesteld stond.
De oplossing was dus door in de shell 'cat /proc/asound/modules' in te typen, daarmee krijg je een lijst van alle geluidskaarten, en hun volgorde (stond bij mij verkeerd).
Vervolgens heb ik de volgorde verandert door in /etc/modprobe.d/alsa-base de volgorde te veranderen, dat doe je door in de shell  'gksu gedit /etc/modprobe.d/alsa-base'  in te voeren, en dan een lijst toe te voegen, voorbeeld:

options snd-C index=0
options snd-A index=1
options snd-B index=2

Waarbij dus snd-C dus de naam van de geluidskaart is die je als eerste wilt hebben, snd-A de tweede etc.

Bij mij is dat nu dus:

options snd-emu10k1 index=0
options snd-via82xx index=1

Dus, voor mensen die nog meer problemen hebben met hun geluid, het kan dus hier aan liggen, ook al heb je de onboard chip uitgezet.
Internet doet het nog steeds, dus dat lijkt, tot  nu toe, goed te gaan.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Geen geluid met Audigy 2 ZS
« Reactie #2 Gepost op: 2008/03/12, 10:34:11 »
Bedankt voor het terugkoppelen. Overigens: petje af voor je niveau.... Voor een beginner heb je het verbazend professioneel en diepgaand aangepakt.

Groet, Pjotr.

Razenko

  • Gast
Geen geluid met Audigy 2 ZS
« Reactie #3 Gepost op: 2008/04/01, 16:39:28 »
Bedankt voor je reactie Pjotr,

Ik heb het overigens niet helemaal zelf opgelost hoor :),
Het meeste ervan heb ik ergens uit een wiki gehaald, na lang zoeken op Google.

Offline Petervdw

  • Lid
  • Steunpunt: Nee
Geen geluid met Audigy 2 ZS
« Reactie #4 Gepost op: 2008/04/01, 16:48:01 »
Aan Razenko
Heb dank. Op het moment lopen er nog een paar problemen van mensen, die hier heel blij mee zullen zijn. Ik heb het in ieder geval genoteerd.
Heel goed, dankjewel.
Vr.groet, peter