Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Fan draait constant  (gelezen 5941 keer)

Gast

  • Gast
Fan draait constant
« Gepost op: 2006/07/23, 19:28:44 »
Hallo,

Ik heb een laptop van dell, een inspiron 5160.

Wanneer ik in Windows XP werk, dan draait mijn fan (van de cpu) nooit constant, maar in 'periodes'.

Wanneer ik in Ubuntu werk, versie 6.06, dan draait deze wel continue.

Ik 'vermoed' dat er dus een probleem is?

Omdat ik ook graag eens de temperatuur had geweten in ubuntu, als de fan zo continue draait, installeerde ik het pakket sensors-applet.

Dat krijg ik echter niet opgestart: als ik in een console sensors-applet doe dan krijg ik de melding dat het commando niet gekend is.

Dan maar geprobeerd met i8kutils, omdat dit 'specifiek voor dell laptops' werd gemaakt; maar ook daar loopt het mis: als ik dat opstart, dan komt er bovenaan links zo'n klein schermpje, dit kan ik wel groter maken zodat ik twee 'lege vakken' krijg.

Verder gebeurt er in 'dat programma' niets....

Iemand die raad weet?

Alvast hartelijk dank!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #1 Gepost op: 2006/07/23, 19:37:03 »
sensors-applet is waarschijnlijk een gnome applet die je moet toevoegen aan je gnome-panel:

rechtermuisknop op lege plaats in taakbalk/gnome-panel -> toevoegen aan paneel -> applet zoeken en toevoegen
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline woteb

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #2 Gepost op: 2006/07/24, 07:13:04 »
draai eens in een terminal het commando:

top

Hoef je niet een sudo voor te gebruiken.

Daar zie je alle lopende processen en geheugenverbruik.
Als er een proces is met veel geheugenverbruik kun je het zo zien.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #3 Gepost op: 2006/07/24, 18:23:29 »
ik denk eerder dat het een ACPI probleem is waardoor de fan zoiezo niet uitgeschakeld wordt, in plaats van een proces dat CPU opslorpt zoals woteb vermoedt.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Fan draait constant
« Reactie #4 Gepost op: 2006/07/24, 19:11:10 »
Bestaat er een manier om deze te kunnen instellen. Het valt me op dat de mijne ook constant draait ...
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #5 Gepost op: 2006/07/25, 19:27:01 »
In 'rust' heb ik een temperatuur van 65-68 graden celcius.
mijn cpu (die maximaal aan 3,06 Ghz draait) draait dan op 1,87 Ghz.

Het Top commando geeft dit:

Citaat
top - 19:25:14 up  1:25,  2 users,  load average: 0.59, 1.38, 2.33
Tasks: 101 total,   1 running,  97 sleeping,   2 stopped,   1 zombie
Cpu(s):  1.0% us,  0.3% sy,  0.0% ni, 98.7% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:    515804k total,   356428k used,   159376k free,     3596k buffers
Swap:  2048276k total,    18992k used,  2029284k free,   177436k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 4428 root      15   0  103m  18m 8780 S  1.0  3.6  13:34.05 Xorg
 4503 haldaemo  16   0  6912 5516 1564 S  0.3  1.1   0:02.39 hald
 6225 pieter    15   0 44892  18m  10m S  0.3  3.6   0:10.79 python
 8113 pieter    16   0  2196 1112  856 R  0.3  0.2   0:00.01 top
    1 root      16   0  1564  528  460 S  0.0  0.1   0:01.02 init
    2 root      34  19     0    0    0 S  0.0  0.0   0:03.29 ksoftirqd/0
    3 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0
    4 root      10  -5     0    0    0 S  0.0  0.0   0:04.04 events/0
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper
    6 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread
    8 root      10  -5     0    0    0 S  0.0  0.0   0:00.57 kblockd/0
    9 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid
  137 root      15   0     0    0    0 S  0.0  0.0   0:19.17 pdflush
  138 root      15   0     0    0    0 S  0.0  0.0   0:05.46 pdflush
  140 root      16  -5     0    0    0 S  0.0  0.0   0:00.00 aio/0
  139 root      15   0     0    0    0 S  0.0  0.0   0:23.84 kswapd0
  727 root      11  -5     0    0    0 S  0.0  0.0   0:00.01 kseriod
 1823 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khubd
 1840 root      15   0     0    0    0 S  0.0  0.0   0:00.00 khpsbpkt
 1864 root      15   0     0    0    0 S  0.0  0.0   0:00.00 knodemgrd_0
 1939 root      15   0     0    0    0 S  0.0  0.0   0:00.07 kjournald
 2168 root      12  -4  2432  924  368 S  0.0  0.2   0:00.46 udevd
 2187 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0
 2188 root      10  -5     0    0    0 S  0.0  0.0   0:09.92 usb-storage
 3025 root      20   0     0    0    0 S  0.0  0.0   0:00.00 shpchpd_event
 3155 root      15   0     0    0    0 S  0.0  0.0   0:00.00 pccardd
 3658 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 wrapper_wq
 3963 root      16   0  2152 1192  644 S  0.0  0.2   0:00.00 acpid
 4080 root      16   0  1684  496  412 S  0.0  0.1   0:00.01 dd
 4082 klog      15   0  2416 1340  388 S  0.0  0.3   0:00.04 klogd
 4401 root      15   0 10912 1792 1212 S  0.0  0.3   0:00.00 gdm
 4417 root      16   0 11352 2644 1996 S  0.0  0.5   0:00.00 gdm
In Windows draai ik in rust toch een tiental graden koeler, (en daar vind ik 54 ook al 'warm'...). Kan ik hieraan iets doen?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #6 Gepost op: 2006/07/25, 20:44:23 »
Dat zou niet warmer mogen worden in Linux, tenminste als de fan het doet, en aangezien deze constant draait.. vind ik het wel heel vreemd.
Misschien ACPI problemen?
Gebruik je boot parameters om te kunnen booten?
misschien na het booten de output van "dmesg" eens posten?

als het te lange output is om te kopieeren:
dmesg > /tmp/bootlog && gedit /tmp/bootlog
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #7 Gepost op: 2006/07/25, 20:49:22 »
Volgens dit artikel (http://www.swineworld.org/inspiron5160/) - als je CPU throttling inschakelt:

echo -n 6 > /proc/acpi/processor/CPU0/throttling
(om op 100% snelheid te zetten: echo -n 0 ipv 6)

en je doet iets CPU intensief zoals "glxgears" dan zou je je temperatuur/snelheid moeten zien veranderen

cat /proc/acpi/thermal_zone/THRM/temperature
cat /proc/cpuinfo|grep MHz
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #8 Gepost op: 2006/07/25, 21:07:10 »
De output van dmesg gaf dit:

Citaat
[17179569.184000] Linux version 2.6.15-26-386 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 PREEMPT Mon Jul 17 19:52:53 UTC 2006
[17179569.184000] BIOS-provided physical RAM map:
[17179569.184000]  BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[17179569.184000]  BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[17179569.184000]  BIOS-e820: 0000000000100000 - 000000001ffcd000 (usable)
[17179569.184000]  BIOS-e820: 000000001ffcd000 - 0000000020000000 (reserved)
[17179569.184000]  BIOS-e820: 00000000fec00000 - 00000000fec20000 (reserved)
[17179569.184000]  BIOS-e820: 00000000feda0000 - 00000000fee10000 (reserved)
[17179569.184000]  BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[17179569.184000] 0MB HIGHMEM available.
[17179569.184000] 511MB LOWMEM available.
[17179569.184000] On node 0 totalpages: 131021
[17179569.184000]   DMA zone: 4096 pages, LIFO batch:0
[17179569.184000]   DMA32 zone: 0 pages, LIFO batch:0
[17179569.184000]   Normal zone: 126925 pages, LIFO batch:31
[17179569.184000]   HighMem zone: 0 pages, LIFO batch:0
[17179569.184000] DMI 2.3 present.
[17179569.184000] ACPI: RSDP (v000 DELL                                  ) @ 0x000fdea0
[17179569.184000] ACPI: RSDT (v001 DELL    CPi R   0x27d50315 ASL  0x00000061) @ 0x1ffef701
[17179569.184000] ACPI: FADT (v001 DELL    CPi R   0x27d50315 ASL  0x00000061) @ 0x1fff0400
[17179569.184000] ACPI: MADT (v001 DELL    CPi R   0x27d50315 ASL  0x00000047) @ 0x1fff0c00
[17179569.184000] ACPI: SSDT (v001  PmRef    CpuPm 0x00003000 INTL 0x20030522) @ 0x1ffef731
[17179569.184000] ACPI: DSDT (v001 INT430 SYSFexxx 0x00001001 MSFT 0x0100000e) @ 0x00000000
[17179569.184000] ACPI: PM-Timer IO Port: 0x1008
[17179569.184000] ACPI: Local APIC address 0xfee00000
[17179569.184000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[17179569.184000] Processor #0 15:4 APIC version 20
[17179569.184000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
[17179569.184000] Processor #1 15:4 APIC version 20
[17179569.184000] WARNING: NR_CPUS limit of 1 reached.  Processor ignored.
[17179569.184000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[17179569.184000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[17179569.184000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
[17179569.184000] IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
[17179569.184000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[17179569.184000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[17179569.184000] ACPI: IRQ0 used by override.
[17179569.184000] ACPI: IRQ2 used by override.
[17179569.184000] ACPI: IRQ9 used by override.
[17179569.184000] Enabling APIC mode:  Flat.  Using 1 I/O APICs
[17179569.184000] Using ACPI (MADT) for SMP configuration information
[17179569.184000] Allocating PCI resources starting at 30000000 (gap: 20000000:dec00000)
[17179569.184000] Built 1 zonelists
[17179569.184000] Kernel command line: root=/dev/hdc2 ro quiet splash
[17179569.184000] mapped APIC to ffffd000 (fee00000)
[17179569.184000] mapped IOAPIC to ffffc000 (fec00000)
[17179569.184000] Initializing CPU#0
[17179569.184000] PID hash table entries: 2048 (order: 11, 32768 bytes)
[17179569.184000] Detected 3057.205 MHz processor.
[17179569.184000] Using pmtmr for high-res timesource
[17179569.184000] Console: colour VGA+ 80x25
[17179570.912000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[17179570.916000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[17179570.924000] Memory: 508724k/524084k available (1976k kernel code, 14800k reserved, 606k data, 288k init, 0k highmem)
[17179570.924000] Checking if this processor honours the WP bit even in supervisor mode... Ok.
[17179571.004000] Calibrating delay using timer specific routine.. 6119.54 BogoMIPS (lpj=12239097)
[17179571.004000] Security Framework v1.0.0 initialized
[17179571.004000] SELinux:  Disabled at boot.
[17179571.004000] Mount-cache hash table entries: 512
[17179571.004000] CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 0000459d 00000000 00000000
[17179571.004000] CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 0000459d 00000000 00000000
[17179571.004000] monitor/mwait feature present.
[17179571.004000] using mwait in idle threads.
[17179571.004000] CPU: Trace cache: 12K uops, L1 D cache: 16K
[17179571.004000] CPU: L2 cache: 1024K
[17179571.004000] CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 0000459d 00000000 00000000
[17179571.004000] mtrr: v2.0 (20020519)
[17179571.004000] CPU: Intel Mobile Intel(R) Pentium(R) 4 CPU 3.06GHz stepping 01
[17179571.004000] Enabling fast FPU save and restore... done.
[17179571.004000] Enabling unmasked SIMD FPU exception support... done.
[17179571.004000] Checking 'hlt' instruction... OK.
[17179571.020000] checking if image is initramfs... it is
[17179571.520000] Freeing initrd memory: 6617k freed
[17179571.536000] ACPI: Looking for DSDT ... not found!
[17179571.536000] ENABLING IO-APIC IRQs
[17179571.536000] ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
[17179571.680000] NET: Registered protocol family 16
[17179571.680000] EISA bus registered
[17179571.680000] ACPI: bus type pci registered
[17179571.704000] PCI: PCI BIOS revision 2.10 entry at 0xfcf1e, last bus=2
[17179571.704000] PCI: Using configuration type 1
[17179571.704000] ACPI: Subsystem revision 20051216
[17179571.716000] ACPI: Interpreter enabled
[17179571.716000] ACPI: Using IOAPIC for interrupt routing
[17179571.716000] ACPI: PCI Root Bridge [PCI0] (0000:00)
[17179571.716000] PCI: Probing PCI hardware (bus 00)
[17179571.716000] ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
[17179571.724000] PCI quirk: region 1000-107f claimed by ICH4 ACPI/GPIO/TCO
[17179571.724000] PCI quirk: region 1080-10bf claimed by ICH4 GPIO
[17179571.724000] PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
[17179571.724000] Boot video device is 0000:01:00.0
[17179571.724000] PCI: Transparent bridge - 0000:00:1e.0
[17179571.724000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[17179571.728000] ACPI: PCI Interrupt Link [LNKA] (IRQs 9 10 *11)
[17179571.728000] ACPI: PCI Interrupt Link [LNKB] (IRQs 5 7) *11
[17179571.728000] ACPI: PCI Interrupt Link [LNKC] (IRQs 9 10 *11)
[17179571.732000] ACPI: PCI Interrupt Link [LNKD] (IRQs 5 7 9 10 *11)
[17179571.732000] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
[17179571.732000] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
[17179571.732000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
[17179571.732000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCIE._PRT]
[17179571.732000] Linux Plug and Play Support v0.97 (c) Adam Belay
[17179571.732000] pnp: PnP ACPI init
[17179571.740000] pnp: PnP ACPI: found 10 devices
[17179571.740000] PnPBIOS: Disabled by ACPI PNP
[17179571.740000] PCI: Using ACPI for IRQ routing
[17179571.740000] PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
[17179571.756000] pnp: 00:01: ioport range 0x4d0-0x4d1 has been reserved
[17179571.756000] pnp: 00:01: ioport range 0x800-0x80f has been reserved
[17179571.756000] pnp: 00:01: ioport range 0x1000-0x1005 could not be reserved
[17179571.756000] pnp: 00:01: ioport range 0x1008-0x100f could not be reserved
[17179571.756000] pnp: 00:02: ioport range 0xf400-0xf4fe has been reserved
[17179571.756000] pnp: 00:02: ioport range 0x1006-0x1007 has been reserved
[17179571.756000] pnp: 00:02: ioport range 0x1010-0x105f could not be reserved
[17179571.756000] pnp: 00:02: ioport range 0x1060-0x107f has been reserved
[17179571.756000] pnp: 00:02: ioport range 0x1080-0x10bf has been reserved
[17179571.756000] pnp: 00:02: ioport range 0x10c0-0x10df has been reserved
[17179571.756000] pnp: 00:07: ioport range 0x900-0x97f has been reserved
[17179571.756000] PCI: Bridge: 0000:00:01.0
[17179571.756000]   IO window: c000-cfff
[17179571.756000]   MEM window: fc000000-fdffffff
[17179571.756000]   PREFETCH window: d0000000-dfffffff
[17179571.756000] PCI: Bus 3, cardbus bridge: 0000:02:04.0
[17179571.756000]   IO window: 0000d000-0000d0ff
[17179571.756000]   IO window: 0000d400-0000d4ff
[17179571.756000]   PREFETCH window: 30000000-31ffffff
[17179571.756000]   MEM window: f6000000-f7ffffff
[17179571.756000] PCI: Bridge: 0000:00:1e.0
[17179571.756000]   IO window: d000-efff
[17179571.756000]   MEM window: f6000000-fbffffff
[17179571.756000]   PREFETCH window: 30000000-31ffffff
[17179571.756000] PCI: Setting latency timer of device 0000:00:1e.0 to 64
[17179571.756000] PCI: Enabling device 0000:02:04.0 (0000 -> 0003)
[17179571.756000] ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 169
[17179571.756000] audit: initializing netlink socket (disabled)
[17179571.756000] audit(1153861385.756:1): initialized
[17179571.756000] VFS: Disk quotas dquot_6.5.1
[17179571.756000] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[17179571.756000] Initializing Cryptographic API
[17179571.756000] io scheduler noop registered
[17179571.756000] io scheduler anticipatory registered
[17179571.756000] io scheduler deadline registered
[17179571.756000] io scheduler cfq registered
[17179571.756000] isapnp: Scanning for PnP cards...
[17179572.108000] isapnp: No Plug & Play device found
[17179572.124000] PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[17179572.124000] i8042.c: Warning: Keylock active.
[17179572.128000] serio: i8042 AUX port at 0x60,0x64 irq 12
[17179572.128000] serio: i8042 KBD port at 0x60,0x64 irq 1
[17179572.128000] Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
[17179572.132000] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
[17179572.132000] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[17179572.132000] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[17179572.132000] mice: PS/2 mouse device common for all mice
[17179572.132000] EISA: Probing bus 0 at eisa.0
[17179572.132000] Cannot allocate resource for EISA slot 1
[17179572.132000] EISA: Detected 0 cards.
[17179572.132000] NET: Registered protocol family 2
[17179572.136000] input: AT Translated Set 2 keyboard as /class/input/input0
[17179572.172000] IP route cache hash table entries: 8192 (order: 3, 32768 bytes)
[17179572.172000] TCP established hash table entries: 32768 (order: 5, 131072 bytes)
[17179572.172000] TCP bind hash table entries: 32768 (order: 5, 131072 bytes)
[17179572.172000] TCP: Hash tables configured (established 32768 bind 32768)
[17179572.172000] TCP reno registered
[17179572.172000] TCP bic registered
[17179572.172000] NET: Registered protocol family 1
[17179572.172000] NET: Registered protocol family 8
[17179572.172000] NET: Registered protocol family 20
[17179572.172000] Using IPI Shortcut mode
[17179572.172000] ACPI wakeup devices:
[17179572.172000]  LID PBTN PCI0 USB0 USB1 USB2 USB3 MODM PCIE
[17179572.172000] ACPI: (supports S0 S1 S3 S4 S5)
[17179572.172000] Freeing unused kernel memory: 288k freed
[17179572.208000] vga16fb: initializing
[17179572.208000] vga16fb: mapped to 0xc00a0000
[17179572.356000] Console: switching to colour frame buffer device 80x25
[17179572.356000] fb0: VGA16 VGA frame buffer device
[17179573.380000] Capability LSM initialized
[17179573.408000] ACPI: Processor [CPU0] (supports 8 throttling states)
[17179573.412000] ACPI: Thermal Zone [THM] (71 C)
[17179573.980000] ICH4: IDE controller at PCI slot 0000:00:1f.1
[17179573.980000] PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
[17179573.980000] ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 16 (level, low) -> IRQ 169
[17179573.980000] ICH4: chipset revision 1
[17179573.980000] ICH4: not 100% native mode: will probe irqs later
[17179573.980000]     ide0: BM-DMA at 0xbfa0-0xbfa7, BIOS settings: hda:DMA, hdb:pio
[17179573.980000]     ide1: BM-DMA at 0xbfa8-0xbfaf, BIOS settings: hdc:DMA, hdd:pio
[17179573.980000] Probing IDE interface ide0...
[17179574.716000] hda: _NEC DVD+/-RW ND-6500A, ATAPI CD/DVD-ROM drive
[17179575.404000] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[17179575.420000] Probing IDE interface ide1...
[17179575.712000] hdc: FUJITSU MHU2100AT, ATA DISK drive
[17179576.384000] ide1 at 0x170-0x177,0x376 on irq 15
[17179576.444000] hda: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
[17179576.444000] Uniform CD-ROM driver Revision: 3.20
[17179576.472000] hdc: max request size: 128KiB
[17179576.472000] hdc: 195371568 sectors (100030 MB) w/8192KiB Cache, CHS=65535/16/63, UDMA(100)
[17179576.476000] hdc: cache flushes supported
[17179576.476000]  hdc: hdc1 hdc2 hdc3 hdc4
[17179576.860000] usbcore: registered new driver usbfs
[17179576.860000] usbcore: registered new driver hub
[17179576.860000] USB Universal Host Controller Interface driver v2.3
[17179576.860000] ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 16 (level, low) -> IRQ 169
[17179576.860000] PCI: Setting latency timer of device 0000:00:1d.0 to 64
[17179576.860000] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[17179576.860000] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
[17179576.860000] uhci_hcd 0000:00:1d.0: irq 169, io base 0x0000bf80
[17179576.860000] hub 1-0:1.0: USB hub found
[17179576.860000] hub 1-0:1.0: 2 ports detected
[17179576.916000] ieee1394: Initialized config rom entry `ip1394'
[17179576.964000] ACPI: PCI Interrupt 0000:00:1d.1 -> GSI 19 (level, low) -> IRQ 177
[17179576.964000] PCI: Setting latency timer of device 0000:00:1d.1 to 64
[17179576.964000] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[17179576.964000] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
[17179576.964000] uhci_hcd 0000:00:1d.1: irq 177, io base 0x0000bf40
[17179576.964000] hub 2-0:1.0: USB hub found
[17179576.964000] hub 2-0:1.0: 2 ports detected
[17179577.068000] ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 185
[17179577.068000] PCI: Setting latency timer of device 0000:00:1d.2 to 64
[17179577.068000] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[17179577.068000] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
[17179577.068000] uhci_hcd 0000:00:1d.2: irq 185, io base 0x0000bf20
[17179577.068000] hub 3-0:1.0: USB hub found
[17179577.068000] hub 3-0:1.0: 2 ports detected
[17179577.172000] ACPI: PCI Interrupt 0000:00:1d.7[D] -> GSI 23 (level, low) -> IRQ 193
[17179577.172000] PCI: Setting latency timer of device 0000:00:1d.7 to 64
[17179577.172000] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[17179577.172000] ehci_hcd 0000:00:1d.7: debug port 1
[17179577.172000] PCI: cache line size of 128 is not supported by device 0000:00:1d.7
[17179577.172000] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 4
[17179577.172000] ehci_hcd 0000:00:1d.7: irq 193, io mem 0xf4fffc00
[17179577.176000] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[17179577.176000] hub 4-0:1.0: USB hub found
[17179577.176000] hub 4-0:1.0: 6 ports detected
[17179577.204000] usb 1-1: new low speed USB device using uhci_hcd and address 2
[17179577.280000] ohci1394: $Rev: 1313 $ Ben Collins
[17179577.280000] ACPI: PCI Interrupt 0000:02:04.1[A] -> GSI 16 (level, low) -> IRQ 169
[17179577.328000] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[169]  MMIO=[faffd800-faffdfff]  Max Packet=[2048]
[17179577.396000] Attempting manual resume
[17179577.408000] kjournald starting.  Commit interval 5 seconds
[17179577.408000] EXT3-fs: mounted filesystem with ordered data mode.
[17179577.708000] usb 1-1: new low speed USB device using uhci_hcd and address 3
[17179578.608000] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[354fc0003acc3030]
[17179588.896000] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[17179588.900000] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[17179588.924000] Linux agpgart interface v0.101 (c) Dave Jones
[17179588.928000] agpgart: Detected an Intel 855GM Chipset.
[17179588.936000] agpgart: AGP aperture is 128M @ 0xe0000000
[17179589.196000] nvidia: module license 'NVIDIA' taints kernel.
[17179589.200000] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 20 (level, low) -> IRQ 201
[17179589.200000] NVRM: loading NVIDIA Linux x86 Kernel Module  1.0-8762  Mon May 15 13:06:38 PDT 2006
[17179589.612000] input: PC Speaker as /class/input/input1
[17179589.788000] usbcore: registered new driver hiddev
[17179589.804000] input: HID 062a:0000 as /class/input/input2
[17179589.804000] input: USB HID v1.10 Mouse [HID 062a:0000] on usb-0000:00:1d.0-1
[17179589.804000] usbcore: registered new driver usbhid
[17179589.804000] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[17179589.900000] hw_random hardware driver 1.0.0 loaded
[17179589.904000] ts: Compaq touchscreen protocol output
[17179589.948000] Real Time Clock Driver v1.12
[17179590.012000] ACPI: PCI Interrupt 0000:00:1f.5 -> GSI 17 (level, low) -> IRQ 209
[17179590.012000] PCI: Setting latency timer of device 0000:00:1f.5 to 64
[17179590.288000] Synaptics Touchpad, model: 1, fw: 5.9, id: 0x256eb1, caps: 0x804713/0x0
[17179590.332000] input: SynPS/2 Synaptics TouchPad as /class/input/input3
[17179590.832000] intel8x0_measure_ac97_clock: measured 55422 usecs
[17179590.832000] intel8x0: clocking to 48000
[17179590.832000] b44.c:v0.97 (Nov 30, 2005)
[17179590.836000] ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 17 (level, low) -> IRQ 209
[17179590.836000] eth0: Broadcom 4400 10/100BaseT Ethernet 00:11:43:61:83:3e
[17179590.840000] ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 16 (level, low) -> IRQ 169
[17179590.840000] Yenta: CardBus bridge found at 0000:02:04.0 [1028:0196]
[17179590.840000] Yenta: Using CSCINT to route CSC interrupts to PCI
[17179590.840000] Yenta: Routing CardBus interrupts to PCI
[17179590.840000] Yenta TI: socket 0000:02:04.0, mfunc 0x00001002, devctl 0x64
[17179591.072000] Yenta: ISA IRQ mask 0x0cf8, PCI irq 169
[17179591.072000] Socket status: 30000020
[17179591.072000] Yenta: Raising subordinate bus# of parent bus (#02) from #02 to #06
[17179591.072000] pcmcia: parent PCI bridge I/O window: 0xd000 - 0xefff
[17179591.072000] cs: IO port probe 0xd000-0xefff: clean.
[17179591.072000] pcmcia: parent PCI bridge Memory window: 0xf6000000 - 0xfbffffff
[17179591.072000] pcmcia: parent PCI bridge Memory window: 0x30000000 - 0x31ffffff
[17179591.720000] pccard: CardBus card inserted into slot 0
[17179591.808000] cs: IO port probe 0x100-0x3af: clean.
[17179591.808000] cs: IO port probe 0x3e0-0x4ff: clean.
[17179591.808000] cs: IO port probe 0x820-0x8ff: clean.
[17179591.808000] cs: IO port probe 0xc00-0xcf7: clean.
[17179591.808000] cs: IO port probe 0xa00-0xaff: clean.
[17179591.828000] ieee80211_crypt: registered algorithm 'NULL'
[17179591.832000] ieee80211: 802.11 data/management/control stack, git-1.1.7
[17179591.832000] ieee80211: Copyright (C) 2004-2005 Intel Corporation
[17179591.856000] bcm43xx driver
[17179591.856000] PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
[17179591.856000] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 16 (level, low) -> IRQ 169
[17179591.856000] PCI: Setting latency timer of device 0000:03:00.0 to 64
[17179593.232000] lp: driver loaded but no devices found
[17179593.300000] SCSI subsystem initialized
[17179593.312000] sbp2: $Rev: 1306 $ Ben Collins
[17179593.312000] ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
[17179593.312000] ieee1394: sbp2: Try serialize_io=0 for better performance
[17179593.372000] Adding 2048276k swap on /dev/hdc3.  Priority:-1 extents:1 across:2048276k
[17179593.532000] EXT3 FS on hdc2, internal journal
[17179593.672000] NET: Registered protocol family 17
[17179593.684000] md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
[17179593.684000] md: bitmap version 4.39
[17179594.124000] device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
[17179594.836000] cdrom: open failed.
[17179595.428000] NTFS driver 2.1.25 [Flags: R/O MODULE].
[17179595.500000] NTFS volume version 3.1.
[17179595.560000] FAT: bogus number of reserved sectors
[17179595.560000] VFS: Can't find a valid FAT filesystem on dev hdc4.
[17179598.448000] ndiswrapper version 1.8 loaded (preempt=yes,smp=no)
[17179600.496000] ACPI: AC Adapter [AC] (on-line)
[17179600.772000] ACPI: Battery Slot [BAT0] (battery present)
[17179600.840000] ACPI: Lid Switch [LID]
[17179600.840000] ACPI: Power Button (CM) [PBTN]
[17179600.840000] ACPI: Sleep Button (CM) [SBTN]
[17179600.916000] ibm_acpi: ec object not found
[17179600.940000] pcc_acpi: loading...
[17179601.032000] ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
[17179601.520000] acpi-cpufreq: CPU0 - ACPI performance management activated.
[17179606.144000] ppdev: user-space parallel port driver
[17179606.544000] apm: BIOS not found.
[17179614.308000] Bluetooth: Core ver 2.8
[17179614.308000] NET: Registered protocol family 31
[17179614.308000] Bluetooth: HCI device and connection manager initialized
[17179614.308000] Bluetooth: HCI socket layer initialized
[17179614.356000] Bluetooth: L2CAP ver 2.8
[17179614.356000] Bluetooth: L2CAP socket layer initialized
[17179614.356000] Bluetooth: RFCOMM socket layer initialized
[17179614.356000] Bluetooth: RFCOMM TTY layer initialized
[17179614.356000] Bluetooth: RFCOMM ver 1.7
[17179621.964000] NET: Registered protocol family 10
[17179621.964000] lo: Disabled Privacy Extensions
[17179621.964000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[17179621.964000] ADDRCONF(NETDEV_UP): eth1: link is not ready
[17179621.964000] IPv6 over IPv4 tunneling driver
[17179643.680000] SoftMAC: Open Authentication completed with 00:12:17:d4:c2:2d
[17179643.700000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[17179644.060000] SoftMAC: Open Authentication completed with 00:12:17:d4:c2:2d
[17179644.112000] ieee80211_crypt: registered algorithm 'CCMP'
[17179659.352000] CCMP: replay detected: STA=00:12:17:d4:c2:2d previous PN 000000000055 received PN 000000000055
[17179661.468000] eth1: no IPv6 routers present

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #9 Gepost op: 2006/07/25, 21:17:46 »
Citaat van: profoX
Volgens dit artikel (http://www.swineworld.org/inspiron5160/) - als je CPU throttling inschakelt:

echo -n 6 > /proc/acpi/processor/CPU0/throttling
Als ik dit uitvoer krijg ik 'toegang geweigerd', ook met root

Citaat
(om op 100% snelheid te zetten: echo -n 0 ipv 6)

en je doet iets CPU intensief zoals "glxgears" dan zou je je temperatuur/snelheid moeten zien veranderen

cat /proc/acpi/thermal_zone/THRM/temperature
cat /proc/cpuinfo|grep MHz
Dit gaat de temp dan toch alleen maar de hoogte injagen?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #10 Gepost op: 2006/07/25, 21:20:49 »
Mja.. er valt mij wel iets op:

[17179569.184000] Processor #0 15:4 APIC version 20
[17179569.184000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
[17179569.184000] Processor #1 15:4 APIC version 20
[17179569.184000] WARNING: NR_CPUS limit of 1 reached.  Processor ignored.

Heb jij 2 processors of 2 processor cores ofzo? :P dan moet je een -smp kernel nemen anders kan je maar 1 van die processors/cores laten werken
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #11 Gepost op: 2006/07/25, 21:26:05 »
Nee, maar 't is wel een CPU die aan Hyper Threading doet.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #12 Gepost op: 2006/07/25, 21:29:24 »
en zie je dan 2 virtuele processors ofzo? want ik vind het wel vreemd dat hij 2 processors detecteert
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #13 Gepost op: 2006/07/25, 21:41:17 »
Nee, ik heb intussen zelf even wat opgezocht en blijkbaar moet je in menu.lst van de grub bootloader een parameter/optie toevoegen: ht=on

Ik heb dus deze lijn staan:

kernel      /boot/vmlinuz-2.6.15-26-386 root=/dev/hdc2 ro quiet splash ht=on

Echter, die tweede 'vrituele cpu' wordt niet herkend; ik zit nog steeds met

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #14 Gepost op: 2006/07/25, 21:47:26 »
Zou het kunnen dat ik de verkeerde kernel heb ge

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #15 Gepost op: 2006/07/25, 21:48:20 »
volgens mij heb je een -smp kernel nodig dan..
sudo apt-get install linux-686-smp voor Intel Pentium 2, 3, 4, M, D
sudo apt-get install linux-k7-smp voor AMD K7/Athlon met 32bit Ubuntu
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #16 Gepost op: 2006/07/25, 21:50:52 »
Citaat van: strike
Zou het kunnen dat ik de verkeerde kernel heb ge
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #17 Gepost op: 2006/07/25, 22:29:48 »
*ooops*

Geen idee of het door het niet installeren van die restricted-modules komt (wat doen die eigenlijk?) maar 'k zit wel met 'een probleem' in mijn bootloader op dit moment :(

Die nieuwe kernel stond inderdaad vermeld en als ik daarmee boot dan zie ik inderdaad ook mijn twee virtuele cpu's en de temperatuur is ook 'normaal', net zoals in Windows. Wat ik in grub echter ontbreek nu is de mogelijkheid om te booten in windows, die optie werd blijkbaar 'overschreven' en is nergens meer terug te vinden.

Weet jij wat ik precies in menu.lst moet plaatsen?
De windows staat op hdc1

Overigens: kan ik die restriced-modules nu ook nog installeren?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #18 Gepost op: 2006/07/25, 23:11:42 »
Citaat van: strike
*ooops*

Geen idee of het door het niet installeren van die restricted-modules komt (wat doen die eigenlijk?) maar 'k zit wel met 'een probleem' in mijn bootloader op dit moment :(

Die nieuwe kernel stond inderdaad vermeld en als ik daarmee boot dan zie ik inderdaad ook mijn twee virtuele cpu's en de temperatuur is ook 'normaal', net zoals in Windows. Wat ik in grub echter ontbreek nu is de mogelijkheid om te booten in windows, die optie werd blijkbaar 'overschreven' en is nergens meer terug te vinden.

Weet jij wat ik precies in menu.lst moet plaatsen?
De windows staat op hdc1

Overigens: kan ik die restriced-modules nu ook nog installeren?
Ja die kan je nu ook nog installeren.. normaal gezien werden die wel automatisch mee ge-update hoor: sudo apt-get install restricted-modules-$(uname -r) als je in je nieuwe kernel bent geboot

$sudo gedit /boot/grub/menu.lst

helemaal onderaan toevoegen:
title         Windows 95/98/NT/2000
root          (hd2,0)
makeactive
chainloader   +1
volgens mij h
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Fan draait constant
« Reactie #19 Gepost op: 2006/07/25, 23:13:08 »
PS: draait je fan nu normaal?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline strike

  • Lid
  • Steunpunt: Nee
Fan draait constant
« Reactie #20 Gepost op: 2006/07/25, 23:29:30 »
Als ik die restricted modules met het door jou opgegeven commando wil installeren krijg ik dit:

Citaat
pieter@pieter-laptop:~$ sudo apt-get install restricted-modules-$(uname -r)
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... Klaar
E: Kon pakket restricted-modules-2.6.15-26-686 niet vinden
Wat de fan betreft: die draait nu inderdaad een heel stuk rustiger, maar wel ook nog continue: in Windows is dat met 'intervallen'
Aan welke snelheid die precies draait kan ik Ubuntu jammer genoeg niet aflezen, geen ondersteuning misschien in Ubuntu voor de fan speed? (In Windows heb ik die wel via Speedfan)

Wat de bootloader betreft: dat is opgelost, bleek wel hd(0,0) te zijn?
hd(2,0) gaf een disk not existed; en aangezien mijn nieuwe kernel verwees naar hd(1,0) gokte ik maar op hd(0,0) omdat ik wist dat linux op partitie twee stond.

Wel raar dat diezelfde disk binnen Ubuntu dan gemount wordt onder hdc1, want dat systeem 'snap ik min of meer', of dat dacht ik toch :P

zoefzoef

  • Gast
Fan draait constant
« Reactie #21 Gepost op: 2007/06/14, 07:51:49 »
Dag allen, ik wil graag dit topic nieuw leven inblazen daar ik last heb van hetzelfde probleem.

Ik heb een evoN800c, daar zit een PentiumM in. Ik heb gisteren de laatste versie van Ubuntu gedownload en geinstalleerd. Mijn grootste probleem nu is dat de laptop in vergelijking tot XP veel warmer wordt en dat de fan constant aan staat. In XP wilde deze nog wel eens onhoorbaar zijn, nu echter zeer zelden (pas 1x terwijl ik wat aan het typen  Ook lijkt de batterij veel sneller leeg te zijn.

Ik heb de stappen uit dit topic doorgelopen en nagekeken. Ubuntu switcht afhankelijk of ik veel doe of niet al tussen 1.2 en 1.6 Ghz. De fan gaat nog harder draaien als ik wat zwaardere dingen doe.

Een 'top' terwijl ik aan het typen ben en verder weinig open heb staan levert een cpu belasting van misschien 2% en idle dus 98%. Maw, ik zie niet in waarom de laptop nu toch al zo warm is. De system monitor laat zien dat de HD in regelmatige intervallen een spike geeft op de activiteit.

Tot zover diverse informatie. Mijn vragen zijn:
1) wat zou de oorzaak kunnen zijn van het  grote temperatuurverschil tov XP? Wat kan ik er aan doen?
2) Hoe kan ik nachecken of Ubuntu inderdaad de geoptimaliseerde instellingen gebruikt voor een pentiumM?
3) nog andere suggesties hoe ik het hoge batterij verbruik in Ubuntu (vergeleken met XP) terug kan dringen?

Informatie is erg welkom. Ik ben onder de indruk van Ubuntu (na een kort avontuur met Redhat enkele jaren geleden) echter dit hitte probleem en kortere accuduur zijn voor mij wel breekpunten.

Groeten, Max.