Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Resolutie binnen ubuntu.  (gelezen 2091 keer)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Gepost op: 2006/07/23, 16:59:55 »
Hallo,

Ik heb eindelijk Ubuntu kunnen installeren, maar nu krijg ik de resolutie niet goed. In /etc/X11/xorg.cof staat alles goed. Default Depth staat op 24 en bij 24 staat als hoogste resolutie 1280*1024. Mijn ati video kaart lijkt te worden herkend, MAAR in Gnome kan ik ALLEEn 640*480 kiezen op 60 Hz. Hoe kan dit, en veel belangrijker: HELP :-P

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #1 Gepost op: 2006/07/23, 17:08:29 »
wat voor ati kaart?
$lspci|grep VGA

welke driver gebruik je nu in xorg?
$cat /etc/X11/xorg.conf|grep 'Section "Device"' -A 10|grep Driver

ofja, gewoon cat /etc/X11/xorg.conf en kijken wat er bij Driver staat in Section "Device" :P
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #2 Gepost op: 2006/07/23, 19:03:30 »
IK heb een ATI Radeon X700 Pro. Zo staat ie ook in xorg. Welke driver ik heb weet ik zo niet. Ik switch nu tussne besturingssysteem omdat ik die resolutie dus niet werkbaar vind / is. Ik zal eens kijken welke driver ik gebruiik'. Post ik dadelijk hier....

budster

  • Gast
Resolutie binnen ubuntu.
« Reactie #3 Gepost op: 2006/07/23, 19:10:50 »
post jouw xorg configruratie bestand hier eens.

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #4 Gepost op: 2006/07/23, 19:13:40 »
Oke de driver is "ati". Dit staat onder de sectie "device". Lijkt mij goed ? Toch vind ik het raar dat in xorg.conf alles goed lijkt te zijn, maar Gnome me geen keuze geeft behalve 640*480.  ProfoX: zou je me willen toevoegen in jabber (ik heb je al uitgenodigd geloof ik) dan kun je me wellicht ter plekke helpen? tnx

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #5 Gepost op: 2006/07/23, 19:28:07 »
Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
        Driver          "ati"
        BusID           "PCI:4:0:0"
EndSection

Section "Monitor"
        Identifier      "L1915S"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
        Monitor         "L1915S"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #6 Gepost op: 2006/07/23, 19:31:25 »
Citaat van: Jerry
Oke de driver is "ati". Dit staat onder de sectie "device". Lijkt mij goed ? Toch vind ik het raar dat in xorg.conf alles goed lijkt te zijn, maar Gnome me geen keuze geeft behalve 640*480.  ProfoX: zou je me willen toevoegen in jabber (ik heb je al uitgenodigd geloof ik) dan kun je me wellicht ter plekke helpen? tnx
ik heb je toegevoegd..

ik raad je trouwens aan meteen de proprietary fglrx driver te installeren, dan werkt je kaart veel sneller met 3D games enzo :)

edit: misschien kan je voorlopig eens de "radeon" driver proberen ipv "ati" die heb je standaard ook, normaal gezien

of probeer voorlopig resolutie 1024x768 in plaats van 1280x1024 (verwijder die ff)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #7 Gepost op: 2006/07/23, 19:51:55 »
Citaat van: profoX
Citaat van: Jerry
Oke de driver is "ati". Dit staat onder de sectie "device". Lijkt mij goed ? Toch vind ik het raar dat in xorg.conf alles goed lijkt te zijn, maar Gnome me geen keuze geeft behalve 640*480.  ProfoX: zou je me willen toevoegen in jabber (ik heb je al uitgenodigd geloof ik) dan kun je me wellicht ter plekke helpen? tnx
ik heb je toegevoegd..

ik raad je trouwens aan meteen de proprietary fglrx driver te installeren, dan werkt je kaart veel sneller met 3D games enzo :)

edit: misschien kan je voorlopig eens de "radeon" driver proberen ipv "ati" die heb je standaard ook, normaal gezien

of probeer voorlopig resolutie 1024x768 in plaats van 1280x1024 (verwijder die ff)
1 Hoe installeer ik die proprietary driver?

2 Die radeon driver gebruik ik automatisch als ik het woord ati vervang voor radeon?

3 Mijn monitor kan wel 1280x1024 aan. Waarom zou ik dat dan niet gebruiken?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #8 Gepost op: 2006/07/23, 20:04:25 »
Citaat van: Jerry
1 Hoe installeer ik die proprietary driver?

Nota: op dit moment is ubuntu.com nog steeds down, dus kan je waarschijnlijk niks installeren via apt-get........
update: is weer on line :) eindelijk

$sudo apt-get install linux-restricted-modules-$(uname -r)
$sudo apt-get install xorg-driver-fglrx
$sudo depmod -a
$sudo gedit /etc/X11/xorg.conf
in dit bestand "ati" of "radeon" vervangen door "fglrx"
$sudo aticonfig --overlay-type=Xv

ctrl+alt+backspace om X te restarten
probeer nadien ff:
$glxinfo|grep direct

Je zou moeten zien:
direct rendering: Yes

2 Die radeon driver gebruik ik automatisch als ik het woord ati vervang voor radeon?

ja, en dan X herstarten
(ctrl+alt+backspace of sudo /etc/init.d/gdm restart)

3 Mijn monitor kan wel 1280x1024 aan. Waarom zou ik dat dan niet gebruiken?
Misschien heeft die "ati" driver moeite met jouw videokaart en die resolutie.. geen idee..
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #9 Gepost op: 2006/07/23, 20:17:02 »
Citaat van: Jerry
Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
        Monitor         "L1915S"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
Een DefaultDepth van 24 maar in je Depth heb je enkel een Depth van 1 bit ?
voeg ook ff toe:
Depth           24
Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
edit: nevermind, je had gewoon je hele xorg.conf niet gepost :P
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #10 Gepost op: 2006/07/23, 21:59:03 »
Citaat van: profoX
Citaat van: Jerry
Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
        Monitor         "L1915S"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
Een DefaultDepth van 24 maar in je Depth heb je enkel een Depth van 1 bit ?
voeg ook ff toe:
Depth           24
Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
edit: nevermind, je had gewoon je hele xorg.conf niet gepost :P
Nee ik weet niet hoe ik ALLES kan selecteren, misschien moet je me dat eens uitleggen, lol

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #11 Gepost op: 2006/07/23, 22:12:19 »
Je kan de offici
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #12 Gepost op: 2006/07/23, 22:19:02 »
Hier mijn volledige xorg.conf:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
   Driver      "radeon"
   BusID      "PCI:4:0:0"
EndSection

Section "Monitor"
   Identifier   "L1915S"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies, Inc. Radeon X700 Pro (RV410)"
   Monitor      "L1915S"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #13 Gepost op: 2006/07/23, 22:26:11 »
Ik weet niet of dat het probleem is,
maar je hebt geen HorizSync en VertRefresh ingesteld bij je monitor..
Heb je een handleiding van die monitor? De refresh rates staan daar normaal gezien in.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Resolutie binnen ubuntu.
« Reactie #14 Gepost op: 2006/07/23, 22:40:04 »
misschien is nog iemand anders ermee geholpen: het probleem was inderdaad de HorizSync en de VertRefresh, die moet je als volgt aanpassen:

in het bestand: /etc/X11/xorg.conf

Section "Monitor"
    Identifier    "L1915S"
    Option        "DPMS"
    HorizSync       28.0 - 51.0
    VertRefresh     43.0 - 60.0
EndSection
De juiste HorizSync en VertRefresh vind je in de handleiding van je monitor of laptop
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Jerry

  • Gast
Resolutie binnen ubuntu.
« Reactie #15 Gepost op: 2006/07/23, 22:44:58 »
YABADBADOOOOO :D tnx profoX. wow, moi is happy ! Nu nog de goede driver enzoo en audio en video codect dan ben ik helemaal happy ! maar dat is een ander topic