Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Instalatie problemen, GRUB fouten.  (gelezen 739 keer)

Bright

  • Gast
Instalatie problemen, GRUB fouten.
« Gepost op: 2008/03/06, 22:53:33 »
Hallo,

Onlangs heb ik Ubuntu geïnstalleerd op mijn pc. P5K e Wifi, Q6600, 2 x 1 GB geheugen, etc. 1 500 gb SATA schijf.
Draai samen met Linux. Gaat allemaal prima.

Nu heb ik 2 x 250 gb in RAID 0 toegevoegd aangesloten op SATA 1 en SATA 2 en heb ik Vista opnieuw geinstaleerd op die RAID schijfen. Werkt tot dus ver prima. Nu had ik nog 1 500 gb schijf over die ik wou gaan gebruiken voor Linux.
Geformateerd, Ubuntu 7.10 Live cd geboot, en netjes geinstalleerd op deze schijf ( aangesloten op Slave SATA aansluiting op MB ). Installatie vraagt of ik Opstart programma ( Grub dus ) wil installeren, en op (hd0). Nou prima.
Geinstalleerd. Maar nu boot mijn pc niet meer.

Wanneer ik opstart krijg ik verschillende foutmeldingen. Eerst kreeg ik error 21. Toen mijn windows hdd als first boot device aangesteld in bios, krijg ik foutmelding error 17. Linux schijf als eerste boot device en windows helemaal niet meer aangesloten krijg ik fout melding error 22.

Doe ik wat verkeerd, kun je niet op 2 verschillende hdd's installeren? Moet ik wat anders doen?

Tell me. Want mijn pc doet nu helemaal niks meer.

Al vast bedankt.

Met vriendelijke groet,

Jordy

Quatroking

  • Gast
Instalatie problemen, GRUB fouten.
« Reactie #1 Gepost op: 2008/03/06, 23:23:23 »
Citaat
21 : "Unknown boot failure"

This error is returned if the boot attempt did not succeed for reasons which are unknown.

17 : "Invalid device requested"

This error is returned if a device string is recognizable but does not fall under the other device errors.

22 : "Must load Multiboot kernel before modules"

This error is returned if the module load command is used before loading a Multiboot kernel. It only makes sense in this case anyway, as GRUB has no idea how to communicate the presence of location of such modules to a non-Multiboot-aware kernel.
De defenities van de grub errors voor de gene die niet willen googlen.

Heb je al gekeken naar de jumpers van je harde schijven? De schijf waar je GRUB op heb staan moet geloof ik op master, en de 2de schijf op slave. CD-ROM moet ook op slave.

Bright

  • Gast
Instalatie problemen, GRUB fouten.
« Reactie #2 Gepost op: 2008/03/06, 23:34:13 »
Gebruik SATA, maar had de schijf waar linux op staat op slave geplugd, maar heb ik nu veranderd, maar nog niet op nieuw geinstalleerd. Dat kan ik nog proberen.
Had al naar de foutmeldignen gegoogled, maar dat zei mij nog niet veel.
Dus op Master 1, en 2 RAID 0 schijfen en dan op Master 3 ? En cd rom op slave?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Instalatie problemen, GRUB fouten.
« Reactie #3 Gepost op: 2008/03/06, 23:34:30 »
RAID...... Dan kun je de gewone Ubuntu-CD niet gebruiken voor installatie op de harde schijf. Je hebt de Alternate CD nodig, want alleen daarmee kun je RAID-stuurprogramma's installeren.

De Alternate CD zit hier:
ftp://ftp.tudelft.nl/pub/Linux/releases.ubuntu.com/7.10/ubuntu-7.10-alternate-i386.iso

Wat is dat toch met raid, de laatste tijd... veel mensen die dat hebben... Harde schijven zijn sowieso al breekbare dingen, als je ook nog eens een raid in elkaar zet, dan zijn je gegevens helemaal kwetsbaar. Maar goed, dat is mijn persoonlijke opvatting.

Bright

  • Gast
Instalatie problemen, GRUB fouten.
« Reactie #4 Gepost op: 2008/03/07, 12:13:45 »
Wat ik niet begrijp is het volgende.
Linux heeft naar mijn idee niks te maken met de RAID opstelling. Linux wordt op een andere hardeschijf geinstalleerd.
Kan ik niet zorgen dat mijn MBR op de Linux schijf wordt geinstalleerd?

Maar ik zal de alternate cd eens proberen.

Bright

  • Gast
Instalatie problemen, GRUB fouten.
« Reactie #5 Gepost op: 2008/03/07, 20:07:44 »
Heb het probleem al opgelost.

Heb Ubuntu op nieuw geinstalleerd maar nu handmatig grub op een andere hd geinstalleerd ( normaal hd0,0) dit heb ik nu geweizigd in hd2,0 ( windows schijf ). En toen kon ik wel in grub komen, alleen werkte het nog niet. Toen handmatig linux terug gezet naar hd0,0 en toen kon ik linux booten.


Later met nano /boot/grub/menu.lst het volgende toegevoegd.

title          Windows Vista
root          (hd0,0)
savedefault
makeactive
chainloader +1

en toen werkt het.

In elkgeval gedankt voor de tips.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Instalatie problemen, GRUB fouten.
« Reactie #6 Gepost op: 2008/03/07, 23:07:49 »
Dubbel compliment: voor het hier melden (handig voor anderen) en vooral voor het zelf oplossen. Dat is de mentaliteit!

Groet, Pjotr.