Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: apt-get update wel erg lang bezig  (gelezen 1165 keer)

Offline jopy

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Gepost op: 2008/02/28, 14:59:58 »
Hallo mensen,

Sinds ongeveer een maand heb ik een beetje ruzie met apt-get en synaptic.
Wanneer ik "sudo apt-get update" uitvoer in de terminal blijft ie standaard ergens steken.
bijvoorbeeld hier:

......
Get:462 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:463 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:464 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:465 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:466 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:467 http://security.ubuntu.com gutsy-security/multiverse Sources [833B]
99% [153 Packages bzip2 0]
Dan stop ik hem maar met ctrl-c.
Is het normaal die ie zoveel dingen op moet halen?
Ik dacht dat het misschien aan m'n sources.list lag, dus ik zoek de source-o-matic op maar die werkt helaas niet meer.
Met een andere sources.list voor gutsy die ik van het internet geplukt heb werkt het ook niet.
Mijn connectie is gewoon goed, al geeft hij bij het updaten wel eens een snelheid van bijv. maar  599B/s. Dat is heel wisselend.

Iemand die me kan helpen hiermee?

Jonathan

schoappied

  • Gast
apt-get update wel erg lang bezig
« Reactie #1 Gepost op: 2008/02/28, 15:08:41 »
Ligt aan je internetaansluiting of de adressen van je sources.list aanpassen naar een nederlandse of belgische...

Offline jopy

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #2 Gepost op: 2008/02/28, 15:14:07 »
mijn internetaansluiting is wel draadloos, dus je zou kunnen zeggen dat het niet stabiel genoeg is, maar bij andere programma's werkt het internet wel gewoon de hele tijd goed. Ook tijdens dat apt-get vastloopt, en ervoor en erna.
alles wat nederlands kan zijn heb ik volgens mij nederlands, alleen bijv. "http://security.ubuntu.com/ubuntu gutsy-security main restricted" is denk ik gewoon internationaal?

Ik denk dat als het probleem bij de sources.list ligt, dat er dan wat fout zou zijn aan de volgende regels:
deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse

Offline JvH

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #3 Gepost op: 2008/02/28, 15:21:14 »
Wat ik de laatste tijd wel heb (misschien hangt het hier ook mee samen, of gaat het zelfs om hetzelfde probleem) is dat het downloaden van pakketten via Synaptic onderbroken wordt.
Het overzicht met te downloaden bestanden blijft wel gewoon staan, maar de progressbar gaat niet verder en de resterende tijd verspringt naar 'onbekend'.
Als ik een tijdje wacht gaat ie dan opeens weer verder met downloaden. Verder is er dan ook niets aan de hand - de pakketten lijken goed binnen te komen en alles wordt netjes geïnstalleerd. Echt vreemd. Misschien dat de Nederlandse server kuren heeft?

schoappied

  • Gast
apt-get update wel erg lang bezig
« Reactie #4 Gepost op: 2008/02/28, 15:29:02 »
@ jopy, dat kun je testen door tijdelijk je sources.list aan te passen door een # voor die betreffende regels te zetten.

sudo pico /etc/apt/sources.list

Offline jopy

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #5 Gepost op: 2008/02/28, 15:59:23 »
Zonder die regels is hij binnen 2 seconden klaar.
Als ik alleen de bovenste twee (dus niet de multiverse en universe) toevoeg, loopt ie alweer vast.

schoappied

  • Gast
apt-get update wel erg lang bezig
« Reactie #6 Gepost op: 2008/02/28, 16:04:44 »
Citaat van: jopy
Zonder die regels is hij binnen 2 seconden klaar.
Als ik alleen de bovenste twee (dus niet de multiverse en universe) toevoeg, loopt ie alweer vast.
Als er alternatieven zijn qua servers, nl of be ipv com, dan kun je dat proberen. Ik weet zo niet of die alternatieven er zijn... Het zou ook gewoon tijdelijk kunnen zijn, dat ie het morgen gewoon weer ok doet..

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #7 Gepost op: 2008/02/28, 16:18:19 »
systeem=>beheer=>softwarebronnen en eens een andere server aanvinken...

Offline jopy

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #8 Gepost op: 2008/02/28, 17:06:50 »
Ik heb de ftp server van tudelft gekozen bij die softwarebronnen en nu gaat het al een stuk sneller.

Ik krijg deze foutmeldingen nog:
Failed to fetch http://security.ubuntu.com/ubuntu/dists/gutsy-security/main/i18n/Translation-en_US.bz2  Error reading from server - read (104 Connection reset by peer)
Failed to fetch http://security.ubuntu.com/ubuntu/dists/gutsy-security/universe/i18n/Translation-en_US.bz2  Error reading from server - read (104 Connection reset by peer)
Reading package lists... Done
W: GPG error: http://security.ubuntu.com gutsy-security Release: The following signatures were invalid: NODATA 2
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.
Als ik nog een keer update geeft ie precies hetzelfde.
Bedankt voor het meedenken.
Ik heb al een flink tijdje last van dit probleem. Nu ik het wel weer helemaal kan verversen (hetzij met foutmeldingen) krijg ik ook ineens meldingen van nieuwe updates enzo :P.

Offline woteb

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #9 Gepost op: 2008/02/28, 17:29:01 »
Kijk een hier: http://www.oudvaders.nl/tools.htm

Dan kun je de juiste sources.list bestanden ophalen (voor Feisty en Gutsy).
Kopieer die als root naar de /etc/apt directory: sudo cp /etc/apt is dan waar je de sources.list hebt gedownload.

Daarna: sudo apt-get update && sudo apt-get upradeEn alles zou moeten werken...

De fout zit namelijk in de regels waar ik een # heb gezet. Dit heb ik dan veranderd (de goede regels staan eronder:

# deb http://security.ubuntu.com/ubuntu feisty-security main restricted
# deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
# deb http://security.ubuntu.com/ubuntu feisty-security universe
# deb-src http://security.ubuntu.com/ubuntu feisty-security universe
# deb http://security.ubuntu.com/ubuntu feisty-security multiverse
# deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse

deb http://nl.archive.ubuntu.com/ubuntu feisty-security main restricted
deb-src http://nl.archive.ubuntu.comnl.archive.ubuntu.com/ubuntu feisty-security main restricted
deb http://nl.archive.ubuntu.com/ubuntu feisty-security universe
deb-src http://nl.archive.ubuntu.com/ubuntu feisty-security universe
deb http://nl.archive.ubuntu.com/ubuntu feisty-security multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu feisty-security multiverse

Dus.... overal waar je http://security.ubuntu.com..... tegen komt, moet je dat veranderen in http://nl.archive.ubuntu.com.....
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline jopy

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #10 Gepost op: 2008/02/28, 17:37:35 »
Dankje, nu werkt alles prima. Dat scheelt een hoop gedoe ;).
Krijg ik op deze manier wel alle beveiligingsupdates binnen?

Offline woteb

  • Lid
  • Steunpunt: Nee
apt-get update wel erg lang bezig
« Reactie #11 Gepost op: 2008/02/28, 18:24:02 »
jazeker..... alles wat je wil hebben...
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)