Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Visuele effecten  (gelezen 5016 keer)

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Gepost op: 2008/02/21, 22:37:48 »
Beste allen,

Ik gebruik Ubuntu 4 a 5 dagen en zit met de volgende punten:

- Ik kan mijn Visuele effecten niet veranderen naar extra of aangepast.
  - Compiz heeft dus geen effect.

- Amarok gebruikt 100% van mijn CPU als hij van nummer wisselt.

Het lijkt erop dat mijn systeem te langzaam is en dat vind ik raar.

Op deze zelfde site vond ik systeemeisen:

Ubuntu (Gnome), Kubuntu (KDE) en Edubuntu

Soepel draaien:
Processor: Pentium 3, 800 Mhz
RAM-geheugen: 512 MB
Harde-schijfruimte: 10 GB

Mijn systeem is als volgt:
CPU                                         Intel Pentium 4, 1919 MHz (19 x 101)

Moederbord:                             MSI 850 Pro5 (MS-6545)  (4 PCI, 1 AGP, 1 CNR, 4 RIMM, Audio)

Motherboard Chipset                 Intel Tehama i850

System Memory                        1024 MB  (RDRAM)
Videokaart                                ATI Radeon 9550 (RV350)
Harde Schijf 1                           SEAGATE ST318406LW SCSI Disk Device  (18 GB, 10000 RPM, Ultra160 SCSI)

Harde Schijf 2                           MAXTOR 4K040H2  (40 GB, 5400 RPM, Ultra-ATA/100)

Harde Schijf 3                           ST360015A  (60 GB, 7200 RPM, Ultra-ATA/100)

Ubuntu heb ik geinstaleerd op de Maxtor schijf.

Mij lijkt dat mijn systeem aan de eisen voldoet maar toch werkt het niet naar behoren.

Is mijn systeem nou echt te langzaam voor ubuntu?

Offline StaarTT

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #1 Gepost op: 2008/02/21, 22:43:17 »
Na zoveel verstand heb ik nog niet van Ubuntu, maar weet wel dat jou systeem zeker niet te langzaam is.
De oorzaak van de visuele effecten, ligt waarschijnlijk aan je ATI video kaart.
Zoek even op het forum op ATI..
Succes..
Ubuntu 9.10 De Karmische Koala @ DELL Pentium M 1.73 GHz, 1.5 Gb DDR2, ATI X300
                 "The Ubuntu Counter Project - user number # 21498"

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #2 Gepost op: 2008/02/21, 22:46:24 »
Maar hoe verklaren we dan dat de CPU uitloopt naar 100 % bij het wisselen van een nummer?

Offline StaarTT

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #3 Gepost op: 2008/02/21, 22:51:03 »
Citaat van: hbijlsma
Maar hoe verklaren we dan dat de CPU uitloopt naar 100 % bij het wisselen van een nummer?
ff gegoogled voor je..

Citaat
Met de engine GStreamer wordt mijn processor 100% gebruikt tijdens het afspelen. Hoe kan ik dit voorkomen?
 
 Als u GStreamer met alsasink gebruikt, dan vereist Amarok dat het apparaat een mixer aanlevert. Dit mixen betekent dat verschillende programma's tegelijkertijd toegang kunnen krijgen tot de geluidskaart, en dat het geluid door elkaar kan worden afgespeeld. Dit kan worden bereikt door een geluidskaart te gebruiken die hardware-mixing ondersteunt (zoals SBLive), of door het gebruiken van de plugin "dmix" voor alsa. Deze biedt software-mixing. Zie Setting up Dmix for ALSA.

Na de installatie dient u "dmix" als geluidsapparaat op te geven in de instellingendialoog voor de engine
Hoop dat dit helpt..
Ubuntu 9.10 De Karmische Koala @ DELL Pentium M 1.73 GHz, 1.5 Gb DDR2, ATI X300
                 "The Ubuntu Counter Project - user number # 21498"

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #4 Gepost op: 2008/02/21, 22:54:26 »
Ga nu ff kijken

Offline StaarTT

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #5 Gepost op: 2008/02/21, 22:58:20 »
Hmmz, ik ken Amarok niet.. Dus ben ff gaan kijken wat het pcies is..
En het eerst wat me opviel(als ik het goed gezien heb) dat het geschreven is voor KDE, en Ubuntu maakt gebruik van Gnome!!
Ubuntu 9.10 De Karmische Koala @ DELL Pentium M 1.73 GHz, 1.5 Gb DDR2, ATI X300
                 "The Ubuntu Counter Project - user number # 21498"

Offline Riny Feller

  • Lid
    • De wereld van Riny Feller
  • Steunpunt: Nee
Visuele effecten
« Reactie #6 Gepost op: 2008/02/21, 23:02:03 »
Aan Gnome hoeft het echt niet te liggen. Hier draait het prima :D

Misschien is het verstandig om als database MySQL te gebruiken. Lijkt me in elk geval verstandig als je een hele grote collectie hebt.

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #7 Gepost op: 2008/02/21, 23:05:13 »
Oh ja en over mijn ATI kaart:

Ik heb daar al mee lopen klooien ik heb daar ook vragen over gesteld in dit forum en dat werkte tot op heden allemaal niet. Zorgde alleen voor dat Ubuntu niet meer opstarte.

Maar zo traag is mijn video kaart toch ook weer niet dat ubuntu niet vol kan draaien?

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #8 Gepost op: 2008/02/21, 23:13:41 »
Citaat van: StaarTT
Citaat van: hbijlsma
Maar hoe verklaren we dan dat de CPU uitloopt naar 100 % bij het wisselen van een nummer?
ff gegoogled voor je..

Citaat
Met de engine GStreamer wordt mijn processor 100% gebruikt tijdens het afspelen. Hoe kan ik dit voorkomen?
 
 Als u GStreamer met alsasink gebruikt, dan vereist Amarok dat het apparaat een mixer aanlevert. Dit mixen betekent dat verschillende programma's tegelijkertijd toegang kunnen krijgen tot de geluidskaart, en dat het geluid door elkaar kan worden afgespeeld. Dit kan worden bereikt door een geluidskaart te gebruiken die hardware-mixing ondersteunt (zoals SBLive), of door het gebruiken van de plugin "dmix" voor alsa. Deze biedt software-mixing. Zie Setting up Dmix for ALSA.

Na de installatie dient u "dmix" als geluidsapparaat op te geven in de instellingendialoog voor de engine
Hoop dat dit helpt..
Mijn versie van Amarok is: 1.4.7 daar wordt het volgende over gezegt:

Note also that "For ALSA 1.0.9rc2 and higher you don't need to setup dmix.

Dus ik denk niet dat dit het is.

Da_peer

  • Gast
Visuele effecten
« Reactie #9 Gepost op: 2008/02/22, 11:31:07 »
Over de visuele effecten:
De ATI videokaarten zijn een bekend probleem. Op het internet vond ik in dit artikel onder de tab "Voorbereiding" wellicht een oplossing voor je probleem.

Wat wellicht ook kan helpen is na het indrukken van ALT + F2 is compiz --replacein te voeren voor een herstart.

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Visuele effecten
« Reactie #10 Gepost op: 2008/02/22, 11:45:25 »
Citaat van: hbijlsma
Oh ja en over mijn ATI kaart:

Ik heb daar al mee lopen klooien ik heb daar ook vragen over gesteld in dit forum en dat werkte tot op heden allemaal niet. Zorgde alleen voor dat Ubuntu niet meer opstarte.

Maar zo traag is mijn video kaart toch ook weer niet dat ubuntu niet vol kan draaien?
Deze kaart dient wel ten volle worden herkend door ubuntu, hij staat in de database als goed werkend? Restricted drivers doen het niet bij deze kaart? (ik vraag dit omdat een kennis eenzelfde soort kaart heeft, en ubuntu graag wil uitproberen)

Sancho

  • Gast
Visuele effecten
« Reactie #11 Gepost op: 2008/02/22, 12:16:33 »
@hbijsma: Heb de de compiz settings manager geinstalleerd? Zo nee: sudo apt-get install compizconfig-settings-manager

@StaarTT: vele programma's geschreven voor KDE werken goed onder GNOME. Zo heb ik ook Konversation voor IRC

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #12 Gepost op: 2008/02/22, 19:02:52 »
Citaat van: kebabfish
Citaat van: hbijlsma
Oh ja en over mijn ATI kaart:

Ik heb daar al mee lopen klooien ik heb daar ook vragen over gesteld in dit forum en dat werkte tot op heden allemaal niet. Zorgde alleen voor dat Ubuntu niet meer opstarte.

Maar zo traag is mijn video kaart toch ook weer niet dat ubuntu niet vol kan draaien?
Deze kaart dient wel ten volle worden herkend door ubuntu, hij staat in de database als goed werkend? Restricted drivers doen het niet bij deze kaart? (ik vraag dit omdat een kennis eenzelfde soort kaart heeft, en ubuntu graag wil uitproberen)
Ubuntu draait wel maar met de standaard look. Ik heb het idee dat mijn systeem wel meer aan kan dan dat. Vandaar dat ik hier een topic over begon.

Da_peer:

Het artikel heb ik gelezen maar dat staat bij mij allemaal goed.

en de tweede optie heb ik geprobeerd maar haalde niks uit.

In ieder geval wel bedankt voor de tips

Offline StaarTT

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #13 Gepost op: 2008/02/22, 19:32:28 »
@Sancho

Citaat van: Sancho
@StaarTT: vele programma's geschreven voor KDE werken goed onder GNOME. Zo heb ik ook Konversation voor IRC
Ow dat wis nog niet..
Maare ff over Konversation, ik ben daar ook ff mee bezig geweest. Ik zit hier (op me werk) achter een proxy server. Maar heb geen idee waar ik dat kan instellen in Konversation..
Ubuntu 9.10 De Karmische Koala @ DELL Pentium M 1.73 GHz, 1.5 Gb DDR2, ATI X300
                 "The Ubuntu Counter Project - user number # 21498"

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #14 Gepost op: 2008/02/24, 16:07:08 »
Citaat van: riny
Aan Gnome hoeft het echt niet te liggen. Hier draait het prima :D

Misschien is het verstandig om als database MySQL te gebruiken. Lijkt me in elk geval verstandig als je een hele grote collectie hebt.
Je had gelijk. Ik laat nu Amarok gebruik maken van MYSQL en nu loopt het erg Soepel. Bedankt voor de tip.


Nu nog het laatste mijn videokaart. ATI 9550....

Ik ben een stukje verder gekomen op https://help.ubuntu.com:

Met behulp van: "sudo vim /etc/X11/xorg.conf" pas ik mijn xorg aan maar het lijkt erop dat het niet wordt opgeslagen.

Wanneer ik aanpassingen heb aangebracht start ik doormiddel van "ctrl-alt-backspace" opnieuw op. vervolgens alt-F2 en tik dan het volgende in: sudo /etc/init.d/gdm restart

Vervolgens ga ik kijken naar mijn xorg maar zijn geen een van de veranderingen opgeslagen en staat alles nog hoe het orgineel was.

Hoe kan dit?

Offline siegi

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #15 Gepost op: 2008/02/24, 18:17:00 »
Hoe slaag je een bestand op met vim?
escape :wq (is de juiste procedure).

Maar als ik jouw was zou ik gewoon gedit gebruiken dit is lekker grafisch.

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #16 Gepost op: 2008/02/24, 19:42:21 »
Nou de ATI driver heb ik aan de praat!!!

Nu het volgende probleem:

Wanneer ik mijn visuele effecten wil aanpassen krijg ik het volgende bericht:

Desktop effects could not be enabled

Vervolgens tik ik "compiz" in in de console en dan krijg ik het volgende bericht:

Checking for Xgl: not present.
Blacklisted PCIID '1002:4153' found
aborting and using fallback: /usr/bin/metacity

Hoe kan ik dit oplossen?

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Visuele effecten
« Reactie #17 Gepost op: 2008/02/25, 00:31:22 »
Zo te zien werkt je kaart niet goed met compiz, wil je het toch echt proberen, kun je compiz proberen te staten met dit commando

SKIP_CHECKS=yes compiz
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #18 Gepost op: 2008/02/25, 19:55:59 »
Zo Jongens,

Ik ben weer een stuk verder!!

- Amarok loopt goed via de Mysql en dat gaat prima nu met nummers wisselen!

- Mijn ATI 9550 heb ik aan de praat met de restricted drivers. En heb nu direct rendering.

- Compiz kreeg ik ook aan de praat door mijn kaart van de blacklist te halen.

- Bij uiterlijke voorkeuren en dan visuele effecten kan ik aangeven hoe mij desktop eruit ziet.

Bij het laatste punt gaat het dus ook mis. Wanneer ik opnieuw opstart gaat alles normaal. Ik kan inloggen en kom in Ubuntu. Vervolgens kan ik zien hoe leuk het desktop verwisseld. Maar wanneer ik naar een snelmenu ga klapt Ubuntu eruit.

Op dit moment ben ik zover dat het een sport is geworden om het toch voor elkaar te krijgen.

Nu, zijn er forum bezoekers die wellicht een oplossing hiervoor hebben?

Onderwel ga ik natuurlijk zelf ook nog opzoek naar oplossingen en als ik die vind laat ik dat weten.

groeten en hopelijk hebben jullie nog tips!

AronVanAmmers

  • Gast
Visuele effecten
« Reactie #19 Gepost op: 2008/03/06, 23:14:01 »
Een tip om de CPU usage van Amarok onder Compiz te verminderen: schakel de visualizations uit. Ik had altijd het standaard equalizertje aan staan. Xorg nam dan 30% CPU als Amarok zichtbaar was. Met de visualizations uit is dat nog maar 10%.

(hier gevonden)

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #20 Gepost op: 2008/03/14, 01:15:35 »
Beste allen,

Na heel veel uitproberen is het me gelukt!!!! en wel met Hardy Heron!

Alles werkt nu optimaal en zonder problemen!

Ik ben blij dat ati onder Hardy Heron (ook al is het nog maar een alfa) in een keer werkt!!

Groeten,

Hugo

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #21 Gepost op: 2008/03/14, 02:09:33 »
Hou der wel ff rekening mee dat morgen of bij de volgende update van HH je pc het misschien niet meer doet !
En je hem opnieuw moet installeren.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline hbijlsma

  • Lid
  • Steunpunt: Nee
Visuele effecten
« Reactie #22 Gepost op: 2008/03/14, 19:18:20 »
Citaat van: Gandyman
Hou der wel ff rekening mee dat morgen of bij de volgende update van HH je pc het misschien niet meer doet !
En je hem opnieuw moet installeren.
Bedankt voor de waarschuwing maar hoezo dan?

------------------Edit-----------------

Heb het gezien.