Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: .run files krijg ik niet aan de praat  (gelezen 744 keer)

Relinquish

  • Gast
.run files krijg ik niet aan de praat
« Gepost op: 2008/02/18, 13:00:41 »
Hallo allemaal, kon niet lang uitblijven natuurlijk sinds de installatie van ubuntu 7.10 op dit keer mijn vaste PC.

Ik ben nogal een gamefanaat en ik mag graag Unreal Tournament (UT'99) spelen. Nu is daar wel linux software voor te krijgen (altijd handig) maar ik krijg die niet aan het werken. Een paar spelers van een amerikaanse server spelen ook met een Linux systeem (RedHat) dus ik weet dat het werken moet.

Ik krijg bij gedit de melding:

" Kan het bestand 'home/veronique/ut-install-436-GOTY.run' niet openen met gebruikmaking van de Unicode (UTF-8)-tekencodering. Ga na of u niet probeert om een binair bestand te openen. Selecteer een andere codering uit het menu en probeer het opnieuw."

Ben niet de grootste schijtert, dus ik probeer de andere codering: Westers (ISO-8859-15)

Zelfde melding alleen dan natuurlijk de andere tekencodering vermeld.

Ik had dit met mijn drivers van mijn grafische kaart ook. Heb ik goddank een merk wat linuxdrivers uitgeeft krijg ik ook daar de .run file niet mee aan de praat!

Nu ben ik nogal een noob met linux, ik draai het al een tijdje op mijn laptop (7.04) maar met openoffice was ik daar klaar met installeren, dit keer heb ik wat meer software nodig en ik ben nu al met Wine aan de slag (lang leve het forum) om de UT software installeren (wat overigens ook niet erg lukt, cd met .exe natuurlijk weer...zucht) maar het moet op de een of andere manier toch wel werkend te krijgen zijn of ben ik nu achtelijk aan het worden? De documentatie heb ik al doorgelicht, maar daar staat over dit specifieke probleem niets vermeld en de zoekmachine geeft ook niets aan met betrekking tot .run files.

Zolang je niet de sloomheid van XP eist kan Linux toch alles zo'n beetje wel aan of niet? Wie o wie kan mij helpen en mijn clangenoten blij maken?

Edit: installatie van UT zelf is inmiddels gelukt het goed laten draaien is echter een tweede...

Offline Sjoerd Broekhuijsen

  • Forumteam
  • Steunpunt: Nee
.run files krijg ik niet aan de praat
« Reactie #1 Gepost op: 2008/02/18, 17:06:42 »
Hoe heb je hem geinstalleerd?
Je zou hem moeten kunnen installeren via de terminal:

cd *De map waar hij in staat bv* (/home/ubuntu/unreal)
Hier is ubuntu jouwn gebruikersnaam en unreal de map waar je run bestand in staat.

Dan doe je sudo chmod +x unreal.run    (het kon ook chmod unreal.run +x zijn, ik ben niet 100% zeker)
hier is unreal.run de naam van het .run bestand, dit moet je dus vervangen door hoe het bestand heet.

dan sudo ./unreal.run
weer dus unreal  vervangen door hoe het run bestand heet, Als het goed is zou het zo moeten werken
PC: Processor - AMD Athlon II X4 640 (quad core, 3.0GHz), 4GB DDR2 RAM 800MHz, Videokaart: ATI Sapphire HD4850 met 512MB geheugen, 500gb 7200RPM HDD, Ubuntu 12.04 LTS

Wat doe je als je vraag is opgelost?

Relinquish

  • Gast
.run files krijg ik niet aan de praat
« Reactie #2 Gepost op: 2008/02/18, 18:37:17 »
Heb hem nu via Wine enigzins aan de slag gekregen, maar de resultaten zijn niet om naar huis te schrijven. Begrijp echt geen donder er meer van, ben vandaag inmiddels al dik 8 uur bezig om UT alleen al aan de praat te krijgen (afgelopen nacht niet eens meegerekend) en hem fatsoenlijk te laten draaien met openGL (aan openGL ben nog niet eens aan toegekomen) bash, sh, mount /cdrom ik heb een hele gebruiksaanwijzing gevonden hoe ik hem zou moeten laten werken maar op de een of andere manier krijg ik het maar niet voor elkaar.

Ben al geen linux held, op mn laptop draait hij gewoon standaard, daar ben ik overigens ook nog nooit in de terminal geweest, maar ik weet dat het k

Relinquish

  • Gast
.run files krijg ik niet aan de praat
« Reactie #3 Gepost op: 2008/02/18, 20:37:34 »
EDIT: UT er weer afgegooid, het lijkt echt een begin zonder einde. Linux en vrouwen gaan NIET samen, dat blijkt wel weer! Zag er even hoopgevend uit maar het draait voor geen meter, dus ergens doe ik wat fout...

Wonderbaarlijkerwijs draait het systeem nog steeds na bijna 12 uur rommelen in de Terminal, verbaasd me eigenlijk wel een beetje.

Gebruikelijke rijtje commandos:

veronique@veronique-desktop:~$ cd /home/veronique/UnrealTournament
veronique@veronique-desktop:~/UnrealTournament$ sudo chmod +x UTI.run
veronique@veronique-desktop:~/UnrealTournament$ sudo ./UTI.run
Verifying archive integrity...tail: Warning: "+number" syntax is deprecated, please use "-n +number"
[: 133: 2341625838: out of range
OK
Uncompressing Unreal Tournament version 436 Linux installtrap: 154: cd /tmp; /bin/rm -rf $tmpdir; exit $res: bad trap
veronique@veronique-desktop:~/UnrealTournament$

Het bestand staat hier: /home/veronique/UnrealTournament
Het bestand heet: UTI.run (werd achtelijk om elke keer die lange naam in te voeren dus heb een kortere gegeven)