Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: microcode "bcm43xx_microcode.fw"  (gelezen 2292 keer)

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Gepost op: 2008/02/15, 19:50:19 »
Ik ben al een tijdje ge├»nteresseerd  in het werken met *nix systemen, zelf werk ik regelmatig met MAC en vond het tijd om over te stappen op linux Ubuntu, heb dus de nieuwste versie gedownload van hier en geinstaleerd, ging allemaal prima maar bij het opstarten geeft die een melding dat het bestand "bcm43xx_microcode.fw" niet gevonden kan worden.  Wat ik al gevonden heb is dat het met de driver voor het wireless internet te maken heeft.

Alleen hij wil nu niet verder door starten. hoe kan ik het zo maken dat hij dit omzeild?
En ook een oplossing ervoor zou erg fijn zijn, want het netwerk moet wel werken.

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #1 Gepost op: 2008/02/16, 11:19:34 »
*Kick*

Heeft iemand misschien een oplossing voor dit probleem??

Offline Dorst

  • Lid
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #2 Gepost op: 2008/02/16, 11:24:59 »
Heb je die driver al geactiveerd onder Beheer >> Beperkt ondersteunde stuurprogramma's?

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #3 Gepost op: 2008/02/16, 11:25:50 »
Ik kan nergens in, hij wil niet doorstarten. hij doet een paar hardware checks en dan blijft die zeuren over "bcm43xx_microcode.fw" .

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
microcode "bcm43xx_microcode.fw"
« Reactie #4 Gepost op: 2008/02/16, 12:06:26 »
Waarschijjnlijk is het niet de broadcom-driver die het probleem geeft. Dat lijkt misschien zo omdat dat de laatste (fout-) melding is die je ziet.

Kijk eens in deze draad waar zich iets soortgelijks heeft voorgedaan:
http://forum.ubuntu-nl.org/message/143504

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #5 Gepost op: 2008/02/16, 12:22:31 »
Ik heb in de bios nu de kaart uitgeschakeld, maar nu kom ik nog niet verder, hij blijft hangen in de check.
Hij stopt na: *running local boot scripts (/etc/rc.local)            [ok]

Als ik /var/log/messages intik dan geeft die een permission denied aan.
Dus ik kan ook niet de log bekijken

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #6 Gepost op: 2008/02/17, 22:37:55 »
* Kick *

Nog steeds het zelfde probleem, niemand oplossing??

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #7 Gepost op: 2008/02/18, 08:43:01 »
hebt ge toevallig ubuntu 7.04? ik denk dat dit is opgelost in de nieuwste versie, 7.10...

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #8 Gepost op: 2008/02/18, 10:50:43 »
Ik heb Ubuntu 7.10 (Gutsy Gibbon) gedownload. Dus dat zou goed moeten zijn.
Het gaat trouwens over een HP campaq 6715s

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #9 Gepost op: 2008/02/18, 11:26:43 »
doe eens: sudo nano /var/log/messages
dat zou het moeten doen...

ik kom er niet zo meteen aan uit...volgens mij is het een probleem met de grafische omgeving...
klopt het dat ge deze kaart hebt? ati radeon xpress 1250?

doe eens: sudo dpkg-reconfigure -phigh xserver-xorg
kies daar voor de vesa driver, als ge terug in de console zijt typt ge: startx

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #10 Gepost op: 2008/02/18, 14:18:05 »
Pakket 'dpkg-reconfigure' is niet geinstaleerd en geen info beschikbaar
Pakket 'dpkg --info (= dpkg-deb --info_ om archiefbestanden te bekijken,
gebruik dpkg --contents  (= dpkg-deb contents_ om de inhoud weer te geven

Verder kom ik hier niet mee, nu las ik dat het misschien aan het breedbeeld scherm kan liggen? Zal het helpen als ik hem aan een oude CRT 4:3 hang??

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #11 Gepost op: 2008/02/18, 17:24:04 »
Oke, ik heb het geprobeerd op een oude 4:3 scherm, maar het blijft het zelfde !

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #12 Gepost op: 2008/02/18, 17:29:05 »
volgens mij ligt het gewoon aan de grafische kaart (maar ik kan er ook totaal naast zitten natuurlijk!)...ik weet niet of ge het al gelezen hebt, maar ati kaarten zijn (nog) niet zo vriendelijk met linux...

ik heb even geen idee meer, maar zal deze avond nog eens wat rondpluizen, misschien kom ik wel iets helpends tegen...

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #13 Gepost op: 2008/02/18, 19:59:36 »
Ja had het al wel gelezen, het zou erg fijn zijn als je wat vind! Ga zelf ook nog even goed opzoek, maar blijft jammer dat Ati neit goed ondersteunt word maar die fout ligt grotendeels bij hun.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #14 Gepost op: 2008/02/19, 09:43:00 »
ok, ik heb misschien iets gevonden...het was een duits forum, maar ik heb dit eruit kunnen opmaken:

kies in grub voor recovery mode...als ge uw gebruikersnaam en wachtwoord hebt opgegeven zit ge in de command line...
daar typt ge:
sudo nano /etc/modules    (ik denk niet dat sudo moet, volgens mij zijt ge al root in recovery mode...dat ziet ge aan $=user of #=root)
voeg onderaan dit bestand dit woord toe:
fglrx

deze file opslaan en nano afsluiten...terug in de console typt ge:    (hiervoor hebt ge wel een werkende internet verbinding nodig, dus gebruik geen draadloos, want dat zal nog niet ingesteld zijn)
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux restricted modules $(uname r)
sudo apt-get install xorg driver fglrx
depmod A   (hier ben ik niet zo zeker van of het gaat werken...ik zou eerder "depmod -a" of "depmod -A" proberen)

dan typt ge:
sudo nano /etc/X11/xorg.conf   (let hier op de hoofdletter X)
in dat bestand zoekt ge naar:
section "device"
in dat blokje staat normaal gezien iets van:
Identifier "ATI Radeon Xpress ..."
Driver "vesa"

verander het woord "vesa" in "fglrx"...even opslaan, afsluiten en typ in de commandline:
reboot

probeer nu eens normaal op te starten...

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #15 Gepost op: 2008/02/19, 22:04:44 »
Oke ik heb het nu allemaal geprobeerd, maar nog steeds niks.
Hij geeft na de hardware checks niks meer aan maar door starten doet die nog niet.

Ook bij het dat bestand identifier staat geen Ati radeon Xpress... maar iets van generieke videokaart of iets dergelijks.
Kan ik dit aanpassen in Ati radeon Xpress 1250 ?

In ieder geval al erg bedankt!

Edit: Heb het even geprobeerd, bij verandering van de naam wil die helemaal niet meer opstarten en vraagt die om een login en pass waarnaar die alleen nog een command line geeft.  Na dit terug gezet te hebben werkt alles weer redelijk zoals het was. Hij komt met de checks nu tot * Running local boot scripts (/etc/rc.local)               [ok]

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #16 Gepost op: 2008/02/20, 09:22:41 »
hmm...en hij heeft geen fouten gegeven bij de commandos?  ik heb trouwens een foutje gevonden...
sudo apt-get install linux restricted modules $(uname r)
moet:
sudo apt-get install linux restricted modules $(uname -r)
worden (het streepje voor de r)
*edit: nog een foutje gevonden:
sudo apt-get install xorg driver fglrx
moet worden:
sudo apt-get install xorg-driver-fglrx

ook gek dat het iets uitmaakt als ge die naam veranderd...

normaal zou het systeem deze file zelf kunnen aanpassen door het commando:
sudo dpkg-reconfigure xserver-xorg
maar ben er nog niet aan uit waarom dat niet werkt bij u...

nuja, ik heb ook even gekeken naar dat rc.local gedoe...dit is wat er bij mij in /etc/rc.local staat:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0
dus zou hij eigenlijk door moeten gaan bij succes of fout...open deze file ook eens:
sudo nano /etc/rc.local
en kijk of er bij u op het einde ook "exit 0" staat en niks anders zonder een # ervoor...


ik zou bijna zeggen om eens een re-install te doen van ubuntu...had ge eigenlijk internet verbinding tijdens de installatie?

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #17 Gepost op: 2008/02/20, 11:42:39 »
Bij mij staat er precies het zelfde, dus hier kan het niet aan liggen denk ik.
Bij de installatie had ik geen internet, kan dat een probleem zijn? Ik kan het anders inderdaad wel even herinstalleren en dan met internet.

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #18 Gepost op: 2008/02/20, 14:55:03 »
Oke, ik heb net alles opnieuw geïnstalleerd, met internet eraan. Helaas nog steeds het zelfde probleem.
Ik heb al weer geprobeerd met dat apt-get update enzo maar ook dit werkt niet. Ik kom nu wel verder en hij geeft aan dat hij nl.archive.ubuntu.com niet kan bereiken. dit is bij sudo apt-get install xorg-driver-fglrx.

Een internet verbinding heeft die wel, want met installeren heeft die ook dingen gedownload.

utopiamedia

  • Gast
microcode "bcm43xx_microcode.fw"
« Reactie #19 Gepost op: 2008/02/24, 19:15:22 »
Helaas dus niemand die een oplossing heeft voor dit probleem?

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
microcode "bcm43xx_microcode.fw"
« Reactie #20 Gepost op: 2008/02/25, 09:25:24 »
hmm zijt ge zeker dat ge internet verbinding hebt? waarschijnlijk is de network daemon nog niet gestart dan in recovery mode...typ daar eens: ping www.google.be
dan kunt ge zien of hij verbinding maakt...

Offline Remco

  • Lid
    • http://remcovs.blogspot.com/
  • Steunpunt: Ja
microcode "bcm43xx_microcode.fw"
« Reactie #21 Gepost op: 2008/02/25, 10:10:26 »
Ik heb gisteren dezelfde laptop voor slowfox gefixd:

gebruik de 64 bit alternate
installeer met een bekabelde internetverbinding en wifi uit (knopje op je laptop)
na installatie heb je nog geen grafische omgeving
doe:
ctrl alt F1
login en geef password
sudo apt-get install xorg-driver-fglrx
sudo aticonfig --initial
startx

bron:
http://www2.informatik.hu-berlin.de/~jbirkhol/hp6715/index.html

succes