Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Externe schijf .  (gelezen 4004 keer)

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Gepost op: 2008/02/07, 13:21:53 »
Op advies van Lizardman .

Ik heb onlangs Ubuntu geinstalleerd , begin het een klein beetje te begrijpen .
Maar ik krijg met de beste wil van de wereld mijn externe schijf niet aangekoppeld , heeft iets met mounten oid. te maken .
Steeds komt het kadertje " Kan My Book niet aankoppelen " .
Heb ook nog Ubuntu opnieuw geinstalleerd, zonder My Book te ontkoppelen ,
maar ook dat wil niet helpen .
Weet iemand hoe dit op te lossen is ?

Bij voorbaat dank en met vriendelijke groet : Ad .

Offline vanadium

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #1 Gepost op: 2008/02/07, 13:43:44 »
Een mogelijke reden waarom een externe USB schijf niet automatisch koppelt is dat het een schijf is waarvan het bestandssysteem beschadigd is. Uit jou informatie kunnen we echter slechts raden naar de oorzaak. Probeer eens de volledige foutmelding hier weer te geven. Als dat niet kan, voer dan eens in een commandoterminal, met de schijf aangekoppeld, volgend commando uit en kopieer en plak de output hier:

sudo fdisk -l

Op die wijze kunnen we zien hoe je systeem de schijf herkent, en instructies geven over hoe je die in de terminal kan proberen aan te koppelen, zodat we duidelijk de foutmeldingen kunnen zien en interpreteren.

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #2 Gepost op: 2008/02/07, 16:51:51 »
Heel goed advies , geachte vanadium .

Ik heb er helaas niets aan , daar ik niet weet wat sudo is en hoe of dat werkt .
Ook heb ik " Terminalvenster " geprobeerd , maar ik denk dat die zijn benaming iets te letterlijk neemt .
En dat mounten en weet ik wat voor toestanden nog meer , wat ik heb geprobeerd , blijkt , voor mij althans , onmogelijk omdat ik daarvoor de rechten niet zou bezitten .
Iets met  " administrator " en " root " .
Daar ik persoonlijk voor deze computer (Acer Aspire L 100) betaald heb dacht ik hem ook eigendom te mogen noemen en derhalve
niet alleen eigenaar , maar ook " administrator " alsmede " root " te zijn en dus álle rechten bezit .
Misschien kan u me uitleggen wat deze twee woordjes betekenen dan wel inhouden of hoe
ik de handel aanpas aan mij persoonlijk .

Verder kan ik u niet uitleggen of duidelijk maken wat ik verkeerd doe ivm. de externe harde schijf .
De schijf staat wel in de bestandsbladeraar , maar aankoppelen is onmogelijk .
Helaas is dit alles wat ik u kan uitleggen .

Toch dank ik u voor uw reactie .

Met vriendelijke groet : Ad

Offline lizardman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #3 Gepost op: 2008/02/07, 19:44:53 »
Beste WizzAd,
Nog even een zetje in de goede richting ;-)
Allereerst zou ik je, nogmaals, willen adviseren de documentatie eens door te lezen. http://www.ubuntu-nl.org/documentatie/
Op deze pagina's staat ook in heel heldere en begrijpelijke taal vanalles uitgelegd.http://computertip.googlepages.com/ubuntulinux

Het terminalvenster start je dmv: Toepassingen-->Hulpmiddelen-->Terminalvenster
het sudo commando verleent je nadat je het wachtwoord hebt ingegeven administrator rechten.
Dus als je in de terminal ingeeft:
sudo fdisk -ldan zal er eerst om je wachtwoord gevraagd worden. Als je dit ingeeft (je zult niets zien gebeuren, zelfs geen sterretjes) en dan entert dan zal het commando worden uitgevoerd.

Meer over hoe een en ander werkt kun je zoals gezegd op de gegeven links vinden.

suc6
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #4 Gepost op: 2008/02/07, 20:00:23 »
Ik had je ervaring wat hoger ingeschat, aangezien je Ubuntu hebt geïnstalleerd. Dat pleit voor het gebruiksgemak van de Ubuntu installatie :-) . Waar ik ook aan denk als mogelijke oorzaak is dat je schijfvolume een spatie bevat: misschien veroorzaakt dat het probleem. Je zou je schijf eens kunnen hernoemen naar "My_Book \" in plaats van "My Book". Goed mogelijk dat dat reeds het probleem oplost.

Hoe je het label onder linux verandert, hangt af van het bestandssysteem. En ja, je hebt weer de terminal nodig. Het eenvoudigst voorlopig is misschien de schijf onder Windows aan te koppelen en te hernoemen, als het een fat of ntfs bestandssysteem betreft, tenminste (wellicht wel).

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #5 Gepost op: 2008/02/07, 20:44:56 »
Geachte lizardman en vanadium .

Gelooft u mij , ik heb alle documentaties , adviezen en tips niet 1 maar wel tig keer gelezen .
En deze adviezen opgevolgd , zonder eigenwijs te zijn , sterker nog ; Computertip bij de bladwijzers gezet .
Het is ook niet dat Ubuntu niet werkt , al doende leert men , dus ik hou stug vol , immers terug naar XP
is onmogelijk , doch voor ik Ubuntu ging installeren heb ik My Book onder XP afgekoppeld
en alle pluggen verwijderd .
Het gekke aan heel deze toestand is dat met de installatie -cd , dus voor de eigenlijke installatie , de
externe harde schijf wél gewoon herkend werd en dus ook gewoon te gebruiken viel .
De externe schijf is ook nu gewoon aangeduid als My Book .
Maar , nogmaals ; het aankoppelen is niet mogelijk .
En uw advies betreffende terminal ; dit scherm wordt hier geeneens zichtbaar , laat staan dat ik iets kan typen .
Is Ubuntu verwijderen en opnieuw installeren een optie ?
Voor ik het vergeet ; ik kan XP niet herinstalleren omdat ik geen herstel-cd bij de pc heb gevonden .
Voorheen ging dat wel met de back-up dvd , maar die laat het nu ook afweten .
Het spijt me als ik u ontrief , maar gelooft u mij : Ik heb hier een nog grotere hekel aan dan u beiden .

Bij voorbaat dank en met vriendelijke groet : Ad .

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Externe schijf .
« Reactie #6 Gepost op: 2008/02/07, 20:51:12 »
Probeer eens dit:

Locaties - Computer

Komt de My Book nu in beeld? Zoja, dubbelklikken en desgevraagd wachtwoord ingeven. Als het goed is, wordt de My Book nu ad hoc aangekoppeld. Op het bureaublad verschijnt een snelkoppeling die je kunt dubbelklikken om de bestanden op de My Book te bekijken.

Het is een ad hoc oplossing die tijdelijk is; na herstart van je PC is de aankoppeling verdwenen.

Wereldvreemd

  • Gast
Externe schijf .
« Reactie #7 Gepost op: 2008/02/07, 21:20:48 »
Beste mensen, ik besef dat mijn reactie inhoudelijk niets toevoegt, maar mag ik even opmerken dat ik Ad's doorzettingsvermogen als zeer bewonderenswaardig ervaar !
Ik hoop oprecht dat dit technische hobbeltje genomen kan worden en ben er van overtuigd dat met de attitude van Ad het dan zeker helemaal goed gaat komen met zijn Ubuntu-avontuur.
Hou vol !
suc6
Wereldvreemd

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #8 Gepost op: 2008/02/07, 21:37:57 »
Als ik probeer My Book aan te koppelen krijg ik het volgende bericht ;

Kan volume niet aankoppelen .
Ongeldige mount optie bij het aankoppelen van het volume "My Book "  .

Klik ik dan op details verschijnt het volgende :

$Log File indicates unclean shutdown(0,0).
Failed to mount '/dev/sdb1 ' :Operation not supported.
Mount is denied because NTSF is marked to be in use .
Choose one action :
Choise 1 : If you have Windows then disconnect the external devices
by clicking on the ' Safely Remove Hardware ' icon in the Windows
taskbar , then shutdown Windows cleanly .
Choise 2 : If you don't have Windows then you can use the "force " option for your own responsibility .
For example type on the command line : mount - t ntfs-3g/dev/sbd 1/media/My Book-0 force .
Or add the option to the relevant row in the /etc/fst ab file :
/dev/sbd1/media/My Book ntfs-39defaults, force 00 .

Dit is alles wat ik te zien krijg .
Misschien kan een van u hier iets mee .

Ook nu weer : Bij voorbaat dank en met vriendelijke groet : Ad .

PS : Hecht niet teveel waarde aan de naam WizzAd , eigenlijk hoort er een plaatje bij van
Tommy Cooper .....

Offline lizardman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #9 Gepost op: 2008/02/07, 22:43:35 »
Zo'n melding heb ik reeds eerder gezien, en was inderdaad van een windows machien die niet juist was afgesloten.
Door de schijf toen geforceerd te mounten kwam het weer in orde.
je zou eens kunne proberen om op de commandline (dus in de terminal) de voorgestelde regel van choice 2 te kopierenvan de melding die je te zien krijgt dus zoiets als:sudo mount -t ntfs-3g /dev/sbd1 /media/My Book -0 forceIk weet niet zeker of ik het hier precies goed heb geschreven, maar het is bedoeld om aan te geven om welke regel uit de melding het gaat.

als je daarna de schijf netjes hebt ontkoppelt, of de computer restart zou hij de schijf wel moeten kunnen mounten.
Hopelijk lukt het hiermee.
suc6

edit** Ik had je post niet goed gelezen, je kunt dus geen terminal oproepen?

Je kunt waarschijnlijk toch nog eem terminal venster bereiken doormiddel van de toetscombinatie ctrl-alt-f1  je krijgt dan een DOS achtig beeld waar je je kunt aanmelden met je gebruikernaam en wachtwoord. je bent dan als het ware twee maal aangemeld bij Ubuntu. Daar kun je dan de commandos intikken en uitvoeren.
Je kunt weer terug in de grafische omgeving komen door ctrl-alt-f7 te doen.

Maar het feit dat je geen terminalvenster kunt oproepen is geen goed teken, er is dan waarschijnlijk iets niet helemaal goed gegaan bij de installatie.

Er zijn op het forum beslist mensen die hier meer verstand van hebben, hopelijk lezen ze dit draadje..
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #10 Gepost op: 2008/02/08, 02:58:09 »
@lizardman
ff de regel gekopieerd voor hem, je had wat spaties ertussen zitten die er niet horen :P

mount - t ntfs-3g/dev/sbd 1/media/My Book-0 force@WizzAd

eerst ff over die terminal ??

Op de bovenbalk van het scherm zie je linksboven Toepassingen staan.
Indien je daarop klikt krjg je een aantal zaken waaruit gekozen kan worden.

je ziet dan ook staan: Hulpmiddelen

Indien je hierop klikt krijg je een uitgeklapt menu waar weer een aantal zaken staan.
hier zie je ook Terminalvenster staan.

indien je hierop klikt opent er een klein schermpje.

Vervolgens ga je met de muis op de eerste letter staan van de regel in het schempje in mijn postje hieronder.
sudo mount - t ntfs-3g/dev/sbd 1/media/My Book-0 forceNu druk je de linkermuisknop in, en houd deze ingedrukt en ga dan met de muis over de hele regel heen totdat hij gekleurd is.
Laat nu de muis knop los.

Druk nu de rechtmuisknop in en kies kopieeren.
klik nu in het terminal schermpje met de linkermuistoets en klik dan weer op de rechtmuistoets en kies PLAKKEN.
Nu staat de regel helemaal in de terminal

klik nu op enter.
Typ je wachtwoord en offer eventueel een geit :P

Indien Ubuntu zijn werk netjes kan doen zal de harddisk gemount worden.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline vanadium

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #11 Gepost op: 2008/02/08, 09:30:43 »
Beste WizzAd, je ziet dat je er dan toch komt de foutmelding te procuderen, en die bevestigt dat de oorzaak is wat ik aangegeven heb in mijn eerste antwoord (toen moest ik dat raden, nu ben ik het zeker).

Wat je best kan doen is de schijf aankoppelen aan een Windows machine (er zijn er nog genoeg in omloop!). Doe er een schijfcontrole. Sluit dan windows volledig af (géén hibernatie, maar volledig afsluiten)! Start dan voor alle zekerheid met de schijf aangekoppeld Windows  terug op, sluit dan weer volledig af en koppel dan de schijf af. Ik garandeer dat ze nu automatisch zal gekoppeld worden.

Wacht nog maar met de optie van geforceerd mounten van hierboven. De opgegeven regel is trouwens niet correct en dan zijn we nog verder van huis.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #12 Gepost op: 2008/02/08, 12:18:26 »
@Gandyman
Ik was er al niet helemaal zeker van ;)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #13 Gepost op: 2008/02/08, 16:32:00 »
Nog even een paar vraagjes .

Sorry , maar ik heb er weer een paar bedacht .

Heb met het nodige geluk (denk ik) XP weer aan de praat gekregen , met dien verstande dat de gehele harde schijf
nu door XP gebruikt wordt , waar het eerst twee (C en D) delen waren .
Is dit in mijn voordeel , ivm. partitionering , mocht ik besluiten Ubuntu opnieuw te installeren ?
Is het ook nu noodzakelijk om schijfdefragmentatie toe te passen ?
Ook al heb ik vanmiddag de gehele schijf geformatteerd ?
Ook heb ik vanmiddag een Linux Starter magazine , met bijgeleverd Ubuntu 7.10 Gutsy Gibbon schijfje , gekocht .
Kan iemand van u mij vertellen of dit schijfje beter is dan het ISO schijfje wat ik zelf brandde ?
Neemt u mij niet kwalijk dat ik weer mijn toevlucht tot XP zocht , maar dat was in mijn optiek de enigste
mogelijkheid om uw adviezen op te volgen dan wel uit te voeren .
Toch dank ik u allen oprecht , ook voor uw geduld .

Ook bij voorbaat dank voor uw nieuwe adviezen .

Met vriendelijke groet : Ad .

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #14 Gepost op: 2008/02/08, 16:52:26 »
Ik ben je ff kwijt want ik dacht dat het om een externe HD ging ??

maagoe
Nu je xp toch aan de gang hebt kan je gelijk die externe HD eens netjes afkoppelen in xp.
Op die manier voorkom je problemen voor de toekomst.

hoe je een goede dual boot maakt kan je hier lezen:
http://www.ubuntu-nl.org/documentatie/installatie/dualboot_gutsy/
Schrijf de URL op zodat je in de Live-cd naar die site kan gaan en terwijl je Ubuntu installeerd kan je stap voor stap de installatie doen.

Kijk dat is nou de kracht van Ubuntu-linux, werken en installeren tegelijk.

Sja, of een gekochte/gedrukte cd beter is dan een zelf gebrande ??
Zou wel zo moeten zijn he ??

Ikzelf gebruik goede kwaliteit hardware en media om op te branden dus heb nooit last van iets wat half werkt.
WBT de houdbaarheid zou een gedrukte langer moeten kunnen leven dan een zelfgebrande media.

mja
Met een nieuwe uitgaven iedere 3 jaar van Ubuntu maak ik me daar niet zo druk over. :P
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #15 Gepost op: 2008/02/08, 17:13:39 »
Geachte Gandyman .

Sorry dat ik vergat te vermelden dat het om die externe schijf gaat .
Maar dat euvel was blijkbaar enkel maar dmv. Xp op te lossen .
Nu ga ik het aan de hand van het magazine opnieuw proberen .

Ook nu weer : Dank voor uw bijdrage .

Met vriendelijke groet : Ad .

Offline lizardman

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #16 Gepost op: 2008/02/08, 18:18:29 »
Vergeet niet om de adviezen van vanadium betreffende de schijfcontrole op de externe schijf op te volgen.
Om herhaling van het probleem te voorkomen :)

suc6
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #17 Gepost op: 2008/02/08, 20:38:38 »
Citaat
Maar dat euvel was blijkbaar enkel maar dmv. Xp op te lossen .
Dat komt omdat niet alle facetten van ntfs ondersteund zijn in Linux. Als je ooit enkel Linux wil gebruiken, dan zet je de schijf beter om naar het ext3 bestandssysteem (of een ander Linux bestandssysteem).

Er bestaat ook een tool ntfsfix onder Linux, en wellicht kom je daar al een heel eind mee. De beschadigde schijf kan je ook "geforceerd" mounten, (en op eigen risico). Dan kan je de gegevens nog overzetten naar een andere schijf, om daarna de schijf te herformatteren. Je mag echter nooit gewoon blijven doorwerken met geforceerd mounten.

Offline WizzAd

  • Lid
  • Steunpunt: Nee
Externe schijf .
« Reactie #18 Gepost op: 2008/02/08, 21:56:51 »
Ook nu weer : Dank voor uw advies , geachte vanadium .

Het lag echter niet aan de schijf of wat dan ook , het lag aan mij .
Ik dacht er zeker van te zijn de schijf afgekoppeld te hebben onder XP , maar later bleek dat ik bij
de installatie van Ubuntu de hele schijf geformatteerd heb , zodoende ook XP verwijderde , waardoor het onmogelijk werd de schijf veilig af te koppelen .
Dus nu ben ik ervan overtuigd dat de schuld bij mij ligt .
Maar , wees niet bang , dit forum met al haar leden is nog lang niet van me af , met dien
verstande dat mijn aanpak nu wat rustiger zal zijn .
Ik ben nu voorzichtig begonnen met het verkennen van een blad genaamd " Linux Starter " en
het bijgeleverde Gutsy Gibbon schijfje .
En inderdaad wordt My Book nu wel herkend en is ook bruikbaar , voorlopig nog met het
opstart/installatieschijfje .
Dus vroeg of laat komt alles goed .

Nogmaals dank voor eenieder die mij van raad , advies en opbeurende woorden heeft voorzien .

Met vriendelijke groet : Ad .

    Hecht niet teveel waarde aan de naam WizzAd ....