Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: sudo  (gelezen 1246 keer)

Offline Stormzoeker

  • Lid
  • Steunpunt: Nee
sudo
« Gepost op: 2008/02/07, 11:41:21 »
Gisteren deed ie het nog, vandaag krijg ik 'unable to resolve host ' als ik iets met sudo of kdesu wil uitvoeren. Wel een hoop updates binnengekregen vanmorgen. Ik gebruik Hardy. Iemand die mij kan helpen met een oplossing?
[AMD X2 4600+] [8GB geheugen] [540 GB + 2 x 200 GB + 1 x 320 GBHD] [Kubuntu 8.10 + Vista Home Premium]

Paat

  • Gast
sudo
« Reactie #1 Gepost op: 2008/02/07, 11:45:09 »
dude, waarom heb je een avater van XP ? :P

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
sudo
« Reactie #2 Gepost op: 2008/02/07, 11:55:18 »
Wat krijg je te zien als je het commando hostname uitvoert?

Wat staat er in /etc/hostname ?
Daar zou de naam van je computer moeten staan.

Wat staat er in /etc/hosts?

Waarschijnlijk moet je via de recovery mode of een live cd die bestanden herstellen.

Offline Stormzoeker

  • Lid
  • Steunpunt: Nee
sudo
« Reactie #3 Gepost op: 2008/02/07, 11:59:34 »
Citaat van: Johanvd
Wat krijg je te zien als je het commando hostname uitvoert?

Wat staat er in /etc/hostname ?
Daar zou de naam van je computer moeten staan.

Wat staat er in /etc/hosts?

Waarschijnlijk moet je via de recovery mode of een live cd die bestanden herstellen.
Ik had het inderdaad (in een zeldzaam helder moment van mijn kant) net opgelost via recovery mode. In hosts stond wel 127.0.0.1 maar het fixed ip-adres stond er dus niet. Alleen vreemd dat sudo plotseling besloot er mee op te houden ;) Sudo apt-get upgrade deed het vanmorgen nog als een zonnentje...
[AMD X2 4600+] [8GB geheugen] [540 GB + 2 x 200 GB + 1 x 320 GBHD] [Kubuntu 8.10 + Vista Home Premium]

Offline Stormzoeker

  • Lid
  • Steunpunt: Nee
sudo
« Reactie #4 Gepost op: 2008/02/07, 12:05:58 »
Citaat van: Paat
dude, waarom heb je een avater van XP ? :P
Ik vind de kleurtjes zo mooi :P

Citaat van: arie
dat is zoiets als met je feyenoord  t-shirt naar amsterdam gaan :)
Mag het ook een Heerveenshirt zijn? :P
[AMD X2 4600+] [8GB geheugen] [540 GB + 2 x 200 GB + 1 x 320 GBHD] [Kubuntu 8.10 + Vista Home Premium]

Offline Dave

  • Lid
  • Steunpunt: Nee
sudo
« Reactie #5 Gepost op: 2008/02/07, 16:44:21 »
je doet je naam eer aan zeg maar :-)

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
sudo
« Reactie #6 Gepost op: 2008/03/30, 17:13:32 »
Citaat van: Johanvd
Wat krijg je te zien als je het commando hostname uitvoert?

Wat staat er in /etc/hostname ?
Daar zou de naam van je computer moeten staan.

Wat staat er in /etc/hosts?

Waarschijnlijk moet je via de recovery mode of een live cd die bestanden herstellen.
Hallo Johanvd.
Zou je mij aub verder kunnen helpen, ik heb ook het probleem dat het sudo niet meer werkt en hoe dat is gekomen weet ik niet, nu zag ik dit topic staan maar er was al een antwoord gevonden die hier niet staat vermeld.

in mijn /etc/hostname staat:
pc1

in mijn /etc/hosts staat:
127.0.0.1 localhost
127.0.1.1 pc1.MSHOME

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Kan je mij zeggen wat ik moet doen om e.e.a weer te laten werken?
Recovery mode? Wat is dat en hoe doe ik dat?
Een live cd heb ik niet maar zou ik kunnen downloaden natuurlijk.
Groetjes, Robert
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
sudo
« Reactie #7 Gepost op: 2008/03/31, 10:24:48 »
Citaat van: robertvroegop
Wat krijg je te zien als je het commando hostname uitvoert?

Wat staat er in /etc/hostname ?
Daar zou de naam van je computer moeten staan.

Wat staat er in /etc/hosts?

----------------------------------------------------------------------------------------------
| Misschien iemand anders die mij hiermee kan helpen???           |
----------------------------------------------------------------------------------------------

in mijn /etc/hostname staat:
pc1

in mijn /etc/hosts staat:
127.0.0.1 localhost
127.0.1.1 pc1.MSHOME

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Kan je mij zeggen wat ik moet doen om e.e.a weer te laten werken?
Groetjes, Robert
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
sudo
« Reactie #8 Gepost op: 2008/03/31, 15:09:35 »
Dat lijkt allemaal goed te staan.
Wat is de foutmelding die sudo geeft?

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
sudo
« Reactie #9 Gepost op: 2008/03/31, 15:25:31 »
Citaat van: Johanvd
Dat lijkt allemaal goed te staan.
Wat is de foutmelding die sudo geeft?
antwoord:
'unable to resolve host robert@pc1
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
sudo
« Reactie #10 Gepost op: 2008/03/31, 15:33:28 »
Jouw foutmelding is anders dan die van stormzoeker. Bij hem staat alleen de hostnaam in de foutmelding, en bij jou staat ook nog de gebruikersnaam erbij.

In het andere topic geef je aan dat gksudo wel werkt, en sudo niet.
Dat is vreemd want gksudo gebruikt onder de motorkap ook gewoon sudo als het goed is.

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
sudo
« Reactie #11 Gepost op: 2008/04/01, 10:51:59 »
Citaat van: Johanvd
Jouw foutmelding is anders dan die van stormzoeker. Bij hem staat alleen de hostnaam in de foutmelding, en bij jou staat ook nog de gebruikersnaam erbij.

In het andere topic geef je aan dat gksudo wel werkt, en sudo niet.
Dat is vreemd want gksudo gebruikt onder de motorkap ook gewoon sudo als het goed is.
Ik snap het ook niet en daarom poste ik hier mijn vraag, maar ik vind dat ik jullie allang genoeg heb lastig gevallen met mijn probleem, ik dank je voor de reacties en het meedenken, maar ik ga dit probleem niet verder uitzoeken. Ten slotte ben ik eigenwijs geweest om versie 8 te installeren en misschien is het wel een heel klein foutje wat over 3 weken ineens weg is. Ik ga terug installeren naar versie 7.10 en ik wacht echt met spanning af naar de 8.04 over 23 dagen. Nogmaals heel erg bedankt voor de hulp.

Groetjes, Robert
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)