Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu en beamers  (gelezen 8695 keer)

Offline acousticghille

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Gepost op: 2008/02/06, 12:46:04 »
Hi,

Moet vrijdag een voorstelling geven (oo impress) en begin weeral te vrezen ... ubuntu en beamers gaan niet samen is mijn ervaring.
Wanneer ik de laptop opstart met de beamer eraan, dan krijg ik wel beeld via de beamer (ik zie wel niets op mijn scherm - wat bij windows wel kan). Het probleem dat zich dan stelt is de resolutie...ik zie maar een deel van mijn scherm. Hoe doen jullie dat?
Wanneer ik aan de beurt kom en ik wil mijn reeds opgestarte laptop aan de beamer hangen dan gaat het per definitie mis. Waarom kan ik dan niet beamen? Heeft iemand daar een antwoord op? Ik heb wel weet van de toetsencombinaties fn+F5 of fn+F3 en dergelijke, maar die werken niet. En ... bij windows lijkt dit wel te werken ....

Grtz
G

tuxido_devito

  • Gast
Ubuntu en beamers
« Reactie #1 Gepost op: 2008/02/06, 12:50:19 »
Wat voor systeem heb je, ik ben met name geintereseerd in het type videokaart en merk daarvan.

Offline acousticghille

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #2 Gepost op: 2008/02/06, 12:52:50 »
Welk commando in terminal geeft me dat?
Ik zit nu thuis te werken op een andere laptop dus, kan je niet de videokaart van mijn werklaptop geven momenteel.
Heeft de videokaart veel belang? Ik dacht dat via het slot op je pc automatisch het beeld werd doorgegeven. (misschien niet goed uitgedrukt, maar misschien wel te begrijpen;-)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #3 Gepost op: 2008/02/06, 12:52:58 »
Ik heb ook wel eens gestoeid met een projector, maar het ging alleen wanneer ik de schermresolutie op de projector, op 640x480 had staan (op het scherm van m'n flaptop gewoon 1280x800).

Duidelijk nog "werk in uitvoering", Ubuntu en projectoren......

Als niemand anders het verlossende woord spreekt, zou je die impress-presentatie in Windows kunnen geven, via Open Office voor Windows.

Offline acousticghille

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #4 Gepost op: 2008/02/06, 12:55:37 »
Tja, die impress in windows geven is moglijk. Ik heb met name een dual boot ... maar ik verlies niet graag mijn gezicht tegenover de collega's. Ik ben nl een harde ubuntuverdediger op het werk....en dan gaan werken met windows als het erop aankomt........dat probeer ik toch te vermijden hoor;-)

Offline asilnevs

  • Lid
    • jef-damen
    • Ubuntu - Video - 2012
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #5 Gepost op: 2008/02/06, 12:59:03 »
Laatst is er nog zo een topic geweest: http://forum.ubuntu-nl.org/topic/20861
Ook nog altijd niet opgelost vrees ik.
Allemaal Linux gerelateerde links op mijn website http://home.scarlet.be/jefdamen/Ubuntu.html
Mijn filmpjes met Openshot en Kdenlive gemaakt:http://www.youtube.com/user/asilnevs
https://jefdamen.wordpress.com/
We are spiritual beings having a human experience

Offline joop13

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #6 Gepost op: 2008/02/06, 13:01:24 »
Citaat van: acousticghille
Hi,

Moet vrijdag een voorstelling geven (oo impress) en begin weeral te vrezen ... ubuntu en beamers gaan niet samen is mijn ervaring.
Wanneer ik de laptop opstart met de beamer eraan, dan krijg ik wel beeld via de beamer (ik zie wel niets op mijn scherm - wat bij windows wel kan). Het probleem dat zich dan stelt is de resolutie...ik zie maar een deel van mijn scherm. Hoe doen jullie dat?
Wanneer ik aan de beurt kom en ik wil mijn reeds opgestarte laptop aan de beamer hangen dan gaat het per definitie mis. Waarom kan ik dan niet beamen? Heeft iemand daar een antwoord op? Ik heb wel weet van de toetsencombinaties fn+F5 of fn+F3 en dergelijke, maar die werken niet. En ... bij windows lijkt dit wel te werken ....

Grtz
G
Ik heb hetzelfde probleem met mijn Thinkpad, maar als ik Ubuntu opstart met de beamer er aanvast dan doet hij het wel (gedeeltelijk). Ik zou dus ook graag weten hoe we Fn F5 aan het werk kunnen krijgen als in Windows. Op mijn laptop staat, zoals je kunt zien, géén Windows. Dus meestal doe ik het op de manier hierboven beschreven.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #7 Gepost op: 2008/02/06, 13:33:08 »
Citaat van: acousticghille
Tja, die impress in windows geven is moglijk. Ik heb met name een dual boot ... maar ik verlies niet graag mijn gezicht tegenover de collega's. Ik ben nl een harde ubuntuverdediger op het werk....en dan gaan werken met windows als het erop aankomt........dat probeer ik toch te vermijden hoor;-)
Tuurlijk, eerst proberen of 't lukt in Ubuntu.

Maar verder zou ik me niet zo druk maken over reacties van je collega's, als die presentatie toch in Windows moet. Ubuntu is in de *meeste* (en de belangrijkste) opzichten beter dan Windows. Maar niet in *alle* opzichten: op enkele punten scoort Windows (nog) beter. Eerlijk is eerlijk.

En zoiets laat zich goed uitleggen (is mijn ervaring). Sterker nog, je komt zo zelfs beter over: genuanceerd aanprijzen van Linux overtuigt eerder dan fanatieke lof.

Groet, Pjotr.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #8 Gepost op: 2008/02/06, 15:39:55 »
Er wordt verwezen naar m'n eigen draadje.  Daar staat misschien geen pasklaar antwoord in, maar toch een groot stuk van de oplossing.  Verder is het effectief nog redelijk wat handwerk, maar als je eerst alle bijdragen van Gandyman leest, dan ben je al een eind weg.  

Tip: lees ze eerst allemaal en ga dan terug naar de stukken die nog uitleg behoeven.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline acousticghille

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #9 Gepost op: 2008/02/11, 13:35:12 »
Ik dacht een antwoord gevonden te hebben .... maar .... dikke problemen

Ik heb een beamer aangesloten en via systeem/beheer/screens and graphics het tweede scherm aangeklikt. daarin de resolutie aangepast en.....ik kreeg het gebeamd. Maar de kwaliteit was ronduit slecht. Het scherm bibberde de hele tijd.

MAAAAAr, de dag nadien start ik mijn pc op en guess what? Problemen.....toetsenbord = querty ipv azerty en mijn grafische kaart werd niet meer gevonden. Weet iemand wat ik hieraan kan doen?
Is dat normaal dat ubuntu zo begint te flippen?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #10 Gepost op: 2008/02/11, 14:35:37 »
Dat bibberen heeft ongetwijfelt met de frequentie te maken van dat scherm.

Dat alles nu ineens anders staar kan komen omdat je nu werkt met de failsafe xorg.conf die automatisch gebruikt word indien je huidige xorg.conf niet in orde is.

Wat je positief moet zien is dat het dus werkt toen je die functie aanzetten.
Daarna is het nog enkelt een kwestie van fine tunen wat je met de hand kan doen in de xorg,conf.

Je kan je huidige xorg.conf in orde maken met de opdracht:
sudo dpkg-reconfigure -phigh xserver-xorg

In principe op alles met ja beantwoorden.

Wanneer je nu wederom die beamer geactiveerd hebt en alles werkt ( ondanks trillen ) maak je meteen een backup van je xorg.conf
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.beamer

Dit om achteraf eens te kijken wat er gebeurt in je xorg.conf dus wat Ubuntu verzonnen heeft om de boel  te laten werken.

Het openen van je xorg.conf doe je met:
sudo gedit /etc/X11/xorg.conf

misschien wel leuk als je die eens hier wilt posten,

en natuurlijk de
gedit /etc/X11/xorg.conf.beamer

Wanneer je fouten zoekt in je Xorg.0.log kijk je even bij ->(systeem -> beheer -> systeemlogboek)
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline vanadium

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #11 Gepost op: 2008/02/11, 19:12:09 »
Het gedrag van ubuntu in combinatie met een beamer hangt duidelijk samen met de videodriver. Met de proprietaire ATI driver krijg ik zowel op mijn laptop scherm als op de beamer beeld. Het beeld op de beamer is correct, dat op het scherm kan dan "afgesneden" zijn tenzij ik de resolutie bijstel. Met de open source driver is het inderdaad huilen met de pet op. Eigenaardig dat dit inderdaad nog steeds zo ondermaats is: net op die momenten waar je voor een publiek staat.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #12 Gepost op: 2008/02/12, 00:11:30 »
Misschien is dit iets:
http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

Bij mij werkt
xrandr --auto
om een 2e (extern) scherm te herkennen en mirroren.
Er is ook een GUI genaamd grandr, te installeren via synaptic.



Mvg,
Erik

Offline vanadium

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #13 Gepost op: 2008/02/15, 17:15:38 »
Spijtig genoeg moet ik hier ook regressies melden! Op dezelfde plaats waar ik vorig jaar probleemloos voor de eerste keer met Ubuntu heb gepresenteerd, loopt het vandaag nogal fout. Met de beamer aangeschakeld start hij uiteindelijk op in "low graphics mode". Gelukkig kon ik in low graphics mode switchen naar de beamer, zodat de presentatie op het scherm kwam, maar niet op de laptop.

Ik probeer nu eens de tips op de links maar ik verwacht er niet veel van: dit is ondermaats in 2008!

Offline acousticghille

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #14 Gepost op: 2008/02/16, 11:30:43 »
Beste,
Heb de voorgestelde acties nog niet kunnen uitvoeren. Ik moet daarvoor blijkbaar met mijn werklaptop naar die beamer die ik heb gebruikt. Dat kan ik niet zomaar direct klaren.
Ik heb wel enkele van die regels in terminal uitgevoerd, maar mijn problemen bestaan nog steeds na het werken met die beamer. Ik start op en mijn toetsenbord is in qwerty. Ik meld aan .... daarna is het azerty. Vreemd? Ook het opstarten loopt niet zo lekker, het duurt een beetje langer dan anders.

Moet dit niet eens gemeld worden aan de ?bevoegde? instantie dat men hier eens werk van maakt, dit is toch ondenkbaar?
Grtz
G

Offline vanadium

  • Lid
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #15 Gepost op: 2008/02/16, 14:44:44 »
Ik begin in elk geval niet aan die tips. Als dat de wijze is waarop ik mijn hardware moet aan de praat krijgen, dan pas ik. Dat is wellicht wel ergens "gemeld" als issue: ik zal daar eens voor rondkijken. Zien dat het bij Ubuntu gemeld is, kan zeker geen kwaad: die mensen weten dan wel waar ze "upstream" naar toe moeten.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Ubuntu en beamers
« Reactie #16 Gepost op: 2008/03/02, 09:12:39 »
Gewoon ter illustratie, en misschien dat het iemand kan helpen, plaats ik hieronder mijn xorg.conf.  Die heb ik helemaal van niks opgebouwd met sudo gedit.  Ik heb de laatste proprietary driver van ATI geïnstalleerd, maar ik vermoed (het is helaas niet meer dan dat: een vermoeden) dat het eigenlijk werkt met gelijk welke driver.  Voor de Dual Screens maak ik gebruik van Xinerama.  Er zijn drie mogelijke configuraties:
1. Single Screen (Default_Layout), waarin ook Compiz Fusion ingeschakeld is.
2. Dual Screen met een beamer (die hangt aan de DVI-uitgang van m'n laptop en kan ik gewoon hotpluggen) op resolutie 1024x768, wat mooi is voor het projecteren van filmen. (Film_Layout)
3. Dual Screen met diezelfde Beamer op resolutie 800x600, om schema's en tekeningen te projecteren.  De ervaring leert me dat de vensters weliswaar full-screen op dat tweede scherm kunnen gezet worden, maar dat de eigenlijke tekening niet genoeg wordt uitvergroot bij die hogere resoluties waardoor de lijntjes te dun en de letterkes te klein zijn.
De keuze tussen de drie staat in de laatste sectie: Section "ServerLayout".  Daarin wordt één DefaultServerLayout medegedeeld, en was het de bedoeling om bij het opstarten van X een andere ServerLayout te kunnen meegeven met startx -- -layout Film_Layoutbijvoorbeeld.  Dat lukt ook wel vanuit de terminal, maar hij startte dan op met Enlightenment.  Ik had wel m'n Dual Screen en kon wel vensters verslepen, dus als ik "gewoon" leer waar ik alles kan vinden, dan is het perfect bruikbaar.  :)
De fall-back methode is gewoon op te starten en door te booten, gewoon in te loggen, dan met gksudo gedit even de commentaar-tekens te verplaatsen onderaan in die xorg.conf, en vervolgens met CTL+ALT+Backspace de X-server terug op te starten.  Je kan dus met andere woorden eerst nog gewoon op je computer werken en tegen dat je moet beginnen presenteren is het een half minuutje werk...
De tweede mogelijkheid is om bij het booten ESC te drukken, op te starten in Recovery Mode, dan vanop de command-lijn je xorg.conf aan te passen met nano /etc/X11/xorg.conf.  Opslaan met CTL+O, Afsluiten met CTL+X. Veilige modus verlaten met "exit", ENTER en je zit ineens goed.  Maar dan moet je wel klaar staan met je vinger bij het booten, en als er iemand over je schouder meekijkt, is dat ten eerste vervelend en ten tweede zien die dan natuurlijk weer het zo gevreesde zwarte scherm met witte letterkes dat Linux zo'n imago geeft van "iets voor nerds".

Eigenlijk was het de bedoeling om met CTL+ALT+F2 (of F3 tot F6) een nieuwe console te openen en daar het commando te geven dat hierboven staat: startx enz.  Bij mij verschijnt er echter alleen een zwart scherm met linksboven een knipperende cursor (wat ook zo hoort, denk ik) en verder reageert mijn toetsenbord niet meer. (wat dus niet zo hoort, denk ik :( )  Ik ga hierover een nieuw draadje openen, want anders reageren degenen die dat wel weten niet, want die zitten niet met beamers in hun hoofd, dus die slaan dit draadje wellicht over.

Section "Files"

# path to defoma fonts
FontPath     "/usr/share/X11/fonts/misc"
FontPath     "/usr/share/X11/fonts/cyrillic"
FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/Type1"
FontPath     "/usr/share/X11/fonts/100dpi"
FontPath     "/usr/share/X11/fonts/75dpi"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load  "i2c"
Load  "bitmap"
Load  "ddc"
Load  "dri"
Load  "extmod"
Load  "freetype"
Load  "glx"
Load  "int10"
Load  "type1"
Load  "vbe"
EndSection

Section "InputDevice"
Identifier  "Generic Keyboard"
Driver      "kbd"
Option    "CoreKeyboard"
Option    "XkbRules" "xorg"
Option    "XkbModel" "pc105"
Option    "XkbLayout" "be"
Option    "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier  "Configured Mouse"
Driver      "mouse"
Option    "CorePointer"
Option    "Device" "/dev/input/mice"
Option    "Protocol" "ExplorerPS/2"
Option    "ZAxisMapping" "4 5"
Option    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier  "Synaptics Touchpad"
Driver      "synaptics"
Option    "SendCoreEvents" "true"
Option    "Device" "/dev/psaux"
Option    "Protocol" "auto-dev"
Option    "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier  "stylus"
Driver      "wacom"
Option    "Device" "/dev/wacom"# Change to
Option    "Type" "stylus"
Option    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier  "eraser"
Driver      "wacom"
Option    "Device" "/dev/wacom"# Change to
Option    "Type" "eraser"
Option    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier  "cursor"
Driver      "wacom"
Option    "Device" "/dev/wacom"# Change to
Option    "Type" "cursor"
Option    "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

# Hier begint het eigenlijke werk !

Section "Device"
Identifier  "ATI_L"
Driver      "fglrx"
BusID       "PCI:1:0:0"
Option      "MergedFB"  "False"
Screen 0
Endsection

Section "Device"
Identifier  "ATI_B"
Driver      "fglrx"
BusID       "PCI:1:0:0"
Option      "MergedFB"  "False"
Screen 1
Endsection

Section "Monitor"
Identifier  "Monitor_Laptop"
Option      "DPMS"
HorizSync   30-75
VertRefresh 30-60
Endsection

Section "Monitor"
Identifier  "Monitor_Beamer"
Option      "DPMS"
HorizSync   30-75
VertRefresh 30-60
Endsection

# Screen = Monitor + Device

Section "Screen"
Identifier  "Laptop_Screen"
Device      "ATI_L"
Monitor     "Monitor_Laptop"
Defaultdepth 24
    Subsection "Display"
Depth 24
Modes "1280x800"
    EndSubsection
EndSection

Section "Screen"
Identifier  "Beamer_Film"
Device      "ATI_B"
Monitor     "Monitor_Beamer"
Defaultdepth 24
    Subsection "Display"
Depth 24
Modes "1024x768"
    EndSubsection
EndSection

Section "Screen"
Identifier  "Beamer_Math"
Device      "ATI_B"
Monitor     "Monitor_Beamer"
Defaultdepth 24
    Subsection "Display"
Depth 24
Modes "800x600"
    EndSubsection
EndSection

Section "ServerLayout"
Identifier  "Default_Layout"
Screen      "Laptop_Screen"
Option      "Xinerama"  "False"
        Option      "Composite" "True"
InputDevice "Configured Mouse"
InputDevice "Generic Keyboard"
EndSection

Section "ServerLayout"
Identifier  "Film_Layout"
Screen  0   "Laptop_Screen"
Screen 1   "Beamer_Film" RightOf "Laptop_Screen"
Option      "Xinerama"  "True"
InputDevice "Configured Mouse"
InputDevice "Generic Keyboard"
EndSection

Section "ServerLayout"
Identifier  "Math_Layout"
Screen  0   "Laptop_Screen"
Screen 1   "Beamer_Math" RightOf "Laptop_Screen"
Option      "Xinerama"  "True"
InputDevice "Configured Mouse"
InputDevice "Generic Keyboard"
EndSection

Section "ServerFlags"
# uncomment one of the following lines
# (dit is een voorlopige oplossing)
Option "DefaultServerLayout" "Default_Layout"
# Option "DefaultServerLayout" "Film_Layout"
# Option "DefaultServerLayout" "Math_Layout"
EndSection
In de files en modules-sectie staat nog een beetje teveel, maar dat ruim ik nog wel eens op.

Edit: enkele tikfouten
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en beamers
« Reactie #17 Gepost op: 2009/02/08, 14:34:57 »
Hallo allen,

We zijn nu zo'n jaar verder sinds dit topic gestart is.
Omdat ik overweeg een soort van "thuisbioscoopje" in te richten en daarbij gebruik wil gaan maken van een beamer, vroeg ik me af of 8.04 en/of 8.10 inmiddels wel beter met een beamer overweg kunnen?
Naast een DVD speler, evt Nintendo Wii video wil ik mijn Aspire One of evt een PC met een van voornoemde Ubuntu versies hierop aan kunnen sluiten. 

Met vriendelijke groeten,
Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Ubuntu en beamers
« Reactie #18 Gepost op: 2009/02/08, 14:41:15 »
Dat is totaal afhankelijk van de videokaart. Ik gebruik momenteel nVidia, en dat werkt nu prima. Door onwetendheid liep ik eerst tegen wat problemen aan, maar nu is het slechts een kwestie van een paar muisklikken om alles goed te krijgen.

Offline asilnevs

  • Lid
    • jef-damen
    • Ubuntu - Video - 2012
  • Steunpunt: Nee
Re: Ubuntu en beamers
« Reactie #19 Gepost op: 2009/02/08, 15:35:44 »
Allemaal Linux gerelateerde links op mijn website http://home.scarlet.be/jefdamen/Ubuntu.html
Mijn filmpjes met Openshot en Kdenlive gemaakt:http://www.youtube.com/user/asilnevs
https://jefdamen.wordpress.com/
We are spiritual beings having a human experience

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en beamers
« Reactie #20 Gepost op: 2009/02/08, 15:59:12 »
Dank voor de reacties.
Heb het linkje even bij favorieten gezet :)

Gr
Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.