Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu en Windows PC zien elkaar niet  (gelezen 3098 keer)

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Gepost op: 2008/02/05, 18:46:35 »
Ik heb naast Vista nu ook ubuntu geinstalleerd op mn desktop.
Werkt op zich prima. draadloze verbinding, internet etc werkt goed. Ik heb nog een laptop (windows) die ook gebruik maakt van het draadloze netwerk.
Als ik mijn desktop onder Vista start, dan zie ik in de verkenner de laptop staan en kan ik ook op de harde schijf van de laptop kijken. Vanaf de laptop kan ik weer gebruik maken van de printer die op de desktop is aangesloten.
Als ik de desktop onder ubuntu start, dan zie ik de laptop niet en omgedraaid kan ik ook niet meer vanaf de laptop printen. Bij de netwerkinstellingen staat "wervende modus" geactiveerd.

Wat moet ik doen om ervoor te zorgen dat onder ubuntu de desktop ook gewoon via het netwerk te benaderen is?

Offline ruujan

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #1 Gepost op: 2008/02/05, 21:02:19 »
Vista op de desktop zul je nooit via het netwerk kunnen benaderen, want als je Ubuntu start is Vista niet actief. Vandaar dat ook de printer op dat moment niet gedeeld wordt.
Afhanklijk van je type printer zou je wel moeten kunnen printen op de lokale printer aan je desktop. Deze zou je mbv CUPS ook beschikbaar kunnen stellen voor andere machines op het netwerk.


Als je bedoelt dat je je laptop via het netwerk wilt benaderen moet je dat via Samba doen. Ik werk voornamelijk met KDE en dan kun je een windows-machine bereiken met:

smb://[ip-nummer van de machine].

Gnome zul je dit ook wel ergens in moeten kunnen voeren.

Dat de naamresolutie met SMB wel eens slecht werkt, heeft te maken met het feit dat alle pc's in het netwerk na het opstarten zichzelf baas van de werkgroep vinden en pas na enige tijd knokken besluiten wie er uiteindelijk als nameserver gaat fungeren. De SMB-server en de Windows server versies gebruiken hiervoor WINS en dat is een stuk beter. Je moet dan nog wel een DHCP-server hebben die ook de optie WINS-server en WINS nodetype kan uitdelen, iets wat op bijvoorbeeld de meeste huis-, tuin- en keuken-routers niet kan.

Op zich zou echter je laptop na een kwartier wel zichtbaar moeten zijn onder zijn eigen naam.

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #2 Gepost op: 2008/02/06, 14:28:45 »
Ik ben weer een stapje verder.
Ik heb mijn desktop met ubuntu gestart en mijn laptop met Vista.
Ik kan nu op mijn desktop (met de bestandsbladeraar) de bestanden van de laptop zien (natuurlijk alleen de bestanden die ik op delen heb gezet).
Als ik op de laptop in de verkenner kijk, dan zie ik de de naam staan van mijn desktop zoals ik deze onder ubuntu heb genoemd. Echter als ik op deze naam klik dan komt er een pop-up schermpje met het verzoek of ik mijn gebruikersnaam en wachtwoord wil opgeven. En dan krijg ik een foutmelding dat mijn naam/wachtwoord onjuist is!!! Ik heb zowel mijn ubuntu-gebruikersnaam als mijn laptopgebruikersnaam en mijn desktop (vista) gebruikersnaam geprobeerd maar allen zonder resultaat.

Wat ben ik vergeten?

Offline ruujan

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #3 Gepost op: 2008/02/06, 20:43:37 »
Kijk, dan ben je al een heel eind. Je moet nu nog een gebruikersnaam en wachtwoord aanmaken onder samba. smbaddpasswd is geloof ik het juiste commando daarvoor, maar misschien is het ook wel mogelijk vanuit Ubuntu zelf.

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #4 Gepost op: 2008/02/06, 23:03:13 »
Samba is een programma wat ik eerst moet starten?

Offline joop905

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #5 Gepost op: 2008/02/06, 23:50:20 »
hier wat lees voer: http://www.multidesk.be/artikels/artikel/233/  en veel foto`s

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #6 Gepost op: 2008/02/07, 04:54:49 »
He Joop, bedankt voor de tip :)

'k Heb nu eindelijk m'n Windowsdocumenten op de Desktop kunnen raadplegen op de laptop via de router.
Eén probleempje: .pdf en .hml documenten kan ik zonder problemen openen (respectievelijk met Adobe en met Firefox), maar bij een .doc of een .odt bestand, zegt OpenOffice "algemene internetfout". .. :(  Voor de duidelijkheid: dat zijn bestanden in dezelfde map als die andere bestanden die ik wel kan lezen, dus heeft het niet direct met toegangsrechten te maken.

Wat kan hier de oorzaak zijn ?  Is dat een bug in OO, of moet ik daar ergens iets instellen ?

Overigens heb ik ook geprobeerd om naar zo'n map te schrijven, maar dat is ook niet gelukt. Ik ga wel eerst rap effe kijken hiernaast of ik daarvoor de rechten wel heb ingesteld.
Niet dus.  Heb dat nu aangevinkt.  Nog eens proberen...
Yep, nu doet ie het wel.  Toch nog eens gaan zien op de Pc of het er wel op staat...
Dus wel :)  Ik kan dus lezen en schrijven met Tekst-editor (gedit) en dat lezen in Windows met Kladblok.

Toch nog eens OO proberen, hoewel dat lezen ook van te voren had moeten kunnen...

Eh bien, nou breekt mijn klomp !   Nu kan OO wèl lezen....  Niet alleen dat .txt-bestand van daarnet, maar ook de oude .doc die daar opstaan.  Ik moet dus toelating geven om te veranderen, opdat OO het zou kunnen lezen...  Als dit gedrag nog voorkomt bij anderen, vind ik dat een bug...

Verder ben ik al zéééér tevreden dat ik het kan lezen en schrijven..

Nogmaals bedankt, Joop. :cool:
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline lizardman

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #7 Gepost op: 2008/02/07, 12:54:13 »
@Quatz,
Je moet in Ubuntu nog je (windows) gebruikersnaam en paswoord toevoegen aan Samba.
In de terminal:
sudo smbpasswd -a eerst wordt om je rootpasswoord gevraagd. tik dit in, je ziet niets maar dat hoort zo.
en dan twee keer het passwoord voor die nieuwe (windows) gebruiker.

Als alles goed gaat dan kun je daarna vanaf windows de gedeelde (samba) mappen op je Ubuntu machien zien.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #8 Gepost op: 2008/02/07, 21:04:55 »
Ik weet niet zeker of ik het goed begrijp,
In hetzelfde netwerk zit ook nog een andere computer waar ik ook gebruiker (admin) van ben.
Moet ik nu voor iedere computer waar ik gebruiker van ben, deze naam in samba opgeven?

Hendrikdegraaf

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #9 Gepost op: 2008/02/07, 21:35:19 »
Nee, je hoeft alleen op je ubuntu desktop de samba gebruiker toe te voegen. Aan je voorgaande post te zien was dat al gelukt!

Waarschijnlijk zit er iets verkeerd met de bestandsmachtigingen. Met Linux heb je verschillende categoriën Read Write en Execute. Blijkbaar hen jij alleen Read geactiveerd. Vandaar dat je html en pfd wel kan openen, want deze bestanden kun je niet wijzigen.

Zoek maar eens op CHOWN (change owner) CHMOD (change file permissions) deze laatste moet je hebben. Misschien kun je het ook gewoon via eigenschappen vanuit de grafische interface (rechtermuisklik, eigenschappen?)

SUcces!
Hendrik

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #10 Gepost op: 2008/02/07, 21:47:09 »
Nee hoor, ik kan nog niets lezen vanaf een andere machine.
Ik zie op mn laptop de (ubuntu) desktop wel in het netwerk staan. Alleen al sik er op klik moet ik een naam/wachtwoord in tikken en daar gaat het fout...

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #11 Gepost op: 2008/02/07, 22:11:57 »
Citaat van: lizardman
@Quatz,
Je moet in Ubuntu nog je (windows) gebruikersnaam en paswoord toevoegen aan Samba.
In de terminal:
sudo smbpasswd -a eerst wordt om je rootpasswoord gevraagd. tik dit in, je ziet niets maar dat hoort zo.
en dan twee keer het passwoord voor die nieuwe (windows) gebruiker.

Als alles goed gaat dan kun je daarna vanaf windows de gedeelde (samba) mappen op je Ubuntu machien zien.
Ik krijg de volgende foutmelding:

Failed to modify password entry for user ....

Geef je daar nu de naam van de machine zoals die in het windows netwerk bekend is of de naam van 1 van de gebruikers op die machine??

Offline terelfderure

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #12 Gepost op: 2008/02/08, 10:50:46 »
Er staat ook een interessante video op Youtube tw File sharing with ubuntu using samba.
www.youtube.com/watch?v=Ad17kma8rNM
Ik heb dit gevolgd en  ik kan een oude dektop met Windows 98 sharen  met een nieuwe dektop met Gutsy.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #13 Gepost op: 2008/02/08, 12:58:49 »
Citaat van: Quatz
Failed to modify password entry for user ....
Je moet ook nog vooraf deze (windows-)gebruiker aanmaken als gebruiker op je Linux-machine...  Dat kan via Systeem -- Beheer-- Gebruikers en groepen.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline terelfderure

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #14 Gepost op: 2008/02/08, 18:19:31 »
Als ik de site van joop905 bekijk en mijn eigen youtube link, dan zie ik nergens dat er een windowsgebruiker moet ingevuld worden.
Wel bvb sudo smbpasswd -a steven.
En 'steven' is hier de naam van de linux gebruiker.
Of bedoelen jullie wat anders.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #15 Gepost op: 2008/02/08, 20:48:45 »
Uit de manual (te consulteren via man smbpaswd in een terminal:
Citaat
OPTIONS
 -a
          This option specifies that the username following should be added to
          the local smbpasswd file, with the new password typed (type  
          for  the  old password). This option is ignored if the username fol�
          lowing already exists in the smbpasswd file and it is treated like a
          regular  change password command. Note that the default passdb back�
          ends require the user to already exist in the system  password  file
          (usually /etc/passwd), else the request to add the user will fail.


          This option is only available when running smbpasswd as root.
Dit betekent dat steven in jouw geval ten eerste een gebruiker moet zijn op de windowsmachine, maar ook nog eens een gebruiker op de Linux-machine

Bij mij lukte het in elk geval om user "windowsgebruiker" een smbpasswd te geven, na dat ik 'm als linux-gebruiker heb aangemaakt.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline lizardman

  • Lid
  • Steunpunt: Nee
Ubuntu en Windows PC zien elkaar niet
« Reactie #16 Gepost op: 2008/02/09, 16:50:30 »
Ah, ja inderdaad, de nieuwe sambagebruiker moet ook eerst een gewone gebruiker in ubuntu zijn.
Dus de windowsgebruiker moet op ubuntu bekend zijn  als gewone gebruiker *en* als sambagebruiker.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Quatz

  • Gast
Ubuntu en Windows PC zien elkaar niet
« Reactie #17 Gepost op: 2008/02/09, 22:18:57 »
PFFFFFFFFFF

Het werkt, ik kan eindelijk vanaf mn laptop de ubunt machine benaderen......

Nu de volgende stap, printen vanaf de laptop op de printer die aan de ubuntu machine hangt!!