Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Aantal problemen: toetsenbord, Compiz en Amsn  (gelezen 1285 keer)

Offline Arya

  • Lid
  • Steunpunt: Nee
Aantal problemen: toetsenbord, Compiz en Amsn
« Gepost op: 2008/02/03, 02:13:12 »
Hallo daar,
ik ben recent nog overgestapt op Linux(ik gebruik de variant Linux Mint, die is 99% ubuntu, als het al geen 100 is)
nu zijn er een paar problemen waar ik tegen opbots. Ten eerste is het mijn toetsenbord. Ik leef in belgië en dan heb ik af en toe eens voor school of dergelijks zo franse accenten nodig, op mijn windows was het heel gemakkelijk omdat die out of the box werken en ik de sneltoetsen hiervoor wel kende. Maar op ubuntu(lees:mint) krijg ik ze niet aan de praat. In windows was het CTRL + ALT + accent bord +letter waarop je het accent wou.. maar hier jah..ik weet helemaal niet hoe ik dat moet fixen...kan iemand me helpen?

En 2e ding is dat ik dus compiz fusion gebruik, die heeft een heel mooi effectje en dat is de shift switcher, maar mijn probleem is dat die niet werkt als een programma geminimaliseerd staat...

En als 3e heb ik een kleine probleem met Amsn, ik moet voor amsn Snack ofzo installeren om in staat te zijn om voice clips te kunnen horen.. hoe installeer ik dat? :s

Alvast bedankt voor jullie tijd,
help me alstublieft om Windows voorgoed te verlaten? want dit is al de zoveelste keer dat ik probeer linux te gebruiken, maar keer op keer moest ik besluiten dat het niet ging lukken en weer naar windows ging..nu heb ik al bijna alles werkend gekregen(Mijn printer, die eerst ook niet wou werken, maar met een beetje zoekwerk op de ubuntu forums is dat goed gekomen en mijn draadloze verbinding wou vroeger ook niet werken, maar werkt nu ook weer, gelukkiglijk...)

Groetjes,
Arya

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Aantal problemen: toetsenbord, Compiz en Amsn
« Reactie #1 Gepost op: 2008/02/03, 03:25:05 »
Letters: op een Belgisch toetsenbord zou de é, è, (a met accent, maar dit forum kan dat teken niet aan :P -> messed up database) alvast standaard aanwezig moeten zijn op je toetsenbord (onder de knoppen 2, 7 en 0) voor de andere accenten met ' of ` doe ik gewoon ALT GR + accent, en daarna de letter waarop ik het accent wil.. werkt out of the box bij mij, maar ik draai wel Ubuntu, geen Mint.

Geminimaliseerde programma's kunnen geen live preview hebben met Compiz. Je kan ofwel de preview bij de switcher voor geminimaliseerde vensters uitschakelen via ccsm (compiz-config-settings-manager) maar ik denk dat het ook mogelijk is om een statische preview op te slaan ergens via ccsm (ik denk dat o.a. Windows Vista dit ook doet)

Probeer "libsnack2" te installeren via je pakketbeheerder (Systeem - Beheer - Synaptic pakketbeheerder) of via het "sudo apt-get install libsnack2"-commando
PS: let wel op met aMSN, het is geschreven in een zéér trage en geheugen/cpu-vretende programmeertaal/toolkit en hoewel het zoveel functies heeft is het niet altijd even stabiel, en je zal er zeker een performance hit mee ondervinden.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Arya

  • Lid
  • Steunpunt: Nee
Aantal problemen: toetsenbord, Compiz en Amsn
« Reactie #2 Gepost op: 2008/02/03, 04:37:58 »
Citaat van: profoX
Letters: op een Belgisch toetsenbord zou de é, è, (a met accent, maar dit forum kan dat teken niet aan :P -> messed up database) alvast standaard aanwezig moeten zijn op je toetsenbord (onder de knoppen 2, 7 en 0) voor de andere accenten met ' of ` doe ik gewoon ALT GR + accent, en daarna de letter waarop ik het accent wil.. werkt out of the box bij mij, maar ik draai wel Ubuntu, geen Mint.

Geminimaliseerde programma's kunnen geen live preview hebben met Compiz. Je kan ofwel de preview bij de switcher voor geminimaliseerde vensters uitschakelen via ccsm (compiz-config-settings-manager) maar ik denk dat het ook mogelijk is om een statische preview op te slaan ergens via ccsm (ik denk dat o.a. Windows Vista dit ook doet)

Probeer "libsnack2" te installeren via je pakketbeheerder (Systeem - Beheer - Synaptic pakketbeheerder) of via het "sudo apt-get install libsnack2"-commando
PS: let wel op met aMSN, het is geschreven in een zéér trage en geheugen/cpu-vretende programmeertaal/toolkit en hoewel het zoveel functies heeft is het niet altijd even stabiel, en je zal er zeker een performance hit mee ondervinden.
Dank je wel voor je hulp! Nu is mijn eerste en 2e probleem opgelost. Nu zit ik alleen nog met mijn Compiz gedoe, het vreemde eraan is dat die optie eergisteren(bij ubuntu) het nog wel deed, nu alsi k bij ccsm kijk staat er bij de shift switcher de opties 'Hide non Desktop windows' uitgevinkt en bij 'misc options' staat 'Show Minimized' aangevinkt

Offline Marten

  • Lid
  • Steunpunt: Nee
Aantal problemen: toetsenbord, Compiz en Amsn
« Reactie #3 Gepost op: 2008/02/03, 13:18:10 »
Hoi Arya,

over de accenten: er is nog een andere optie en dat is de compose-key. Met zo'n toets behouden alle toetsen (single-quote, bubbel-quote, dakje, etc.) hun functie, maar kan je ze met één druk op een knop boven een letter zetten. Daarnaast maak je makkelijk een €-teken met compose, =, E.

In KDE stel je de compose-key in bij: System Settings -> Regional & Language -> Keyboard Layout. Enable Xkb options aanvinken en dan 'Compose key position' instellen.

Aan je Compiz-vraag te lezen, gebruik je Gnome. Daar is dat natuurlijk ook mogelijk:
system -> preferences -> keyboard -> layout tab.
Zie ook de post http://forum.ubuntu-nl.org/topic/277.

Ik gebruik zelf voor de compose-key de linker win-toets (waar moet je die anders voor gebruiken?).

En ik vind de compose-functionaliteit echt ontzettend veel makkelijker dan de zgn. dead-keys (moet je steeds een spatie indrukken na een een " om dat karakter te krijgen) of de alt-combinaties van MS windows.

Succes ermee.
Marten
"En hij dronk van die wijn, en werd dronken" - Gen 9:21

Offline JvH

  • Lid
  • Steunpunt: Nee
Aantal problemen: toetsenbord, Compiz en Amsn
« Reactie #4 Gepost op: 2008/02/11, 15:11:50 »
Citaat van: "proFox"
voor de andere accenten met ' of ` doe ik gewoon ALT GR + accent
Bedoel je de Compose key? Werkt dat bij jou out-of-the-box? Ik moest dat zelf expliciet instellen in Gutsy.

Citaat van: "Marten"
En ik vind de compose-functionaliteit echt ontzettend veel makkelijker dan de zgn. dead-keys (moet je steeds een spatie indrukken na een een " om dat karakter te krijgen) of de alt-combinaties van MS windows.
Inderdaad, ik kwam dat ook 'toevallig' tegen toen ik op zoek was naar een alternatief voor de us-int indeling.
Niet alleen kun je dan aanhalingstekens typen zonder spatie erna, je kunt er ook nog eens een veel groter scala aan speciale tekens mee produceren. Een ander voordeel voor Belgische gebruikers is dat de Compose key ook op een AZERTY-toetsenbord te gebruiken is.
Ik gebruik de standaard Amerikaanse layout, en heb mijn rechter Win-toets als Compose key ingesteld. Als je Compiz gebruikt, kun je dan met de linker Win-toets + Tab in 3D door je vensters bladeren.

EDIT: beetje offtopic, maar voor de mensen die ook nog Windows gebruiken naast Linux, en ook daar graag gebruik willen maken van de Compose key methode: probeer eens het programma AllChars.