Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Innotek VirtualBox start niet meer op  (gelezen 3982 keer)

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Gepost op: 2008/02/02, 10:50:16 »
Hallo,

Ik heb XP geinstalleerd in een virtualbox van Innotek. (onder UBUNTU)

Installatie verliep goed maar ik kon XP alleen maar opstarten als ik Innotek opstartte in een terminal met root rechten.
XP draaide goed alles werkte.
Om Innotek en dus XP gewoon via het aanklikken van de icon van Innotek op te kunnen starten (hij gaf de foutmelding aan dat ik geen rechten had om het op te starten en ik moest me opgeven bij 'vboxusers') heb ik via 'Gebruikers en groepen' en dan 'groepen beheren' en 'vboxusers' zowel root als mijn gebruikersnaam aangevinkt. Als ik dan Innotek aanklik en dan XP opstart zie ik even het logo van Innotek maar dan krijg ik de error:
'Fatal: could not read from the boot medium! System halted' Geen XP dus.

Als ik weer via een terminal met root rechten Innotek opstart kan ik XP gewoon opstarten en werkt het als een speer!

Hoe kan dat
Wat heb ik fout gedaan
Wat kan ik nog doen om Innotek en XP gewoon op te starten via het aanklikken van het icoontje

Met andere woorden: HELP, wie weet RAAD!

Bedankt voor het meedenken.

Hans

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #1 Gepost op: 2008/02/02, 13:59:58 »
Kan niemand mij een handje op weg helpen????

Alvast bedankt,

Hans

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #2 Gepost op: 2008/02/02, 14:22:41 »
Weet niet zeker of het volgende belangrijk is, maar heb je je computer opnieuw gestart nadat je jezelf en root als vbox-gebruikers hebt aangevinkt?
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Junke1990

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #3 Gepost op: 2008/02/02, 14:30:39 »
al geprobeerd om hem te starten met 'gksudo virtualbox' ??

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #4 Gepost op: 2008/02/02, 14:46:51 »
Je moet jezelf toevoegen aan de vboxusers groep.
Dit kan via systeem>beheer>gebruikers en groepen.

Waarschijnlijk werkt het nu nog steeds niet, omdat je de rechten van de virtualbox bestanden in je home map niet meer goed staan. Dit komt omdat je virtualbox als root gedraaid hebt.
Dit kan je op de volgende manier oplossen:
sudo chown -R $USER:$USER ~/.VirtualBox

komodo13

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #5 Gepost op: 2008/02/02, 14:53:33 »
Bedankt johan . ga even uitproberen hoop dat het bij mij ook werkt.

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #6 Gepost op: 2008/02/02, 15:00:16 »
Oke Johan,

Ik heb onder gebruikers en groepen en 'groepen beheren' aangeklikt, gescrold naar vboxusers en mezelf en de root aangevinkt en toen weer afgesloten. Ik zal zo dat commando geven als VB is afgesloten want ik ben net even G O S aan het installeren.

In ieder geval bedankt!

Hans

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #7 Gepost op: 2008/02/02, 16:03:17 »
sudo chown -R $USER:$USER ~/.VirtualBox  heeft geen enkel effect gehad.

Ik zie zelfs als ik Innotek via het icoon opstart niet eens de andere linux versie (G O S ) staan die ik net geïnstalleerd heb.

Start ik Innoktek op via terminal als root dan zie ik G O S ook en werkt alles naar behoren!

Vreemd hoor.

Ik hoop er nog uit te komen met jullie hulp, bedankt!

Groet,
Hans

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #8 Gepost op: 2008/02/02, 16:07:51 »
Hoe bedoel je "als root"?
Doe je dat via sudo, of zorg je dat je eerst root wordt en voer je daarna dat commando uit?
In het 2e geval staat alles in /root/ en dat is echt niet de bedoeling.

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #9 Gepost op: 2008/02/02, 21:33:29 »
Nee alles staat niet in root! Ik start een terminal op die gaat bij mij automatisch op als root, ga met cd naar /usr/bin en geef daar het VirtualBox commando op. Alles werkt dan perfect. Ben ik gewoon in Ubuntu bezig zonder root rechten en ik ga naar toepassingen en systeem gereedschappen, klik dan op het icoontje van Innotek; dan start Innotek gewoon op maar kan ik XP niet opstarten omdat hij dan de foutmelding geeft dat hij niet kan booten en... ik zie G O S niet staan om in Innotek op te starten. Deze laatste zie ik alleen bij XP staan als ik Innotek opstart als root via de terminal.

Het lijkt me dat ik gewoon Innotek kan gebruiken waar het voor gemaakt is als ik het gewoon via het icoontje opstart en er niet speciaal via een terminal en dan als root moet opstarten.

groeten,

Hans

komodo13

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #10 Gepost op: 2008/02/02, 21:51:32 »
vreemd hoor ik net virtualbox geinstalleerd en de adviezen van johan opgevolgd en windows xp start bij mij wel normaal op. alles werkt naar behoren. alleen weet ik niet hoe ik bestanden moet verplaatsen van ubuntu naar winxp in virtualbox. kan iemand me even uitleggen hoe het moet?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #11 Gepost op: 2008/02/02, 22:34:40 »
Citaat van: dxhunter
Nee alles staat niet in root! Ik start een terminal op die gaat bij mij automatisch op als root...
Dat is niet normaal.
Als je een terminal opent, hoort daar jouw gebruikersnaam te staan. Als daar root staat heb je of het verkeerde icoontje aangeklikt (root terminal ipv gewone terminal) of je instellingen zijn niet goed.

Ik weet vrij zeker dat een gedeelte van je Virtualbox in /root terecht gekomen is.
Open maar eens de verkenner, druk op control-h en ga naar /root. Dan zie je vanzelf dat daar ook een .Virtualbox map staat.

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #12 Gepost op: 2008/02/02, 22:48:57 »
Johan, als ik 'terminal als root' opstart (staat in Toepassingen - Systeemgereedschappen) moet ik mijn wachtwoord opgeven en staat er in mijn terminal het volgende:

---------

root@dxhunter-desktop:/home/dxhunter#
---------

Ik ga dan naar /usr/bin en geef het VirtualBax commando.

In mijn root (via locaties - Persoonlijke map - Bestandsysteem - root) staat alleen Desktop. Zie verder ook niets als ik bij Nautilis verborgen bestanden en reserve bestanden bij voorkeur aan klik!

Als ik Nautilis opstart en dan control-h doe zie ik geen root (heet bij mij '/home/dxhunter') daar zie ik inderdaad een .Virtualbox staan met bij machines alleen XP en geen G O S die ik later geïnstalleerd heb.
Staat deze .Virtualbox daar onterecht (en gelinkt aan het Innotek icontje bij Systeengereedschappen? Staat er dan ergens nog een dir met virtualbox en start ik die dan op als ik het via de terminal doe?

Bedankt voor je meedenken,

Groeten,

Hans

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #13 Gepost op: 2008/02/03, 00:37:54 »
Je moet dus NIET 'terminal als root' openen.
Dan ben je root en dat is niet de bedoeling, tenzij je systeembeheer-taken wil doen.
Alle programma's die je via die terminal opent, openen met root rechten (gevaarlijk!) en schrijven alle persoonlijke data naar /root/
Ga je met zo'n programma in je eigen home map werken(/home/gebruikersnaam), dan help je de rechten van de bestanden in je home map om zeep.

Bij normaal gebruik (en daar valt het gebruik van Virtualbox zeker ook onder) open je de gewone terminal.
Via Toepassingen>Hulpmiddelen>Terminal.

In Nautilus moet je eerst naar het begin van je harde schijf gaan: /
Hier zie je mappen als bin, boot, cdrom enz.
Daar staat ook de map root.
Daar moet je de map .VirtualBox weghalen.
Je zal dan wel GOS weer opnieuw moeten installeren, maar dat is niet anders.


dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #15 Gepost op: 2008/02/03, 08:26:19 »
Johan, goedemorgenn trouwens!
Als ik via Nautilis naar / ga en dan naar root staat er geen .VirtualBox in root! Alleen Desktop verder staat er niks onder of in root!
En Virualbox opstarten via de 'normale' terminal gaat wel maar dan krijg ik die foutmelding wanneer VB opstart dat hij XP niet kan booten en G O S staat er niet bij.
Alleen als ik VB opstart onder root rechten, werkt VB zoals als het hoort! Normaal gebruik ik geen root rechten en weet ik wel wat root rechten betekent. Ik gebruik dat alleen als ik daarom gevraagd wordt. Ik kwam er toevallig achter van de week dat VB bij mij dus alleen goed werkt als ik hem start in een terminal met root rechten. En dat vond ik dus niet 'normaal' en vandaar mijn topic vraag.

Groeten en bedankt voor je hulp.

Hans.

JA en

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #16 Gepost op: 2008/02/03, 13:16:46 »
Heb je in Nautilus ook op control-h gedrukt? Dan pas zie je de verborgen bestanden en mappen. Die beginnen met een punt.

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #17 Gepost op: 2008/02/03, 19:08:24 »
Beste Johan, je had helemaal gelijk! In root staat idd een VB box met een puntje.

Moet ik de inhoud van deze .VB kopiëren/verplaatsen naar de .VB die in mijn home directory staat?

Groeten,

Hans

dxhunter

  • Gast
Innotek VirtualBox start niet meer op
« Reactie #18 Gepost op: 2008/02/08, 13:11:35 »
Beste Johan,

Zou je mijn laatste vraag nog eens willen lezen en hopelijk er een antwoord op kunnen geven?

Hartelijk dank,

Hans

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Innotek VirtualBox start niet meer op
« Reactie #19 Gepost op: 2008/02/08, 14:02:47 »
Het beste is om opnieuw te beginnen met die Virtualbox. Dan neem je geen oude rommel of instellingen mee die ervoor kunnen zorgen dat het niet werkt.
Haal dus de .VirtualBox map uit /root weg, en maak op de goede manier een nieuwe aan in je eigen home map.