Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: traag openen mappen  (gelezen 7052 keer)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Gepost op: 2008/02/01, 09:58:04 »
sinds een week is mijn gutsy zeer traag in het opstarten van programma's, ik weet niet waar het vandaan komt, ik kan niets vinden in /var/log/messages.
Als ik mijn home directory wil openen in nautilus duurt het soms een minuut voor ik het krijg te zien, in console is de map wel direct te listen.
In virtual machine is het idem het duurt eeuwen om iets te openen en te saven in de met host gedeelde mappen (is dus echt een gutsy probleem)

Is er een manier om uit te vissen waar het mis gaat?

Offline kebabfish

  • Lid
  • Steunpunt: Ja
traag openen mappen
« Reactie #1 Gepost op: 2008/02/01, 10:21:18 »
Typ eens in een terminal: top
en post de uitkomst hier. Grote kans dat een ander proces geheugen vreet, of je processor zwaar belast. Tevens is het handig te weten op wat voor systeem je werkt (geheugen, processor etcetc)

Mvg

StevenD

  • Gast
traag openen mappen
« Reactie #2 Gepost op: 2008/02/01, 10:21:33 »
open eens een terminal en typ in nautilus. Geef eens de berichten weer die daar komen. Ik heb hier kde en heb het geprobeerd met dolphin, waar ik geen enkele (fout-)melding kreeg.

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #3 Gepost op: 2008/02/01, 11:27:55 »
Nou hier de uitvoer van top, die geeft trouwens ieder paar seconden weer wat anders waaronder de screensaver maar als ik zie dat mn ram bijna int geheel in gebruik is vraag ik me af wat wie of wat daar dan zo idioot veel gebruik van maakt.

mijn systeem is een P4 2,8 GHz, met 1,1 GB geheugen

top - 11:22:00 up  3:59,  2 users,  load average: 0.08, 0.17, 0.11
Tasks: 125 total,   3 running, 122 sleeping,   0 stopped,   0 zombie
Cpu(s):  7.1%us,  1.2%sy,  0.0%ni, 91.7%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1165168k total,  1081448k used,    83720k free,   151000k buffers
Swap:  3413772k total,        0k used,  3413772k free,   648164k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                  
 6357 roelof    15   0  187m  83m  22m S  5.1  7.4   5:16.25 firefox-bin                                              
 5190 root      15   0  321m  40m 9496 S  1.4  3.6   3:17.30 Xorg                                                    
 5377 roelof    15   0 20584 8056 6372 S  1.2  0.7   0:09.52 gnome-screensav                                          
 5363 roelof    15   0 16756 9696 7996 S  0.5  0.8   0:16.53 metacity                                                
 7140 roelof    15   0 55524  17m  11m R  0.5  1.6   0:03.00 gnome-terminal                                          
 8138 roelof    15   0  2364 1164  876 R  0.2  0.1   0:00.06 top                                                      
    1 root      15   0  2948 1856  532 S  0.0  0.2   0:01.14 init                                                    
    2 root      11  -5     0    0    0 S  0.0  0.0   0:00.00 kthreadd                                                
    3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 migration/0                                              
    4 root      34  19     0    0    0 R  0.0  0.0   0:00.03 ksoftirqd/0                                              
    5 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 watchdog/0                                              
    6 root      10  -5     0    0    0 S  0.0  0.0   0:00.11 events/0                                                
    7 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper                                                  
   26 root      12  -5     0    0    0 S  0.0  0.0   0:00.05 kblockd/0                                                
   27 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid                                                  
   28 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kacpi_notify                                            
  117 root      10  -5     0    0    0 S  0.0  0.0   0:00.01 kseriod

Offline kebabfish

  • Lid
  • Steunpunt: Ja
traag openen mappen
« Reactie #4 Gepost op: 2008/02/01, 11:35:06 »
Wat mij opvalt is dat je swap in het geheel niet gebruikt wordt, maar je ram wel ten volle. Lijkt alsof je swap niet geactiveerd is, maar dat zou ten gevolge hebben dat je processor zwaarder wordt belast. En dat is hier niet het geval.
Maar hoe we nu uit kunnen vogelen wat er dan zoveel ram verbruikt, zou ik zo 123 niet weten...

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #5 Gepost op: 2008/02/01, 11:52:41 »
Volgens mij is het logisch dat het geheugen als eerste wordt aangesproken, en daarna pas de swap, omdat swap nu eenmaal trager is.

Iemand anders nog ideeen

Offline kebabfish

  • Lid
  • Steunpunt: Ja
traag openen mappen
« Reactie #6 Gepost op: 2008/02/01, 11:54:08 »
Als thuis mijn ramgeheugen voor 80% wordt aangesproken (800 mb), dan wordt de swap al wel degelijk gebruikt. Bij jou zit je bijna op 100%, terwijl de swap niet wordt gebruikt...
Volgens mij klopt dat dan niet ;)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #7 Gepost op: 2008/02/01, 11:54:23 »
Trouwens StevenD, dat had ik zelf al uitgeprobeert maar ik krijg geen meldingen als ik nautilus intik in een terminal

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #8 Gepost op: 2008/02/01, 12:02:23 »
hoe activeer ik de swap dan?? in fdisk?

Offline woteb

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #9 Gepost op: 2008/02/01, 12:09:12 »
Post je /etc/fstab eens?
Wat je ook kunt laten zien is de terminaluitvoer: df -hHier mijn uitput:
Citaat
vader@enigma:~$ df -h
Bestandssysteem            Grtte  Gebr Besch Geb% Aangekoppeld op
/dev/hda1             4,0G  2,1G  1,8G  55% /
varrun                126M   96K  125M   1% /var/run
varlock               126M     0  126M   0% /var/lock
procbususb            126M   96K  125M   1% /proc/bus/usb
udev                  126M   96K  125M   1% /dev
devshm                126M     0  126M   0% /dev/shm
lrm                   126M   33M   93M  27% /lib/modules/2.6.20-16-generic/volatile
/dev/hda4              14G  8,8G  4,6G  66% /files
/dev/hda2             9,2G  6,9G  1,9G  80% /home
vader@enigma:~$
Je ziet hier geen swap in beeld, en dat klopt, want dat is /dev/hda3 in mijn situatie. Als je in jouw situatie hier wel de swap ziet, dan is die partitie waarschijnlijk ext3 geformateerd.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #10 Gepost op: 2008/02/01, 12:12:03 »
Bestandssysteem            Grtte Gebr Besch Geb% Aangekoppeld op
/dev/hda1             144G   83G   54G  61% /
varrun                569M  268K  569M   1% /var/run
varlock               569M     0  569M   0% /var/lock
udev                  569M   88K  569M   1% /dev
devshm                569M     0  569M   0% /dev/shm
lrm                   569M   34M  536M   6% /lib/modules/2.6.22-14-generic/volatile

Offline woteb

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #11 Gepost op: 2008/02/01, 12:15:17 »
En je fstab? (/etc/fstab)
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #12 Gepost op: 2008/02/01, 12:24:55 »
even gekeken in Gparted en mijn swap zit op hda4 en is aktief

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #13 Gepost op: 2008/02/01, 12:26:44 »
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/hda1
UUID=6859a0af-361c-4091-a5df-a439431915f2 /               ext3    defaults,errors=remount-ro 0       1
# /dev/hda5
UUID=3c2ee1b5-5a70-453a-b9dc-35f87846f26b none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #14 Gepost op: 2008/02/01, 13:13:33 »
Even geneusd op de andere fora, en kwam deze quote tegen, dus daar zit het probleem niet

Your RAM usage will always be around 100% (unless you just booted). This is by design. Things loaded into RAM that are no longer being used stay in RAM until another program needs that space (ie you open another program and there is no available RAM).


Maar dan is nog steeds de vraag waarom duurt het zolang om mijn programma's te starten.

Offline woteb

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #15 Gepost op: 2008/02/01, 13:39:09 »
Citaat van: smiley1962
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/hda1
UUID=6859a0af-361c-4091-a5df-a439431915f2 /               ext3    defaults,errors=remount-ro 0       1
# /dev/hda5
UUID=3c2ee1b5-5a70-453a-b9dc-35f87846f26b none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
Gaan we aanpassen:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/hda1 UUID=6859a0af-361c-4091-a5df-a439431915f2 /  ext3    defaults,errors=remount-ro 0       1
# /dev/hda5 UUID=3c2ee1b5-5a70-453a-b9dc-35f87846f26b none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

Je ziet dat:
# /dev/hda1 UUID=6859a0af-361c-4091-a5df-a439431915f2 /  ext3    defaults,errors=remount-ro 0       1
# /dev/hda5 UUID=3c2ee1b5-5a70-453a-b9dc-35f87846f26b none            swap    sw              0       0

en

/dev/hda1 /  ext3    defaults,errors=remount-ro 0       1
/dev/hda5  none            swap    sw              0       0

hierin verschillen dat de eerste regels een # ervoor hebben staan en de UUID's hebben, de tweede hebben geen # ervoor en zijn zonder de UUID's.

Mocht dat geen soleaas bieden, dan kun je de eerste regels van de # ontdoen en voor de tweede zetten.
Uiteraard het systeem opnieuw opstarten om het effect te bekijken.

En dat het RAM verbruik ongeveer 100% is gaat natuurlijk in zoverre op aan de hand van het verbruik. Mijn IceWM systeem start namelijk op met 182 MB (van de 256) waarvan 130 MB cache), dus lang niet alles. Start ik Gnome op, dan gaat die vlieger wel op en zit het RAM verbruik op ongeveer 245 MB.

Verder heb ik even gekeken naar jouw output van top en zie dat jij 125 processen heb draaien, terwijl dat bij een standaard geïnstalleerde Ubuntu op 105 moet staan. Er draaien dus 20 processen meer dan standaard. Wat heb jij bijv. allemaal opgestart?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #16 Gepost op: 2008/02/01, 13:47:24 »
ik snap deze even niet kun je iets duidelijker zijn? want ik vraag me af of het wel op dat niveau zit.
Ik denk dat het ergens in de gui versie wat niet goed gaat

Offline woteb

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #17 Gepost op: 2008/02/01, 13:54:41 »
Er zijn systemen die problemen hebben met die UUID tags. Zelf heb ik daar ook last van en heb die uitgezet door die zaken te strippen. Vooral Gutsy gaat bij mij veel sneller draaien zonder die UUID tags.
Wat ik dus heb gedaan is de regels van fstab kopiëren en eronder te plakken. Dus een setje mét en een setje zonder UUID tags. Door die # voor de regels zeg je dat die regels niet mogen worden gebruikt, dus óf bij het setje met, óf met het setje zonder de UUID tags.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #18 Gepost op: 2008/02/01, 14:17:24 »
aha, das duidelijk ik ga het even proberen

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #19 Gepost op: 2008/02/01, 14:32:44 »
nou dat was het dus niet, ik heb het idee dat het door copiz komt, wat is de snelste manier om terug te gaan naar default settings, ofwel kan ik wat deinstalleren en daarna herinstalleren.

Offline woteb

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #20 Gepost op: 2008/02/01, 14:49:50 »
Dat moet je aan de Compizgebruikers vragen. Zelf draai ik geen compiz, heb dat zelfs niet eens geïnstalleerd (eruit gesloopt, scheelt weer resources).
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #21 Gepost op: 2008/02/01, 14:56:42 »
nou in elk geval bedankt voor de hulp

Offline kebabfish

  • Lid
  • Steunpunt: Ja
traag openen mappen
« Reactie #22 Gepost op: 2008/02/01, 15:42:51 »
Ik zit momenteel op een laptop met pentium 4 (1,7 GHz), 512 mb ram, 800 mb aan swap en een 32 mb ati videokaartje. Ik heb compiz met alle poespas aan (desnoods kan ik wat screens plakken). Kopete, awn, azureus en amarok draaien in volle tevredenheid mee op de achtergrond, en firefox surft lekker over het web. Alles werkt zoals het moet, dus bij jou zou dat zeker moeten kunnen.

edit: compiz is gemakkelijk uit te zetten. Rechtermuisklik op het bureaublad, kiezen voor werkbladachtergrond wijzigen, daar naar tabblad visuele effecten gaan en daar het vakje voor "geen" aanvinken.

Compiz is daarna gewoon te verwijderen via synaptic.

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #23 Gepost op: 2008/02/01, 17:18:24 »
:) ja dat doet ie bij mij ook zelfs met virtual machine op de achtergrond, maar op de een of andere manier is er vorige week iets mis gegaan en zit er nu vertraging in het openen van programma's als het eenmaal draait is er ook niets aan de hand, maar weet je hoe vaak ik mijn home map open en weer sluit :p

Ik heb al geprobeert om een nieuwe gebruiker aan te maken, maar heb ik dezelfde problemen.

Offline smiley1962

  • Lid
  • Steunpunt: Nee
traag openen mappen
« Reactie #24 Gepost op: 2008/02/01, 21:19:48 »
Opgelost, een vriend van me vertelde me dat het waarschijnlijk een DNS probleem zou zijn, X is voor een belangrijk deel afhankelijk van DNS waardoor programma's zoeken naar de DNS server, ik had de proxiserver van de zaak wel toegevoegd, maar aan het eind, dus daarom was het allemaal zo traag.
Profiel zaak in netwerk-beheer weggegooid en nieuw aangemaakt met de juiste DNS server, probleem is nu weg.

iedereen bedankt