Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: UT2004 op ubuntu  (gelezen 8381 keer)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Gepost op: 2006/07/12, 15:36:08 »
hmmm, ik ben de zoon van leo. ik heb een probleem. ik wil graag UT2004 spelen op ubutu. ik heb WIne geinstaleerd en verschillende codes ingevoerd in de terminal: geen werkt.

bijv: wine /mnt/BOOT/Program Files/UT2004/System/UT2004.exe
dan geeft hij de error: wine: cannot find '/mnt/BOOT/Program'

Ik heb helemaal speciaal uitgezocht waar op de windows partitie UT2004 staat en heb dat keurig volgens het voorbeeld: http://penguinpower.solarism.nl/pcontent/unrealclassic.php , geprobeerd maar niks werkt! HELP! Ik heb echt heel veel verschillende codes ingevoerd maar geen van ze werken!
Misschien zien jullie iets wat ik niet zie!

Gr. van Menno.

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #1 Gepost op: 2006/07/12, 16:19:04 »
wine /mnt/BOOT/Program Files/UT2004/System/UT2004.exe

moet denk ik zijn:

wine "/mnt/BOOT/Program Files/UT2004/System/UT2004.exe"

doordat er een spatie tussen program en files staat krijg je die error denk ik. Het zou mij trouwens niks verbazen als, wanneer je het aan de praat hebt, het toch niet goed werkt. Wine bevat nog niet echt goed support voor DirectX games/applicaties. Het zou mij niets verbazen wanneer het met bijvoorbeeld Cedega wel zou werken (www.transgaming.org) alleen Cedega daar moet je voor betalen. Het is gebaseerd op Wine, maar daar hebben ze dan o.a. DirectX in verder ontwikkeld meen ik. Ik gebruik Cedega (jawel, gekocht) voor o.a. Command & Conquer: Generals (en ZH), Kolonisten van Catan

Firebird

  • Gast
UT2004 op ubuntu
« Reactie #2 Gepost op: 2006/07/12, 16:35:54 »
Is er normaal geen installer-script op de cd's voorzien zodat je het daarna native kan draaien? Kijk eens naar dit artikel. OpenGL is geen probleem, btw.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #3 Gepost op: 2006/07/12, 17:13:00 »
dank je firebird ik ga aan de slag met aanwijzingen op de website.
ik vertel er nog over, ok?

menno

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #4 Gepost op: 2006/07/12, 17:14:07 »
Eeeeeeuh, Unreal Tournament 2004 hoef je echt niet via een wrapper zoals Wine of Cedega te draaien hoor ! :)

Unreal Tournament 2004 is gewoon beschikbaar voor Linux.
De Linux versie zit inbegrepen op de eerste installatie-cd.
Lees de readme maar
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

sonics

  • Gast
UT2004 op ubuntu
« Reactie #5 Gepost op: 2006/07/13, 08:32:55 »
ja UT2004, Quake serie zijn juisdt DE linux native games.

Offline SWAT

  • Administrator
    • http://www.schauenburg.nl/
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #6 Gepost op: 2006/07/13, 09:50:19 »
en native games runnen dus zonder cedega of wine (en ze runnen goed). Quake 4 en UT2004 lopen super hier :D

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #7 Gepost op: 2006/07/13, 11:00:08 »
/media/cdrom0/CD1
/media/cdrom0/CD2
/media/cdrom0/CD3
/media/cdrom0/CD4
/media/cdrom0/CD5
/media/cdrom0/CD6
/media/cdrom0/CD7
/media/cdrom0/0x0409.ini
/media/cdrom0/AutoRun.inf
/media/cdrom0/Data1.cab
/media/cdrom0/ecesetup.exe
/media/cdrom0/instmsia.exe
/media/cdrom0/instmsiw.exe
/media/cdrom0/linux-installer.sh
/media/cdrom0/Setup.exe
/media/cdrom0/Setup.ini
/media/cdrom0/UT2004 Editor's Choice Edition Mod Installer.msi
mount /dev/cdrom /mnt/cdrom
cp /mnt/cdrom/linux-installer.sh .
./linux-installer.sh
export SETUP_CDROM=/mnt/cdrom (ik heb een dvd)
unmount /mnt/cdrom

op alle commando's volgt: bestand of map niet gevonden...
wat doe ik fout? ik werk met een DVD van ut 2004.
en gebruik 2 terminals: 1 als su de andere als "mounter"
kan iemand mij helpen?

gr Menno

budster

  • Gast
UT2004 op ubuntu
« Reactie #8 Gepost op: 2006/07/13, 11:25:38 »
Heb je bovenstaande posts niet gelezen? UT schijnt gewoon native op Ubuntu te draaien.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #9 Gepost op: 2006/07/13, 11:35:56 »
ik probeer hem native te draaien, de posts zijn duidelijk, alleen ik krijg het prog niet aan de praat.
ik werk nu twee dagen met ubuntu linux.

gr menno

budster

  • Gast
UT2004 op ubuntu
« Reactie #10 Gepost op: 2006/07/13, 11:37:58 »
Volgens mij probeer jij de windows versie te installeren, je moet natuurlijk wel de linux versie installeren.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #11 Gepost op: 2006/07/13, 11:56:17 »
waaruit blijkt dat?

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #12 Gepost op: 2006/07/13, 12:11:00 »
Dat je .exe bestanden probeert op te starten maar als je bash /media/cdrom0/linux-installer.sh doet in een terminal dan werkt het niet?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #13 Gepost op: 2006/07/13, 12:37:18 »
het is geinstalleerd.dank u.bij het opstarten;
opstartscherm verschijnt, dan in terminal :
WARNING: ALC_EXT_capture is subject to change!
opstartscherm verdwijnt weer...hij blijft hangen, heeft u
nog tips?
gr menno

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #14 Gepost op: 2006/07/13, 13:41:53 »
De site van UT2004 raadplegen? ;)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #15 Gepost op: 2006/07/13, 13:53:13 »
ok, de hint is duidelijk, niet meer zeuren..:)

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #16 Gepost op: 2006/07/13, 14:24:58 »
Nee joh :) zo bedoelde ik dat niet... Maar aangezien ik geen UT2004 heb kan ik je verder met eventuele problemen niet helpen.. hooguit dat iemand anders hier UT2004 heeft en hetzelfde probleem heeft gehad je er mee kan helpen maar het lijkt mij zo dat er op de site van UT wat veel voorkomende problemen zijn... Zeuren mag altijd, problemen melden en oplossen ook ;)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #17 Gepost op: 2006/07/13, 17:46:47 »
ok
ik heb ut2004 geinstall. op ubuntu 606.
de command : ut2004 werkt niet.(in de terminal)
klikken op het (linux) ut2004 icon werkt wel maar bij het opstarten;
opstartscherm van ut verschijnt. dan echter  in de terminal :
WARNING: ALC_EXT_capture is subject to change!
opstartscherm verdwijnt weer...hij (ut) blijft hangen, heeft u
nog tips om het op te starten?er moeten toch ut gamers zijn?
gr menno
:)

sonics

  • Gast
UT2004 op ubuntu
« Reactie #18 Gepost op: 2006/07/13, 18:55:13 »
probeer je probleem anders http://www.ubuntuforums.org/forumdisplay.php?f=93 hier eens te stellen.

Offline SWAT

  • Administrator
    • http://www.schauenburg.nl/
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #19 Gepost op: 2006/07/13, 22:15:52 »
gelukkig heb je UT2004 geinstalleerd gekregen (de installer runnen vanaf de CD/DVD hoort geen probleem te zijn, werkt perfect). Het updaten van de game werkt ook super (let wel: je moet de linux patches hebben, NIET de Windows patches, kijk uit!)
Verders moet je ervoor zorgen dat je 3D drivers van je grafische kaart goed geinstalleerd staan en werken (anders heeft het geen nut om UT2004 te runnen)
Als ik het me goed herinner komt ut2004 in /usr/bin/ut2004 te staan, dus zo zou hem ook direct kunnen. Gewoon naar een console/terminal gaan en   /usr/bin/./ut2004    intypen (als die daar staat) en je bent klaar :D

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #20 Gepost op: 2006/07/14, 09:18:25 »
dank swat! even werk aan de winkel, maar dit is weer iets. je hoort het van me.

gr menno

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #21 Gepost op: 2006/07/14, 09:26:09 »
Ik kwam wel ergens tegen dat je die linux-installer.sh als root moet starten (sudo er voor dus) niet helemaal snappend waarom je dat dan zou moeten doen aangezien hij als gewone gebruiker ook gewoon zou moeten installeren.. maar wellicht dat hij wat dingen moet aanpassen/installeren waar je als gewone gebruiker niet bij kan. Misschien is dat een idee? sudo bash /media/cdrom0/linux-installer.sh  zou je dan in een terminal moeten intikken... maar of het verstandig is... dat weet ik niet.

bron: http://ubuntuforums.org/showthread.php?t=33396

MAAR! Ik heb zo'n vermoeden dat je niet de (juiste) drivers voor je grapfische kaart geinstalleerd hebt staan... Als het een ATI is, dan zou je die eens moeten installeren. Post anders eens je xorg.conf hier, te vinden in /etc/X11/xorg.conf (zo uit mijn hoofd). Dit is iets waar een aantal mensen (google) tegenaan zijn gelopen.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #22 Gepost op: 2006/07/14, 09:55:29 »
tijdens de instalatie van UT kreeg je in de terminal het volgende:

Gtk-WARNING **: Kan module in module_path: "liblighthouseblue.so" niet vinden,

Gtk-WARNING **: Kan module in module_path: "liblighthouseblue.so" niet vinden,

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 534 (gtk_entry_get_text): assertion `entry != NULL' failed.
loki_setup: Can't create /home/leor/ut2004: Bestand bestaat

kan iemand me vertellen wat dit is ????

gr menno

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
UT2004 op ubuntu
« Reactie #23 Gepost op: 2006/07/14, 10:33:13 »
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generic Video Card"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Azalin

  • Gast
UT2004 op ubuntu
« Reactie #24 Gepost op: 2006/07/14, 12:07:09 »
Citaat van: leoquant
#
Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:1:0:0"
EndSection
Wat ik al dacht... je hebt geen specifieke drivers geinstalleerd... dan zal UT niet echt draaien denk ik aangezien je nu geen OpenGL hebt. Voor zover ik weet heeft UT dat wel nodig... sowieso zou UT heel traag draaien als het al opstartte...
Welke grafische kaart zit er in je PC? ATi? NVidia? Iets anders?

Voor ati: https://help.ubuntu.com/community/BinaryDriverHowto/ATI
of http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide

Voor nvidia: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Wat die error betreft tijdens de install, geen idee. Het lijkt er op dat hij iets niet kon vinden en dat hij je user map niet kon aanmaken omdat die al bestond.