Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen met installeren nieuwe nvidia drivers  (gelezen 4018 keer)

Gast

  • Gast
Problemen met installeren nieuwe nvidia drivers
« Gepost op: 2006/07/11, 15:35:50 »
Ik heb nu juist voor het eerst linux (Ubuntu: Dapper Drake) op men pc gezet en wil nu de laatste drivers van Nvidia installeren voor men 6600GT.
Maar als ik de instructies volg van de nVidia site, dan geeft hij een foutmelding, namelijk de deze:
ERROR: Unable to find the system utility `ld`; please make sure you have the package
         'binutils' installed.  If you do have binutils installed, then please check that
         `ld` is in your PATH.

dit bij het intypen van: sh NVIDIA-Linux-x86-1.0-8762-pkg1.run

Greetz, Horie

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #1 Gepost op: 2006/07/11, 15:41:24 »
Je hoeft dat zo niet installeren tenzij je daar een speciale reden voor hebt :P

Probeer dit eens:
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#head-442028f641933e559611b8e6993bff808d600069

Als je iets niet snapt of begrijpt, vraag je maar om hulp
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Gast

  • Gast
Problemen met installeren nieuwe nvidia drivers
« Reactie #2 Gepost op: 2006/07/11, 15:59:25 »
Mijn linux is in het nederlands dus snap ik niet echt wat die repositories zijn :-$.
Kzit nu bij toevoegen en welk van de 4 vakjes moet ik dan aanvinken?

Greetz, horie

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #3 Gepost op: 2006/07/11, 16:16:08 »
Systeem -> Beheer -> Synaptic pakketbeheer

In het menu van Synaptic kies je "Instellingen -> Pakketbronnen"

Klik op de knop "Toevoegen"

Duid alle 4 vakjes aan (officieel, beperkt, universe, multiverse) en klik op "Toevoegen" en daarna op "Sluiten"

Klik linksboven op de "Herladen" knop (gele knop met pijltjes)

Ga dan verder vanaf hier: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#head-f8ea537454e53c8ecf3af0d8946a8162ac1c008d
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #4 Gepost op: 2006/07/11, 17:02:36 »
mag ik even...?

Dit is wat is ge
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #5 Gepost op: 2006/07/11, 19:16:11 »
Citaat van: theokus
mag ik even...?

...

Dit staat in de xorg.conf
Section "Device"
   Identifier   "NVIDIA Corporation NV34 [GeForce FX 5500]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection
Euh, jij gebruikt blijkbaar nog de standaard nv driver ZONDER hardwareversnelling.

Wat zegt "glxinfo|grep direct"
en heb je meer dan 2000 FPS als je "glxgears" draait?

Ik denk dat je dit vergeten bent:
sudo nvidia-glx-config enable

Of: pas gewoon "nv" aan in "nvidia" en druk ctrl+alt+backspace om X te restarten
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #6 Gepost op: 2006/07/11, 20:24:17 »
Citaat van: profoX
Citaat van: theokus
mag ik even...?

...

Dit staat in de xorg.conf
Section "Device"
   Identifier   "NVIDIA Corporation NV34 [GeForce FX 5500]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection
Euh, jij gebruikt blijkbaar nog de standaard nv driver ZONDER hardwareversnelling.

Wat zegt "glxinfo|grep direct"
en heb je meer dan 2000 FPS als je "glxgears" draait?

Ik denk dat je dit vergeten bent:
sudo nvidia-glx-config enable

Of: pas gewoon "nv" aan in "nvidia" en druk ctrl+alt+backspace om X te restarten
Okeey, zal dat nog eens proberen.
Heb wel handmatig die dpkg-reconfigure xserver-xorg
gedaan....

theokus@UBU-PC:~$ glxinfo|grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
theokus@UBU-PC:~$

Nul nul nul :)

Maarrrrr ik hen het gedaan:
theokus@UBU-PC:~$ glxinfo|grep direct
direct rendering: Yes
theokus@UBU-PC:~$

Is dat beter ? :)

WAT IS "glxgears" ...
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #7 Gepost op: 2006/07/11, 20:49:47 »
Dus het werkt nu wel ?

glxgears is een programma dat gewoon in OpenGL ronddraaiende tandwielen laat zien en in de terminal om de 5 seconden een melding geeft van het aantal frames per seconde

als je glxgears niet resized en op de voorgrond houdt
moeten de frames met een geforce 5 of hoger ver boven 2500 FPS liggen :)

(sudo apt-get install mesa-utils om te installeren, maar die heb je normaal gezien al als glxinfo werkt)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #8 Gepost op: 2006/07/11, 20:57:10 »
Citaat van: profoX
Dus het werkt nu wel ?

glxgears is een programma dat gewoon in OpenGL ronddraaiende tandwielen laat zien en in de terminal om de 5 seconden een melding geeft van het aantal frames per seconde

als je glxgears niet resized en op de voorgrond houdt
moeten de frames met een geforce 5 of hoger ver boven 2500 FPS liggen :)

(sudo apt-get install mesa-utils om te installeren, maar die heb je normaal gezien al als glxinfo werkt)
Ow zo :)
Het spel draait maar er verschijnen geen gegevens in de terminal...
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #9 Gepost op: 2006/07/11, 21:24:44 »
Citaat van: theokus
Citaat van: profoX
Dus het werkt nu wel ?

glxgears is een programma dat gewoon in OpenGL ronddraaiende tandwielen laat zien en in de terminal om de 5 seconden een melding geeft van het aantal frames per seconde

als je glxgears niet resized en op de voorgrond houdt
moeten de frames met een geforce 5 of hoger ver boven 2500 FPS liggen :)

(sudo apt-get install mesa-utils om te installeren, maar die heb je normaal gezien al als glxinfo werkt)
Ow zo :)
Het spel draait maar er verschijnen geen gegevens in de terminal...
Een tijd geleden is glxgears inderdaad aangepast (maar ondertussen weer opnieuw aangepast, ofwel haal ik dat package tegenwoordig gewoon van een onoffici
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #10 Gepost op: 2006/07/11, 21:33:56 »
Citaat van: profoX
Citaat van: theokus
Citaat van: profoX
Dus het werkt nu wel ?

glxgears is een programma dat gewoon in OpenGL ronddraaiende tandwielen laat zien en in de terminal om de 5 seconden een melding geeft van het aantal frames per seconde

als je glxgears niet resized en op de voorgrond houdt
moeten de frames met een geforce 5 of hoger ver boven 2500 FPS liggen :)

(sudo apt-get install mesa-utils om te installeren, maar die heb je normaal gezien al als glxinfo werkt)
Ow zo :)
Het spel draait maar er verschijnen geen gegevens in de terminal...
Een tijd geleden is glxgears inderdaad aangepast (maar ondertussen weer opnieuw aangepast, ofwel haal ik dat package tegenwoordig gewoon van een onoffici
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #11 Gepost op: 2006/07/13, 02:50:56 »
Dat was dan wel voor een geforce 5 of hoger ofzo

Ik heb een Geforce 3 ti 200 64MB @ nvidia en die heeft 2200 FPS ofzo
En een ATI Mobility Radeon 7500 32MB @ radeon+dri en die heeft 2100 FPS ofzo

...ofzo ;)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #12 Gepost op: 2006/07/13, 03:33:05 »
Citaat van: profoX
Dat was dan wel voor een geforce 5 of hoger ofzo

Ik heb een Geforce 3 ti 200 64MB @ nvidia en die heeft 2200 FPS ofzo
En een ATI Mobility Radeon 7500 32MB @ radeon+dri en die heeft 2100 FPS ofzo

...ofzo ;)
Das niet slecht ;)
As good as it gets

Offline Klojum

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #13 Gepost op: 2006/07/14, 05:42:37 »
Citaat
mag ik even...?
Dit heet nu "een topic kapen", en is op z'n zachtst gezegd niet netjes. Start liever een eigen topic, nu wordt topicstarter Horie gewoon de mond gesnoerd.

Offline FreakyDude

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #14 Gepost op: 2006/08/20, 21:44:32 »
maybe, maar ik had hetzelfde probleem en ben er nu ook min of meer mee geholpen, kan nu eindelijk gears draaien en heb direct rendering, kan alleen nog steeds mijn schermresolutie niet aanpassen.
met een beetje zoeken kan hobie ook zijn probleem oplossen met de info die door de rest gegeven is hier.

edit, en ik bedoel hetzelfde probleem als Horie

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #15 Gepost op: 2006/08/21, 06:15:34 »
Citaat van: FreakyDude
maybe, maar ik had hetzelfde probleem en ben er nu ook min of meer mee geholpen, kan nu eindelijk gears draaien en heb direct rendering, kan alleen nog steeds mijn schermresolutie niet aanpassen.
met een beetje zoeken kan hobie ook zijn probleem oplossen met de info die door de rest gegeven is hier.

edit, en ik bedoel hetzelfde probleem als Horie
Voor de goede orde:
sorry dat ik tussen kwam.

Maar die drivers van de site van Nvidia heb ik niet kunnen installeren ;)
Ik weet gewoon niet hoe dat moet.
Momenteel gebruik ik het "aanbod" van synaptic en ben daar tevreden mee.
Dacht daarbij gewoon dat die drivers van Nvidia beter waren, sneller enz.
Weet dus niet of dat zo is.

Schermresolutie had ik ook last mee > het niet weten dus bedoel ik.
Dit werkt dus:
sudo dpkg-reconfigure xserver-xorg
Doet wat meer dan het scherm aanpassen hoor.
Mijn videokaart wordt herkend plus ook het scherm. (Medion 19 inch van den Aldi..hahaha)
Kies voor "advanced" als het over het scherm gaat.
Ik dacht in het begin ook: "Oei, oei"....
Maar het is dus gelukt na een paar keren Ubuntu ge
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #16 Gepost op: 2006/08/21, 13:27:40 »
De nvidia-glx drivers in synaptic zijn dezelfde als die op de nvidia site, alleen zijn de versienummers van de driver in synaptic soms een beetje verouderd.

Resolutie in 1 keer aanpassen:
sudo dpkg-reconfigure -phigh xserver-xorg
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline theokus

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #17 Gepost op: 2006/08/21, 16:14:58 »
Citaat van: profoX
De nvidia-glx drivers in synaptic zijn dezelfde als die op de nvidia site, alleen zijn de versienummers van de driver in synaptic soms een beetje verouderd.

Resolutie in 1 keer aanpassen:
sudo dpkg-reconfigure -phigh xserver-xorg
profox jong, zeg me nu eens waar jij al die codes haalt ;)
Kan die misschien eens printen en gebruiken.
Moet ik de mensen minder lastig vallen he ;)
As good as it gets

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #18 Gepost op: 2006/08/21, 16:38:11 »
Citaat van: theokus
Citaat van: profoX
De nvidia-glx drivers in synaptic zijn dezelfde als die op de nvidia site, alleen zijn de versienummers van de driver in synaptic soms een beetje verouderd.

Resolutie in 1 keer aanpassen:
sudo dpkg-reconfigure -phigh xserver-xorg
profox jong, zeg me nu eens waar jij al die codes haalt ;)
Kan die misschien eens printen en gebruiken.
Moet ik de mensen minder lastig vallen he ;)
hier en daar :P iemand had onlangs dat probleem met resolutie veranderen en ik heb onthouden welk commando die precies gebruikte :) dpkg-reconfigure xserver-xorg wist ik al, dan gewoon de optie -phigh erbij en klaar

de meeste commands ken ik ondertussen wel uit mijn hoofd, en als ik zelf iets niet weet dan kijk ik gewoon op Google :) of op de ubuntu wiki
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Dave

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #19 Gepost op: 2006/08/21, 21:18:39 »
Citaat van: profoX
Systeem -> Beheer -> Synaptic pakketbeheer

In het menu van Synaptic kies je "Instellingen -> Pakketbronnen"

Klik op de knop "Toevoegen"

Duid alle 4 vakjes aan (officieel, beperkt, universe, multiverse) en klik op "Toevoegen" en daarna op "Sluiten"

Klik linksboven op de "Herladen" knop (gele knop met pijltjes)

Ga dan verder vanaf hier: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia#head-f8ea537454e53c8ecf3af0d8946a8162ac1c008d
krijg dan deze foutmelding

Citaat
W: GPG error: http://seveas.theplayboymansion.net dapper-seveas Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 49A120FD1135D466
W: GPG error: http://people.ubuntu.com ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B0B7481B1F44842D
W: GPG error: http://kubuntu.org dapper Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A506E6D4DD4D5088
W: GPG error: http://kubuntu.org dapper Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A506E6D4DD4D5088
W: GPG error: http://kubuntu.org dapper Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A506E6D4DD4D5088
W: GPG error: ftp://cipherfunk.org dapper Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4CF19C3233BAC1B3

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #20 Gepost op: 2006/08/21, 21:25:59 »
Dat is niet erg. Dat zijn waarschuwingen omdat je bepaalde GPG keys mist, maar je hebt die niet per se nodig. Ze zouden de verbinding veiliger maken als je ze hebt.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Dave

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #21 Gepost op: 2006/08/21, 21:54:56 »
maar nu komt steeds die waarschuwing bij ophalen pakketinformatie

Citaat
Kan niet alle lijstbestanden ophalen

De pakketbron is misschien niet meer beschikbaar of er kon geen contact gemaakt worden door netwerkproblemen. Indien aanwezig wordt een oudere lijst gebruikt. Anders zal de bron dit keer genegeerd worden. Controleer uw netwerkverbinding en of de bron wel correct opgeschreven is.

Offline Dave

  • Lid
  • Steunpunt: Nee
Problemen met installeren nieuwe nvidia drivers
« Reactie #22 Gepost op: 2006/08/21, 21:56:00 »
http://users.lichtsnel.nl/~seveas/dists/dapper-seveas/Release.gpg: Kon niet verbinden met users.lichtsnel.nl:80 (129.125.101.191). - connect (113 Geen route naar host)
ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/dists/dapper/free/binary-i386/Packages.gz: Kan bestand niet ophalen; bericht van server: Failed to open file.
ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/dists/dapper/non-free/binary-i386/Packages.gz: Kan bestand niet ophalen; bericht van server: Failed to open file.
ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/dists/dapper/free/source/Sources.gz: Kan bestand niet ophalen; bericht van server: Failed to open file.
ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/dists/dapper/non-free/source/Sources.gz: Kan bestand niet ophalen; bericht van server: Failed to open file.
http://users.lichtsnel.nl/~seveas/dists/dapper-seveas/all/binary-i386/Packages.gz: Kon niet verbinden met users.lichtsnel.nl:80 (129.125.101.191). - connect (113 Geen route naar host)