Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Resolutieprobleem met Nvidia GeForce 2 MX400 64MB  (gelezen 1570 keer)

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Gepost op: 2008/01/26, 21:18:57 »
Dag,

Ik ben sinds een week Ubuntu-gebruiker. Tot nu toe ben ik zeer te spreken. Wat tot nu toe niet lukt is de Nvidia restricted driver goed te laten werken. Als ik die aanzet wordt 'ie keurig geinstalleerd, daarna heb ik alleen maar resolutie 800x600 tot mijn beschikking. In het aanlogscherm zijn de letters zo klein dat ze onleesbaar zijn. Zodra ik aangelogd ben is alles wel leesbaar, alleen slechts in 800x600.

Dit probleem lijkt op eerdere threads, maar aan de hand van de daar genoemde oplossingen kom ik er niet uit.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #1 Gepost op: 2008/01/26, 21:49:42 »
Meestal kun je alles wel oplossen met de volgende dingen: Maak voor de veiligheid eerst een backup van je xorg.conf configuratiebestand.
Citaat
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.oud
Vervolgens doe je
 
Citaat
sudo dpkg-reconfigure -phigh xserver-xorg
Je kiest dan voor de driver "nvidia" en normaal gezien detecteert hij zelf de mogelijke instellingen van de resolutie.
Bedienen met de TAB-toets en de binnenste ENTER-toets.
Lukt dit nog niet, post hier dan eens de inhoud van dat configuratiebestand
Citaat
gedit /etc/X11/xorg.conf
Eventueel ook van dat oude (zelfde commando maar dan nog met .oud vanachter.

Edit: commando aangepast, zie volgende posts...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #2 Gepost op: 2008/01/26, 21:56:41 »
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.oud
Dat gaat goed

sudo dpkg--configure -phigh xserver-xorg
Hier krijg ik een foutmelding...
sudo: dpkg--configure: command not found

Volgens mij omdat er een spatie ontbreekt tussen dpkg en de --. Als ik die spatie er wel zet krijg ik ook een foutmelding...

bart@bart-desktop:/etc/X11$ sudo dpkg --configure -phigh xserver-xorg
dpkg: tegenstrijdige acties -p (--print-avail) en -

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #3 Gepost op: 2008/01/26, 22:01:41 »
Oeps sorry, moet reconfigure zijn...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #4 Gepost op: 2008/01/26, 22:04:15 »
En don ook nog maar één streepje:
sudo dpkg-reconfigure -phigh xserver-xorg
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline joop905

  • Lid
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #5 Gepost op: 2008/01/26, 22:08:12 »
sudo dpkg-reconfigure -phigh xserver-xorg

sorry de zelfde

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #6 Gepost op: 2008/01/26, 22:23:37 »
vergeet ook niet uw resolutie te selcteren uit het lijstje met de spatiebalk en niet op uw resolutie gaan staan en op enter duwen...
dus eerst op de spatiebalk zodat er een sterretje tussen de [ ] komt te staan, en dan pas op enter drukken...

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #7 Gepost op: 2008/01/26, 22:44:53 »
Heb ik gedaan. In mijn xorg.conf staat keurig alleen 1024x768, echter de resolutie is toch echt 800x600... Ik heb inmiddels de Nvidia restricted driver weer uitgeschakeld. Dan werkt alles prima en zijn ook alle resoluties beschikbaar.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #8 Gepost op: 2008/01/27, 00:11:49 »
Zoek eens in Synaptic naar het programma nvidia-settings.
Heb zelf een ATI, dus kan het niet zelf testen, maar met dat programma moet je toch een en ander kunnen instellen...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline joop905

  • Lid
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #9 Gepost op: 2008/01/27, 00:49:23 »
of doe:

Toepassingen - Hulpmiddelen - Terminalvenster

Tik in: sudo apt-get install nvidia-settings

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #10 Gepost op: 2008/01/27, 10:52:56 »
nvidia-settings start wel, als ik dat vanuit een terminalvenster doe zie ik echter de volgende melding:

ERROR: Cannot open display 'bart-desktop:0.0'.

In nvidia-settings staat de resolutie op 'auto' en die kan niet gewijzigd worden.

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #11 Gepost op: 2008/01/29, 21:29:10 »
Nog even verder gekeken. Op https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.20/+bug/91292 staat een exacte beschrijving van de symptomen die ik ondervind. Helaas biedt de gesuggereerde oplossing ook geen soelaas.... (handmatig aanpassen van HorizSync 30-95 en VertRefresh 50-160 in xorg.conf)

Offline Bart Hoekstra

  • Lid
    • http://members.tele2.nl/bart.hoekstra/
  • Steunpunt: Nee
Resolutieprobleem met Nvidia GeForce 2 MX400 64MB
« Reactie #12 Gepost op: 2008/02/08, 22:19:23 »
Ik ben er uit! Een zoekactie in de Xorg.0.log (systeem -> beheer -> systeemlogboek) leverde deze melding op voor alle resoluties in xorg.conf:

(WW) NVIDIA(0): No valid modes for "1024x768"; removing.

Via google op deze melding kwam ik uit bij deze thread:

http://www.mandrivaclub.nl/site/lofiversion/index.php/t7389.html

Daarin staat de oplossing:

Option "UseEDID" "False" toevoegen aan Section "Device" in xorg.conf.

't is een gepruts, maar het werkt wel! Ik kan nu volop genieten van alle 3d effecten!