Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: FreeNX probleem  (gelezen 989 keer)

sebavl

  • Gast
FreeNX probleem
« Gepost op: 2006/07/10, 21:53:33 »
Ok

jvdv

  • Gast
FreeNX probleem
« Reactie #1 Gepost op: 2006/07/11, 13:34:13 »
Ik heb zojuist ge-upgrade van breezy naar dapper.
Freenx werkte als een zonnetje in breezy, maar helaas werkt freenx nu niet meer...

Ik krijg de volgende mededelingen, de eerste lijkt erg op die van sebavl:
Citaat
NXPROXY - Version 1.5.0

Copyright (C) 2001, 2005 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '1340'.
Info: Synchronizing local and remote caches.
Info: Handshaking with remote proxy completed.
Warning: Failed to read data from the X auth command.
Warning: Generating a fake cookie for X authentication.
Info: Not using NX delta compression.
Info: Using lan link parameters 16384/8/0/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde'.
Info: Not using ZLIB stream compression.
Info: Not using remote ZLIB stream compression.
Info: Not using persistent cache.
Info: Starting X protocol compression.
Info: Established X server connection.
Info: Using shared memory support in X server.
Info: End of session requested by remote proxy.
Info: Shutting down the link and exiting.
en op een andere computer:
Citaat
NX> 203 NXSSH running with pid: 3236
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.1.100 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: xxxx
NX> 102 Password:
NX> 103 Welcome to: linux user: xxxx
NX> 105 listsession --user="xxxx" --status="suspended,running"
--geometry="1280x1024x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'xxxx' for reconnect:

Display Type             Session ID                       Options  Depth
Screen         Status      Session Name
------- ---------------- -------------------------------- -------- -----
-------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: xxxx
NX> 105 startsession --session="arb" --type="unix-kde" --cache="8M"
--images="32M" --cookie="******" --link="lan" --kbtype="pc102/en_US"
--nodelay="1" --encryption="1" --backingstore="never"
--geometry="fullscreen" --media="0" --agent_server="" --agent_user=""
agent_password="******""  --screeninfo="1024x768x32+render"

NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
NX> 700 Session id: linux-1000-9E0D51E18F686132196D0330E838F59E
NX> 705 Session display: 1000
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 5e741e07f2565cd79cfd781929c66a46
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 5e741e07f2565cd79cfd781929c66a46
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye
Killed by signal 15.
Misschien apt-get reinstall??

budster

  • Gast
FreeNX probleem
« Reactie #2 Gepost op: 2006/07/11, 13:54:01 »
Had je freeNX wel via apt geinstalleert? Dan is het natuurlijk niet mee geupgrade.

jvdv

  • Gast
FreeNX probleem
« Reactie #3 Gepost op: 2006/07/11, 14:15:38 »
@budster:
uiteraard had ik de dapper-seveas pakketten ook in /etc/apt/sources.list staan, dat was het dus niet

Maar goed, het is wel opgelost.

Tja, soms moet ik wat beter Googlen:

De oplossing is:
Citaat
~$ sudo apt-get install dbus-1-utils
Die vervangt de (blijkbaar) foute pakketten libdbus-1-1 en libdbus-glib-1-1 uit breezy en installeert ook dbus en dan werkt het.

sebavl

  • Gast
FreeNX probleem
« Reactie #4 Gepost op: 2006/07/11, 17:48:50 »
Bij mij is dit niet de oplossing aangezien het pakket dbus-1-utils al ge