Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (verdoemde) TVkaart  (gelezen 3292 keer)

Offline mugtango

  • Lid
  • Steunpunt: Nee
(verdoemde) TVkaart
« Gepost op: 2008/01/25, 20:08:11 »
Beste collega's Ubuntu-gebruikers:

na lang vechten en proberen is het mij eindelijk gelukt om een dualboot Vista/Ubuntu op mijn Medion 8822 te krijgen.

Zie ook : http://forum.ubuntu-nl.org/topic/18033

Maar nu sta ik voor het volgende probleem: ik kan maar geen tv kijken in Linux.

dmesg geeft:

[  509.838888] saa7134 ALSA driver for DMA sound unloaded
[  940.309222] saa7130/34: v4l2 driver version 0.2.14 loaded
[  940.309691] saa7133[0]: found at 0000:07:09.0, rev: 209, irq: 24, latency: 32, mmio: 0xdf5ff000
[  940.309701] saa7133[0]: subsystem: 16be:0010, board: :Zolid Xpert TV7134 [card=43,insmod option]
[  940.309714] saa7133[0]: board init: gpio is 0
[  940.485418] tuner 1-004b: chip found @ 0x96 (saa7133[0])
[  940.501412] tuner 1-004b: type set to 63 (Philips FMD1216ME MK3 Hybrid Tuner)
[  940.517405] tuner 1-004b: type set to 63 (Philips FMD1216ME MK3 Hybrid Tuner)
[  940.549392] saa7133[0]: i2c eeprom 00: be 16 10 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[  940.549402] saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[  940.549411] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 2c 02 51 96 2b
[  940.549420] saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[  940.549429] saa7133[0]: i2c eeprom 40: ff 21 00 c0 96 10 03 22 15 00 fd 79 44 9f c2 8f
[  940.549438] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  940.549447] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  940.549456] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  940.554508] saa7133[0]: registered device video0 [v4l2]
[  940.554626] saa7133[0]: registered device vbi0
[  940.564070] saa7134 ALSA driver for DMA sound loaded
[  940.564330] saa7133[0]/alsa: saa7133[0] at 0xdf5ff000 irq 24 registered as card -2


lspci geeft:

02:00.0 VGA compatible controller: nVidia Corporation GeForce 7650 GS (rev a1)
04:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
04:00.1 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller
07:09.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)


en tot slot lspci -v:

04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller
        Subsystem: Micro-Star International Co., Ltd. Unknown device 7318
        Flags: bus master, fast devsel, latency 0, IRQ 25
        Memory at dfafc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities:

07:09.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
        Subsystem: Creatix Polymedia GmbH Unknown device 0010
        Flags: bus master, medium devsel, latency 32, IRQ 24
        Memory at df5ff000 (32-bit, non-prefetchable) [size=2K]
        Capabilities:


Als ik alle onderwerpen die ik al gevonden heb doorloop zou er als kaart moeten staan card=12 (medion 7134) (?) en tuner=63. Zoals je kan zien lukt het om de tuner aan te passen, maar hoe ik ook probeer de kaart te veranderen, dmesg blijft  steeds zeggen card=43

Wat doe ik verkeerd en hoe los ik dit op? Ik probeer de kanalen te vinden met Tvtime

nog enkele foutmeldingen:

tomtje@Gutsy-tijdsdief:~$ sudo rmmod saa7133
[sudo] password for tomtje:
ERROR: Module saa7133 does not exist in /proc/modules
tomtje@Gutsy-tijdsdief:~$

tomtje@Gutsy-tijdsdief:~$ sudo rmmod saa7134
ERROR: Module saa7134 is in use by saa7134_alsa
tomtje@Gutsy-tijdsdief:~$

als ik eerst rmmod saa7134_alsa doe en daarna rmmod saa7134 dan gaat dit wel
ste ik dan modprobe saa7134 card=12 tuner=63 dan blijft dmesg zeggen dat card=43 is

Alvast dank bij voorbaat

Offline eendje

  • Lid
  • Steunpunt: Nee
(verdoemde) TVkaart
« Reactie #1 Gepost op: 2008/01/25, 20:58:04 »
Lees onderstaande draadje eens door. Daar hebben we het toen wel aan de praat gekregen met heel veel gemartel. Er zijn een paar mensen die bevestigd hebben dat het werkt. (wel lang draadje en eerst helemaal doorlezen voor je begint)

http://forum.ubuntu-nl.org/topic/2795

Of was dit toevallig al het draadje wat je gelezen had?
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline mugtango

  • Lid
  • Steunpunt: Nee
(verdoemde) TVkaart
« Reactie #2 Gepost op: 2008/02/04, 20:25:40 »
Sorry dat ik nu pas reageer, mar ik heb niet alle dagen de tijd om hier verder naar te zoeken.

Het door u aangewezen draadje had ik inderdaad al proberen volgen, doch ik stuit op 2 problemen:

1) in dmesg geeft het systeem aan dat het subsysteem een  Zolid Xpert kaart is (zie hieronder) terwijl dit niet het geval is.

  537.720369] saa7130/34: v4l2 driver version 0.2.14 loaded
[  537.720596] saa7133[0]: found at 0000:07:09.0, rev: 209, irq: 23, latency: 32, mmio: 0xdf5ff000
[  537.720604] saa7133[0]: subsystem: 16be:0010, board: :Zolid Xpert TV7134 [card=43,insmod option]
[  537.720612] saa7133[0]: board init: gpio is 0
[  537.893527] tuner 1-004b: chip found @ 0x96 (saa7133[0])
[  537.893625] tuner 1-004b: type set to 1 (Philips PAL_I (FI1246 and compatibles))
[  537.893629] tuner 1-004b: type set to 1 (Philips PAL_I (FI1246 and compatibles))
[  537.925523] saa7133[0]: i2c eeprom 00: be 16 10 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[  537.925533] saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[  537.925542] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 2c 02 51 96 2b
[  537.925551] saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[  537.925560] saa7133[0]: i2c eeprom 40: ff 21 00 c0 96 10 03 22 15 00 fd 79 44 9f c2 8f
[  537.925569] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  537.925578] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  537.925586] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[  537.929150] saa7133[0]: registered device video0 [v4l2]
[  537.929191] saa7133[0]: registered device vbi0
[  537.942256] saa7134 ALSA driver for DMA sound loaded
[  537.942372] saa7133[0]/alsa: saa7133[0] at 0xdf5ff000 irq 23 registered as card -2


Een oplossing in de zin van:

tomtje@Gutsy-tijdsdief:~$ sudo rmmod saa7134_alsa
tomtje@Gutsy-tijdsdief:~$ sudo rmmod saa7134
tomtje@Gutsy-tijdsdief:~$ sudo modprobe saa7134 card=81 tuner=56

blijft in dmesg geven:

 1040.883252] saa7133[0]: found at 0000:07:09.0, rev: 209, irq: 23, latency: 32, mmio: 0xdf5ff000
[ 1040.883261] saa7133[0]: subsystem: 16be:0010, board: :Zolid Xpert TV7134 [card=43,insmod option]
[ 1040.883274] saa7133[0]: board init: gpio is 0

met andere woorden: de kaart wordt niet aangepast. Daarom ook een vraag van een leek: wat wil insmod option zeggen?

2) zoals je ziet pas ik saa7134 aan, terwijl er in dmesg altijd sprake is van saa7133. Maar het volgende lukt ook niet:

tomtje@Gutsy-tijdsdief:~$ sudo modprobe saa7133 card=81 tuner=56
FATAL: Module saa7133 not found

hoe kan ik saa7133 dan wel doen vinden, of zit ik hier totaal op een zijspoor?


(P.S. card=81 heb ik via het net teruggevonden, zou ook moeten werken met card=96)


En last but not least:

tomtje@Gutsy-tijdsdief:~$ tvtime
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/tomtje/.tvtime/tvtime.xml
videoinput: Cannot open capture device 0: Bestand of map bestaat niet


maar dit zal wel het gevolg zijn van voorgaande zeker ?

Wie zet mij op het rechte pad aub?

marcelkraan

  • Gast
(verdoemde) TVkaart
« Reactie #3 Gepost op: 2008/05/29, 18:53:52 »
bij werkt het best eenvoudig...
ik heb niets bijzonders gedaan

modprobe -r saa7134
modprobe saa7134 card=81 tuner=56
tvtime

en ik kan de kanalen keizen, echter heb ik er geen antenne opzitten dus dat wordt nix.


wat ik eigenlijk zocht was mijn webcam? ik dacht dat deze in de tuner zat maar dat zit ie niet geloof ik
mijn motion-eye webcam   is weg.. spoorloos hahah