Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: gdm probleempje  (gelezen 1093 keer)

gooseman

  • Gast
gdm probleempje
« Gepost op: 2008/01/23, 15:07:38 »
Hoi,

Ik volg de ontwikkelingen rondom linux al enige tijd maar sinds kort heb ik besloten om er eens serieus mee te gaan stoeien. Ik heb meerdere PCs dus wilde ik onlangs via een andere linux bak mijn Ubuntu systeem remote via een X-sessie overnemen. Dus aan het spelen (zeg maar gerust klooien) gegaan met de diverse gdm instellingen in System - Administration - Login Window. Ik heb het een en ander ingesteld zoals "Remote login enabled". Zoals gebruikelijk tijdens dit soort "speelsessies" heb ik niet opgeschreven wat ik allemaal veranderd heb ;-( en dus heb ik nu het volgende probleem:

Na het opstarten krijg ik het scherm waarin je kunt aangeven welke host je wilt benaderen via een X-sessie. Het scherm geeft aan "No serving hosts were found" en in het invulveld onderaan (Add host:) bevat ook geen namen of IP adressen. Een refresh of Cancel werkt niet. Na Cancel zie ik mijn scherm zwart worden en even fikkeren en dan zie ik het "No serving host were found" scherm weer terug. Kortom, hoe krijg ik mijn normale inlogscherm weer terug?

Ik heb het volgende al geprobeerd. Via een terminal scherm een aantal commando's uitgevoerd mbt gdm zoals update, upgrade en restart maar helaas mocht dit niet niet baten. Uiteraard kan ik het wel oplossen door een nieuwe installatie maar daar leer ik niets van dus dat doe ik dus liever niet.

Ik zal vast iets moeten veranderen in een config file maar welke (gdm.conf of gdm.conf-custom misschien)? En waar moet ik dan naar kijken of welke setting moet ik dan veranderen?

Ik gebruikt Ubuntu 7.10.

Alvast hartelijk dank voor hints en suggesties.

Met vriendelijke groet,

Leo

PS. heb dit probleem trouwens ook op mijn fedora 7 bak dus het is waarschijnlijk een algemene instelling...

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gdm probleempje
« Reactie #1 Gepost op: 2008/01/23, 15:30:48 »
Ik had ook problemen met gdm, ik heb het uiteindelijk opnieuw geinstalleerd, gdm dus via Synaptic.
En anders iemand een iets mindere grove oplossing?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

gooseman

  • Gast
gdm probleempje
« Reactie #2 Gepost op: 2008/01/23, 15:43:59 »
Goedemiddag Gijs,

Dat zou inderdaad een oplossing kunnen zijn ware het niet dat ik niet meer kan inloggen om synaptic te gebruiken. En via een terminal heb ik al geprobeerd. Althans ik hoop dat ik dat op de juist manier heb gedaan:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install gdm

sudo /etc/init.d/gdm restart

Groet,

Leo

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gdm probleempje
« Reactie #3 Gepost op: 2008/01/23, 16:10:15 »
Als je vannuit de terminal startx in geeft kan je dan ook niet bij Synaptic?
Als je namelijk ingeeft sudo apt-get install gdm wilt het programma gdm installeren maar dat is al geïnstalleerd, dus gebeurt er niets.
Eerst het pakket verwijderen met sudo apt-get remove gdm en dan weer installeren met sudo apt-get install gdm.
Succes

Met vriendelijke groet,

Gijs

Edit: tekst aangepast stond eerst reinstall ipv remove, dit is geen commando.
In der Beschränkung zeigt sich der Meister.

gooseman

  • Gast
gdm probleempje
« Reactie #4 Gepost op: 2008/01/23, 17:41:39 »
Nope. Vanuit de terminal geeft startx in eerste instantie aan dat er al een X sessie draait. Dit is dus het (inmiddels uitgevogeld) het "Remote login via XDMCP" scherm. Maar daarna dus sudo apt-get remove gdm en sudo apt-get install gdm geprobeert. En yes... na een startx kreeg ik de standaard desktop weer te zien.

Helaas was mijn probleem nog niet opgelost. Ik wilde namelijk even opnieuw opstarten maar kon zowel Restart als Shutdown niet kiezen. Ook kwam ik niet in gdmsetup. Ik kreeg een melding mbt niet voldoende rechten. Na een sudo halt in een terminal wel opnieuw opgestart maar helaas kwam ik weer in het "Remote login via XDMCP" terecht.

Daarna nog een keer de hele procedure opnieuw gedaan en vanuit een terminal sudo gdmsetup gedraait. Toen kreeg ik het gdmsetup scherm wel te zien en na wat klooien weet ik nu dat het probleem in de Server Settings zit. Bij mij stond Server Settings - Launch: Chooser. Deze heb ik op Greeter gezet en alles werkt weer naar behoren!!!

Dus bedankt Gijs voor de hint, hierdoor heb ik het probleem kunnen oplossen. Nu alleen nog uitvogelen hoe ik die Remote login wel werkend kan krijgen zonder andere gdm problemen ;-)

Met vriendelijke groet,

Leo

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gdm probleempje
« Reactie #5 Gepost op: 2008/01/23, 20:54:04 »
Goed dat het probleem opgelost is.
Als je startx doet kom je in de recovery mode daar zit geen knopjes voor restart en shutdown dus moet je in een terminal het commando reboot now of shutdown now geven dan opnieuw starten en kan je in grub weer "normaal" opstarten, of automatisch door grub.
Helaas kan ik je niet helpen de Remote login, heb ik nooit uitgeprobeerd. Dit draadje wat voor je? http://forum.ubuntu-nl.org/topic/19527

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

gooseman

  • Gast
gdm probleempje
« Reactie #6 Gepost op: 2008/01/24, 00:32:07 »
aha, merci voor de info. Ik zal dat andere topic eens uitpluizen.

Om dit topic af te sluiten geef ik hier nog wat informatie over mijn bevindingen tot nu toe en waar je meer informatie over XDM en X Terminal kunt vinden. Is wellicht handig voor andere mensen die problemen met gdm / xdm hebben.

Eerst een link naar een mini-how-to "XDM en X-Terminal":

http://doc.nl.linux.org/HOWTO/XDM-Xterm-NL/article.html

Hij is al wat ouder maar volgens mij nog prima bruikbaar. In ieder geval om te begrijpen hoe XDM werkt.

Een andere handige link is (engels):

http://www.kaszeta.org/rich/unix/xterminal/

Verder heb ik het probleem zowel op mijn Ubuntu als Fedore Core systeem opgelost. Onder Fedora heb ik een config file aangepast /etc/gdm/custom.conf. Onder Ubuntu heet deze file /etc/gdm/gdm.conf-custom. In deze file moest ik bij de "greeter" sectie de waarde TRUE opgeven. Er worden verschillende notaties gebruikt voor deze instelling maar het effect is hetzelfde. Bij Ubuntu staat nu:

[greeter]
Browser= TRUE

Terwijl in de config file in Fedora staat:

greeter=TRUE

Na wat speurwerk op Internet bleek dat "greeter" refereert naar het standaard loginscherm. Met "chooser" kun je specificeren welke hosts een verbinding kunnen maken met XDM. Vandaar dat ik ook het scherm "Remote login via XDMCP" kwam waarin het systeem naar hosts gaat zoeken.

Met vriendelijke groet,

Leo