Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: bestanden kopieëren gaat traag  (gelezen 1018 keer)

ipsos

  • Gast
bestanden kopieëren gaat traag
« Gepost op: 2008/01/21, 08:27:09 »
In mijn pc zitten twee harddisks. Een ten behoeve van Ubuntu (ext3) en een ten behoeve van data (nfts). Gisteren heb ik de inhoud van de dataschijf willen kopieëren naar de ext3-schijf (dit om de tweede schijf ook in ext3 te formatteren). Het betreft ongeveer 120 gb aan data. Het viel me op dat het proces van kopieëren erg lang duurt. Na ongeveer 11 uur (!) zat ik pas op 65%. Heeft dit te maken met de wijze van formateren (nfts)? Ik heb een soortgelijke actie eens onder Windows XP gedaan maar dat ging aanzienlijk sneller.

Offline vanadium

  • Lid
  • Steunpunt: Nee
bestanden kopieëren gaat traag
« Reactie #1 Gepost op: 2008/01/21, 09:16:51 »
Dat lijkt me abnormaal traag. Het is wel zo dat de tijd om eenzelfde hoeveelheid bytes te kopieren naar ext3 enorm zal verschillen wanneer het minder en grote bestanden betreft dan wanneer het zeer vele, kleine bestanden betreft. Ik denk dat je met rsync hogere performantie haalt vooral met kleine bestanden (vermoed dat die niet na ieder bestandje de schijfhuishouding updatet):

rsync -av

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
bestanden kopieëren gaat traag
« Reactie #2 Gepost op: 2008/01/21, 09:20:47 »
Ik denk dat het inderdaad te maken heeft met ntfs.
Gebruik je deze driver ntfs-3g? Misschien heb je hier wat aan http://www.ntfs-3g.org/support.html#slow
Ik gebruik zelf nog fat32, daar hebben Linux en Windows geen moeite mee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
bestanden kopieëren gaat traag
« Reactie #3 Gepost op: 2008/01/21, 12:05:32 »
Het kan wezen dat je udma standaard staat waardoor je HD niet optimaal gebruikt word.

Het programma wat dit verzorgt is "hdparm"
Je kan dit allemaal instellen.

Wees er wel voorzichtig mee...

hier een stukje info:

####################
testing and configuring
As you'd guess, you should know what your hardware can handle. Please take a look at the user's manual of your hard disk drive and your mainboard/IDE-card.
If you collected all the required information, you can continue. First, we'll need to open two terminals (xterm) and log in as root on both (command: su). The first terminal is used to run commands and the 2nd is used to keep track of the syslogs.
Run this command on the second terminal to start tracking:

>> tail -f /var/log/messages

The other terminal is mainly intended to run hdparm with various parameters. To see how Linux behaves after the test, take a look at the second terminal. Please test with caution - don't push the frontier of your hardware limits! So let's start:
HDPARM's first issue prints the current settings:

>> hdparm -v -i /dev/hda
All we need to know is now on your screen; what parameters are currently in use and what your hdd is capable. A line similar to this one

DMA modes: mdma0 mdma1 mdma2 udma0 udma1 udma2 *udma3 udma4 udma5
is directly read from your hard disk. The asterisk marks the currently transfer mode. In this example it's UDMA3 (Ultra DMA mode 3 (ATA33)). Stay on the first terminal and try:

>> hdparm -d1 -Xzz -i -v -t /dev/hda
with zz replaced by appropiate parameters.
Please note to set the switch -d1 always because this switch enables DMA. The timing switch (-t) will measure your current speed after setting up the new configuration. The higher the zz variable the faster you system will be and the more error are to be expected. So keep tracking on the second terminal to prevent too many CRC errors.
If you notice errors like these slow down:



hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }


reboot
If you ever reboot your PC (or switch it off) Linux must set the parameters again to reach proper speed. You must tell Linux which drive to tune (in the example it's /dev/hda) and pass the parameters. Copy the command line into the start-up file "/etc/rc.sysinit" and save it. Of course, you need root access to do this. On every reboot, Linux will tweak your hardware and you'll enjoy the speed benefit.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

ipsos

  • Gast
bestanden kopieëren gaat traag
« Reactie #4 Gepost op: 2008/02/06, 21:56:31 »
Nu mijn tweede harddisk geformatteerd is in ext3 wil ik mijn bestanden terugzetten. Dit gaat even traag! Heeft dus niets met ntfs te maken blijkbaar? hdparm wil ik best gebruiken maar het is niet zonder risico. Iemand een alternatief?

Offline jan11000

  • Lid
  • Steunpunt: Nee
bestanden kopieëren gaat traag
« Reactie #5 Gepost op: 2008/02/06, 22:33:44 »
Lees eens over fstab, hier kun je instellen hoe ubuntu met de data omgaat ivm met cachen, etc.

Ik heb jounalizing op "orderd" staan.(weet niet of het dit is)
Installeer "storage device manager" of pysdm
Opstarten "gksudo /usr/bin/pysdm"

Offline vanadium

  • Lid
  • Steunpunt: Nee
bestanden kopieëren gaat traag
« Reactie #6 Gepost op: 2008/02/07, 14:17:42 »
Met ntfs-3g en snelheid heb ik nog nooit een probeem gehad (als Ubuntu-only user heb ik nog een Lacie Silverscreen die ik enkel in ntfs formaat kan gebruiken wil ik er dvd images mee kunnen afspelen).

Als je een ouder PC-tje hebt, dan zou het kunnen dat je met Gandyman's tips een serieuze snelheidsboost zult kunnen realizeren.

@jan11000: je moet misschien eens specifieker zijn. Ik denk niet dat instellingen in /etc/fstab veel merkbare verschillen zullen met zich meebrengen.

ipsos

  • Gast
bestanden kopieëren gaat traag
« Reactie #7 Gepost op: 2008/02/10, 14:22:27 »
Heb pysdm geïnstalleerd maar weet niet hoe ik hiermee de snelheid van de harddisk kan vergroten.