Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: private en public key using putty  (gelezen 1675 keer)

klaasth

  • Gast
private en public key using putty
« Gepost op: 2008/01/18, 11:57:00 »
Ik heb op mijn server pc (intern ip 192.168.123.112) een ssh server draaien met als configuratie file (/etc/ssh/sshd_config)

# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile   %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

Dus ik maak een public key en private key met putty gen. De public key past ik in H:\.ssh\authorized_keys (geen extensie) en de private key zit ook in deze directory (H:\.ssh\test.ppk) de private key load in in pageant, en de private key file load ik nog eens in putty bij AUTH section. Als ik dan invul bij putty invul session 192.168.123.22 port: 22 en ik connect, krijg ik een putty venster en vraag ik met wie ik wil inloggen. ik tik klaasth en dan entern en na 5 seconden krijg ik een error iets mis met de beveiliging. Waarschijnlijk doe ik iets fout bij private /public key ofzo. Ik heb al wat tutorials doorgelezen, maar ik graak er niet wijs uit.

Dank bij voorbaad!

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
private en public key using putty
« Reactie #1 Gepost op: 2008/01/18, 12:00:52 »
Je moet de public key plakken in de home-map van de user waarmee je wil inloggen dus bv. /home//.ssh/authorized_keys
Dan zou het wel moeten lukken.
Even terzijde: als je pageant gebruikt dan moet je de private key niet meer aanwijzen bij AUTH, de pageant doet dit voor je.

*edit* ZEER belangrijk!!: de public key moet op één regel staan in het authorized_keys bestand, anders lukt het niet

° Bezoek mijn blog Digital (in)Sanity °

klaasth

  • Gast
private en public key using putty
« Reactie #2 Gepost op: 2008/01/18, 12:18:43 »
ChallengeResponseAuthentication no, ik heb dit op yes gezet ==> als dit op no staat, gebruikt hij niet PAM om te authenticeren, maar ik heb ook nix anders gezegt waar hij moet authenticeren, ik heb deze optie terug op yes gezet en nadien werkt he.
Maar hoe weet ik nu zeker dat er een veilige verbinding opgezet, want ik kan zowel een verbinding opzetten zonder een private key en public key te gebruiken. Maar ik kan het ook met en dan staat mijn private key in H:/.ssh/test.ppk en mijn public key in de file H:/.ssh/authorized_keys (alles aaneen) op de client windows pc. Of is het verplicht om dat in /home//.ssh/authorized_keys op de server pc te zetten. Want dit is mijn nog niet hellemaal duidelijk.

klaasth

  • Gast
private en public key using putty
« Reactie #3 Gepost op: 2008/01/18, 12:31:19 »
Ik heb dus nu ook op de server pc mijn public key gepast in /home/klaasth/.ssh/authorized_keys Maar als ik een ssh connectie opzet zie ik eigenlijk niets dat zegt ofzo dat er een veilige verbinding wordt opgezet of juist niet.

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
private en public key using putty
« Reactie #4 Gepost op: 2008/01/18, 12:35:01 »
Die public key moet effectief in de home-dir staat, anders zou het niet mogen werken. Zoals je settings nu zijn kan je normaal gezien ook niet inloggen zonder private en public key. Deze parameter zorgt daarvoor:
# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

Herstart voor alle zekerheid ook eens even je SSH
sudo /etc/init.d/ssh restart

° Bezoek mijn blog Digital (in)Sanity °

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
private en public key using putty
« Reactie #5 Gepost op: 2008/01/18, 12:36:01 »
Citaat van: klaasth
Ik heb dus nu ook op de server pc mijn public key gepast in /home/klaasth/.ssh/authorized_keys Maar als ik een ssh connectie opzet zie ik eigenlijk niets dat zegt ofzo dat er een veilige verbinding wordt opgezet of juist niet.
Dat komt omdat je met pageant werkt, dus is normaal, het inloggen gebeurd automatisch

° Bezoek mijn blog Digital (in)Sanity °

klaasth

  • Gast
private en public key using putty
« Reactie #6 Gepost op: 2008/01/18, 12:56:28 »
Dankje voor de uitleg, het werkt nu en ik snap het. Nu nog een tweede vraagje: ik zou graag niet authenticeren op basis van mijn login en wil deze optie # Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication yes
 uitzetten, maar hoe moet je dan wel authenticeren????

Hartelijk dank!!!

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
private en public key using putty
« Reactie #7 Gepost op: 2008/01/18, 13:24:49 »
Hmm, goeie vraag. Ik zou het gewoon eens testen eigenlijk. Zet die optie eens op 'no' en herstart je SSH (zoals hierboven uitgelegd). Volgens mij kan je dan nog altijd normaal inloggen met je public/private key. Ik heb trouwens dit gevonden ivm deze setting: http://www.redhat.com/archives/redhat-list/2002-June/msg02462.html

° Bezoek mijn blog Digital (in)Sanity °

klaasth

  • Gast
private en public key using putty
« Reactie #8 Gepost op: 2008/01/18, 17:15:53 »
Ma het werkt das het voornaamste, hartelijk bedankt DarkStar. Da van die setting zal ik ne keer later uitpluizen alsek wat meer ervaring heb.

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
private en public key using putty
« Reactie #9 Gepost op: 2008/01/19, 00:41:23 »
Graag gedaan klaasth :) Veel succes nog!

° Bezoek mijn blog Digital (in)Sanity °