Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen internet en netwerk connectie  (gelezen 1459 keer)

laminaatplaat

  • Gast
geen internet en netwerk connectie
« Gepost op: 2008/01/11, 19:32:43 »
Ik probeer mijn desktop die ik dagelijks gebruik Ubuntu 7.10 te draaien helaas heeft de computer internet noch netwerk verbinding. Ik hoop dat iemand mij uit de brand kan helpen. uit een vorig ubuntu avontuur op een oude laptop herinner ik me dat je dit moest posten

guy@guy-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:DC:7B:72:CC  
          inet6 addr: fe80::210:dcff:fe7b:72cc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:2914 (2.8 KB)
          Interrupt:21 Base address:0xf00

eth0:avah Link encap:Ethernet  HWaddr 00:10:DC:7B:72:CC  
          inet addr:169.254.8.254  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Base address:0xf00

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:704 (704.0 b)  TX bytes:704 (704.0 b)

guy@guy-desktop:~$
De netwerkport zit op het moederbord en ik kan er niet achterkomen wat voor moederbord het is helaas. Met de eerder genoemde ubuntu laptop kom ik wel op het internet dus ik denk niet dat het aan mijn WRT54g router ligt. Deze staat ingesteld op DHCP modus.

edit: het is Pentium 4 fujitsu siemens scaleo 600 en het gaat om een netwerk met draad.

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
geen internet en netwerk connectie
« Reactie #1 Gepost op: 2008/01/11, 22:49:31 »
Kijk eens even dit topic na, vooral het laatste antwoord, misschien dat dit je al op weg kan helpen.
Het netwerkadres dat je krijg op de interface eth0:avah is namelijk geen geldig IP adres, en je eth0 heeft geen IP adres. Via de oplossing in de link zou je eth0 wel een IP adres moeten krijgen en wordt de eth0:avah uitgeschakeld.

° Bezoek mijn blog Digital (in)Sanity °

laminaatplaat

  • Gast
geen internet en netwerk connectie
« Reactie #2 Gepost op: 2008/01/11, 23:40:02 »
guy@guy-desktop:~$ sudo ifdown eth0:avah
[sudo] password for guy:
ifdown: interface eth0:avah not configured
guy@guy-desktop:~$ sudo ifdown eth0
There is already a pid file /var/run/dhclient.eth0.pid with pid 5222
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:10:dc:7b:72:cc
Sending on   LPF/eth0/00:10:dc:7b:72:cc
Sending on   Socket/fallback
guy@guy-desktop:~$ sudo ifup eth0
There is already a pid file /var/run/dhclient.eth0.pid with pid 134519120
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:10:dc:7b:72:cc
Sending on   LPF/eth0/00:10:dc:7b:72:cc
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
guy@guy-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:DC:7B:72:CC  
          inet6 addr: fe80::210:dcff:fe7b:72cc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:273 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:77169 (75.3 KB)
          Interrupt:21 Base address:0xf00

eth0:avah Link encap:Ethernet  HWaddr 00:10:DC:7B:72:CC  
          inet addr:169.254.8.254  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Base address:0xf00

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1056 (1.0 KB)  TX bytes:1056 (1.0 KB)

guy@guy-desktop:~$
Bedankt voor de snelle info, maar het werkt helaas nog steeds niet. Helaas weet ik zelf niet wat dit allemaal precies betekend dus graag nog hulp.

EDIT: met windows XP en VISTA moest ik altijd de netwerkkaart op 10MBIT full/half duplex mode zetten om internet te laten werken. hoe doe ik dat bij ubuntu? (schoot me ineens te binnen, heb het gevoel dat daar het probleem in zit)

laminaatplaat

  • Gast
geen internet en netwerk connectie
« Reactie #3 Gepost op: 2008/01/12, 13:43:11 »
De kabel die ik gebruikte bleek niet goed te zijn...Ik heb computer ergens anders in het huis aangesloten en toen werkte het meteen ...

Offline DarkStar

  • Lid
    • Mijn persoonlijke website
  • Steunpunt: Nee
geen internet en netwerk connectie
« Reactie #4 Gepost op: 2008/01/12, 13:45:12 »
Best vreemd dat je in XP op 10mbit moet gaan om het werkend te krijgen...
Wat voor router gebruik je?
Enig idee welke netwerkkaart er in je laptop zit?

post ook eens de inhoud van je interfaces file
less /etc/network/interfacesJe kan eventueel ook eens via dit commando proberen om het werken te krijgen:
sudo ifconfig eth0:avah down
sudo ifconfig eth0 down
sudo ifconfig eth0 up
Dit zal er voor zorgen dat je interface eth0:avah uitgeschakeld wordt, en dat je interface eth0 herstart wordt.

Die eth0:avah is trouwens een soort van 'virtuele' interface op je eth0 (de effectieve netwerkinterface). Die eth0:avah heb je in principe enkel nodig als je meerdere IP adressen wil toekennen aan dezelfde fysieke netwerkkaart.

Als blijkt dat mijn oplossing hierboven werkt, dan is het best om alles wat met eth0:avah te maken heeft, te verwijderen uit de /etc/network/interfaces file. Dat kan als volgt:
sudo gedit /etc/network/interfacesNa bewerken de file opslaan en dit commando ingeven om alles betreffende netwerk te herstarten
sudo /etc/init.d/networking restartSucces!

*EDIT* Ik lees net je antwoord over die kabel (blijkbaar gelijktijdig gepost) => soms kan het dus ook simpel zijn :-)

° Bezoek mijn blog Digital (in)Sanity °