Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Packard Bell R3400 (de problemen en een paar oplossingen)  (gelezen 2758 keer)

Rroet

  • Gast
Packard Bell R3400 (de problemen en een paar oplossingen)
« Gepost op: 2006/07/05, 11:13:02 »
Ik heb een fijne Packard Bell laptop gekocht. (Wie wil er nu een packard hell laptop, ik want ik heb hem goedkoop in de uitverkoop op de kop kunnen tikken).... echter nu loop ik tegen en paar problemen aan.

Heeft een van jullie ook een Packard Hell R3400 laptop en zouden jullie met mij wat ervaringen uit willen wisselen om het een en ander toch goed aan de praat te kunnen krijgen.

Hierbij mijn ervaringen met het apparaat:

De specs: ( http://support.packardbell.com/nl/item/?pn=PB22B00005&g=1400 )
- AMD Mobile Sempr0n 3000+
- 1gb geheugen (zelf geupgrade vanaf 512mb)
- Ati chipset RS480 (hier zit hem het probleem)
- exotische netwerkkaart (uli526x)
- Ati Radeon Xpress 200m 5955 videokaart
-=================================-
Mijn probleem is als volgt, het is niet allemaal goed te omschrijven aangezien ik op zommige punten geen screencaptures kan maken:

- Ati chipset: MP-BIOS bug: 8254 timer not connected to IO-APIC (ubuntu/dapper)
- echi_hcd (usb2.0), systeem bevriest. (ubuntu/breezy)
- netwerkkaart driver niet goed herkend/geladen (ubuntu/breezy)

Dapper, (maar niet verstandig):
Ik kan de Dapper installatie cd niet booten omdat er een probleem is met de Ati chipset. 8254 timer not connected to IO-APIC, systeem bevriest. Daardoor moet ik sowieso om de cd te kunnen booten al opstarten met "acpi=off noapic nolapic". Na het booten (in grafische modus) en het installeren stopt de installatie tijdens het afconfigureren net voor het installeren van grub. De installer crasht gewoon, Ik heb geen error log kunnen  vinden.  Hierdoor heb ik dus wel een ingericht systeem, echter nog geen bootable systeem :(

Breezy, een begin naar de oplossingen:
Mijn FIX voor nu is het starten van de ubuntu installatie met een breezy CD, de Ati chipset timer issues zjin namelijk kernel 2.6.15 specifiek en de breezy cd werkt met de 2.6.12 kernel. Hierdoor is de installatie goed af te ronden en kan ik binnen een mum van tijd een breezy installatie in de lucht krijgen.

PROBLEEM, je zal gelijk merken dat tijdens het booten je machine vast loopt.... bekend probleem, even zorgen dat je "GEEN!!" usb apparaten in je usb poorten hebt zitten. Even aanmelden aan het systeem en het volgende doen:

(lees alvast vooruit naar het netwerkkaart probleem, dan kan je 2 vliegen in 1 klap slaan)...
sudo -s


rmmod ohci_hcd
rmmod ehci_hcd


modprobe ohci_hcd


ECHTER, de 2.6.12 kernel heeft nog een probleem met het goed herkennen van de netwerkkaart chip die op het moederbord van de R3400 zit. Hier zit namelijk een uli526x chip op. Dit probleem heb ik als volgt met hulp van de ubuntu forums opgelost: http://ubuntuforums.org/showthread.php?t=83710&page=2&highlight=uli526x
(volg de link, je komt op de 2de pagina terecht). Je moet nu in de 2de post op de 2de pagina het bestandje uli526x.ko.gz downloaden. Dit is een compiled module waarmee je het volgende moet doen, (1 keer maar, we upgraden gelijk naar ubuntu/dapper!!).

De laptop heeft geen floppy drive, Zet de module dus op een usb stick en zorg dat je de usb stick werkend krijgt onder linux (lees het stukje over laden usb drivers hierboven)...

Hierna doen we het volgende:
sudo -s

mkdir /mnt/tmp
dmesg (dit is nodig om even uit te lezen op welke /dev mapping je usb stick woont.)
mount /dev/ /mnt/tmp
cp /mnt/tmp/uli526x.ko.gz /root/
cd /root
gzip -d uli526x.ko.gz
rm -rf /lib/modules/2.6.12-9-686/kernel/drivers/net/tulip/*
cp uli526x.ko /lib/modules/2.6.12-9-686/kernel/drivers/net/tulip/
depmod -ae

modprobe uli526x
ifconfig eth0 up
dhclient eth0 (indien je een dhcp server hebt)
Nu heb je als het goed is interpret op je laptop. Tijd om snel de overstap naar ubuntu/dapper te maken.

sudo vi /etc/apt/sources.listHaal de eerste regel in het bestand weg (de regel waarin je cdrom vermeldt staat. Indien die niet bestaat, niet wissen). dit is het makkelijkste door met de cursor naar de regel te gaan en hier 2x op de letter 'd' te drukken.

type nu het volgende in:
:%s/breezy/dapper/en sla het bestand op en sluit het af door :wq!in te typen.

Is vi te moeilijk? Doe het dan met nano, Dit is vergelijkbaar met notepad op de cli. Het kan weinig, dus verwacht er ook niet te veel van.

Nu kan de standaard upgrade methode beginnen: apt-get update
apt-get dist-upgrade
Neem nu gerust een kopje koffie, We gaan ongeveer 330mb downloaden en installeren.

Hierna heb je een groot en deels werkende laptop, :)

Het stuk is nog in bewerking, er verschijnt dus nog meer bij.

Offline eendje

  • Lid
  • Steunpunt: Nee
Packard Bell R3400 (de problemen en een paar oplossingen)
« Reactie #1 Gepost op: 2006/07/09, 14:59:44 »
Citaat
Ik kan de Dapper installatie cd niet booten omdat er een probleem is met de Ati chipset. 8254 timer not connected to IO-APIC, systeem bevriest. Daardoor moet ik sowieso om de cd te kunnen booten al opstarten met "acpi=off noapic nolapic"
Heb je ook ACPI in de BIOS uit gezet? Ik heb er ook een keer ruzie mee gehad en door het uit te zetten in de BIOS werkte het allemaal wel. Zeker nu je tijdens het installeren ACPI ook uit zet.

De rest gaat me een beetje boven de pet :D
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Packard Bell R3400 (de problemen en een paar oplossingen)
« Reactie #2 Gepost op: 2006/07/09, 15:05:02 »
De kernel 2.6.17 werd ge-backport naar Dapper. Misschien geeft die wel support voor uw hardware. Dus of Edgy installeren (first release binnenkort) of Vanuit Dapper upgraden, of de backport toevoegen in je source-list in Dapper. (Echter geen idee of het alles zal oplossen... maar dat is alleszins de allerlaatste kernel)

Rroet

  • Gast
Packard Bell R3400 (de problemen en een paar oplossingen)
« Reactie #3 Gepost op: 2006/07/28, 15:59:51 »
Sorry voor mijn enorm late reactie.
Ik heb een of andere bios waar ik acpi niet uit kan zetten. Helaas, dus ik moet eens kijken of ik een back-port kan vinden van 2.6.17, echter.... er zijn nog geen backports voor dapper te vinden volgens mij.

Geduld is een schone zaak... Gelukkig heb ik dat geduld niet en heb ik inmiddels zelf vanaf source een nieuwe kernel gemaakt. Dit heeft de meeste problemen voor mij opgelost.

Alleen XGL icm de Ati XPress 200M nog een groot probleem. Het word gewoon ENORM traag en crasht om de haverklap. Daarom heb ik maar gewoon de fglrx drivers geinstalleerd en leef ik maar zonder XGL ;)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Packard Bell R3400 (de problemen en een paar oplossingen)
« Reactie #4 Gepost op: 2006/07/28, 16:22:58 »
Ik heb btw verstand van gecensureerde ACPI's op gecensureerde bios'en ;)

Als je de nodige tijd wilt nemen om je ACPI te debuggen kan je een DSDT table bestand maken waarmee je ACPI problemen gefixt zouden moeten zijn.

Bij mijn gecensureerde Acer laptop had iemand anders gelukkig de debugging al gedaan :) maar voor jouw laptop vind ik niets. Meer info op http://acpi.sourceforge.net/

Nota: je moet alleen ACPI weten te debuggen, als dit lukt, dan kan je dat meteen toepassen op Ubuntu zonder te hoeven hercompileren (kernel heeft standaard een patch om dsdt tables via initramfs in te laden)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Packard Bell R3400 (de problemen en een paar oplossingen)
« Reactie #5 Gepost op: 2006/07/28, 16:26:49 »
Citaat van: Rroet
Alleen XGL icm de Ati XPress 200M nog een groot probleem. Het word gewoon ENORM traag en crasht om de haverklap. Daarom heb ik maar gewoon de fglrx drivers geinstalleerd en leef ik maar zonder XGL ;)
Ati Radeon Xpress 200M zou moeten werken met XGL en de proprietary fglrx driver. Maar het is niet zeker of het werkt met alle versies van drivers.

Quote van Gentoo wiki van iemand met een 64bit laptop:
Citaat van: Gentoo wiki
*  Radeon Xpress 200M 128M
          o Chipset: X200
          o Driver: ati-drivers-8.24.8_x86_64
          o Notes: Tried 8.25.18-x86_64 and 8.26.18-x86_64 without success. Tested on HP Pavilion ze2397 Turion 64 notebook.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)