Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Kan geen geluid opnemen via microfoon  (gelezen 1106 keer)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Kan geen geluid opnemen via microfoon
« Gepost op: 2008/01/03, 18:05:57 »
Ik krijg steeds een foutmelding als ik de microfoon in wil stellen.
Die wil ik gaan gebruiken voor o.a. Ekiga.

Als ik via Systeem>Voorkeuren>Geluid de geluiden test, dan werkt alles, behalve de geluidsopname voor audioconferentie. Zie het volgende screenshot voor de foutmelding:


Kon de testpijplijn voor ‘gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat’ niet construerenHet veranderen van de keuze van ALSA naar OSS of het kiezen van de audiochip maakt geen verschil. Ik krijg nog steeds dezelfde foutmelding te zien.

Alle andere geluiden werken wel goed, dus ik heb geen flauw idee waar deze fout vandaan komt.

Het gaat om de geïntegreerde geluidskaart op het moederbord, de Abit AN-M2HD.

Wat verdere gegevens:
sudo lspci -v
[knip]
00:07.0 Audio device [0403]: nVidia Corporation MCP67 High Definition Audio [10de:055c] (rev a1)
        Subsystem: ABIT Computer Corp. Unknown device [147b:1c2e]
[knip]

sudo lshw -C multimedia
  *-multimedia            
       description: Audio device
       product: MCP67 High Definition Audio
       vendor: nVidia Corporation
       physical id: 7
       bus info: pci@0000:00:07.0
       version: a1
       width: 32 bits
       clock: 66MHz
       capabilities: pm msi ht bus_master cap_list
       configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2 module=snd_hda_intel

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
In de configuratiebestanden ~/.asoundrc en ~/.asoundrc.asoundconf staan geen instellingen.
In /etc/ staan ook geen alsa configuratiebestanden.

Ook met het commando gstreamer-properties krijg ik een foutmelding:


Heeft iemand enig idee waar ik verder kan zoeken?

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Kan geen geluid opnemen via microfoon
« Reactie #1 Gepost op: 2008/01/03, 19:26:02 »
He, vergeten te zoeken :P

http://forum.ubuntu-nl.org/message/160188

Groet

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Kan geen geluid opnemen via microfoon
« Reactie #2 Gepost op: 2008/01/04, 00:35:04 »
Dat topic had ik ook al gevonden, maar er wordt nergens een goede oplossing gegeven. Ook de verschillende bug reports zijn nog niet opgelost.

Na wat prutsen met de schuifjes en met de gst-launch commando's gaat de situatie wel iets vooruit.
Die gekke foutmelding is nog steeds niet opgelost, maar ik krijg nu wel wat geluid uit de microfoon :)
Het is alleen veel te zacht en ik kan het niet harder krijgen met een vinkje of schuifje ergens...
Morgen weer verder zoeken en prutsen

Offline joop905

  • Lid
  • Steunpunt: Nee
Kan geen geluid opnemen via microfoon
« Reactie #3 Gepost op: 2008/01/04, 00:40:30 »
ik krijg dezelfde fout melding met een NVidia  ALC662
maar microfoon werkt gewoon
 joop905@ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 Analog [ALC662 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 Digital [ALC662 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Kan geen geluid opnemen via microfoon
« Reactie #4 Gepost op: 2008/01/04, 09:12:57 »
@johanvd

Hier staat bij volumeregeling, ->bewerken->voorkeuren "Microfoon" "Microfoon Opname" en "Mic Boost" aangevinkt.

Bij de tab "schakelaars" (die wordt zichtbaar door de vink van "Microfoon opname") staat "Microfoon opname" aangevinkt. Zowel "Microfoon" en "Mic Boost" staan helemaal open.

Als je de optie "opname" aanzet zie je Een schuif voor Speaker en een schuif voor Microfoon, dat heb ik losgekoppeld en "speaker" dichtgezet. "Microfoon" staat helemaal open.

Misschien heb je er wat aan..

Groet