Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: openftd op debian  (gelezen 1126 keer)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
openftd op debian
« Gepost op: 2008/01/03, 11:17:38 »
Even een vraagje over debian hier.

Ik wilde dus even openftd installeren en dan krijg ik dit:

dpkg -i openftd_1.0.1-1_i386.deb
Selecting previously deselected package openftd.
(Reading database ... 44436 files and directories currently installed.)
Unpacking openftd (from openftd_1.0.1-1_i386.deb) ...
dpkg: dependency problems prevent configuration of openftd:
 openftd depends on libart-2.0-2 (>= 2.3.18); however:
  Version of libart-2.0-2 on system is 2.3.17-1.
 openftd depends on libatk1.0-0 (>= 1.13.2); however:
  Version of libatk1.0-0 on system is 1.12.4-3.
 openftd depends on libbonobo2-0 (>= 2.15.0); however:
  Version of libbonobo2-0 on system is 2.14.0-3.
 openftd depends on libbonoboui2-0 (>= 2.15.1); however:
  Version of libbonoboui2-0 on system is 2.14.0-5.
 openftd depends on libc6 (>= 2.6-1); however:
  Version of libc6 on system is 2.3.6.ds1-13etch4.
 openftd depends on libcairo2 (>= 1.4.0); however:
  Version of libcairo2 on system is 1.2.4-4.
 openftd depends on libcurl3-gnutls (>= 7.16.2-1); however:
  Package libcurl3-gnutls is not installed.
 openftd depends on libdbus-1-3 (>= 1.1.1); however:
  Version of libdbus-1-3 on system is 1.0.2-1.
 openftd depends on libdbus-glib-1-2 (>= 0.74); however:
  Version of libdbus-glib-1-2 on system is 0.71-3.
 openftd depends on libfreetype6 (>= 2.3.5); however:
  Version of libfreetype6 on system is 2.2.1-5+etch1.
 openftd depends on libgcc1 (>= 1:4.2.1); however:
  Version of libgcc1 on system is 1:4.1.1-21.
 openftd depends on libglade2-0 (>= 1:2.6.1); however:
  Version of libglade2-0 on system is 1:2.6.0-4.
 openftd depends on libglib2.0-0 (>= 2.14.0); however:
  Version of libglib2.0-0 on system is 2.12.4-2.
 openftd depends on libgnome2-0 (>= 2.17.3); however:
  Version of libgnome2-0 on system is 2.16.0-2.
 openftd depends on libgnomeui-0 (>= 2.19.1); however:
  Version of libgnomeui-0 on system is 2.14.1-2.
 openftd depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Version of libgnomevfs2-0 on system is 1:2.14.2-7.
 openftd depends on libgnutls13 (>= 1.6.3-0); however:
  Version of libgnutls13 on system is 1.4.4-3.
 openftd depends on libgtk2.0-0 (>= 2.12.0); however:
  Version of libgtk2.0-0 on system is 2.8.20-7.
 openftd depends on libgtkhtml3.14-19 (>= 3.16.0); however:
  Package libgtkhtml3.14-19 is not installed.
 openftd depends on libkrb53 (>= 1.6.dfsg.1); however:
  Version of libkrb53 on system is 1.4.4-7etch4.
 openftd depends on libnotify1 (>= 0.4.4); however:
  Package libnotify1 is not installed.
 openftd depends on libnotify1-gtk2.10; however:
  Package libnotify1-gtk2.10 is not installed.
 openftd depends on liborbit2 (>= 1:2.14.8); however:
  Version of liborbit2 on system is 1:2.14.3-0.2.
 openftd depends on libpango1.0-0 (>= 1.18.2); however:
  Version of libpango1.0-0 on system is 1.14.8-5.
 openftd depends on libsqlite3-0 (>= 3.4.2); however:
  Package libsqlite3-0 is not installed.
 openftd depends on libstdc++6 (>= 4.2.1); however:
  Version of libstdc++6 on system is 4.1.1-21.
 openftd depends on libxdamage1 (>= 1:1.1); however:
  Version of libxdamage1 on system is 1:1.0.3-3.
 openftd depends on libxml2 (>= 2.6.29); however:
  Version of libxml2 on system is 2.6.27.dfsg-1.
 openftd depends on libxrandr2 (>= 2:1.2.0); however:
  Version of libxrandr2 on system is 2:1.1.0.2-5.
 openftd depends on libxslt1.1 (>= 1.1.20); however:
  Version of libxslt1.1 on system is 1.1.19-1.
 openftd depends on zlib1g (>= 1:1.2.3.3.dfsg-1); however:
  Version of zlib1g on system is 1:1.2.3-13.
dpkg: error processing openftd (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openftd


hoe kan ik al die pakketjes makkelijk installeren ? apt-get -f install zorgt er gewoon voor dat ftd weer wordt verwijderd. Wanneer ik 1 pakketje wil installeren dan zegt hij dus dat ik apt-get install -f moet doen.....
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
openftd op debian
« Reactie #1 Gepost op: 2008/01/03, 12:32:49 »
Ik denk dat, hoewel het een .deb bestand is, je dit niet kan installeren. Installeer het pakket gewoon via de repositories:
sudo apt-get install openftd

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
openftd op debian
« Reactie #2 Gepost op: 2008/01/03, 12:38:24 »
nou ik ben nu zover dat ik alleen deze nog over heb:

dpkg -i openftd_1.0.1-1_i386.deb
Selecting previously deselected package openftd.
(Reading database ... 48565 files and directories currently installed.)
Unpacking openftd (from openftd_1.0.1-1_i386.deb) ...
dpkg: dependency problems prevent configuration of openftd:
 openftd depends on liborbit2 (>= 1:2.14.8); however:
  Version of liborbit2 on system is 1:2.14.7-0.1.
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline vis

  • Lid
  • Steunpunt: Nee
openftd op debian
« Reactie #3 Gepost op: 2008/01/03, 12:40:15 »
Waarom gebruik je niet gewoon de source installatie op deze pagina?

http://www.ftd4linux.nl/wiki/index.php/Ubuntu_installatie

Heb je nog een nieuwere verise ook en het is gewoon een kwestie van copy/paste.

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
openftd op debian
« Reactie #4 Gepost op: 2008/01/03, 12:41:47 »
ok kan ik wel even proberen ja :)

weet je ook toevallig hoe ik dit moet doen:

The following packages have been kept back:
  linux-image-2.6-686
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
openftd op debian
« Reactie #5 Gepost op: 2008/01/03, 14:48:13 »
Probeer dit eens:
- apt-get update
- apt-get dist-upgrade

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
openftd op debian
« Reactie #6 Gepost op: 2008/01/03, 17:22:52 »
ja dat ging ook niet lukken
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
openftd op debian
« Reactie #7 Gepost op: 2008/01/03, 17:28:12 »
Euh, volgens dit (http://www.debian-administration.org/articles/69) moet het wel lukken. Zeker dat je dist-upgrade gedaan hebt (is niet gelijk aan upgrade).

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
openftd op debian
« Reactie #8 Gepost op: 2008/01/04, 09:09:48 »
nee weet ik, ik heb dan ook eerst update gedaan toen upgrade en toen dist upgrade...... ik bleef die melding maar houden dan image bla bla was kept behind. snap het zelf ook niet. Heb maar weer gewoon etch gedaan en dat gaat goed :) openftd doet het ook weer goed hier.
Ik praat niet te snel, je luisterd te langzaam ;-)