Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Zwart scherm bij startx: Meerdere oorzaken mogelijk?  (gelezen 795 keer)

Mulimans

  • Gast
Zwart scherm bij startx: Meerdere oorzaken mogelijk?
« Gepost op: 2008/01/03, 00:19:13 »
Ik probeer de Desktop-versie van Ubuntu 7.10 te draaien op de pc van mijn moeder via de cd-rom, maar loop tegen het volgende probleem aan:
Op het moment dat het bureaublad zou moeten verschijnen wordt het scherm zwart en blijft zwart. Het opstart-proces blokkeert echter niet - Zo hoor je op een gegeven moment ook dat opstart-geluid -, alleen ontbreekt het beeld dus.

Nu lees ik op andere fora dat het met het ontbreken van drivers voor de videokaart te maken kan hebben, maar wat ik dan niet begrijp is dat als ik de cd draai op mijn eigen pc en expres een verkeerde driver in "/etc/X11/xorg.conf" instel, dat ik dan na poging de X-server te starten netjes de optie krijg Ubuntu in safe-mode te draaien. Waarom krijg ik die optie dan niet aangeboden op de pc van mijn moeder?

Ook las ik dat het te maken zou kunnen hebben met het aktief zijn van een onboard videokaart, maar die is uberhaupt daar niet aanwezig.

Zou dat verschijnsel van dat ineens zwarte scherm, maar verder wel correct opstarten, dan misschien ook met iets anders te maken kunnen hebben?

De betreffende pc heeft de volgende videokaart:
Matrox Graphics MGA G200
Ik meen dat de drivers hiervoor wel standaard op de cd aanwezig waren.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Zwart scherm bij startx: Meerdere oorzaken mogelijk?
« Reactie #1 Gepost op: 2008/01/03, 05:53:14 »
Er kan een resolutie gekozen worden die te groot is voor je monitor.
Die springt dan ook op zwart.

Even de goede drivers/resolutie instellen en het zou moeten werken.

Mulimans

  • Gast
Zwart scherm bij startx: Meerdere oorzaken mogelijk?
« Reactie #2 Gepost op: 2008/01/03, 16:53:37 »
Ok bedankt, ga ik even op letten als ik er weer achter zit.

En mocht dat het zijn, dan komt het toch aan op het aanpassen van de waarden achter 'Modes' in de 'Screen' section zoals hieronder?
(/etc/X11/xorg.conf)


Section "screen" #    
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "640x480@60" "640x480@72" "640x480@75" "800x600@56" "800x600@72" "800x600@75" "800x600@60" "832x624@75" "1024x768@75" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1600x1200@65" "1600x1200@60"
EndSubSection
EndSection