Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid probleempje  (gelezen 945 keer)

Paat

  • Gast
Geluid probleempje
« Gepost op: 2007/12/18, 19:14:37 »
bij mij doet het hele geluid het niet.. heb ik de bios m'n internet (moederbord) geluid uitgezet maar dit werkt niet. Ook heb ik in andere topics gelezen over geluid maar kom er echt niet uit sad echt balen want vind ubuntu echt vet, wil er zeker vast in gaan werken maar als ik geen geluid kan krijgen houdt het snel op.. zal m'n probleem ff omschrijven

heb dat alsa ding geinstaleerd wat iedereen steeds zegt..hier kan ik kiezen tussen PCM, FRONT en Recorder...ook heb ik bij de instelling gepruts..alsa pijplijn of die oss e.d. maar niks wil werken sad

Iemand enig idee hoe ik geluid kan krijgen? heb sowieso niet veel verstand van het hele linus / ubuntu gebeuren..dus is behoorlijk lastig voor me..

Offline Beans

  • Lid
  • Steunpunt: Nee
Geluid probleempje
« Reactie #1 Gepost op: 2007/12/18, 19:55:56 »
Dit heb ik gebruikt op mijn laptop Toshiba.
Komt ergens uit forum.
Ook had ik dikke problemen met geluid
.
Toshiba sound fix! ( L35 and more?)
I have a toshiba l35-S2161 and had been through absolute hell trying to get sound working and I have finally done it! I have sound coming out of both speakers and my headphones.

Maybe someone can refine this process but it worked perfectly for me. I'm a complete linux noob but this isn't hard to do.(it was hard to figure out though. :P) Going through this myself I know how hard it can be for complete newbies to follow the seemingly easiest instructions. So I will try to explain this as simply as possible.

Here it goes.

Step one is you need the newest version of the alsa sound drivers. To do that cut and paste each line of the below code box into the terminal one at a time. Wait untill one function is done before pasting in the next. The terminal is located in applications> accessories>terminal.

Code:

sudo apt-get install build-essential linux-headers-$(uname -r)
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.14.tar.bz2
tar -xjf alsa-driver-1.0.14.tar.bz2
cd alsa-driver-1.0.14
./configure
sudo make
sudo make install

Once through all of the commands reboot your computer.

-------------------

Once the computer is back up go back into the terminal and enter this:

Code:

sudo gedit /etc/modprobe.conf

You will be prompted for your user account password. When you type it will look like nothing is happening but thats just a security feature.

In the text file that pops up enter this and save it:

Code:

options snd-hda-intel model=6stack-digout

Once saved reboot your computer

---------------------

Once your computer is back up go back into the terminal and enter
Code:

alsamixer

Use the arrow keys to move around on this screen. On anything you see double MM on press the M key and maximize the volume. Do this to anything with the double MM.

Once you do your headphones should be working! Go to the volume control panel and go to edit>preferences> and enable surround. From what I have seen that is the one that adjusts your headphones.

I hope this helps some people out there! I will probably wake up tomorrow and see how badly written this gude is and I appologize for that but its 2:30 AM here. I just wanted to get this up to help those with this problem.

A big thank you to dannyboy79 for sticking with me and my noob questions about installing alsa.
Life is a journey, not a destination.

Paat

  • Gast
Geluid probleempje
« Reactie #2 Gepost op: 2007/12/18, 21:47:04 »
Alvast bedankt voor je snelle reactie dude :D zal is ff kijken of ik het voor mekkaar kan krijgen

Paat

  • Gast
Geluid probleempje
« Reactie #3 Gepost op: 2007/12/18, 22:11:57 »
ok, het meeste is gelukt maar ik heb nog steeds geen geluid, kan misschien liggen aan dit stuk:

./configure
sudo make
sudo make install

dit staat er nu bij mij :

paat@paat-desktop:~$ cd alsa-driver-1.0.14
paat@paat-desktop:~/alsa-driver-1.0.14$ ./configure
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
paat@paat-desktop:~/alsa-driver-1.0.14$
paat@paat-desktop:~/alsa-driver-1.0.14$

ik kan nu ook niet sudo make doen want hij zegt dat ik eerst het configure script moet draaien..

iemand enig idee wat het probleem hier is ?

Paat

  • Gast
Geluid probleempje
« Reactie #4 Gepost op: 2007/12/19, 09:13:40 »
dude na ff weer te hebben geprutst is het gelukt :D heb eindelijk geluid :D super vet! bedankt man!