Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NTFS en Linux  (gelezen 3838 keer)

Thanatios

  • Gast
NTFS en Linux
« Gepost op: 2006/06/26, 22:58:43 »
Voor zo ver ik het weet, kan linux dus geen NTFS partities benaderen. En dus heb ik een probleem.

Ik zelf heb op dit moment 4 partities.
C: (NTFS)(WINDOWSXP)
D: (NTFS)(DATA)
G: (EXT3)(UBUNTU)
H: (SWAP)

Ik heb dus een probleem met de Partitie D. Daarop bewaar ik alle benodigde bestanden meestal, zo als backups, programma's, muziek en video's. Aleen, op dit moment kan ik die partitie op geen enkel manier benaderen.
Hij is niet te zien in Deze Computer op Windows.
En via linux kan ik hem niet benaderen.

Dus wat ik precies wil is:
1. De partitie het weer laten doen
2. De partitie zo maken, zo dat je het kan benaderen vanuit zo wel Linux als Windows. (Ik heb gelezen dat, dat met FAT32 kan als filesystem, maar ik weet het niet helemaal zeker)

Ik hoop dat iemand mij kan helpen :)
Alvast bedankt

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
NTFS en Linux
« Reactie #1 Gepost op: 2006/06/26, 23:37:39 »
Je hebt inderdaad een fat 32 nodig. Maar eerst alles eraf halen, want bij omschakeling verlies je alles!

Doe dit, dan zal na reboot de partitie benaderbaar zijn via Ubuntu:

wget http://www.ubuntulinux.nl/files/diskmounter
sudo bash diskmounter
rm diskmounter

reboot of sudo mount -a

Daarna gparted installeren (na alles overgezet te hebben)
sudo apt-get install gparted

In sys -> admin -> gnome partion editor

Daar uw schijf unmounten en omzetten naar fat 32

Scriptje van hierboven terug (om fstab terug aan te passen)

reboot of sudo mount -a

Uw data terug zetten.

That's it :)

Thanatios

  • Gast
NTFS en Linux
« Reactie #2 Gepost op: 2006/06/27, 00:08:12 »
Het grootste probleem eigenlijk is, dat die partitie vol zit met zo ongeveer 15GB aan bestanden. Ik wil dat wel opslaan (Op mijn andere Partitie, namelijk Station C: want dat past niet op 1 CD'tje), maar daarvoor moet ik eerst de partitie zichtbaar maken in Windows. :/

EDIT: Ik heb alles maar toch geformateerd. Ik besloot dus helemaal opnieuw te beginnen met alles :P
Mijn D Station nu is FAT32, maar ik kan er nogsteeds niet bij binnen komen. Hoe gaat dat tewerk? :/

EDIT2: Ik vond dit zojuist op google:
#  For Linux, do the following steps to make the FAT32 partition accessible:

   1. Create the directory that serves as the mount point (e.g. mkdir /osshare). The mount point is the location in the filesystem where you want this FAT32 partition to appear.
   2. Put an entry in the /etc/fstab file for the share partition. Be very careful in editing this file, as it's used at system startup! For an example, check out the /osshare entry in my /etc/fstab file. The umask option determines the permissions for all filesystems on the partition.
   3. Upon your next reboot into Linux, the share partition should get mounted automatically. If you wish to mount the FAT32 partition immediately, use the mount command, e.g.: mount /osshare

Aleen ik kan sommige dingen ervan niet. Kan iemand het iets beter uitleggen?

sonics

  • Gast
NTFS en Linux
« Reactie #3 Gepost op: 2006/06/27, 08:11:23 »
Ik heb een FAT partitie als link tussen windows en linux om te kunnen saven.
Om files te openen is het geen probleem NTFS te benaderen. Saven zal niet gaan met NTFS, daar kan linux niet goed mee omgaan.

Mijn FSTAB is als volgt (gewoon de Ubuntu wiki gevolgd)

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda3       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hda2    /mnt/fat vfat  iocharset=utf8,umask=000  0    0
/dev/sda1    /mnt/win1 ntfs  nls=utf8,umask=0222 0    0
/dev/sdb1    /mnt/win2 ntfs  nls=utf8,umask=0222 0    0
/dev/hda1    /mnt/media ntfs  nls=utf8,umask=0222 0    0

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
NTFS en Linux
« Reactie #4 Gepost op: 2006/06/27, 08:28:37 »
Citaat van: Thanatios
Mijn D Station nu is FAT32, maar ik kan er nogsteeds niet bij binnen komen. Hoe gaat dat tewerk?
Gebruik diskmounter:
wget http://www.ubuntulinux.nl/files/diskmounter
sudo bash diskmounter
rm diskmounter

David

  • Gast
NTFS en Linux
« Reactie #5 Gepost op: 2006/07/02, 22:40:00 »
Hm, nu had ik gister mijn vfat eindelijk zo ver dat ik bestanden etc aan kon passen, de link tussen Windows en Ubuntu was gelegd... met de nadruk op was, want vandaag wil het opeens niet meer :(

Iemand enig idee of het aan de /etc/fstab kan liggen?

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda5       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda1       /media/hda1     ntfs    defaults        0       0
/dev/hda6       /media/hda6     vfat    defaults        0       0

/dev/hda7       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

#Added by diskmounter utility
/dev/hda8 /media/hda8 vfat rw,user,fmask=0111,dmask=0000,umask=000 0 0
Alvast bedankt!

Edit: na een CHMOD werkt alles prima :)

David

  • Gast
NTFS en Linux
« Reactie #6 Gepost op: 2006/07/03, 11:59:41 »
Nog even twee domme vragen misschien...  Als ik samba of nfs niet heb ge

teardrop_onthefire

  • Gast
NTFS en Linux
« Reactie #7 Gepost op: 2006/07/07, 17:04:45 »
Het laatste getalletje van de chmod is "everyone" dus ook het "internet"

budster

  • Gast
NTFS en Linux
« Reactie #8 Gepost op: 2006/07/07, 18:55:08 »
Citaat van: David
Nog even twee domme vragen misschien...  Als ik samba of nfs niet heb ge

Offline jespdj

  • Lid
  • Steunpunt: Nee
NTFS en Linux
« Reactie #9 Gepost op: 2006/07/07, 23:11:53 »
Dat je vanuit Linux geen NTFS partities kunt benaderen is niet waar, want ik kan mijn twee Windows NTFS partities gewoon zien (Ubuntu 6.06).

Ik heb wel ergens gelezen dat NTFS partities alleen read-only te benaderen zijn.

Meer info hier.
Dell XPS M1530 | Core 2 Duo T9300 (2,5 GHz) | 4 GB RAM | nVidia 8600M GT | Ubuntu 8.04

budster

  • Gast
NTFS en Linux
« Reactie #10 Gepost op: 2006/07/07, 23:31:36 »
NTFS lezen vanuit linux gaat goed, schrijven is experimenteel.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
NTFS en Linux
« Reactie #11 Gepost op: 2006/07/08, 00:35:42 »
Hou ook Captive in de gaten,
implementatie van ntfs.sys driver van windows

Die kan wel gewoon NTFS lezen
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

David

  • Gast
NTFS en Linux
« Reactie #12 Gepost op: 2006/07/10, 09:02:55 »
Citaat van: budster
Op het moment dat je uitlogt dan unmount je de schijven ook, en verdwijnt deze ook bij het mountpoint, chmod permanent maken kan niet je moet ze als user mounten, volgens mij (WEET IK NIET ZEKER!) moet je user bij options zetten.
Zelf heb ik nog even zitten experimenteren en bij mij werkt het volgende:

Als je iets 'permanent'  chmodden dan zul je dit de eerste keer 'handmatig'  moeten doen in de terminal:
sudo chmod 777 /bestanden_waar_het_om_gaatDaarna kun je via System > Preferences > Sessions > tabblad Startup Programs dezelfde terminal regel toevoegen. Ik heb gemerkt dat dit prima werkt! :)

Azalin

  • Gast
NTFS en Linux
« Reactie #13 Gepost op: 2006/07/10, 10:16:06 »
Kun je niet beter de umask en de dmask in je fstab aanpassen? Dan verander je de bits van je bestanden ook niet en krijg je geen problemen in bijvoorbeeld Windows. Als je chmod doet lijkt me dat Windows daar niet heel erg blij van wordt (misschien zelfs wel ongedaan maakt na schrijven naar een file, op z'n minst zal je dan dat hele chmod verhaal weer opnieuw moeten doen voor de files die aangepast zijn). Ik bedoel, je doet hier een rechten verhaal toepassen op een systeem dat dat op een heel andere manier gebruikt. Als je in je fstab die rechten al goed hebt staan, dan weet het systeem wel hoe het zit. Lijkt mij dat je op deze manier nogal wat problemen zou kunnen krijgen... correct me if I am wrong. Dat je (nog) geen problemen hebt ondervinden wil natuurlijk niks zeggen. Wat niet is, kan nog komen :)

/dev/hda6       /media/hda6     vfat    defaults
wordt dan
/dev/hda6       /media/hda6     vfat    rw,user,fmask=0111,dmask=0000,umask=000 0 0