Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen ATI X1200  (gelezen 2492 keer)

Sebah

  • Gast
Problemen ATI X1200
« Gepost op: 2007/12/07, 22:32:06 »
Hallo allemaal,

Ik ben dus vanaf vandaag een officiële Ubuntu gebruiker en dat valt allemaal wel mee. :)

Maarrrr en dat ik het probleem, ik heb problemen met mijn Compiz te installeren.
Ik heb al mijn updates gedownload, maar ik denk dat het probleem bij mijn ATI drivers liggen.

Mijn video kaart is een ATI X1200, en het lijkt alsof hij niet herkent wil worden door Ubuntu.
Dingen die ik al geprobeerd heb.
-uiterlijk -> visual effects -> en dan aanpassen, met de volgende foutboodschap als resultaat "Desktop effect cannot be enabled"

- restricted drivers -> en daar ATI accelerated graphics driver proberen te enablen met dit als resultaat "Could not apply changes! Fix broken packages first!"

Geen idee wat ik nu moet doen, hulp zou fantastisch hard geapprecieerd worden.

Seba

edit: typo

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #1 Gepost op: 2007/12/07, 22:38:55 »
doe eens in je terminal (Toepassingen -> Hulpmiddelen)
sudo apt-get update
sudo apt-get upgrade

Wat zijn de foutmeldingen (Niet de hele tekst enkel de laatste regels)?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Sebah

  • Gast
Problemen ATI X1200
« Reactie #2 Gepost op: 2007/12/07, 22:43:14 »
Bij het eerste geen foutmelding, en deze laatste regels

"5B opgehaald in 0s (13B/s)
Pakketlijsten worden ingelezen... Klaar"


Bij het tweede

"Instellen van poppler-utils (0.6.2-1~gutsy1) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place"

Ik hoop dat het dit was wat he bedoelde.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #3 Gepost op: 2007/12/07, 23:01:32 »
Je krijgt geen foutmelding? Dat is de laatste regel? Geen melding dat hij klaar is?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Sebah

  • Gast
Problemen ATI X1200
« Reactie #4 Gepost op: 2007/12/07, 23:08:12 »
dit is de reply na het opnieuw invoeren van de 2e regel

"Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd."



en daar eindigt het

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #5 Gepost op: 2007/12/07, 23:25:01 »
Citaat van: Sebah
- restricted drivers -> en daar ATI accelerated graphics driver proberen te enablen met dit als resultaat "Could not apply changes! Fix broken packages first!"
Vreemd dat hij klaagt over gebroken pakketten en via een upgrade blijkt alles toch in orde te zijn. Hij blijft deze foutmelding geven?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Sebah

  • Gast
Problemen ATI X1200
« Reactie #6 Gepost op: 2007/12/07, 23:26:39 »
Jep

Sebah

  • Gast
Problemen ATI X1200
« Reactie #7 Gepost op: 2007/12/08, 00:00:26 »
Ok dus ik ben aan het proberen de driver van mijn grafische kaart te instaleren

Ik voer deze commande in:
"sh  ati-driver-installer-7-11-x86.x86_64.run"
Hij doet een beetje en zegt daarna dat ik super-user moet zijn om het te installeren

ik voer "sudo su -" in en ik kom in de root@ terecht, wat volgens mij de super-user is?

ik probeer de installatie commando terug in the geven en ik krijg dit:
"sh: Can't open ati-driver-installer-7-11-x86.x86_64.run"


Wat doe ik mis?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #8 Gepost op: 2007/12/08, 01:18:31 »
Door dat commando kom je in een andere map terecht, namelijk de "home" map van root. (/root)
Wat je beter kan doen:
sudo sh  ati-driver-installer-7-11-x86.x86_64.run

Overigens is sudo su - in Ubuntu niet de gebruikelijke manier om root te worden.
Om één enkel commando als root uit te voeren:
sudo commando
Of, als je een grafisch programma wil uitvoeren als root:
gksudo commando

Wil je langere tijd als root werken, bijv. om meerdere commando's als root uit te voeren:
sudo -i
Vergeet hierna niet om exit te typen. Hiermee word je weer de gewone gebruiker.

Dit staat trouwens ook in de documentatie.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #9 Gepost op: 2007/12/08, 10:59:26 »
Citaat
gksudo nautilus

navigeer je naar het bestand:

    /var/lib/dpkg/status
en zoek naar "gebroken" bestanden: gebruik de zoekfunctie binnen het bestand, opdracht: ati
je weet zeker dat er geen gebroken pakketten omtrent ati in het bestand genoemd werden? dan nautilus afsluiten.
daarna eventueel: sudo apt-get update
                          sudo apt-get upgrade

Sebah

  • Gast
Problemen ATI X1200
« Reactie #10 Gepost op: 2007/12/08, 11:41:05 »
Ok het installeren van de drivers is gelukt hoezee... helaas heeft het weinig tot geen resultaat gehad, situatie is ongewijzigd gebleven.

Na het zoeken van het bestand voor ati heb ik deze paragraaf gevonden

Package: xserver-xorg-video-ati
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 912
Maintainer: Ubuntu Core Developers
Architecture: i386
Version: 1:6.7.195-1ubuntu2
Replaces: xserver-xorg (<< 6.8.2-35), xserver-xorg-video-atimisc, xserver-xorg-driver-r128, xserver-xorg-driver-radeon, xserver-xorg-driver-ati
Provides: xserver-xorg-video-1.0, xserver-xorg-video-atimisc, xserver-xorg-driver-r128, xserver-xorg-driver-radeon
Depends: libc6 (>= 2.6-1), xserver-xorg-core (>= 2:1.3.0.0)
Conflicts: xserver-xorg-video-atimisc, xserver-xorg-driver-r128, xserver-xorg-driver-radeon, xserver-xorg-driver-ati
Description: X.Org X server -- ATI display driver
 This driver for the X.Org X server (see xserver-xorg for a further description)
 provides support for the ATI Mach, Rage, Radeon, and FireGL series.  It
 provides the 'atimisc', 'r128' and 'radeon' sub-drivers.
 .
 Note that this is not the same as the ATI-provided, binary-only, 'fglrx'
 driver, which provides additional 3D functionality for some newer Radeon
 cards, but is not supported.
 .
 This driver provides support for Mach, Rage, Rage128, Radeon, and most
 FireGL series ATI cards.
 .
 More information about X.Org can be found at:
 
 
 
 .
 This package is built from the X.org xf86-video-ati driver module.
Original-Maintainer: Debian X Strike Force

Alles terug geupdate en geupgrade maar voorlopig geen resultaat.

Alvast bedankt voor de replies :)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #11 Gepost op: 2007/12/08, 11:46:38 »
wat is de uitkomst van: fglrxinfo

Sebah

  • Gast
Problemen ATI X1200
« Reactie #12 Gepost op: 2007/12/08, 11:50:40 »
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

krijg ik als resultaat

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #13 Gepost op: 2007/12/08, 12:54:31 »
je hebt ati drivers geinstalleerd, maar ze zijn lijkt mij niet aan het werk.
glx=traag.
ik denk dat je je xorg.conf hier moet posten.

Sebah

  • Gast
Problemen ATI X1200
« Reactie #14 Gepost op: 2007/12/08, 13:07:11 »
Ok, en waar vind ik die xorg.conf ?
Excuse als dit een stomme vraag lijkt, ben nog maar sinds gisteren bezig met linux

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #15 Gepost op: 2007/12/08, 13:22:28 »
Citaat van: Sebah
Ok, en waar vind ik die xorg.conf ?
Excuse als dit een stomme vraag lijkt, ben nog maar sinds gisteren bezig met linux
gedit /etc/X11/xorg.conf  in de terminal

Sebah

  • Gast
Problemen ATI X1200
« Reactie #16 Gepost op: 2007/12/08, 13:29:22 »
Hier het resultaat:

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
 # (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
 
Section "Files"
EndSection
 
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
EndSection
 
Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection
 
Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection
 
Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection
 
Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection
 
Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:1:5:0"
EndSection
 
Section "Monitor"
   Identifier   "MD30999PD"
   Option      "DPMS"
EndSection
 
Section "Screen"
   Identifier   "Default Screen"
   Device      "Generic Video Card"
   Monitor      "MD30999PD"
   DefaultDepth   24
   SubSection "Display"
      Modes      "1440x1440" "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
   EndSubSection
EndSection
 
Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
 
# Uncomment if you have a wacom tablet
#   InputDevice     "stylus"   "SendCoreEvents"
#   InputDevice     "cursor"   "SendCoreEvents"
#   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Problemen ATI X1200
« Reactie #17 Gepost op: 2007/12/08, 14:47:41 »
Section "Device"
    Identifier    "Generic Video Card"
    Driver        "vesa"
    BusID        "PCI:1:5:0"

geen ati drivers, probeer eens: sudo dpkg-reconfigure xserver-xorg
kies bij de drivers: ati. de rest default.

Sebah

  • Gast
Problemen ATI X1200
« Reactie #18 Gepost op: 2007/12/08, 15:06:43 »
Dat gedaan, en ATI gekozen en ATI RADEON X1200 ingevuld en nu kom ik hier op uit

Pakketconfiguratie                                                              
                                                                                 
 ┌────────────────┤ Bezig met configureren van xserver-xorg ├────────────────