Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Programma's starten via ssh  (gelezen 4112 keer)

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Programma's starten via ssh
« Gepost op: 2007/12/03, 17:04:13 »
Hoi,

Op een oude pc heb ik de serverversie 7.10 geïnstalleerd. De installatie ging vlot en kan nu via SSH inloggen via m'n laptop.
Programma's installeren gaat goed. Maar hoe kan ik nu bijvoorbeeld amsn starten op de server en dit op de remote laptop tonen?

In /etc/ssh/sshd_config staat X11Forwarding yes dus, X11 forwarding staat ingeschakeld.

Thans toch krijg ik steeds de foutmelding:
Application initialization failed: no display name and no $DISPLAY environment variable
Error in startup script: no display name and no $DISPLAY environment variable
    while executing
"load /usr/lib/tk8.4/../libtk8.4.so.0 Tk"
    ("package ifneeded" script)
    invoked from within
"package require Tk"
    (file "/usr/bin/amsn" line 48)
Bedankt,
Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #1 Gepost op: 2007/12/03, 17:20:45 »
Log je wel in met het volgende commando:
ssh -X servernaam

Door die -X zet je X11 forwarding pas echt aan.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #2 Gepost op: 2007/12/03, 17:22:29 »
Ja, zowel geprobeerd met ssh -X ipadres als ssh -X kris@ipadres beide zonder resultaat.

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline lizardman

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #3 Gepost op: 2007/12/03, 18:32:27 »
als je inlogt met : ssh -l username -Y IPvanserver
lukt het dan nog steeds niet?
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #4 Gepost op: 2007/12/03, 19:19:42 »
Helaas lizardman, dezelfde melding verschijnt op men scherm als ik in men eerste post heb gezet.

Er is toch niets speciaals wat ik nog moet installeren? Zowel server als client zijde?

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #5 Gepost op: 2007/12/03, 22:13:58 »
Zo te zien zit het probleem niet bij SSH maar bij het amsn programma zelf: de melding is dat de Tk library geinstalleerd moet worden. Tk is een general purpose windowing library voor scripting talen als TCL en Perl die op zijn beurt weer het X protocol gebruikt. Dus, installeer Tk op de machine waar amsn op gaat draaien en het zou moeten werken.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #6 Gepost op: 2007/12/03, 22:30:13 »
Wanneer ik het met firefox probeer krijg ik: (firefox-bin:4914): Gtk-WARNING **: cannot open display:

Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Programma's starten via ssh
« Reactie #7 Gepost op: 2007/12/03, 23:31:43 »
Citaat van: Scormen
Wanneer ik het met firefox probeer krijg ik: (firefox-bin:4914): Gtk-WARNING **: cannot open display:

Kris
Slechts een idee, maar misschien moet je proberen het display mee te geven. Zet iets in de trant van,  achter je opdracht: DISPLAY:0

Offline quick30

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #8 Gepost op: 2007/12/04, 00:18:09 »
Hier
http://www.windowsecurity.com/articles/SSH.html
las ik

If the configuration option ForwardX11 is active and the user is using X11 (the DISPLAY environment variable is set) all X11 traffic is automatically forwarded over a secure SSH channel and the connection to the real X server is made from the local machine.

Dus op de client en server moet X11 als DISPLAY variabele zijn ingesteld.

Daarnaast heeft johanvd een goed punt die ForwardX11 moet wel geactiveerd zijn. Geen idee hoe je daar achter komt...

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #9 Gepost op: 2007/12/04, 12:37:50 »
Die staat voor de server in /etc/ssh/sshd_config en voor de client in /etc/ssh/ssh_config
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline lizardman

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #10 Gepost op: 2007/12/04, 18:00:27 »
Ik heb ooit met Fedora server op andere lokatie eenzelfde probleem gehad, kan me alleen niet meer herinneren hoe ik het toen heb opgelost :P
Het had geloof ik iets te doen met xhost+  ingeven of zo om X te laten connecten met de andere bak.
Sorry dat ik nu ff niet duidelijker kan zijn .....(vergeetachtig aan het worden.... :) )

edit: het commando xhost+ moet je ingeven op de bak zelf, het werkt niet als je het via ssh doet.(xauth en xhost moeten geinstalleerd zijn)

edit2: ff vraagje: heb je ook de ssh client en de ssh server opnieuw opgestart nadat je de .conf file had aangepast??
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Programma's starten via ssh
« Reactie #11 Gepost op: 2007/12/04, 18:46:28 »
     -Y     Enables trusted X11 forwarding.  Trusted X11 forwardings are not
              subjected to the X11 SECURITY extension controls.

              ssh  may  additionally obtain configuration data from a per-user
              configuration file and a system-wide  configuration  file.   The
              file  format and configuration options are described in ssh_con-
              fig(5).

              ssh exits with the exit status of the remote command or with 255
              if an error occurred.
Dit kwam ik toevallig tegen in het manual van ssh (" man ssh" ). Probeer eens uit met "ssh -Y" maar alleen als je de client volledig vertrouwd!
Misschien dat je dan automatisch wel de display variables krijg doorgespeeld.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #12 Gepost op: 2007/12/04, 19:07:59 »
@raggar
Heeft  ie al geprobeerd, zie post #4 en #5, het heeft helaas niet mogen baten.
Ik kwam op launchpad de volgende bug tegen:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/136947
Ik moet er wel bij opmerken dat ik hier wel xforwarding krijg als ik met mijn gutsy-laptop inlog op een dapper bak.
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #13 Gepost op: 2007/12/04, 19:20:45 »
Draai je op beide systemen Gutsy?

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Programma's starten via ssh
« Reactie #14 Gepost op: 2007/12/04, 23:17:38 »
Citaat van: lizardman
@raggar
Heeft  ie al geprobeerd, zie post #4 en #5, het heeft helaas niet mogen baten.
Ik kwam op launchpad de volgende bug tegen:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/136947
Ik moet er wel bij opmerken dat ik hier wel xforwarding krijg als ik met mijn gutsy-laptop inlog op een dapper bak.
Over heen gelezen, bedankt dat je het ff meld.

En ja, het lijkt erop dat je last hebt van de bug... Hou dat even in de gaten en post hier een bugreport. Dan zal er binnenkort wel een oplossing komen.

Offline lizardman

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #15 Gepost op: 2007/12/05, 10:25:20 »
Ik heb zojuist ff geprobeerd om een gutsy-gutsy ssh sessie op te zetten en te kijken of X-forwarding werkt.
Hier werkt het! het zijn wel twee (Gnome)desktop installaties, dus geen server.
Kwam deze link tegen: http://ubuntuforums.org/showthread.php?t=22558
Hij is wel oud, maar niet geschoten is altijd mis... toch? vanaf post#6 wordt het interessant,
Hopelijk heb je hier wat aan :-)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline quick30

  • Lid
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #16 Gepost op: 2007/12/06, 21:07:23 »
Als beide een X11 server gebruiken dan moet het automatisch kunnen werken (zie de quote uit m'n vorige post). Dus test met maar eens met een knoppix cd o.i.d.?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #17 Gepost op: 2007/12/07, 16:55:33 »
Andere tip, om voor ons wat meer informatie op te vissen: voeg de optie "-vvv" es toe aan je commando (dus: ssh -vvv ....) en post de output hier ...
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
Programma's starten via ssh
« Reactie #18 Gepost op: 2007/12/09, 11:39:04 »
Hoi mensen,

Excuseer dat ik dit topic wat heb laten rusten. Op de "server" heb ik de ubuntu-desktop geïnstalleerd, bovenop de installatie van de serverversie. Nu kan ik zonder problemen programma's op men locale pc starten.

Als ik wat meer tijd heb, ga ik eens terug kijken naar het probleem bij een verse server-installatie.

Toch bedankt voor alle reacties!
Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog