Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: na Ubuntu installatie (dual boot met Vista) probleem met opstarten  (gelezen 1278 keer)

Hoox

  • Gast
Hallo,

Ik ben nieuw op dit forum en ook Ubuntu is nieuw voor mij (ik heb er eigenlijk de ballen verstand van :)). Bij het installeren van Ubuntu 7.10 op mijn computer onstaat een probleem. Ik heb een Ubuntu Live cd gedownload en daarmee wil ik ubuntu installeren op een andere harde schijf dan waar ik Windows Vista op heb staan. Ik wil ubunto zo installeren dat ik mbv EasyBCD kan kiezen tussen Vista en Ubuntu.

Uit een aantal google-sessies en forums ben ik wel een en ander te weten gekomen. Op dit forum staan ook vergelijkbare topics maar ik heb nergens iets gevonden wat precies overeenkomt met mijn problemen. Mijn laatste installatie poging heb ik goed bijgehouden zodat ik hier misschien een preciezer antwoord kan krijgen dan ik her en der kan vinden.

Het probleem: Installeren gaat prima maar Ubuntu start niet op. Ik heb veel gelezen over Grub meldingen maar die heb ik niet gezien (net alsof grub nog niet wordt aangeroepen).

Mijn pc:

Asus P5b, intel core2duo, 3 sata en 1 pata schijf, 1 sata cdrom brander.

Bios:

Write protect staat uit (MBR kan geschreven worden).
Boot volgorde: CDROM, 1e Sata.

Verslag van de installatie:

Ik heb op mijn 3e sata schijf ruimte vrij gemaakt voor Ubuntu. Ik heb de bij een eerdere poging aangemaakte partities op die vrijgemaakte ruimte verwijderd, van de vrije ruimte heb ik 1 partitie van gemaakt en heb dit geformateerd (allemaal in windows). Ik heb de oude verwijzing naar ubuntu in EasyBCD verwijderd.

Nu heb ik Ubuntu opgestart (live CD) en heb het install proces vanaf de desktop gestart. Ik heb gekozen voor een handmatige schijf indeling. Ik heb op de 3e schijf 3 partities gemaakt:

1 ext3 / 6GB (root heb ik begrepen.. dit is even wennen)
2 swap 2048 (ik heb 2GB geheugen)
3 ext3 /home 11GB (rest vd vrije ruimte)

op het overzicht tijdens de installatie ziet het er nu zo uit (ik heb het snel op klad gezet dus is niet helemaal compleet):

sda1    ntfs       320070
sdb1    ntfs       250057
sdc1    ntfs       250057
sdd1    ntfs       230061
sdd2    ext3    /    5996
sdd3    swap       2048
sdd4    ext3    /home    11951

Na het invullen van gebruikersgegegevens heb ik via de knop 'geavanceerd' ingesteld dat de bootloader wordt geinstalleerd op (hd3,1). Dit komt overeen met schijf 4, 2e partitie (koste me heel wat tijd om achter te komen). De installatie is verder prima verlopen.

De live cd wordt verzocht uit te nemen, daarna is de computer netjes geboot naar Vista.

In Vista heb ik met het programma EasyBCD een nieuwe opstartregel gemaakt. Bij het tabblad linux heb ik de 2e partitie (nr1) op de4e schijf (nr3) geselecteerd. Dit komt allemaal overeen met het overzicht tijdens de installatie. Bij de naam heb ik "Ubuntu" ingevuld.

Na saven en rebooten krijg ik een opstart menu. Ik kies voor "Ubuntu" en dan krijg ik de volgende melding:

BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollart http://winimage.com/bootpart.htm

Loading new partition
Bootsector from C.H. Hochtst├Ątter
Cannot load from harddisk
Insert Systemdisk and press any key


Als ik op een toets druk komt er nog een melding en reboot het systeem.

- Ik krijg geen grubfoutmeldingen (ik heb begrepen dat deze het booten van ubuntu regelt, in diverse fora wordt daar over gesproken)
- Ik heb voor het herstarten na de installatie vanaf de live cd menu.lst (uit de map boot/grub) naar mijzelf gemaild. Ik heb begrepen dat deze belangrijk is voor het goed werken van Grub. Onderin het bestand staat wel een aantal keer (hd3,1) dus dat lijkt goed. Op verzoek kan ik dit bestand hier posten maar het lijkt mij niet nodig aangezien het lijkt alsof Grub niet eens gestart wordt.

Vanaf hier weet ik niet meer wat ik kan doen. Wie heeft raad?

Offline mcgyver

  • Lid
  • Steunpunt: Nee
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #1 Gepost op: 2007/12/01, 08:06:27 »
Je had de bootloader liever standaard kunnen laden.

Offline jan11000

  • Lid
  • Steunpunt: Nee
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #2 Gepost op: 2007/12/01, 08:20:18 »
Indien je geen grub ziet met opstarten, dan heb in de bios de verkeerde hd voorgekozen, indien dit niet werkt dan super grub vanaf cd installeren, en opnieuw proberen.

Indien grub nu wel opstart dan moet je de goede hd aangeven.
De waarden kunnen kopleet anders zijn dan bij installatie, soms net andersom, dus pas menu-lst aan op je hd, je kan gewoon meerder ubuntu's aangeven met steeds andere schijven tot je weet welke werkt.

Hoox

  • Gast
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #3 Gepost op: 2007/12/01, 16:10:11 »
Citaat van: mcgyver
Je had de bootloader liever standaard kunnen laden.
Je bedoeld gewoon op (hd0) dus. Maar overschrijf je dan niet de bootsector van Vista? Lijkt mij niet verstandig.. Kun je daar meer over zeggen?

Citaat van: jan11000
Indien je geen grub ziet met opstarten, dan heb in de bios de verkeerde hd voorgekozen, indien dit niet werkt dan super grub vanaf cd installeren, en opnieuw proberen.
Ik wil dat de PC boot op de eerste hd, dan krijg ik een bootmenu (EasyBCD) waar ik kan kiezen uit Vista of Ubuntu (welke op de derde hd staat). Ik vraag me af of je mijn probleem wel goed hebt begrepen...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #4 Gepost op: 2007/12/01, 16:30:09 »
Je overschrijft inderdaad de bootloader van Vista. Dit is niet erg, want je installeert een nieuwe bootloader: grub.
Hiermee kan je zowel Vista als Ubuntu opstarten.

Zie ook de installatiehandleidingen in de documentatie.

Hoox

  • Gast
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #5 Gepost op: 2007/12/01, 18:04:02 »
Citaat van: Johanvd
Zie ook de installatiehandleidingen in de documentatie.
Ik heb hier al gekeken maar ga het nog eens goed doorspitten. Ik herriner mij van andere fora dat Vista geen wijzigingen in de eigen bootsector accepteerd, of dat Vista dan niet meer wil booten met grub. Alle handleidingen gaan tot nu toe uit van XP. En dat is een heel ander beestje natuurlijk.

Ondertussen duik ik de handleidingen in, als iemand uit ervaring weet dat grub in de bootsector (zoals Johanvd beschrijft) werkt met Vista dan hoor ik het graag.


Offline mcgyver

  • Lid
  • Steunpunt: Nee
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #7 Gepost op: 2007/12/01, 20:57:17 »
Ik heb een dual boot met vista, wees dus niet bang. Het is foutloos gegaan tijdens de installatie. Dat wil zeggen dat ik NIETS van Vista of Ubuntu hoefde te repareren achteraf.

edit:

Wat ik altijd doe is een partitie maken voor windows. Dit doe ik tijdens de windwos installatie. Het gedeelte dat bestemd is voor Ubuntu laat ik ongepartitioneerd (niet helemaal eigenlijk want het is al een partitie) en ongeformatteerd. Na de windows installatie doe ik Ubuntu. Tijdens de installatie maak ik HANDMATIG een / , een /home en een swap partitie aan op het gedeelte dat ik had vrijgelaten. Het is nog nooit verkeerd gegaan en ik kan je garanderen dat ik al ontzettend veel installaties heb gedaan.

edit2: Ik heb je probleem uitstekend begrepen. Grub is beter dan je denkt, vertrouw ons maar.

Hoox

  • Gast
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #8 Gepost op: 2007/12/01, 21:21:29 »
Citaat van: mcgyver
Ik heb een dual boot met vista, wees dus niet bang. Het is foutloos gegaan tijdens de installatie. Dat wil zeggen dat ik NIETS van Vista of Ubuntu hoefde te repareren achteraf.

edit:

Wat ik altijd doe is een partitie maken voor windows. Dit doe ik tijdens de windwos installatie. Het gedeelte dat bestemd is voor Ubuntu laat ik ongepartitioneerd (niet helemaal eigenlijk want het is al een partitie) en ongeformatteerd. Na de windows installatie doe ik Ubuntu. Tijdens de installatie maak ik HANDMATIG een / , een /home en een swap partitie aan op het gedeelte dat ik had vrijgelaten. Het is nog nooit verkeerd gegaan en ik kan je garanderen dat ik al ontzettend veel installaties heb gedaan.

edit2: Ik heb je probleem uitstekend begrepen. Grub is beter dan je denkt, vertrouw ons maar.
Mooi! Ik ga voor de zekerheid alles backuppen en dan doe ik een nieuwe Ubuntu install met handmatig aangemaakte /, /home en swap partities en bootloader laat ik op standaard staan. Laat straks nog weten hoe het is afgelopen.

Hoox

  • Gast
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #9 Gepost op: 2007/12/01, 23:11:01 »
Zo dit bericht heb ik getypt vanuit Ubuntu welke prima is opgestart dmv grub. Allemaal hartelijk bedankt! (en nog vele vragen zullen volgen via dit forum..)

Offline Bobbie

  • Lid
  • Steunpunt: Nee
na Ubuntu installatie (dual boot met Vista) probleem met opstarten
« Reactie #10 Gepost op: 2007/12/01, 23:13:56 »
Leuk te horen, dat goed is gekomen.