Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid op laptop Omnibook 4150 met NM256 chip  (gelezen 463 keer)

pwii

  • Gast
Geen geluid op laptop Omnibook 4150 met NM256 chip
« Gepost op: 2007/11/30, 12:03:30 »
Heb enige tijd geleden Xubuntu geinstalleerd op een HP Omnibook 4150. Alles erekt, inclusief wireless (weliswaar via ndiswrapper), maar geen geluid ;-(  Na checken van de meeste fora blijkt dit nog voor te komen op dit type laptop.  Maar ondanks het toepassen van alle 'black magic' tot nu toe geen succes. Probleem is dat ik geen lijn zie in de toegepaste truuks, en dat veelal bepaalde commando's fouten geven wegens andere distributie of weet ik wat.  Maar als ik het probleem een beetje logisch aanpak, beginnende bij de hardware, dan levert uit uitvoeren van een aantal commando's het volgende op:



uname -r
    2.6.22-14-generic

lshw
    [...]
    *-multimedia UNCLAIMED
    description: Multimedia audio controller
    product: NM2200 [MagicMedia 256AV Audio]
    vendor: Neomagic Corporation
    physical id: 0.1              
    bus info: pci@0000:01:00.1
    version: 20  
    width: 32 bits
    clock: 33MHz
    capabilities: pm cap_list
    configuration: latency=0
    [...]

dmesg | grep nm_256
    [   48.008000] nm256: The device is blacklisted. Loading stopped

dmesg | grep opl3
   
    [   47.184000] opl3sa2: can't grab port 0x0
    [   47.236000] snd-opl3sa2-pnpbios: probe of 00:0d failed with error -16

lsmod | grep snd
    snd_ac97_codec        100644  0
    ac97_bus                3200  1 snd_ac97_codec
    snd_seq_dummy           4740  0
    snd_opl3sa2            21804  0    
    snd_opl3_lib           11520  1 snd_opl3sa2
    snd_hwdep              10244  1 snd_opl3_lib
    snd_cs4231_lib         26112  1 snd_opl3sa2
    snd_pcm_oss            44672  0
    snd_mixer_oss          17664  1 snd_pcm_oss
    snd_seq_oss            33152  0
    snd_pcm                80388  3 snd_ac97_codec,snd_cs4231_lib,snd_pcm_oss                    

snd_page_alloc         11400  2 snd_cs4231_lib,snd_pcm
    snd_mpu401_uart         9600  1 snd_opl3sa2
    snd_seq_midi            9600  0
    snd_rawmidi            25728  2 snd_mpu401_uart,snd_seq_midi
    snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
    snd_seq                53232  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              24324  4 snd_opl3_lib,snd_cs4231_lib,snd_pcm,snd_seq
    snd_seq_device          9228  6 snd_seq_dummy,snd_opl3_lib,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    snd                    54660 14 snd_ac97_codec,snd_opl3sa2,snd_opl3_lib,
snd_hwdep,snd_cs4231_lib,snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_pcm,snd_mp401_uart,snd_rawmidi,snd_seq,
snd_timer,snd_seq_device
    soundcore               8800  1 snd

alsamixer
    alsamixer: function snd_ctl_open failed for default: no such device
De juiste chip wordt dus gevonden, maar de driver wordt niet geinstalleerd. Installatie van de opl3sa2 driver geeft een fout alsof de driver geen controle over de chip kan krijgen. Er worden toch heel wat sound drivers geinstalleerd, w.o. de opl3sa2, maar geen enkele lijkt controle te hebben over de chip, vandaar geen geluid.  Manueel modprobe proberen met opties die ik op allerlei fora vind (zelfs gewoon een enable), levert steeds de "can't grab port 0x0".

Wie kan mij wat bijkomende aanwijzingen - tips - ... geven?

Alvast bedankt!