Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: problemen met ATI Radeon 9550 128 MB  (gelezen 1767 keer)

mr. B

  • Gast
problemen met ATI Radeon 9550 128 MB
« Gepost op: 2006/06/22, 17:57:42 »
Hoi allemaal.





Als newbee in Linux gebruik ik nu ongeveer 1 jaar Ubuntu en het bevalt mij prima.

Ik heb tot nu toe alles zelf kunnen oplossen op 1 ding na, waarvan ik hoopte dat ik het na het updaten naar Dapper

zou kunnen oplossen... maar helaas.



Het probleem betreft mijn video kaart, een ATI radeon 9550 128 MB.



Na de installaties van Breezy als Dapper kamp ik met de volgende problemen (symptonen):



1:

kwaliteit van beeld (films, mpeg, divx) is "slecht" (bewegende beelden zijn een beetje blokkerig (maar via windows spatzuiver)

(ik heb de nieuwste packages voor het afspelen van mpeg, avi, divx, etc. voor Mplayer en totem al geinstalleerd)



2:

TV-out werk niet (goed). Werk wel in textmode/ shell, maar zodra de grafische omgeving start stoort het beeld dusdanig dat

niets te herkennen is, waarna het beeld van de TV na enkele seconden helemaal zwart wordt.





Naar mijn bescheiden mening betreft dit een driver-probleem, of instellingen van de driver.

Dus het eerste wat ik heb gedaan is de X-server opnieuw configureren met het volgende commando:

"sudo dpkg-reconfigure xserver-xorg"



Hierbij werd zowel mijn kaart als mijn monitor automatisch herkend, als driver selecteerde ik FGLRX

(een eerdere poging met ATI als driver maakte de situatie aleen slechter, namelijk dezelfde klachten maar dan zonder fglrx ondersteuning)



Xorg geeft tijdens het instellen aan dat de instellingen zullen gelden voor slecht 1 monitor en dat de andere monitoren (en TV's?) handmatig moeten worden ingesteld in de volgende file /etc/x11/xorg.conf

(Heb in de file gekeken, maar heb geen idee hoe ik dat zou moeten doen)

(Dit verklaart in mijn ogen waarom mijn TV dan op zwart springt, TV kan resolutie van Monitor niet aan. instellingen van TV worden gekloond van monitor?)



Vervolgens teste ik met de volgende commando's of fglrx goed werkt:

"glxgears"

"fgl_glxgears"
In beide gevallen had ik suc6.

"fglrxinfo" gaf de volgende informatie:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5814 (8.25.18)



Om de tweede monitor in te kunnen stellen in een grafisch menuutje (ben niet zo handig in de shell) downloade ik via Synaptic "fireglcontrol"



Maar als ik fireglcontrol opstart met het volgende commando "sudo fireglcontrol" krijg ik deze melding in de shell:



X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode:  148
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
  Major opcode:  148
  Minor opcode:  3
  Resource id:  0x0
Failed to open device




Het programma start overigens wel, maar ik bijna niets instellen en gewijzigde instellingen worden niet doorgevoerd en opgeslagen)


Hierop loop ik nu vast, ik heb geen idee wat dit inhoud en hoe ik dit zou kunnen oplossen.

Kan iemand mij helpen? ...zie het maar als een uitdaging ;)





Groeten

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
problemen met ATI Radeon 9550 128 MB
« Reactie #1 Gepost op: 2006/06/22, 18:15:13 »
installeer fglrx-control :)

Lees ook eens de man van aticonfig,  aticonfig --initial=dual-head is interessant :D

mr. B

  • Gast
problemen met ATI Radeon 9550 128 MB
« Reactie #2 Gepost op: 2006/06/22, 18:26:26 »
"fireglcontrol"  is toch de command van fglrx-control?

mr. B

  • Gast
problemen met ATI Radeon 9550 128 MB
« Reactie #3 Gepost op: 2006/06/22, 18:28:27 »
aticonfig --initial=dual-head:

Found fglrx primary device section
Found fglrx secondary device section
Nothing to do, terminating.

is dit goed?

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
problemen met ATI Radeon 9550 128 MB
« Reactie #4 Gepost op: 2006/06/22, 18:40:46 »
Citaat van: mr. B
"fireglcontrol"  is toch de command van fglrx-control?
Inderdaad, sorry, erover gelezen...

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
problemen met ATI Radeon 9550 128 MB
« Reactie #5 Gepost op: 2006/06/22, 18:44:34 »
Citaat van: mr. B
aticonfig --initial=dual-head:

Found fglrx primary device section
Found fglrx secondary device section
Nothing to do, terminating.

is dit goed?
Heel goed! Zie je ook de 2 devices in /etc/X11/xorg.conf?
Post die file eens even. Ook niet mijn sterkste punt, maar zo kan iedereen helpen.

mr. B

  • Gast
problemen met ATI Radeon 9550 128 MB
« Reactie #6 Gepost op: 2006/06/22, 19:01:12 »
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen         "Default Screen" 0 0
   Screen         "aticonfig-Screen[1]" RightOf "Default Screen"
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
   InputDevice    "stylus" "SendCoreEvents"
   InputDevice    "cursor" "SendCoreEvents"
   InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

   # path to defoma fonts
   FontPath     "/usr/share/X11/fonts/misc"
   FontPath     "/usr/share/X11/fonts/cyrillic"
   FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/X11/fonts/Type1"
   FontPath     "/usr/share/X11/fonts/100dpi"
   FontPath     "/usr/share/X11/fonts/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load  "bitmap"
   Load  "ddc"
   Load  "dri"
   Load  "extmod"
   Load  "freetype"
   Load  "glx"
   Load  "int10"
   Load  "type1"
   Load  "vbe"
EndSection

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "CoreKeyboard"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc104"
   Option       "XkbLayout" "us"
EndSection

Section "InputDevice"
   Identifier  "Configured Mouse"
   Driver      "mouse"
   Option       "CorePointer"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "ExplorerPS/2"
   Option       "ZAxisMapping" "4 5"
   Option       "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "stylus"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "stylus"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "eraser"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "eraser"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "cursor"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "cursor"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
   Identifier   "Philips 190C"
   HorizSync    30.0 - 83.0
   VertRefresh  56.0 - 76.0
   Option       "DPMS"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[1]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "ATI Technologies, Inc. RV350 AS [Radeon 9600]"
   Driver      "fglrx"
   BusID       "PCI:3:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[1]"
   Driver      "fglrx"
   BusID       "PCI:3:0:0"
   Screen      1
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "ATI Technologies, Inc. RV350 AS [Radeon 9600]"
   Monitor    "Philips 190C"
   DefaultDepth     24
   SubSection "Display"
      Depth     1
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[1]"
   Device     "aticonfig-Device[1]"
   Monitor    "aticonfig-Monitor[1]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
problemen met ATI Radeon 9550 128 MB
« Reactie #7 Gepost op: 2006/06/22, 20:47:09 »
Ik denk dat hier de fout zit:

Screen         "aticonfig-Screen[1]" RightOf "Default Screen"

Gaat ervan uit dat je beide gebruikt als 1 scherm. (en dat uw TV rechts staat) Ik dacht dat
Screen         "aticonfig-Screen[1]" 0 1
eerder in de buurt is, maar pas het nog niet aan. Ben niet zeker genoeg van mijn stuk.

@ Dennis, ja inderdaad, config X is een top 10 miserie :) Hoewel het wel geniaal is, zoals hier, een X met 2 devices... Had het nog niet gezien, vind het wel leuk. (zeker mocht het ook werken...)