Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Compiz werkend gekregen  (gelezen 745 keer)

Herrman17

  • Gast
Compiz werkend gekregen
« Gepost op: 2007/11/28, 15:02:47 »
Hallo,

Ik heb Compiz eindelijk werkend gekregen op een ATI Radeon 9600 TX grafische kaart.
Toch zie ik een paar problemen, zo moet ik na het opstarten van de computer de GL desktop eens uitzetten en dan weer aan om de kubus werkend te krijgen.
Ook werkt Advanced Desktop Settings niet onder KDE, ik kan het wel opstarten maar ik kan geen enkele optie aan of uitkruisen terwijl ik de toegangsrechten heb om te lezen en te schrijven in dat programma. Met Gnome werkt het wel maar ik werk onder KDE en zie daar geen enkele verandering als ik instellingen doe in Gnome en terug naar kde ga met CTRL-ALT_BACKSPACE

Het programma Xbindkeys werkt ook niet meer, ik heb dit nodig om de extra knoppen op mijn microsoft trackball te kunnen gebruiken.

Ik zie hier ook dat ik 12 bureaubladen heb terwijl ik in Bureaubladen instellen er maar 1 ingesteld heb, als ik er meer kies worden die vermengvuldigt met 12, 2 Bureaubladen is dan 24, 3 word 36 enz.
 
Hier een copy van mijn xorg.conf:


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
   Option      "XkbVariant"   "be"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies Inc RV350 NF [Radeon 9600]"
   Driver      "ati"
   BusID      "PCI:1:0:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
   HorizSync   30-70
   VertRefresh   50-160
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc RV350 NF [Radeon 9600]"
   Monitor      "SyncMaster"
   DefaultDepth   24
   SubSection "Display"
      Modes      "1440x900" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"

# Uncomment if you have a wacom tablet
#   InputDevice     "stylus"   "SendCoreEvents"
#   InputDevice     "cursor"   "SendCoreEvents"
#   InputDevice     "eraser"   "SendCoreEvents"
EndSection


Iemand tips?

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Compiz werkend gekregen
« Reactie #1 Gepost op: 2007/11/28, 23:07:36 »
Welkom bij Ubuntu! Ik probeer kort een paar antwoorden te geven op je vragen. Maar als het lastiger wordt dan is het misschien handig om van elk probleem een nieuw topic te maken. Probeer eerst het volgende:

"Ik zie hier ook dat ik 12 bureaubladen heb terwijl ik in Bureaubladen instellen er maar 1 ingesteld heb, als ik er meer kies worden die vermengvuldigt met 12, 2 Bureaubladen is dan 24, 3 word 36 enz.

Dit is een instelling in advanced desktop settings van compiz, ga naar "general settings" --> desktop size --> horizontal viritual desktops. En zet dat op 4 of iets dergelijks.


"Ik heb Compiz eindelijk werkend gekregen op een ATI Radeon 9600 TX grafische kaart.
Toch zie ik een paar problemen, zo moet ik na het opstarten van de computer de GL desktop eens uitzetten en dan weer aan om de kubus werkend te krijgen."

Probeer eens het volgende toe te voegen in je "xorg.conf" misschien dat het iets uithaalt
Section "Extensions"
        Option          "Composite"     "0"
EndSection

Het programma Xbindkeys werkt ook niet meer, ik heb dit nodig om de extra knoppen op mijn microsoft trackball te kunnen gebruiken.
Start dit vanuit een terminal (in de terminal Xbindkeys) en als er foutmeldingen zijn. Post die hier of op een nieuw topic.

Herrman17

  • Gast
Compiz werkend gekregen
« Reactie #2 Gepost op: 2007/11/29, 15:59:12 »
Bedankt voor uw antwoord.

Ik heb het volgende geprobeerd:

In xorg.conf heb ik deze regels ingezet met als resultaat dat Kde niet meer opstart, ik krijg een tekstscherm.
Als ik deze regels weer verwijder start Kde terug

Ik heb in advanced desktop settings van compiz, general settings --> desktop size --> horizontal viritual desktops
een 4 gezet maar het resultaat blijft hetzelfde, nog steeds worden mijn bureaubladen vermenigvuldigt met 12

Xbindkeys werkt ook niet als ik het opstart in het terminalvenster, ik krijg echter geen foutmelding.

Nog suggesties?

Herrman17

  • Gast
Compiz werkend gekregen
« Reactie #3 Gepost op: 2007/11/30, 14:09:57 »
Ik heb het gevonden, na wat sleutelen aan de instellingen in Advanced Desktop Effects Settings lijkt het te werken
Ook Xbindkeys werkt weer, hiervoor heb ik in xorg.conf de volgende instellingen moeten doen:

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option        "Buttons"      "7"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
EndSection

Bedankt voor de tips die u mij gegeven hebt.