Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: sweex LW057 wireless adapter (Marvell 88W8335+88W8010)  (gelezen 5684 keer)

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Gepost op: 2007/11/25, 11:31:32 »
hallo iedereen.

Ik heb gisteren bovenstaande kaart gekocht. Helaas werkt het niet onder windows XP PRO. Belangrijker nog: In Gutsy wordt hij netjes gezien maar in m'n systeem heb ik geen ETH1 staan (ETH0 is m'n netwerkkaart met bedrading).

De verbinding van ETH0 naar de modem lukt. Van de Wireless netwerkkaart (ETH1?) lukt niet.

Wie heeft er een goed idee? Voor mij heel belangrijk want dan kan m'n dochter genieten van Ubuntu op haar kamer en weer 1 pc zonder windows.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #1 Gepost op: 2007/11/25, 11:34:30 »
Je hoeft toch niet verbinding te maken via Systeem - Beheer - Netwerk? Je kunt gewoon klikken op het netwerksymbooltje rechts in je bovenste werkbalk (Network Manager). Met een paar muisklikken leg je zo een draadloze verbinding.

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #2 Gepost op: 2007/11/25, 11:49:31 »
bedankt voor de tip. Heb dat gedaan en ben daar gegaan naar:
Opties > Draadloos activeren
Helaas was deze optie grijs (niet te selecteren).
Toen ben ik gaan kijken naar de netwerkkaarten onder:
Handmatige configuratie...
Daar zag ik alleen eth0 als netwerkkaart. Klopt dat dan of moet ik de draadloze netwerkkaart nog configureren?

Ik ben bang dat er niet een linux-native driver is voor deze kaart. Dan moet ik aan de slag met ndiswrapper (nog nooit gedaan).

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #3 Gepost op: 2007/11/25, 12:06:17 »
Ben zoeven begonnen dit te volgen:
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide

Bij de uitvoer van het commando "lshw" vond ik dit over m'n wireless netwerkkaart:
        *-network:1 UNCLAIMED
             description: Ethernet controller
             product: 88w8335 [Libertas] 802.11b/g Wireless
             vendor: Marvell Technology Group Ltd.
             physical id: a
             bus info: pci@0000:00:0a.0
             version: 03
             width: 32 bits
             clock: 66MHz
             capabilities: bus_master cap_list
             configuration: latency=64

Dan mag ik opmaken uit het woor "UNCLAIMED" dat er nog geen driver voor het apparaat is geinstalleerd? Dat controleer ik op de volgende pagina:
http://linux-wless.passys.nl/
geef de maker van de chipset op: Marvell. Resultaat: rood (dat betekent niet ondersteund). Geen hoop meer voor mij?

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #4 Gepost op: 2007/11/25, 13:57:07 »
Ben nu aan het controleren of m'n kaart (lees chipset) wordt ondersteund door ndiswrapper. Het ziet er wel naar uit tot nu toe. Alleen was de WAP beveiliging nog niet getest...
http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,list_m-n/
kijk dan naar (punt 4 dacht ik) met de titel "Card: Marvell 88W8335 - Libertas 802.11b/g Wireless (rev 03)"
Of zoek op "Marvell"

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #5 Gepost op: 2007/11/25, 14:49:52 »
Nu wil ik gaan testen of het gaat lukken als ik ndiswrapper installeer. Ik heb dus met Adapt ndiswrapper geinstalleerd. Helaas lukte het starten van het programma niet vanuit het menu.

Zal het zo ook testen van de commando regel.

Is het nog nodig om op m'n x86-64 systeem nog op een andere manier NDISwrapper te installeren?

Offline quick30

  • Lid
  • Steunpunt: Nee
sweex LW057 wireless adapter (Marvell 88W8335+88W8010)
« Reactie #6 Gepost op: 2007/11/25, 15:47:33 »
vanaf de commandoregel krijg ik deze uitvoer. Uitgevoerd als root natuurlijk:
root@tux:~# /usr/sbin/ndisgtk
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/usr/sbin/ndisgtk:89: Warning: invalid (NULL) pointer instance
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: Screen for GtkWindow not set; you must always set
a screen for a GtkWindow before using the window
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: gdk_pango_context_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_context_set_font_description: assertion `context != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_context_set_base_dir: assertion `context != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_context_set_language: assertion `context != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_new: assertion `context != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_text: assertion `layout != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_attributes: assertion `layout != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_alignment: assertion `layout != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_ellipsize: assertion `PANGO_IS_LAYOUT (layout)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_single_paragraph_mode: assertion `PANGO_IS_LAYOUT (layout)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_set_width: assertion `layout != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: PangoWarning: pango_layout_get_extents: assertion `layout != NULL' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: gtk_icon_size_lookup_for_settings: assertion `GTK_IS_SETTINGS (settings)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: Invalid icon size 4

  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
/usr/sbin/ndisgtk:89: GtkWarning: gtk_icon_theme_load_icon: assertion `GTK_IS_ICON_THEME (icon_theme)' failed
  self.widgets = gtk.glade.XML(DATA_DIR + "/ndisgtk.glade", domain="ndisgtk")
Segmentatiefout (core dumped)
root@tux:~#

In het menu staat dit als commando:
kdesu /usr/sbin/ndisgtk --kde
De kdesu en --kde heb ik eraf gehaald daar ik hem via de console wilde uitvoeren en ik zorgde ervoor dat ik het commando uitvoerde als root.

Wat doe ik niet goed? Of ligt het niet aan mij?