Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem bij upgraden van 7.04 naar 7.10  (gelezen 1470 keer)

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Gepost op: 2007/11/22, 21:44:21 »
Reeds enkele maanden probeer ik van windows om te schakelen naar ubuntu, hiervoor gebruik ik een dual-boot. Alles stond na veel gesukkel en herinstallaties eindelijk ongeveer goed voor mijn dagelijks gebruik.

Wanneer ik wil upgraden naar Gutsy krijg ik bij het heropstarten ongeveer de volgende melding:

Kernel panic - not syncing: IO-APIC + timer doesn't work! Try using the 'noapic' kernel parameter

Ik heb dus gedaan wat er gesuggereerd wordt zonder resultaat, vervolgen las ik ergens noapic te vervangen door acpi=off.
Tot mijn groot plezier bleek dit te werken, hoewel ik niet begreep waarom. Helaas wanneer de na-installatie voltooid was en kon ik niet meer afsluiten een probleem met Networkmanager geloof ik.

Installatie met de CD geeft hetzelfde probleem, feisty daarentegen geeft totaal geen problemen bij herinstallatie.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
probleem bij upgraden van 7.04 naar 7.10
« Reactie #1 Gepost op: 2007/11/22, 22:51:49 »
Er zijn een paar mogelijkheden, om met een oude BIOS te werken:
noacpi, acpi=off en acpi=force.
Mischien kan je een andere optie proberen, en hier vertellen of het werkt, dan leren wij ook weer iets ;)
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

JimZ

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #2 Gepost op: 2007/11/23, 00:48:09 »
't Is noapic toch......?

Gr,
Jim

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #3 Gepost op: 2007/11/23, 15:35:58 »
bedankt voor de reactie,

noapic geeft uiteindelijk een zwart scherm met een pinkent streepje in de linkerbovenhoek, misschien moet ik wat meer geduld hebben, maar het duurt toch wel erg lang.

acpi=force heeft geen invloed

Het meeste ben ik dus met acpi=off, maar zoals ik als zei kan ik dan mijn systeem niet meer afsluiten. Misschien is daar dan weer een oplossing voor. Ik heb al gezocht en ik moest ergens iets in de broncode van de networkmanager  veranderen, mooi begeleid, maar blijkbaar lag daar het probleem net iets anders en was door de aanpassing een ernstige fout opgetreden. Ik moet wel toegeven dat ik heb geprutst.

Hetzelfde probleem doet zich voor wanneer ik suse 10.3 probeer te installeren.

Misschien is het irrelevant maar wanneer ik feisty opstart krijg ik kort ongeveer de melding ...not connected to IQ-APIC...maar alles verloopt verder goed.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
probleem bij upgraden van 7.04 naar 7.10
« Reactie #4 Gepost op: 2007/11/23, 15:44:25 »
Gebeurt er precies hetzelfde als je opstart van een 7.10 live cd?
Als het daarmee wel goed gaat, dan is er misschien iets niet helemaal goed gegaan met de upgrade van 7.04->7.10

Je kan trouwens ook nog de volgende optie proberen:
noapic nolapic

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #5 Gepost op: 2007/11/23, 16:26:14 »
Ik probeer nu steeds vanop de live CD, aangezien het upgraden tot tweemaal toe hetzelfde probleem gaf.

noapic nolapic geeft hetzelfde als noapic (zwart scherm met pinkend streepje)

Bij opstarten van feisty krijg ik dus kort op het scherm:... timer doesn't work...not connected te IQ-APIC...(ik krijg niet echt de tijd om het op te schrijven vandaar ...) maar mijnen kernel schiet niet in paniek :lol:. Maar aangezien het gelijkaardig is als wat er uiteindelijk op mijn scherm verschijnt bij installatie van Gutsy, denk ik dat het er iets mee te maken heeft.

groetjes,

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
probleem bij upgraden van 7.04 naar 7.10
« Reactie #6 Gepost op: 2007/11/23, 16:53:20 »
Welke onderdelen zitten er in je computer?
Vooral het moederbord is belangrijk.

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #7 Gepost op: 2007/11/23, 19:02:02 »
HP Pavilion 061
Intel(R) Pentium(R) 4 CPU 3.20GHz
moederbord  Asterope RC410-M REV:1.01

schijf windows
description: SCSI Disk
  product: ST3200826AS
   vendor: ATA

schijf ubuntu
 description: ATA Disk
  product: MAXTOR STM3320820A
   vendor: Maxtor

Ik heb iets ander geprobeerd en opgestart met de parameters acpi=off pci=noacpi. Dit geeft hetzelfde als acpi=off, alles is geherinstalleerd en werkt. Ik kan heropstarten zonder problemen, helaas uitzetten gaat niet. Op het moment dat de pc zou moeten uitvallen krijg ik een hoop tekst met als laatste regel:

NetworkManager: nm_hal_deinit(): libhal shutdown failed - Connection is
closed

NetworkManager: nm_dbus_signal_device_status_change: assertion `cb_data->data->d
bus_connection' failed
NetworkManager: nm_dbus_signal_device_status_change: assertion `cb_data->data->d
bus_connection' failed

ik heb er geen idee van wat het zou kunnen betekenen

groetjes

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #8 Gepost op: 2007/11/24, 21:29:48 »
Ben echt ten einde raad,op sommige site wordt er gezegd dat het zou te maken hebben met een bug in NetworkManager. Bij anderen moest er iets veranderd worden aan #end default files#.
Het punt is dat alles geinstalleert geraakt met acpi=off, maar je kan toch moeilijk met een systeem blijven werken die niet deftig afsluit.

Uiteindelijk wou ik dan maar Opensuse10.3 eens verkennen, maar tot overmaat van ramp krijg ik de installatie niet draaiende, met de parameters acpi=off lukt het ook hier weer, maar bij het heropstarten geraak ik niet verder dan een zwart scherm, 10.2 idem dito. Wat doe ik toch verkeert? Feisty installatie doe ik ondertussen blindelings (bij al het zoekwerk heb ik mijn systeem de laatste drie dagen een 10 tal keer geinstalleerd) en sluit wel behoorlijk af.

We zoeken verder, als iemand een hint kan geven of een overzichtje van de mogelijke bootoptions.
Alvast bedankt,

groetjes

Offline Ubert

  • Lid
  • Steunpunt: Nee
probleem bij upgraden van 7.04 naar 7.10
« Reactie #9 Gepost op: 2007/11/24, 22:09:59 »
Installatie met de CD geeft hetzelfde probleem, feisty daarentegen geeft totaal geen problemen bij herinstallatie.  Ik denk dat je de gutsy cd bedoelt? Wat ik zou doen is ff een alternate cd branden. En als dat ook niet werkt een keer kubuntu branden.

JimZ

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #10 Gepost op: 2007/11/24, 22:45:10 »
Die network foutmeldingen zie ik ook voorbijkomen tijdens het afsluiten.

Niettemin draait de boel perfect en ook "Powerdown" werkt vlekkeloos bij mij dus die meldingen zijn denk ik niet de oorzaak daarvan.

Maar er zijn wel meer verhalen over dit probleem te vinden, blijkbaar wordt het veroorzaakt door een slordig geprogrammeerd BIOS dat dus niet aan de specificatie voldoet.

Je zou het volgende nog kunnen proberen:

Open een terminal en type:
gksudo gedit /etc/modulesen voeg onderaan de volgende regel toe:
apm power_off=1Sla het bestand op en sluit Gedit af en probeer het na een herstart van de pc nog eens.

de toevoeging "acpi=off" zou ik overigens wel laten staan in je menu.lst.

Gr,
Jim

loki

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #11 Gepost op: 2007/11/24, 23:12:14 »
:D apm power_off=1 :D blijkt de juiste toverformule!!! ( en natuurlijk acpi=off)

Ik had dit al eens geprobeerd maar toen niet herstart en mijn settings achteraf goedgezet. Niet zo slim dus, nu te hopen dat het mooi blijft afsluiten en ik niet te vroeg victorie kraai.

Nu de netwerkfoutmeldingen zijn toch weg, maar ik snap het allemaal nog niet goed wat nu eigenlijk het probleem was/is.

In ieder geval moet ik jullie echt bedanken, ik zat hier al een tijdje mee te sukkelen.

Groetjes

JimZ

  • Gast
probleem bij upgraden van 7.04 naar 7.10
« Reactie #12 Gepost op: 2007/11/24, 23:46:07 »
Citaat
apm power_off=1 blijkt de juiste toverformule!!!
Mooi zo !

En bedankt voor het melden natuurlijk :) .

Gr,
Jim