Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet  (gelezen 4830 keer)

Gast

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Gepost op: 2006/06/18, 16:36:07 »
Ik heb Ubuntu geinstalleerd op me AMD 64 x2 met ati videokaart. Werkte allemaal goed, totdat ik de driver voor met videokaart ging installeren aangezien ik geen games kon spelen. Na dit gedaan te hebben en gereboot blijft het systeem hangen wanneer de driver voor de videokaart wordt opgestart, krijg dan de melding "X-server is now disabled, restart GDM when it is configured correctly" en dan start ie op in text-modus. Heb al verschillende kere geprobeerd de driver te herconfigureren en te herinstalleren. Maar niks helpt.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #1 Gepost op: 2006/06/18, 16:57:45 »
Zit de oplossing hier?
https://launchpad.net/distros/ubuntu/+source/gdm/+bug/29055

In uw terminal dit invoeren:
apt-get --reinstall upgrade

En anders:
sudo dpkg-reconfigure xserver-xorg  om x11 terug te reconfigureren
sudo dpkg-reconfigure gdm              om gdm terug te reconfigureren
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Gast

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #2 Gepost op: 2006/06/18, 17:17:16 »
In uw terminal dit invoeren:
apt-get --reinstall upgrade

Werkt niet, geeft geen effect

sudo dpkg-reconfigure xserver-xorg  
Ook gedaan geeft ook geen effect

sudo dpkg-reconfigure gdm
Zegt dat hij het herlaadt, dan stopt hij er mee en zegt ie het te configureren wanneer alle x-services gestopt zijn. maar heeft ook geen effect

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #3 Gepost op: 2006/06/18, 17:33:10 »
Zou moeten werken met fglrx.
Volg eens dit:
https://wiki.ubuntu.com/BinaryDriverHowto/ATI

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #4 Gepost op: 2006/06/18, 17:45:14 »
Lazlo, laat anders alle lijnen met "(EE)" in het Xorg logbestand eens zien:

commando:
cat /var/log/Xorg.0.log|grep "(EE)"
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Gast

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #5 Gepost op: 2006/06/18, 19:11:22 »
Citaat van: profoX
Lazlo, laat anders alle lijnen met "(EE)" in het Xorg logbestand eens zien:

commando:
cat /var/log/Xorg.0.log|grep "(EE)"
Hij schijnt dat log bestand niet te kunnen vinden..

Heb me driver geinstallerd dmv easy ubuntu, daarna kwam ik alleen nog maar de commandline binnen.

Gast

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #6 Gepost op: 2006/06/18, 19:17:29 »
Citaat van: zappa
Zou moeten werken met fglrx.
Volg eens dit:
https://wiki.ubuntu.com/BinaryDriverHowto/ATI
Then you need to manually edit the xorg.conf file. So:

sudo gedit /etc/X11/xorg.conf

Wanneer ik die stap wl doen krijg ik de melding: cannot open display: (null)

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #7 Gepost op: 2006/06/18, 19:24:58 »
Zit die pagina wel in je pc?
Kan je ze terugvinden door te bladeren naar die map?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Gast

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #8 Gepost op: 2006/06/18, 19:30:07 »
mm kan ie ook niet vinden
volgens mij komt het door easy ubuntu, deze gaf wel een mogelijkheid om een backup terug te zetten maar deze werkt niet;

sudo cp/etc/X11/xorg.conf_backup/etc/X11/xorg.conf

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #9 Gepost op: 2006/06/18, 19:35:33 »
shit man, hoe kan dat ...
Doe eens cd /etc/X11 in uw terminal
en dan ls
geef de uitvoer daar eens van
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #10 Gepost op: 2006/06/18, 19:54:33 »
Anders eerst X herinstalleren.
sudo dpkg xserver-xorg-core --reinstall

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #11 Gepost op: 2006/06/18, 20:11:32 »
Heb maar gewoon een clean install gedaan, werkte allemaal niet. Heb er wel wat van geleerd: gebruik geen easy ubuntu om tijd te winnen, kost alleen maar meer tijd.

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #12 Gepost op: 2006/06/18, 20:23:40 »
Nu doe ik het dus handmatig  Volgens de help van ubuntu.com moet ik voor 3d dit installeren:

Video driver for ATI graphics accelerators
Video driver for the ATI Radeon and FireGL graphics accelerators.

This version of the ATI driver officially supports:
 * ATI Radeon 8500, 9000, 9100, 9200, 9250 (R2xx)
 * ATI Radeon 9500, 9550, 9600, 9700, 9800, X300, X400, X600 (R3xx)
 * ATI Radeon X700, X800 (R4xx)
 * ATI Mobility 9000, 9600, 9800
 * ATI FireGL 8700, 8800, E1, E2, X1, X2, X3, Z1, T2, 5100, 7100, 7200
 * ATI Mobility FireGL 9000, T2, T2e

This package provides 2D display drivers and hardware accelerated OpenGL.

Alleen hier staat mijn videokaart niet tussen en hiermee doe ik hetzelfde als easy ubuntu.

Als ik dit niet doe, kunnen er dan wel gewoon games op de pc worden gespeeld, zoals Enemy Territory.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #13 Gepost op: 2006/06/18, 20:26:15 »
Werkt alles naar behoren op je pc? Werken de screensavers goed?
Dan zie ik geen reden waarom je die andere driver moet installeren.
Probeer 't spel eens en als 't goed werkt zou ik er vanaf blijven.
;)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #14 Gepost op: 2006/06/18, 20:31:51 »
Volgens mij doen er wel redelijk wat screensavers het niet, ze geven in ieder geval geen voorbeeld. Dit is verder niet zo een groot probleem want ik gebruik ze toch niet echt.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #15 Gepost op: 2006/06/18, 21:01:20 »
Als uw bewegende screensavers het niet doen vrees ik dat het spel ook niet vlot zal draaien.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #16 Gepost op: 2006/06/18, 22:33:36 »
Volg dit maar:
https://wiki.ubuntu.com/BinaryDriverHowto/ATI

fglrx is de driver van ATI zelf. Dan heb je hardware acceleration. Je kan dit testen door fglrxinfo in de terminal: Als je ati of radeon ipv mesa ziet is het OK :) Bovendien zal het dan automatisch mee updaten (groooooot voordeel)

Wat bedoel je met 3d? compiz en xgl of het 3ddesktop pakket? Ze zijn beide buggy (trust me :)), maar die laatste zeker...

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #17 Gepost op: 2006/06/19, 07:58:02 »
Citaat van: zappa
Volg dit maar:
https://wiki.ubuntu.com/BinaryDriverHowto/ATI

fglrx is de driver van ATI zelf. Dan heb je hardware acceleration. Je kan dit testen door fglrxinfo in de terminal: Als je ati of radeon ipv mesa ziet is het OK :) Bovendien zal het dan automatisch mee updaten (groooooot voordeel)

Wat bedoel je met 3d? compiz en xgl of het 3ddesktop pakket? Ze zijn beide buggy (trust me :)), maar die laatste zeker...
Heb im gedaan, maar nu ben ik weer terug bij af, na booten gaat ie weer naar commandline. Wanneer ik het configuratie bestand aan wil passen en te kijken of alles wel goed stond krijg ik dit:(sudo aticonfig --initial)

Uninitialised file found configuring
Using etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0



Maar hij geeft niet eerst de foutmelding dat ie de driver heeft uitgeschakeld.

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #18 Gepost op: 2006/06/19, 10:13:30 »
Kan ik geen andere driver gebruiken, die fglrx heb ik nog nergens een bericht van gehoord dat ie werkt met mijn videokaart...

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #19 Gepost op: 2006/06/19, 11:26:58 »
Ik vind het niet meteen of het kan of niet... Maar naar mijn weten, indien fglrx niet werkt, zal je geen drivers vinden die sneller zijn dan mesa... Maar de documentatie van de link, eronder onder Breezy is ook goed, Dat is namelijk wat die commando's in Dapper doen. In uw geval lijkt het mij interessant om het eens op de tweede manier te doen om te zien wat er misgaat. Als je het zo forceert om fglrx te gebruiken, en het werkt niet, wel ja, dan weet je het tenminste zeker.

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #20 Gepost op: 2006/06/19, 12:01:25 »
ATI heeft toch zelf ook linux drivers, waarom kan ik die dan niet beter gebruiken?

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #21 Gepost op: 2006/06/19, 12:07:15 »
Dat is fglrx :(
OK, misschien is de versie van ati.com iets recenter, maar dat zla het verschil niet maken.

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #22 Gepost op: 2006/06/19, 12:09:05 »
Heb dus vanaf een geheel clean systeem, alle multiemedia codes, programma's, netwerk en dingen die ik erop wil hebben erop staan. Heb nog helemaal nik qua drivers geinstalleerd, kan nu wel gewoon op goede kwaliteit mpeg afspelen.

Nu heb ik als test TuxRacer (PlanetPenguin) geinstalleerd, deze doet het niet, klik hem aan maar start niet op verder. Weet trouwens niet of deze wel werkt met amd 64, heb hem geinstalleerd volgens de help guide van ubuntu onder games.

http://tweakers.net/meuktracker/12720

Als het goed is is dit dezelfde als fglrx die op de servers staat

Lazlo

  • Gast
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #23 Gepost op: 2006/06/19, 12:43:25 »
Mm, schijnt nu gelukt te zijn, heb gereboot en hij start goed op.

Het eerste ging goed, hij heeft de goede driver:
    lazlo@lazlo-desktop:~$ sudo aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.
Hier gaat iets niet goed, geen idee wat.
    lazlo@lazlo-desktop:~$ sudo aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-1
lazlo@lazlo-desktop:~$
Wanner ik kijk of alles werkt dmv fglrxinfo krijg ik dit:

    lazlo@lazlo-desktop:~$ fglrxinfo
Error: couldn't find RGB GLX visual!
Dit is me xorg.conf file:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier     "Default Layout"
Screen      0  "aticonfig-Screen[0]" 0 0
InputDevice    "Generic Keyboard"
InputDevice    "Configured Mouse"
InputDevice    "stylus" "SendCoreEvents"
InputDevice    "cursor" "SendCoreEvents"
InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath     "/usr/share/X11/fonts/misc"
FontPath     "/usr/share/X11/fonts/cyrillic"
FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/Type1"
FontPath     "/usr/share/X11/fonts/100dpi"
FontPath     "/usr/share/X11/fonts/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load  "i2c"
Load  "bitmap"
Load  "ddc"
Load  "dri"
Load  "extmod"
Load  "freetype"
Load  "glx"
Load  "int10"
Load  "type1"
Load  "vbe"
EndSection

Section "InputDevice"
Identifier  "Generic Keyboard"
Driver      "kbd"
Option    "CoreKeyboard"
Option    "XkbRules" "xorg"
Option    "XkbModel" "pc104"
Option    "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier  "Configured Mouse"
Driver      "mouse"
Option    "CorePointer"
Option    "Device" "/dev/input/mice"
Option    "Protocol" "ExplorerPS/2"
Option    "ZAxisMapping" "4 5"
Option    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "stylus"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "stylus"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "eraser"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "eraser"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "cursor"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "cursor"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier   "H782B"
Option    "DPMS"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]"
Option    "VendorName" "ATI Proprietary Driver"
Option    "ModelName" "Generic Autodetecting Monitor"
Option    "DPMS" "true"
EndSection

Section "Device"
Identifier  "ATI Technologies, Inc. ATI Default Card"
Driver      "vesa"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]"
Driver      "fglrx"
Option    "VideoOverlay" "on"
Option    "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device     "ATI Technologies, Inc. ATI Default Card"
Monitor    "H782B"
DefaultDepth     24
SubSection "Display"
Depth     1
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth     4
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth     8
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth     15
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth     16
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth     24
Modes    "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device     "aticonfig-Device[0]"
Monitor    "aticonfig-Monitor[0]"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "DRI"
Mode         0666
EndSection

Offline ptb

  • Lid
  • Steunpunt: Nee
Ubuntu met ATI RADEON EAX1300PRO Silent werkt niet
« Reactie #24 Gepost op: 2006/06/19, 13:19:40 »
Volgens mij is de fglrx driver nog niet geschikt voor de X1x00 (= R5xx) serie videokaarten.
de nieuwste Ati driver heeft die ondersteuning al wel.
Ik heb zelf ook AMD 64 met een X1600 videokaart, dus ik wacht op de fglrx driver