Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Tekstweergave Firefox  (gelezen 5196 keer)

JimZ

  • Gast
Tekstweergave Firefox
« Gepost op: 2007/11/20, 21:52:39 »
Dit "probleempje" heb ik al zolang ik met Ubuntu in de weer ben, dus Dapper, Feisty en nu Gutsy (32- en 64 bit).

Op sommige websites wordt de tekst blijkbaar niet goed afgekapt maar loopt door de tekst op de volgende regel heen. Zie screenshot:


(rechtsklik voor een duidelijker beeld svp).

maar een oplossing heb ik nog nooit kunnen vinden.

Iemand op dit forum die mogelijk de oplossing weet? Zou fijn zijn, want het is eigenlijk nog het enige schoonheidsfoutje in een verder fijn systeem.

Gr,
Jim

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #1 Gepost op: 2007/11/20, 22:04:44 »
Fout vervaardigde webstek. Ik heb het bij die webstek ook. Niet te geloven, dat beroepscomputeraars als de lui van PCM, zich niet houden aan de standaarden voor webontwerp zoals het World Wide Web Consortium (W3C) die heeft vastgesteld.

Haal die webstek maar eens door de online validator die het W3C ter beschikking stelt, en huiver van de uitkomst: http://validator.w3.org/

Ik doe het zelf maar even gelijk:
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.pcmweb.nl%2Fnieuwsoverzicht.jsp&charset=%28detect+automatically%29&doctype=Inline&group=0

20 fouten! Op die pagina alleen al! Tijd voor een e-mail naar PCM?

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #2 Gepost op: 2007/11/20, 22:09:20 »
Kan de fout reproduceren als ik bij deweergave kies voor grotere lettertekens.
Ondertussen kan JimZ wel eens proberen met Beeld-->Tekstgrootte-->normaal
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #3 Gepost op: 2007/11/20, 22:41:47 »
pjotr:
Is ongetwijfeld waar, ik heb het op meerdere websites en die deugen ook niet volgens W3C. Maar blijft wel overeind dat in Firefox onder (durf het bijna niet te zeggen...) Windows (XP+Vista) het probleem niet speelt.

En de rendering engine van FF is toch in beide gevallen hetzelfde zou je zeggen.

Prosper:
Helaas, helaas, de tekstgrootte staat in alle gevallen alreeds op "normaal", ik kan het wel oplossen door die te verkleinen maar dan heb je wel een borduurloep of zo nodig om het nog te kunnen lezen.

Gr,
Jim

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #4 Gepost op: 2007/11/21, 07:04:59 »
Hier effe een screenshot van mijn instellingen in Bewerken-->Voorkeuren-->Geavanceerd.
Het is natuurlijk niet zeker dat die ook bij jou het gewenste resultaat zullen geven, maar dan heb je een vergelijkingspunt. Dit zijn bij mij de "normale" instellingen.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #5 Gepost op: 2007/11/21, 12:02:41 »
Ik zit heel veel op PCM website maar heb dat probleem absoluut niet en heb ook niks speziaals ingesteld.
Grtz Tom.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Marrinty

  • Gast
Tekstweergave Firefox
« Reactie #6 Gepost op: 2007/11/21, 14:00:35 »
Ik gebruik deze website ook al enige tijd en heb hier ook nog geen problemen met ondervonden. (Ik maak wel gebruik van Opera)

Heb het ook maar even uitgetest bij Firefox en heb ook geen problemen ondervonden.

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #7 Gepost op: 2007/11/21, 14:29:13 »
Allereerst iedereen hartelijk bedankt voor het meedenken tot zover :).

Helaas lossen de door Prosper gegeven instellingen het probleem niet op. Het enige dat bij mij anders stond was "Minimale lettergrootte" daar staat bij mij "13" i.p.v. "Geen".

En als ik dat verander worden de betreffende letters op die PCM-site wat kleiner en lopen ze dus iets minder veel door elkaar, maar door elkaar lopen blijven ze.

Wat mij dan ook zo verbaast is dat sommigen (pjotr o.a.) er ook last van hebben en anderen weer niet en dat het bij mij dus al tijden geheel automatisch fout gaat in alle distro's, zelfs SuSE 10.3 en Fedora 7 doen hetzelfde.

Maar terwijl ik dit schrijf bedenk ik me wel dat ik al tijdenlang alle instellingen van FF (en TB) na een verse install gewoon oversleep van de ene naar de andere installatie en daarmee dus ook de evt. fouten, dus dat laatste is dan wel weer een beetje logisch.

Gr,
Jim

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #8 Gepost op: 2007/11/21, 14:38:20 »
Citaat van: JimZ
Allereerst iedereen hartelijk bedankt voor het meedenken tot zover :).

Helaas lossen de door Prosper gegeven instellingen het probleem niet op. Het enige dat bij mij anders stond was "Minimale lettergrootte" daar staat bij mij "13" i.p.v. "Geen".

En als ik dat verander worden de betreffende letters op die PCM-site wat kleiner en lopen ze dus iets minder veel door elkaar, maar door elkaar lopen blijven ze.

Wat mij dan ook zo verbaast is dat sommigen (pjotr o.a.) er ook last van hebben en anderen weer niet en dat het bij mij dus al tijden geheel automatisch fout gaat in alle distro's, zelfs SuSE 10.3 en Fedora 7 doen hetzelfde.

Maar terwijl ik dit schrijf bedenk ik me wel dat ik al tijdenlang alle instellingen van FF (en TB) na een verse install gewoon oversleep van de ene naar de andere installatie en daarmee dus ook de evt. fouten, dus dat laatste is dan wel weer een beetje logisch.

Gr,
Jim
Dan gooi Firefox er af en herinstal Firefox ,  dan weer een beetje werk voor uw bladwijzers en wat addons maar dan bent U gerust.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #9 Gepost op: 2007/11/21, 18:05:42 »
Nou, behalve de bladwijzers en addons zijn er ook nog een hele rits wachtwoorden en bewust opgeslagen cookies en die laatste twee zet je voor zover ik weet niet zomaar even over.

Maar als ik het echt zat word dan is een herinstall natuurlijk inderdaad een optie. Maar handiger is dan misschien om even een tweede account aan te maken en te kijken wat FF daarin dan doet want daarmee zet je tenslotte ook alle instellingen weer terug naar standaard.

Enfin, ik zie wel.

Gr,
Jim

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #10 Gepost op: 2007/11/21, 19:07:56 »
Ik denk dat het probleem zit in de minimale lettergrootte, Jim. Bij mij staat die op 12, bij jou op 13. Ik heb dus enigszins een probleem op die webstek, maar jij nog meer. De letters van het menu worden te groot.

Probeer eens de minimale lettergrootte terug te zetten op de standaard "geen", en installeer de add-on No Squint eens? Daarmee kun je lettertypen per webstek "blijvend" vergroten/verkleinen. Niet-blijvend kan natuurlijk altijd, door de Ctrl-toets ingedrukt te houden en een paar keer op de plustoets (+) te meppen.

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #11 Gepost op: 2007/11/21, 22:33:24 »
Bedankt voor de tip pjotr, maar ik schreef twee postjes terug:
Citaat
Helaas lossen de door Prosper gegeven instellingen het probleem niet op. Het enige dat bij mij anders stond was "Minimale lettergrootte" daar staat bij mij "13" i.p.v. "Geen".

En als ik dat verander worden de betreffende letters op die PCM-site wat kleiner en lopen ze dus iets minder veel door elkaar, maar door elkaar lopen blijven ze.
Duzzzz...... ;) .

En als ik ze zover verklein dat het niet doorloopt dan heb ik dus de in m'n tweede postje al aangehaalde borduurloep weer nodig :( .

Voorlopig leer ik er maar mee leven denk ik.

Gr,
Jim

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #12 Gepost op: 2007/11/21, 22:56:01 »
En nog even ter aanvulling:

Dezelfde pagina in FF onder XP:



Jim

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #13 Gepost op: 2007/11/21, 23:26:24 »
Nou, ook nog even de msttcorefonts geïnstalleerd en met:
dpkg-reconfigure x-ttcidfont-confgeconfigureerd en vervolgens de instellingen uit Firefox-XP exact overgenomen in Firefox-Gutsy maar helaas, probleem blijft hardnekking hetzelfde.

Gr,
Jim

Bandicoot

  • Gast
Tekstweergave Firefox
« Reactie #14 Gepost op: 2007/11/22, 00:03:49 »
Zo ziet de site bij mij er uit in firefox ( ik gebruik Gutsy) .




(Als het plaatje geladen is er nog wel even op klikken om hem op volle grootte te zien)

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #15 Gepost op: 2007/11/22, 00:09:24 »
Ja, dat lukt mij ook, maar dat bedoel ik dus met "kleine lettertjes" en die al vaker genoemde loup die je dan nodig hebt.

Zal wel aan de leeftijd van m'n ogen liggen, die zijn namelijk net zo oud als ik ;) .

Tja.......

Gr,
Jim

Bandicoot

  • Gast
Tekstweergave Firefox
« Reactie #16 Gepost op: 2007/11/22, 00:26:46 »
Ik weet niet of je persé Firefox wilt gebruiken maar misschien is Opera een alternatief ?? Zo ziet de pagina er bij mij uit in Opera:



In opera kunnen de letters zlefs nog groter zonder dat er een doorloop is, Opera heeft namelijk een optie fit to width  , hij maakt dan de pagina automatisch breder als er een doorloop is.

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #17 Gepost op: 2007/11/22, 00:52:32 »
Ziet er inderdaad goed uit ja.

Maar ik "hang" inderdaad nogal aan FF omdat ik handmatig de configuratie heb aangepast zodat ik in al m'n systemen (Winxp, Vista, Gutsy32, Gutsy64, Fedora en SuSE) steeds hetzelfde bookmarkbestand te zien krijg.

Da's handig want anders blijf je im- en exporteren en wordt de zaak al gauw verschrikkelijk onoverzichtelijk.

Nou zal zoiets ook wel kunnen in Opera maar dat wordt dan wel een MEGA-onderneming.

Maar bedankt voor de hint, misschien iets voor de komende lange winteravonden.

Gr,
Jim

Bandicoot

  • Gast
Tekstweergave Firefox
« Reactie #18 Gepost op: 2007/12/01, 22:49:03 »
Ik heb inmiddels geen last meer van de te kleine letters in Firefox en dus ook niet van de tekstdoorloop. Onderstaand screenshot heb ik gemaakt in Firefox (onder Ubuntu) Heb geen minimale fontgrootte aanstaan in Firefox. Is me gelukt doordat ik over het algemeen niet tevreden was over de font en ik via een howto mijn fonts het "windows" uiterlijk heb gegeven. Ben benieuwd of je ze noch steeds te klein vind zo ( alleen ff op de pagina letten, dat mijn letters in de balk en het menu zo klein zijn is mijn eigen keuze)


JimZ

  • Gast
Tekstweergave Firefox
« Reactie #19 Gepost op: 2007/12/01, 22:59:52 »
Zier er inderdaad goed uit ja.

Maarre...... die HowTo waar je het over hebt, is die geheim of zo? :(

Gr,
Jim

Bandicoot

  • Gast
Tekstweergave Firefox
« Reactie #20 Gepost op: 2007/12/01, 23:09:04 »
ha ha nee hoor. www.sharpfonts.com . Wat trouwens ook nog de moeite is: FF detecteerd je DPI settings niet goed , in about:config moet je de waarde van : layout.css.dpi  aanpassen en op 0 zetten (staat standaard op -1). Wel ff checken of je DPI settings door xorg goed gedetecteerd worden .. Heb een 19 inch TFT en had mijn fonts op 96 DPI staan , het bleek echter dat middels : edensal@Gutsy-desktop:~$ xdpyinfo | grep resolution
resolution: 85x86 dots per inch    ik deze waarde kreeg, heb toen maar xorg een gedwongen DPI setting van 96x96 opgegeven en dat scheelde een hoop.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #21 Gepost op: 2007/12/01, 23:27:04 »
U heeft toch Java aangevinkt.
U heeft toch javascript aan.
Tekstgroote normaal.
Paginastijl Bassis.
Tekenset Unicode (utf8)
Zo staat dus alles bij mij en ik heb hem dus zeer duidelijk.
Grtz Tom.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

JimZ

  • Gast
Tekstweergave Firefox
« Reactie #22 Gepost op: 2007/12/02, 18:14:42 »
bandicoot schreef:
Citaat
www.sharpfonts.com
Maar dat had ik dus al gedaan, zie DIT postje.

Maar die layout.css.dpi van FF zal ik even aanpassen. Kijken of dat helpt.

wandarooze:
1. Ja
2. Ja
3. Ja
4. Ja
5. Stond op Westers (ISO-8859-1), nu verzet naar Unicode (UTF-8) maar ik zie eerlijk gezegd geen enkel verschil.

Gr,
Jim

EDIT:

en helaas geldt datzelfde voor die layout.css.dpi setting in FF.

J.

Bandicoot

  • Gast
Tekstweergave Firefox
« Reactie #23 Gepost op: 2007/12/02, 19:25:49 »
Ik zie in betreffende post alleen maar dat je de mscorefonts hebt geïnstalleerd , niet dat je ook de rest hebt gedaan, dwz het installeren van het XML bestand.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Tekstweergave Firefox
« Reactie #24 Gepost op: 2007/12/02, 20:13:51 »
Citaat van: Bandicoot
Ik zie in betreffende post alleen maar dat je de mscorefonts hebt geïnstalleerd , niet dat je ook de rest hebt gedaan, dwz het installeren van het XML bestand.
Bij mij staat xml core aan (te vinden via synaptic pakket beheer).
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.4 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.