Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Desktop start niet goed op  (gelezen 2777 keer)

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Gepost op: 2007/11/16, 16:52:03 »
Op dit moment moet ik de computer twee keer opstarten om te kunnen werken. De eerste keer verschijnen wel de werkbalken maar er mist een groot deel van de informatie. Daarbij kan ik ook niet de computer afsluiten en laten herstarten via de knop. Herstarten via Ctrl-Alt-Backspace levert op dat ik alleen nog maar een volledig lege desktop heb waarbij ook de werkbalken niet meer verschijnen. Herstarten via de reset-knop levert wel het gewenste resultaat.

Het opstarten via ctrl-F1 levert, zo te zien, geen fouten op bij het opstarten. Dus lijkt het erop dat Gnome niet goed opstart. Iemand een idee hoe ik dit kan oplossen? Kan ik de gnome configuratie opnieuw bouwen? Of zo?
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #1 Gepost op: 2007/11/16, 16:58:23 »
Staan er relevante foutmeldingen in ~/.xsession-errors of in /var/log/ ?
Heb je al geprobeerd om in het inlogmenu bij sessies een andere sessie te kiezen?

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #2 Gepost op: 2007/11/16, 17:20:16 »
Waar vind ik xsession error log Sorry al gevonden, bekijk hem nu... Daar staat in:
(process:5410): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.

(process:5414): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
/etc/gdm/Xsession: Beginning session setup...
SESSION_MANAGER=local/Hoofdcomputer:/tmp/.ICE-unix/5407
Windowmanager waarschuwing: Lezen van opgeslagen sessiebestand /home/joop/.metacity/sessions/default0.ms mislukt: Openen van bestand ‘/home/joop/.metacity/sessions/default0.ms’ is mislukt: Bestand of map bestaat niet

(gnome-panel:5488): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 24
Initializing gnome-mount extension
** Message: Opstarten van bureaublad-op-afstand server
Niet in staat om bureaublad-bestand /usr/share/applications/mozilla-thunderbird.desktop voor paneelstarter : Bestand of map bestaat niet te openen
no suitable application
En ik heb ook al eens een nieuwe sessie opgestart, in dit geval via Ctrl-Alt-Del niet de vorige sessie maar een gnome sessie. Dit levert ook een volledig, op een gele kleur na, leeg scherm op.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #3 Gepost op: 2007/11/17, 21:20:51 »
Iemand een idee hoe ik een oplossing kan vinden?
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Desktop start niet goed op
« Reactie #4 Gepost op: 2007/11/17, 23:10:01 »
Krijg je geen foutmelding bij het inloggen? Dit betekend dat je /home niet beschikbaar is. Ik kan me hierin drie dingen voorstellen. Dat je /home is verwijderd (staat dat op een aparte partitie?), dat /home verkeert staat aangegeven of dat de rechten voor /home verkeert staan. Daarvoor zul je /etc/fstab moeten posten en de schijfen die je hebt (de inhoud van fstab /dev/hda (of /dev/sda als dat de eerste schijf is)). En in een terminal (eventueel in recovery modus) "cd /home" "ls -l".  Post ook daar de inhoud van, wanneer /home niet bereikbaar is laat dat dan ook weten!

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #5 Gepost op: 2007/11/18, 00:55:21 »
De /home staat op mijn partitie met root.
ls -l levert op:
joop@Hoofdcomputer:~$ cd /home
joop@Hoofdcomputer:/home$ ls -l
totaal 8
drwxr-xr-x 34 geertje users 4096 2007-11-04 00:50 geertje
drwxr-xr-x 80 joop    joop  4096 2007-11-17 23:26 joop
joop@Hoofdcomputer:/home$
Mijn etc/fstab ziet er zo uit:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/hdb3
UUID=7b43b74f-153e-432d-8d72-26fb8d0436e5 /               ext3    defaults,errors=remount-ro 0       0
# /dev/hda1
UUID=b02af126-4d02-49a1-9cfb-8d8ee0c4cc96 /media/hda1     reiserfs defaults        0       0
# /dev/hda3
UUID=3B3F-1B0A  /media/hda3     vfat    defaults,utf8,umask=007,gid=46 0       0
# /dev/hdb1
UUID=4670-0116  /media/hdb1     vfat    defaults,utf8,umask=007,gid=46 0       0
# /dev/hdb2
UUID=4670-01B6  /media/hdb2     vfat    defaults,utf8,umask=007,gid=46 0       0
# /dev/hda2
UUID=8521ffae-4d47-47a9-89e0-7a92b7f69fa8 none            swap    sw              0       0
# /dev/hdb4
UUID=179b8466-ffea-4237-b92a-e8b33472b19a none            swap    sw              0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/hdc        /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
Maar het vreemde blijft dat bij de tweede keer opstarten het probleem verdwenen is.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Desktop start niet goed op
« Reactie #6 Gepost op: 2007/11/18, 13:16:59 »
Citaat van: joop13
Maar het vreemde blijft dat bij de tweede keer opstarten het probleem verdwenen is.
Daar heb ik gisteravond overheen gelezen. Dit is inderdaad vreemd, je zou zeggen dat een externe toepassing dit veroorzaakt die in jou profiel actief is. Heeft geertje dezelfde problemen met inloggen?

Omdat dit klinkt als een bug ben ik even opzoek gegaan in launchpad. Het enige dat ik heb kunnen vinden is wel iemand met hetzelfde probleem maar er zijn nog geen reacties op gekomen. https://bugs.launchpad.net/ubuntu/+bug/159411
Misschien dat je daar in ieder geval een bugreport kan geven.

Zelf zal ik nog even verder zoeken. Want dit is wel een vreemd probleem. Heb je voordat je dit probleem had vreemde dingen gedaan? Bv. een oude backup van je /home terug gezet, een programma geinstalleerd of verwijderd of ergens in gerommeld?

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #7 Gepost op: 2007/11/18, 16:46:38 »
Het enige opvallende wat ik gedaan heb tussen toen het nog goed was en nu is het installeren van Compiz en het verwijderen ervan. Inmiddels denk ik het, al een tijd geleden, weer volledig verwijderd te hebben met remove auto purge.

Vandaag start hij weer gewoon op. Dus ik kijk nu ook even op Launchpad om het bugrapport eventueel aan te vullen.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Desktop start niet goed op
« Reactie #8 Gepost op: 2007/11/18, 18:35:06 »
--purge betekend dat hij ook de configuratie meeneemt. Dit is iets waar je voor kunt kiezen. Maar met autoremove haal je allen de pakketten weg die niet nodig zijn.
Dus met apt-get autoremove --purge haal je alleen de bestanden weg die niet nodig zijn en die geen configuratie nodig hebben.

Met apt-get remove --purge compiz verwijder je alles zoals je wilt. Zou het kunnen zijn dat je toevallig het bovenste hebt uitgevoerd?

Ik denk dat je dit kunt oplossen door compiz weer even tijdelijk te installeren, uitproberen en dan te verwijderen met apt-get remove. De configuratie nog even behouden, dan weet je zeker dat het bestand uit je /home niet wordt verwijderd.

EDIT
Ps. dit ziet eruit als een bug, dit soort bestanden horen nooit verwijderd te worden. Dus je kunt het wel op launchpad zetten.

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #9 Gepost op: 2007/11/18, 19:58:37 »
Citaat van: raggar
--purge betekend dat hij ook de configuratie meeneemt. Dit is iets waar je voor kunt kiezen. Maar met autoremove haal je allen de pakketten weg die niet nodig zijn.
Dus met apt-get autoremove --purge haal je alleen de bestanden weg die niet nodig zijn en die geen configuratie nodig hebben.

Met apt-get remove --purge compiz verwijder je alles zoals je wilt. Zou het kunnen zijn dat je toevallig het bovenste hebt uitgevoerd?

Ik denk dat je dit kunt oplossen door compiz weer even tijdelijk te installeren, uitproberen en dan te verwijderen met apt-get remove. De configuratie nog even behouden, dan weet je zeker dat het bestand uit je /home niet wordt verwijderd.

EDIT
Ps. dit ziet eruit als een bug, dit soort bestanden horen nooit verwijderd te worden. Dus je kunt het wel op launchpad zetten.
Ik heb de derde mogelijkheid gedaan, dus inclusief compiz, en daarna ook nog de manager verwijderd.

Maar wat bedoel je met ziet eruit als een bug? Welke bestanden horen nooit verwijderd te worden?
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Desktop start niet goed op
« Reactie #10 Gepost op: 2007/11/18, 20:01:49 »
/home/joop/.metacity/sessions/default0.ms uit je eerste bericht.
Deze zit in je /home en is belangrijk voor metacity. Echter wanneer je metacity niet gebruikt hoort het default0.ms bestand weer terug te worden gezet.
Volgens mij is dit niet gebeurt. Persoonlijk zal ik de bug plaatsen bij metacity, echter wel met de foutmelding van boven erbij...

Werkt het nu wel weer?

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #11 Gepost op: 2007/11/18, 20:11:37 »
Op dit moment werk ik al een poosje met Ubuntu na een goede opstart. Ik heb hem nog niet weer opnieuw opgestart. Ik heb even in het de directory gekeken, maar op dit moment staat er ook geen default0.ms in. Is dat de bug?

Op dit moment weer opgestart, zonder problemen. Ik ga morgen weer eens kijken wat er gebeurt als ik hem, na een poosje rust, weer opstart.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #12 Gepost op: 2007/11/20, 01:23:57 »
Citaat van: joop13
Op dit moment weer opgestart, zonder problemen. Ik ga morgen weer eens kijken wat er gebeurt als ik hem, na een poosje rust, weer opstart.
Vandaag was het weer, in totaal 3 keer, opstarten voordat hij het goed deed. Kan ik van al mijn ms bestanden ééntje hernoemen naar default0.ms om het probleem op te lossen?
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Desktop start niet goed op
« Reactie #13 Gepost op: 2007/11/20, 01:51:59 »
Je kunt het proberen, maar ik weet niet zeker of het iets oplost. Ik heb zelf ook geen default0.ms bestand staan, maar wie weet. Kopieer hem in ieder geval, niet gewoon hernoemen. Je weet nooit of het iets uithaalt.
Kan geertje wel gewoon opstarten? Dan zou je de .metacity van haar kunnen overnemen...

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #14 Gepost op: 2007/11/20, 02:19:31 »
Ja, ze kan gewoon opstarten maar als ik vanuit mijn user kijk naar haar .metacity via gksudo nautilus dan staat daar ook geen default in. Dus dan lijkt overnemen niet het probleem op te lossen van de missende default. Met het bijbehorende probleem dat ik de rechten wel even weer voor mij moet klaarmaken, niet zo moeilijk maar toch.

Eén van de dingen die me ook opvielen tijdens het afsluiten is dat de afsluitbalk van bijvoorbeeld firefox direct na het aanklikken van afsluiten verdwenen is. Een probleem dat ik ook tegenkwam bij Beryl. Zou ik dan toch nog ergens files van Compiz/Beryl hebben kunnen staan die ik eerst moet verwijderen? Of een config waarin ik deze zaken kan verbeteren?

Inmiddels komt het probleem niet meer voor, maar waarom niet, is mij niet duidelijk. Daarom heb ik hem maar op opgelost gezet.

En inmiddels moet ik WEER twee keer opstarten voordat ik het geheel weer klaar heb. Dus maar weer op onopgelost gezet. Iemand een idee??????
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #15 Gepost op: 2007/12/07, 19:59:39 »
Joop,
In reactie op jouw reactie op mijn post alhier http://forum.ubuntu-nl.org/topic/19124
dacht ik er goed aan te doen dit verhaal ook eens door te nemen.
Vanaf je eerste post zijn jouw verhalen zeer herkenbaar - ook dat gedoe met Ctrl-Alt-Bckspc (leeg buroblad zonder balken).
Het lijkt er hier op, dat het inmiddels iets stabieler loopt. Ik kan in principe alles gewoon doen, ook al krijg ik de bekende foutmelding (zie de post die ik al noemde). Volgens mij is het Ctrl-Alt-Backspace verhaal verholpen met een andere driver voor mijn grafische kaart - ik draai nu de restricted driver. Zou dat voor jou een oplossing zijn?

Dat Gnome-gebeuren, dat weet ik ook nog niet. Ik ben nog op zoek!

Offline joop13

  • Lid
  • Steunpunt: Nee
Desktop start niet goed op
« Reactie #16 Gepost op: 2007/12/07, 22:44:06 »
Ik draai ook de restricted driver voor Nvidia. Maar het gedoe is eigenlijk begonnen toen ik Compiz heb gebruikt. Dat beviel niet, toen heb ik hem verwijderd en krijg nu dit effect. Wat ook zo nu en dan weer weg is......
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.