Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nividia-settings wil niet starten  (gelezen 1594 keer)

Offline B3rt

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Gepost op: 2007/11/15, 01:32:34 »
Ik heb op mijn Gutzi een nividia videokaart  me 2 17" TFT schermen en compiz geinstalleerd.

Dit werkt allemaal prima op 1 ding na.
Als ik iets maximaliseer dan gaat dit over 2 schermen, nu had ik gelezen dat ik twinview moest gebruiken en dat ik dit kan instellen met behulp van de tool nvidia-settings

Als ik deze start dan opent zich dit wel alleen is er geen informatie zichtbaar, ook krijg ik een melding dat mijn x-org niet klopt en dat ik als root nvidia-xconfig moet draaien eerst.

Dit doe ik, dan wordt er een backup van mijn xorg gemaakt, er wordt GEEN wijziging gemaakt erin, start ik daarna weer nvidia-settings krijg ik weer exact dezelfde melding.


Ik heb al van alles probeert om het werken te krijgen.
Heb alles van nvidia al eens verwijderd en opnieuw geïnstalleerd, heb ook drivers via envo (of zoiets) tooltje.
Ook staat de beperkte driver ondersteuning aan.

Kan me iemand vertellen hoe ik dit kan oplossen?

Zoals ik al zei ik heb mijn 2 schermen werkend met compiz en in 3d echter ik wil niet dat de windows maximaliseren over 2 schermen.

Bandicoot

  • Gast
Nividia-settings wil niet starten
« Reactie #1 Gepost op: 2007/11/15, 09:56:59 »
je hebt sudo nvidia-xconfig gedaan ? En daarna oo sudo nvidia-settings ?? Misschien dat je na de xconfig ff xmoet herstarten ?

Offline B3rt

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #2 Gepost op: 2007/11/15, 11:14:57 »
Ja met sudo en ook zonder sudo geprobeerd, dit had geen effect, de zelfde melding.
Ook X herstarten nadat ik xconfig gedaan hebm, geen effect.

Met vreemde is dat xconfig NIETS veranderd in de xorg.conf, een diff geeft geen enkel verschil aan.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #3 Gepost op: 2007/11/15, 11:27:38 »
sudo nvidia-settings

Offline B3rt

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #4 Gepost op: 2007/11/15, 15:14:36 »
Beste Pjotr123....

Ik schreef al: dit werkt niet!

Error:
You do not appear to be using the NVIDIA Xdriver
Please edit your configuration file (just run 'nvidia-xconfig\ as root), and restart the X server

Als je dit doet dan krijg je netjes weer dezelfde error, nvidia settings wordt wel geopend echter er staat niets in wat je kan instellen.

En JA in de xorg.conf staat;    Driver         "nvidia"

Ook mijn 3d (en compiz) werkt gewoon en ik krijg ook het nvidia splash screen bij start-up.

Offline J de vries

  • Lid
    • http://ubuntu-bits.blogspot.com/
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #5 Gepost op: 2007/11/15, 15:24:23 »
Citaat
Heb alles van nvidia al eens verwijderd en opnieuw geïnstalleerd, heb ook drivers via envo (of zoiets) tooltje.
Als je Envy hebt geinstalleerd en nvidia-glx-new ook, heb je waarschijnlijk een probleem = conflict.
Citaat
sudo apt-get remove nvidia-glx-new - -purge
is de wijze om nvidia-glx te verwijderen alvorens je envy instaleerd.

Overigens is het totaal onnodig Envy te gebruiken voor nvidia in Gutsy Gibbon.

Ik raad je dan dus ook aan om eerst nvidia-glx-new eerst draaiend te krijgen, eventueel een reinstall van Ubuntu zelfs, daar Envy niet ondersteund wordt door Ubuntu en dus op eigen risico is.

P.S. er is een howto uninstall Envy in de FAQ van Alberto Milone's Wiki:
Citaat
1) Launch Envy and use the "Uninstall" function to uninstall the Nvidia or the ATI driver

2) Uninstall the Envy from Synaptic/Adept or from the command line

3) Set the driver back to either "nv" ( instead of "nvidia", if you use a Nvidia card) or "ati" ( instead of "fglrx", if you use an ATI card) in the Section Device of your /etc/X11/xorg.conf which you can edit by typing:

sudo nano -w /etc/X11/xorg.conf

NOTE: press CTRL+X to exit (save the file)

4) Log out and press CTRL+ALT+Backspace (so as to restart the Xserver)
NOTE: if the Xserver crashes you will have to use "vesa" instead of "ati" or "nv"

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #6 Gepost op: 2007/11/15, 16:17:48 »
Nee he, weer zo'n akelig installatiescript.... Het zoveelste slachtoffer. De beste oplossing is een volledige schone herinstallatie van Ubuntu. Deïnstalleren van Envy is onvoldoende.

Beste mensen: Automatix, Envy en EasyUbuntu zijn vergif voor je systeem. Gebruik ze niet!!!!!

Offline koen_92

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #7 Gepost op: 2007/11/15, 20:00:18 »
Citaat van: pjotr123
Beste mensen: Automatix, Envy en EasyUbuntu zijn vergif voor je systeem. Gebruik ze niet!!!!!
Ik geloof het best wel, maar waarom precies.
Ik gebruik het zelf niet, omdat het overal afgeraden wordt, maar dus waarom eigenlijk?

Offline B3rt

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #8 Gepost op: 2007/11/15, 21:30:32 »
Ok ik heb mijn systeem uiteindelijk herinstalleerd.

Alles werkt nu op 1 ding na....

Als ik nu via compiz mijn kubus draai dan krijg ik 2 kubussen te zien, 1 op het linker en 1 op het rechter scherm....

Ik heb wel 1 buroblad en ook maximaliseert deze netjes op 1 monitor, nu alleen het draaien van de bubus nog.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #9 Gepost op: 2007/11/15, 23:55:10 »
Citaat van: koen_92
Citaat van: pjotr123
Beste mensen: Automatix, Envy en EasyUbuntu zijn vergif voor je systeem. Gebruik ze niet!!!!!
Ik geloof het best wel, maar waarom precies.
Ik gebruik het zelf niet, omdat het overal afgeraden wordt, maar dus waarom eigenlijk?
Kort gezegd: die dingen gedragen zich als een installeerder, maar pakken niet de volledige verantwoordelijkheid op die daarbij hoort, zoals het mede installeren van alle afhankelijke ondersteunende bestanden.

Gevolg: een gammel en instabiel systeem.

Offline koen_92

  • Lid
  • Steunpunt: Nee
Nividia-settings wil niet starten
« Reactie #10 Gepost op: 2007/11/16, 17:25:58 »
Ok, bedankt dan weet ik dat ook weer.