Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Brother Netwerkpinter  (gelezen 1478 keer)

mderking

  • Gast
Brother Netwerkpinter
« Gepost op: 2007/11/09, 20:02:17 »
Ik krijg mijn netwerkpintern van Brother niet aan de gang.

Het betreft een Brother MFC-5440CN

Ik heb via de brother side, in het terminal venster via sudo de boel geinstalleerd, zoals aangegeven op deze pagina:

http://solutions.brother.com/linux/sol/printer/linux/cups_network.html

Grotendeels wil het lukken. Als ik kijk onder localhost:631 dan kom op de de site, en daar staat mijn printer vermeld ook gewoon vermeld.

Als ik echter een test pagina laat afdrukken, gebeurt er niets. De job blijft staan, maar er komt niet uit de printer.

Ik heb een Draytek 2910VG router, zonder verder apparte instellingen, met computer als 192.168.123.10 en printer als 192.168.123.11

Printer wordt aangeduid onder localhost:631 alsvolgt:
Description: MFC5440CN
Location:
Printer Driver: Brother MFC-5440CN CUPS v1.1
Printer State: processing, accepting jobs, published.
Device URI: lpd://192.168.123.11/binary_p1

De job wordt ondertussen aangegeven alsvolgt:
MFC5440CN-2     Test Page     mderking     17k     Unknown     held since
Fri Nov 9 18:54:37 2007

Er zit verder geen verandering in. Op het moment dat ik geen job hebt staan, staat er i.p.v. " processing" het woord "idle"


Heeft iemand een suggestie wat dit kan zijn. Welke poort wordt er voor pinten gebruikt (dan kan ik deze nog eens expliciet openzetten in de router, al staan er verder geen limitaties op).

Ik heb een standard Xubuntu 7.10 installatie zonder apparte firewalls of iets dergelijks. Graag hoor ik van iemand enige suggesties die ik kan uittesten of die ik over het hoofd heb gezien.

m.v.g,
Mark

EDIT: Ik zie nu pas (eerder stond hier wel het ip-adres) de volgende regel nog boven de printer data staan:
MFC5440CN (Default Printer) "/usr/lib/cups/backend/lpd failed"

Dit zal er wel mee te maken kunnen hebben,. Ik zag ook nog wat log files staan, die plaats ik ook meteen maar even:

error log:
E [09/Nov/2007:18:35:08 +0000] CUPS-Add-Modify-Printer: Unauthorized
E [09/Nov/2007:18:40:19 +0000] [cups-driverd] Unable to open PPD directory "/opt/share/ppd": No such file or directory
E [09/Nov/2007:18:40:40 +0000] [cups-driverd] Unable to open PPD directory "/opt/share/ppd": No such file or directory
E [09/Nov/2007:18:41:20 +0000] CUPS-Add-Modify-Printer: Unauthorized
E [09/Nov/2007:18:41:33 +0000] CUPS-Add-Modify-Printer: Unauthorized
E [09/Nov/2007:18:46:56 +0000] PID 10430 (/usr/lib/cups/backend/lpd) stopped with status 1!
E [09/Nov/2007:18:53:16 +0000] CUPS-Set-Default: Unauthorized
E [09/Nov/2007:18:54:28 +0000] PID 11404 (/usr/lib/cups/backend/lpd) stopped with status 1!
E [09/Nov/2007:18:54:40 +0000] PID 13262 (/usr/lib/cups/cgi-bin/printers.cgi) crashed on signal 9!
E [09/Nov/2007:18:59:51 +0000] PID 12343 (/usr/lib/cups/backend/lpd) stopped with status 1!
E [09/Nov/2007:19:03:36 +0000] [cups-driverd] Unable to open PPD directory "/opt/share/ppd": No such file or directory
E [09/Nov/2007:19:04:19 +0000] CUPS-Add-Modify-Printer: Unauthorized

m.v.g,
Mark

Offline joop905

  • Lid
  • Steunpunt: Nee
Brother Netwerkpinter
« Reactie #1 Gepost op: 2007/11/10, 01:28:31 »
hier wat hulp: http://forums.openprinting.org/list.php?24

geluk er mee.

mderking

  • Gast
Brother Netwerkpinter
« Reactie #2 Gepost op: 2007/11/10, 11:21:44 »
Staan 2 topics op voor deze printern..... beide komen er ook nog niet uit ;-(

Heeft iemand suggesties wat voor een tests ik kan doen, om te zien of hij werkt?

Offline Thom

  • Lid
  • Steunpunt: Nee
Brother Netwerkpinter
« Reactie #3 Gepost op: 2007/11/10, 14:05:00 »
Ik zou eerst controleren of de printer als standalone werkt. Zo niet dan is de installatie mislukt. Als je even Brother MFC 115C googled op deze site vind je een post met daarin een link naar de Brother Linux driver site. Via deze site heb ik de MFC 115C werkend gekregen. Wel goed de instructies volgen.
Indien de printer wel standalone werkt maar niet in het netwerk, controleer dan even of je printer gevonden wordt vanaf een andere PC. Zo niet dan moet je het probleem zoeken in je netwerkinstellingen. Ik heb nu een Brother 9660 (aangesloten op een Windows PC) en een Brother MFC 115C (zowel Windows als Linux) geïnstalleerd als netwerkprinters, dus het moet mogelijk zijn.
HP Compaq AMD66 Althlon 2, 2 Gb geheugen, Dual boot Ubuntu 12.04 + Windows 7
Onbekende P4, 1,0 Gb geheugen, Dual boot Ubuntu 11.04 + Window XP3
HP PC Pentium 4, 512Mb geheugen, Dual boot Ubuntu 11,04 + Windows XP3

mderking

  • Gast
Brother Netwerkpinter
« Reactie #4 Gepost op: 2007/11/11, 12:49:57 »
Brother instructies heb ik gevolgt. Ook nog even op een duitse website gekeken, die gaf gelijke instructies met als uitzondering dat ik socket:ip-adres:9100 moest gebruiken i.p.v.  ldp://ip-adres/binary_p1 zoals aangegeven op de Brother pagina.

Beide pakt hij niet. Ik heb de opdrachten zoals op de brothersite gevolgt, via terminal scherm sudo. Daarbij kwam bij de cups een melding dat CSH nog geinstalleerd moest worden, dus ook deze nog via sudo apt-get install csh geinstalleerd. Maar nogsteeds NaDa.

Als stand alone testen betekend dat ik eerst ergens een USB kabel moet regelen en de computer of printer moet verslepen, dus dat laat ik liefer achterwegen. Ik heb echter de printer al eerder onder windows werkend gehad, ik volgensmij werkte hij ook onder Ubuntu 7.04 (maar dat weet ik niet meer zeker). Ben nu sinds 7.10 overgegaan naar volledig 7.10 met Xubuntu..   Maar ik denk dat ik er binnenkort maar weer normale Ubuntu op zet, ik ervaar momenteel instabiliteit.

mderking

  • Gast
Brother Netwerkpinter
« Reactie #5 Gepost op: 2007/11/17, 21:45:39 »
Zoals Homer Simson zou zeggen:  DOOH!

Het betrof hier een gevalletje " wat ben ik een domkop"

Ik was vandaag een server aan het installeren, en moest daarbij een SSL verbindign naar de server opzetten. Dit wou niet lukken naar hiet ip, dus ik deed maar even telnet...  dit lukte, kreeg ik Brother in beeld..

Blijkt mijn printer door een kleine wijziging van mezelf door mijn router als IP adres het nummer 192.168.123.13 te hebben gekregen. En aangezien ik steeds .11 probeerd, werkte het niet bepaald :-(((

M.a.w: Het werkt dus wel perfect, ik had gewoon een verkeerd ip-adres (adres dat ik gebruikte hoorde bij een test-desktop van me).

Problem solved, en de bother link + uitleg is dus gewoon perfect.