Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....  (gelezen 1032 keer)

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Gepost op: 2007/11/09, 14:06:41 »
Hallo,
Ik heb een vraag; mijn harddisk is constant aan het zoemen en daar wordt ik wel een beetje gestoord van. Bij alles wat ik doe zoemt de harddisk. Ik snap heus wel dat wanneer ik een programma op start dat dan de hd even zoemt maar hij stopt gewoon niet meer.

Voorbeeld: Ik open firefox en bekijk wat filmpjes op het internet of ik luister naar een muziekje met streamtuner, nou dan heb ik meer lawaai van mijn hd dan dat ik lekker kan kijken of luisteren.

Toen ik nog WinXP gebruikte had ik daar totaal geen last van.
Ik heb Ubuntu 7.10 van de originele cd (via shipit ontvangen) geïnstalleerd.

Ik heb een swapfile van 3Gig dus dat zou genoeg moeten zijn.

Heeft iemand enig idee hoe ik die harddisk weer stil kan krijgen?

Groetjes, Robert.
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Reactie #1 Gepost op: 2007/11/09, 14:16:02 »
Probeer dit eens:

1. Schakel het "file access time" stempel uit in /etc/fstab, door het toevoegen van de optie noatime bij elke partitie behalve de swap. Voorbeeld van zo'n gewijzigde fstab:
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=7a212543-83c0-43db-a7f3-f631de4a79a3 /               ext3    defaults,errors=remount-ro,noatime 0       1
# /dev/sda2
UUID=be015ac3-1341-429d-a76f-962ab9adc12b /home           ext3    defaults,noatime        0       2
# /dev/sda1
UUID=4444ABE816D7576B /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46,noatime 0       0
# /dev/sda6
UUID=eef581d8-6d79-41f4-9293-6832cb1a735f /media/sda6     ext3    defaults,noatime        0       0
# /dev/sda7
UUID=4869e6d8-a45a-4a32-bd2c-b19240d028ae /media/sda7     ext3    defaults,noatime        0       0
# /dev/sda8
UUID=4671-BB54  /media/sda8     vfat    defaults,utf8,umask=007,gid=46,noatime 0       0
# /dev/sda5
UUID=efdb6f12-033f-436b-b317-9679e192e2ca none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
2. Verhoog verder in /etc/rc.local de interval waarmee pdflush werkt, van 5 seconden naar 30 seconden.  
De inhoud van zo'n gewijzigde /etc/rc.local :

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
#
# Change interval to 30 seconds for pdflush:
echo 3000 > /proc/sys/vm/dirty_expire_centisecs
#
exit 0
3. Pas voor alle zekerheid ook /etc/rc.local.shutdown aan:
#
# Change interval for pdflush to normal:
#
echo 500 > /proc/sys/vm/dirty_expire_centisecs
#
Opslaan, sluiten, computer herstarten.

Helpt dit?

Offline robert vroegop

  • Lid
    • http://www.vroegop.eu
  • Steunpunt: Nee
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Reactie #2 Gepost op: 2007/11/09, 14:18:21 »
Nou dat is wel heel snel geantwoord, ik ga het zo meteen uitproberen en dan zal ik de uitkomst hier melden. Alvast bedankt voor je reactie.


edit: ik heb het aangepast en het lijkt wel iets minder te zijn, dus mijn volgende vraag is; kan ik die waarde van 3000 verhogen naar bijvoorbeeld 6000?
2009... het is alweer bijna voor bij. Ik geniet nog elke dag van Ubuntu. Natuurlijk heb ik ook een ander OS maar Ubuntu blijft voor mij de Nummer 1. :-)

artvds2708

  • Gast
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Reactie #3 Gepost op: 2007/11/10, 22:31:49 »
@pjotr123

Ik begreep het eerste deel niet zo, vandaar dat ik die lijst maar even post.
Wat moet ik, eventueel, veranderen ?
Een stillere HD is altijd welkom

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=271594fd-c2e5-40b5-a6d0-ae18776d0216 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=65caa7e5-1b97-4941-965c-f2d824b37830 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

Offline vanadium

  • Lid
  • Steunpunt: Nee
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Reactie #4 Gepost op: 2007/11/11, 09:34:13 »
defaults,errors=remount-ro,noatime

t.t.z: je voegt de optie noatime gewoon toe na een comma bij de reeds aanwezige opties

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Hardisk Zoemt en Zoemt en Zoemt..... dat wil ik niet....
« Reactie #5 Gepost op: 2007/11/11, 10:51:06 »
Citaat van: robertvroegop
Nou dat is wel heel snel geantwoord, ik ga het zo meteen uitproberen en dan zal ik de uitkomst hier melden. Alvast bedankt voor je reactie.
Om Pjotr123 te verslaan met snel posten moet je wel heel erg vroeg opstaan Robert ;)
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas v├ęcu comme on l'aurait voulu"