Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 7.10 ATI driver wel of niet activeren?  (gelezen 2428 keer)

Offline hps58

  • Lid
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Gepost op: 2007/11/08, 19:03:45 »
Ik heb eerst geprobeerd Kubuntu te installeren dat ging in principe wel goed alleen kreeg ik Compiz niet aan de praat. Heb toen Ubuntu gedownload en alle info op de site gelezen en wat ik zag beviel me wel. Installatie heb ik vanmiddag gedaan, zit echter ook hier met het feit dat ik geen Compiz aan de praat krijg.

Misschien doe ik iets verkeerds, weet ook zo niet wat ik met het volgende moet doen:

"2. Controleer of alle hardware goed werkt en installeer eventueel drivers. Drivers installeren is meestal niet noodzakelijk, omdat die al in de Linuxkernel zitten. Een uitzondering daarop vormen de fabrieksdrivers voor Nvidia en ATI videokaarten. Voor optimale prestaties van je Nvidia of ATI videokaart, wil je daarvoor de gesloten-bron fabrieksdriver installeren.

De Restricted drivers manager geeft vanzelf aan of die beschikbaar is voor jouw videokaart, door een melding in het systeemvak rechtsbovenin je scherm. Klik op het meldingspictogram en volg de stappen. "

Ik krfeeg die melding, heb toen het holje aangevinkt zodat de 3d zou gaan werken.....maar als ik dan naar Systeem-Beheer-Voorkeuren ga kan ik geen visuele efecten activeren.

En als ik het weer ongedaan maak, krijg ik ook als antwoord dat de visuele effecten niet geactiveerd kunnen worden.

Ik heb een ATI Radeon Mobility X700 video kaart in mijn Acer laptop.

Heb die al uitstaan en kan op dit moment geen andere info geven.

Ik lees de antwoorden morgen wel, ga nu naar huis.....nog geen internet

mvrgr
Herman
Desktop: Ubuntu 8.04.
Laptop: Windows XP
Linux user # 501016

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #1 Gepost op: 2007/11/08, 21:49:50 »
Met Ati kaarten is het nog niet mogelijk om (stabiel) gebruik te maken van de desktop effects.
De open source driver levert vaak crashes op icm de desktop effects, en de gesloten fabrieksdriver van Ati kan nog niet   overweg met de desktop effects.

Het is wel mogelijk om de desktop effects te gebruiken met de fabrieksdriver en het pakker xserver-xgl, maar dat levert weer problemen op in programma's als google earth heb ik begrepen.

Je moet dus nog even geduld hebben voordat de desktop effects goed werken op jouw laptop. Als het goed is komen er over een tijdje nieuwe drivers uit van Ati die deze problemen niet hebben.

Welke Acer laptop heb je precies? Ik heb ook een Acer laptop met de X700 videokaart. (Aspire 5024)

Arny48

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #2 Gepost op: 2007/11/08, 22:05:03 »
Nou, dat klopt niet wat je zegt.
Ik heb de instructies opgevolgd die op deze forum zijn gegeven hoe je compiz moet instaleren onder een ATI videocard(heb elf een ATI X1600 pro)
Gisteren heb ik zorgvuldig de instructie opgevolgt en zonder problemen draait nu Compiz en ja zelfs de Cube draaidt probleemloos.
Ik zal proberen een afbeelding te laten zien.

Arny48

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #3 Gepost op: 2007/11/08, 22:27:11 »

gekky29

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #4 Gepost op: 2007/11/09, 01:27:36 »
Citaat van: Arny48
Nou, dat klopt niet wat je zegt.
Ik heb de instructies opgevolgd die op deze forum zijn gegeven hoe je compiz moet instaleren onder een ATI videocard(heb elf een ATI X1600 pro)
Gisteren heb ik zorgvuldig de instructie opgevolgt en zonder problemen draait nu Compiz en ja zelfs de Cube draaidt probleemloos.
Ik zal proberen een afbeelding te laten zien.
waar zijn die instructies ?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #5 Gepost op: 2007/11/09, 05:16:40 »
Citaat van: Arny48
Nou, dat klopt niet wat je zegt.
Ik heb de instructies opgevolgd die op deze forum zijn gegeven hoe je compiz moet instaleren onder een ATI videocard(heb elf een ATI X1600 pro)
Gisteren heb ik zorgvuldig de instructie opgevolgt en zonder problemen draait nu Compiz en ja zelfs de Cube draaidt probleemloos.
Ik zal proberen een afbeelding te laten zien.
Sowieso is de X700 chip (en een aantal andere) "geblacklist" in Compiz met de open source drivers. Er waren teveel vastlopers bij teveel mensen. Bij mij werkt het wel na de blacklist te hebben veranderd, maar ook niet echt stabiel.

Met Xgl en de gesloten drivers kan het prima werken, maar dat heeft weer andere nadelen.

Een handleiding is hier te vinden:
http://ubuntuforums.org/showthread.php?t=580748

Offline hps58

  • Lid
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #6 Gepost op: 2007/11/09, 07:17:20 »
Citaat van: Johanvd
Citaat van: Arny48
Nou, dat klopt niet wat je zegt.
Ik heb de instructies opgevolgd die op deze forum zijn gegeven hoe je compiz moet instaleren onder een ATI videocard(heb elf een ATI X1600 pro)
Gisteren heb ik zorgvuldig de instructie opgevolgt en zonder problemen draait nu Compiz en ja zelfs de Cube draaidt probleemloos.
Ik zal proberen een afbeelding te laten zien.
Sowieso is de X700 chip (en een aantal andere) "geblacklist" in Compiz met de open source drivers. Er waren teveel vastlopers bij teveel mensen. Bij mij werkt het wel na de blacklist te hebben veranderd, maar ook niet echt stabiel.

Met Xgl en de gesloten drivers kan het prima werken, maar dat heeft weer andere nadelen.

Een handleiding is hier te vinden:
http://ubuntuforums.org/showthread.php?t=580748
Ik zal deze handleiding eens goed gaan doornemen, ik wel die kubus wel eens zien en als er met andere pakketten dan problemen zijn, moet
ik dan maar eens zien wat belangrijker is. Het is een gadget Compiz maar het is mijn eer te naar om het niet aan de gang te krijgen.

Specs van mijn Acer, zie mijn onderschrift.
Desktop: Ubuntu 8.04.
Laptop: Windows XP
Linux user # 501016

Piet

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #7 Gepost op: 2007/11/09, 13:57:43 »
De nieuwste (8.42.3 op dit moment) ati fglrx drivers ondersteunen nu wel (eindelijk!) AIGLX.
Als je die drivers installeert kan je zonder XGL te gebruiken compiz draaien.
Elders op dit forum staat een heel bruikbare handleiding over hoe dit te doen: http://forum.ubuntu-nl.org/topic/16521
Ik gebruik nu zelf ook compiz met deze 8.42.3 drivers en dat draait allemaal prima, een hele verbetering t.o.v. XGL

JimZ

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #8 Gepost op: 2007/11/09, 22:17:56 »
Ben trouwens wel benieuwd naar de preciese Compiz instellingen van Arny48 :O .

Gr,
Jim

Offline JvH

  • Lid
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #9 Gepost op: 2007/11/14, 10:44:45 »
Goedemorgen iedereen.

Dit is mijn eerste post op dit forum. Heb 2 weken voor de release van Gutsy Gibbon kennis gemaakt met Ubuntu, en Linux in het algemeen.
Helaas ben ik een van de minder fortuinlijke computergebruikers die beschikken over een ATI-kaart (Radeon 1900XT), en heb dus nog niet volop kunnen genieten van de Compiz eye candy.
In Ubuntu 7.10 heb ik het wel werkend gekregen door de pakketten xserver-xgl te installeren, icm compizconfig-settings-manager te voor geavanceerde instellingsmogelijkheden.
Zoals al eerder in deze thread is aangegeven, kunnen niet alle spellen (vooral als het gaat om fullscreen mode) kennelijk niet met xserver-xgl door één deur.

De hierboven geposte howto voor AIGLX (wat dat ook mag zijn) is mij nog echt te hoog gegrepen. Ik las echter ook hier en daar dat de nieuwe en verbeterde ATI-driver op een gegeven moment als update beschikbaar zou komen.
Ik moet bekennen dat ik van het hele verhaal (xserver, aiglx, fglrx...) weinig begrijp. Ben vanuit Windows gewend om simpelweg een driver te downloaden en te installeren om 3D-graphics aan de praat te krijgen, dus ben niet veel gewend zeg maar.

Mijn vragen:
- Zal met die update compiz ook voor de (meeste) ATI-kaarten out-of-the-box werken?
- Moet ik dan via Synaptic een bepaald pakket installeren, of krijg ik die update automatisch binnen?
- Kan ik dan de restricted ATI-driver en de pakketten xserver-xgl + compizconfig-settings-manager beter weer verwijderen?

Grtz,

JvH

Piet

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #10 Gepost op: 2007/11/14, 11:22:56 »
JvH:
- ja, zodra de nieuwste driver in de ubuntu repositories komt kan je die gewoon via synaptic (of adept als je kde gebruikt) installeren. Compiz zal dan werken nadat je 1 klein dingetje in het bestand /etc/X11/xorg.conf hebt gewijzigd.

- Bij mijn weten heeft ubuntu standaard compiz geinstalleerd, eventueel kan je het even controleren in synaptic (of adept) door te zoeken naar compiz en missende pakketen te installeren. Maar in je post lees ik ook dat je het nu werkend hebt via xgl, dus compiz zal ook wel gewoon geïnstalleerd zijn.

- Vooralsnog kan je die pakketen gewoon laten staan, pas wanneer die nieuwste restricted ati driver (8.42.3) beschikbaar is via de repositories zal je xgl moeten verwijderen of op zijn minst uitschakelen.

Offline JvH

  • Lid
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #11 Gepost op: 2007/11/14, 11:48:45 »
@Piet,

Dank voor je snelle reactie. Toch nog wat vragen, want zoals gezegd snap ik er erg weinig van. Mijn excuses :)

Citaat
ja, zodra de nieuwste driver in de ubuntu repositories komt kan je die gewoon via synaptic installeren.
Wordt dat dan een update van de restricted driver die ik nu gebruik, of moet ik zelf een pakket aanvinken? In het laatste geval, naar welke naam moet ik zoeken?

Citaat
Compiz zal dan werken nadat je 1 klein dingetje in het bestand /etc/X11/xorg.conf hebt gewijzigd.
Wat dan?

Citaat
pas wanneer die nieuwste restricted ati driver (8.42.3) beschikbaar is via de repositories zal je xgl moeten verwijderen of op zijn minst uitschakelen.
xserver-xgl ga ik sowieso verwijderen. Want hoewel compiz wel wil werken (zolang ik niet al te veel wilde opties aanvink :P) vind ik het wel jammer dat enkele spellen niet meer fullscreen willen draaien. De reden dat ik het toch vroeg: ik vroeg me af of de nieuwe driver dat xserver-xgl ook op de een of andere manier nodig zou hebben.

Groeten,

JvH

Piet

  • Gast
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #12 Gepost op: 2007/11/14, 12:16:55 »
JvH:
ten eerste, geen probleem dat je het niet snapt, gewoon hardnekkig blijven vragen dan kom je er wel :)

- De nieuwe driver zal gewoon als update verschijnen op een gegeven moment. Hopelijk maken de package maintainers  een beetje haast, want die nieuwste driver is toch wel een beetje een mijlpaal voor ati gebruikers onder linux.

- Je moet zorgen dat 'composite' enabled wordt. De driver die je nu gebruikt kan dat niet aan, en zal dat dus waarschijnlijk nadrukkelijk uitgeschakeld hebben. Je zal het bestand /etc/X11/xorg.conf moeten openen en kijken of de volgende tekst erin staat.
Section "Extensions"
    Option  "Composite" "Enable"
EndSection
Waarschijnlijk zal er nu 'disable' of '0' staan achter 'composite'. Zodra je die nieuwste driver hebt zal je het moeten wijzigen naar wat hierboven staat. Als het stukje tekst nog niet in je xorg.conf staat zal jet het even moeten toevoegen (zodra die nieuwe driver er is dus)

-Nee, xgl is nodig omdat die vorige ati drivers nooit die 'Composite' extentie ondersteunden. Zodra je die nieuwste driver hebt zal je xgl dus niet meer nodig hebben (yay!)

Offline JvH

  • Lid
  • Steunpunt: Nee
Ubuntu 7.10 ATI driver wel of niet activeren?
« Reactie #13 Gepost op: 2007/12/14, 21:19:45 »
Het is al weer een tijdje geleden sinds de laatste post, maar toch zou ik naar aanleiding van de laatste post nog 1 vraag willen stellen.

Citaat van: Piet
De nieuwe driver zal gewoon als update verschijnen op een gegeven moment.
Gaat de restricted driver manager me dan een waarschuwing geven, zodat ik weet wanneer het tijd is om xorg.conf aan te gaan passen en compiz in te schakelen?