Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Atheros AR5006EG Wireless LAN werkt niet  (gelezen 9995 keer)

RobotFreak

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Gepost op: 2007/11/08, 14:35:35 »
Gisteren ben ik snel door de installatie heen gekomen van ubuntu 7.10.
Alles werkt al goed, behalve draadloos internet.
Na wat zoeken heb ik met ndiswrapper de XP driver voor de Acer 5510 geïnstalleerd.
Ndiswrapper geeft nu via "ndiswrapper -l" het volgende aan:

net5211: driver installed
           device (168C:001C) present (alternate driver: ath_pci)

Dat werkt dus nog niet, de help bestanden laten me "sudo lshw -C network" invoeren:

  *-network UNCLAIMED    
       description: Ethernet controller
       product: AR5006EG 802.11 b/g Wireless PCI Express Adapter
       vendor: Atheros Communications, Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
  *-network
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 1
       bus info: pci@0000:06:01.0
       logical name: eth0
       version: 10
       serial: 00:16:d4:d0:21:c0
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s

Heeft iemand een ideetje dat mij op weg kan helpen?
Alvast bedankt!

Lekoes

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #1 Gepost op: 2007/11/12, 12:40:22 »
Ik heb precies hetzelfde probleem.

Ik heb op de site van madwifi gevonden dat het moet kunnen werken, http://madwifi.org/ticket/859
maar ik snap alleen niet hoe..

Ik hou je op de hoogte, als je er onderhand al uitgekomen bent dan hoor ik het graag..

RobotFreak

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #2 Gepost op: 2007/11/12, 17:51:54 »
Ik heb een fout gemaakt, het gaat niet om de AR5006EG maar om de AR5007EG.
Op madwifi staat dat die nog niet ondersteund wordt...

EDIT: WTF!!!!
In windows zegt ie dat het de 5007 is, maar linux zegt dat het de 5006 is...

Offline lizardman

  • Lid
  • Steunpunt: Nee
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #3 Gepost op: 2007/11/12, 18:17:58 »
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

perika

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #4 Gepost op: 2007/11/13, 18:02:26 »
als Ubuntu aangeeft dat het de 5006 is en het ZOU de 5007 zijn dan verklaart dat
dat mensen zeggen dat de 5006 niet werkt (5006 wordt ondersteund door madwifi)
omdat het misschien wel in feite de 5007 is. Ik zie toch hier in de forums dat over het algemeen atheros chips wel werken.

Lekoes

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #5 Gepost op: 2007/11/13, 20:54:08 »
Ubuntu geeft bij mij aan dat het de 5006 is, terwijl Vista het over een LAN Express AS IEEE 802.11g PCI-E adapter heeft
Bij fabrikant staat dan wel weer Atheros...
Ik heb een Sony Vaio VGN-NR11m/s, en kan op de site van de fabrikant niet vinden welke wireless kaart er in zit...
Als windows en Ubuntu 2 verschillende dingen zeggen, wie heeft dan gelijk?


Ik krijg mijn "5006" nog steeds niet aan de praat

Heb je onderhand al een oplossing gevonden?

Offline lizardman

  • Lid
  • Steunpunt: Nee
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #6 Gepost op: 2007/11/14, 19:34:47 »
kijk eens hier http://ubuntuforums.org/showthread.php?t=212600 het schijnt voor sommigen te werken.
suc6
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Coenox

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #7 Gepost op: 2007/11/14, 20:28:12 »
Ik heb het opgegeven op mijn Acer laptop. Eerst acer-acpi geinstalleerd om de atheros kaart aan de praat te krijgen, maar geen wifi. Mijn oplossing: voor 20 euro een Sweex pcmcia insteek wifi kaart gekocht (Ralink RT2500 chipset), werkt out of the box. Werkt prima tot er een goede oplossing is.

perika

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #8 Gepost op: 2007/11/14, 21:01:55 »
@ Coenox Kun je het precieze model even vermelden, wie weet kan ik er
straks ook wat mee (en anderen natuurlijk)

Bvd Peter

Lekoes

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #9 Gepost op: 2007/11/14, 21:29:01 »
Citaat van: lizardman
kijk eens hier http://ubuntuforums.org/showthread.php?t=212600 het schijnt voor sommigen te werken.
suc6
Ik probeer nu op de volgende manier madwifi te installeren

On fresh Edgy, restricted-modules is not installed so I just went head & installed that driver directly.
go to your madwifi folder
$ cd scripts
$ ./madwifi-unload.bash
$ ./find-madwifi-modules.sh /lib/modules/
$ cd ..
$ sudo make
$ sudo make install
$ sudo modprobe ath_pci
$sudo modprobe wlan_scan_sta
$ sudo ifconfig ath0 up
System - administration - networking: My wireless device is now listed in here

If you have restricted-modules already installed, you must disable & uninstall it first
$ sudo ifconfig ath0 down
after $ sudo make above:
$ sudo make uninstall

Wanneer ik echter madwifi wil installeren zegt ie het volgende:

jelmer@jelmer-laptop:~/madwifi-0.9.3.3/scripts$ ./madwifi-unload.bash
FATAL: Module wlan is in use.

Dus ik dacht dat ik dan  eerst de boel moet uitschaken:

jelmer@jelmer-laptop:~$ sudo ifconfig ath0 down
ath0: ERROR while getting interface flags: Onjuist apparaat


maar ook dat werkt niet...

Ik heb madwifi trouwens al via synaptic pakketbeheer geinstalleerd (nou ja madwifi tools, weet niet of dat hetzelfde is)

voor mijn gevoel ben ik heel dichtbij, wie kan me verder helpen?

perika

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #10 Gepost op: 2007/11/14, 22:17:33 »
Ik weet wel dat er standaard madwifi wordt geïnstalleerd bij de ubuntu installatie.Je wilt dus proberen om de nieuwste versie van madwifi te installeren.
Hier staat hoe en volgens mij is dat iets anders dan jij hebt gedaan.
http://madwifi.org/wiki/UserDocs/FirstTimeHowTo

Lekoes

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #11 Gepost op: 2007/11/14, 22:36:52 »
Volgens mij is dat precies wat ik gedaan heb

First, set all your MadWifi devices down:

ifconfig ath0 down
ifconfig wifi0 down
#Repeat these 2 ifconfig lines for every MadWifi device you have

dit geeft alleen het volgende
 
jelmer@jelmer-laptop:~$ ifconfig ath0 down
ath0: ERROR while getting interface flags: Onjuist apparaat
jelmer@jelmer-laptop:~$ ifconfig wifi0 down
wifi0: ERROR while getting interface flags: Onjuist apparaat

en dit:
Assuming that you're inside the MadWifi directory, execute the following scripts to remove the current modules from your system and its memory:

cd scripts
./madwifi-unload.bash
./find-madwifi-modules.sh $(uname -r)
cd ..

is volgens mij wat ik beschreef...

Ik snap het niet helemaal... hij ziet hem niet  maar hij is er wel
jelmer@jelmer-laptop:~$ sudo lshw -C network
  *-network              
       description: Ethernet interface
       product: 88E8039 PCI-E Fast Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 14
       serial: 00:1a:80:17:98:3c
       size: 10MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.18 duplex=half firmware=N/A ip=192.168.1.2 latency=0 link=yes module=sky2 multicast=yes port=twisted pair speed=10MB/s
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR5006EG 802.11 b/g Wireless PCI Express Adapter
       vendor: Atheros Communications, Inc.
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0

perika

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #12 Gepost op: 2007/11/15, 21:27:31 »
@Lekoes
Mijn laptop heeft 'n pciid: 168c:001c en geeft aan AR5006EG.
Kijkend op de site van Ndiswrapper>List of cards Known to work, zie ik dat meerdere cards deze combinatie hebben:
Chipset: Atheros AR5007EG
pciid: 168c:001c
(Google maar eens met ar5006eg ar5007eg dan zie je dat het veel voorkomt
dat de 5006 eigenlijk de 5007 is)
Ik denk dat ik dus de AR5007EG heb en misschien jij ook wel.Dat gaat nog niet werken met Madwifi, kans is groot dat het wel lukt met ndiswrapper

Lekoes

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #13 Gepost op: 2007/11/16, 10:35:09 »
Ok ik zie em staan
#
Laptop: Acer Aspire 5570Z

    *
      Chipset: Atheros AR5007EG (rev 01)
    *
      PCI ID: 168c:001c
    *
      Driver: ftp://ftp.work.acer-euro.com/notebook/aspire_5100/driver/802ABG_Atheros_v5_1_1_9.zip
    *
      ndiswraper version : > 1.45
    *
      other : need to uninstall all madwifi kernel module before use ndiswrapper
    *
      other : if you can’t get any AP signal, try to enable wifi radio through wlan switch (it’s look like nothing happened when you try to enable through wifi, because the LED is not compatible with linux(i’m using ubuntu 7.04), but if you try ‘iwlist wlan0 scan’ you’ll see some AP information
    *
      other : 64-bit XP driver is available at http://www.giga-byte.com.tw/Support/Communication/Driver_Model.aspx?ClassValue=Communication&ProductID=2215&ProductName=GN-WI01GT


Hoe kom ik er nu achter wat mijn pciid is?
en hoe verwijder ik madwifi? gewoon via synaptic pakketbeheer?

perika

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #14 Gepost op: 2007/11/16, 18:12:01 »
Hier zie je hoe je aan je aan je pciid komt, onder 2.3

https://wiki.ubuntu.com/NlWifi/ndiswrapper

Natrix

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #15 Gepost op: 2007/11/19, 21:15:39 »
Ik heb een Acer 5610 met een Atheros AR5007EG , en heb het met behulp van de volgende link aan de praat gekregen

http://ivangarcia.org/blog/?p=13

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #16 Gepost op: 2007/11/20, 01:59:22 »
Citaat van: RobotFreak
net5211: driver installed
           device (168C:001C) present (alternate driver: ath_pci)
Ik heb niet de hele tread doorgelezen maar moet je niet gewoon de alternate driver uninstallen? dus "sudo rmmod ath_pci" en opnieuw opstarten?

Dan zou het moeten werken denk ik...

Ps. zorg er wel voor dat je een driver gebruikt die door nsdiswrapper wordt ondersteund!

EDIT:
Vond net de trouble guide, daar staat hetzelfde: http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,troubleshooting/

Yqwert

  • Gast
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #17 Gepost op: 2008/01/31, 07:09:22 »
Met Ndiswrapper lukt het bij mij ook niet. Ik heb Madwifi geinstalleerd met behulp van de uitleg op http://www.stchman.com/ath_drv.html , maar ik zie geen verschil; de latency is nog steeds 0. Doe ik iets verkeerd?

Offline Roland

  • Lid
    • http://www.black-wrangler.nl
  • Steunpunt: Nee
Atheros AR5006EG Wireless LAN werkt niet
« Reactie #18 Gepost op: 2008/02/01, 20:09:00 »
Ik heb sinds vandaag een Acer Aspire 3680 met dezelfde Wifikaart en het is mij gelukt met de link uit post #16.

Werkt SUPERRRRRR    ;-)

Gr Roland
Ubuntu user #12040 ;)