Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: LAN snelheid  (gelezen 963 keer)

phalkone

  • Gast
LAN snelheid
« Gepost op: 2007/11/07, 20:52:38 »
Ik heb volgende situatie op mijn thuisnetwerk: 2 ubuntu computers en 1 mac. 1 van deze ubuntu computers gebruik ik als webserver en recent als router. Ik heb onlangs ook een aantal harde schijven in deze computer geplaatst en zou deze nu graag als NAS gebruiken. De snelheid tussen deze servercomputer en de andere computers op mijn netwerk is echter enorm slecht. De computers zijn met elkaar verbonden via een 100 Mbps switch. De maximum snelheid die ik zeer uitzonderlijk haal is maar 8 Mbps; meestal haal ik maar 2-3 Mbps of loopt alles vast.
Ik heb zowel nfs als samba uitgeprobeerd en ook veel zitten knoeien met de instellingen: aantal instances veranderen, block size veranderen... Dit alles mocht echter niet baten (ik kan altijd verbinding maken, maar ofwel loopt alles vast, ofwel is de snelheid bedroevend). Vanavond heb ik samba op mijn andere ubuntu computer geïnstalleerd en hiermee haal ik wel normale snelheden. Ik heb ook eens geprobeerd de netwerkkabels tussen beide ubuntu computers te wisselen, maar dit gaf dezelfde resultaten.
Ik denk nu dat ik misschien een hardware probleem heb met mijn LAN NIC van mijn servercomputer. Toen ik nog 7.04 had, kreeg ik altijd de boodschap "e1000: eth0: e1000_request_irq: Unable to allocate MSI interrupt Error: -22". Met de installatie van 7.10 is deze boodschap verdwenen.

Nog wat verdere info:
xxx@xxx:~$ sudo lshw -C network
[sudo] password for xxxx:
  *-network              
       description: Ethernet interface
       product: 82566DM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 02
       serial: xxxxxxxxxx
       size: 100MB/s
       capacity: 1GB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.20-k2-NAPI duplex=full firmware=1.1-0 ip=192.168.0.1 latency=0 link=yes module=e1000 multicast=yes port=twisted pair speed=100MB/s
  *-network
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth1
       version: 10
       serial: xxxxxxxxx
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=yes maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s

xxxxx@xxxxx:~$ dmesg | grep e1000
[  138.058365] e1000: 0000:00:19.0: e1000_probe: (PCI Express:2.5Gb/s:Width x1) 00:19:d1:3d:27:ef
[  138.206053] e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
[  143.464534] e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[  143.464541] e1000: eth0: e1000_watchdog: 10/100 speed: disabling TSO

xxxx@xxxxx:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr xxxxxxxxx
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::219:d1ff:fe3d:27ef/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26254 errors:2679 dropped:0 overruns:0 frame:1458
          TX packets:37884 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:5032210 (4.7 MB)  TX bytes:50358122 (48.0 MB)
          Base address:0x30c0 Memory:50300000-50320000

eth1      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxx  
          inet6 addr: fe80::210:a7ff:fe14:6305/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:70806 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25408 errors:0 dropped:0 overruns:0 carrier:0
          collisions:15 txqueuelen:1000
          RX bytes:54932817 (52.3 MB)  TX bytes:4020279 (3.8 MB)
          Interrupt:21 Base address:0xc000
Hierbij gebruik ik eth0 voor mijn LAN en eth1 voor mijn WAN via PPPoE. Ik heb ook de indruk dat mijn WAN trager geworden is sinds ik mijn ubuntu computer als router gebruik. Vroeger haalde ik snelheden rond de 300 KBps en nu haal ik snelheden rond de 200 KBps. Dit gebeurt ook als ik via wget op de server computer iets download (het ligt dus niet aan de LAN snelheid). Ik weet echter niet hoe ik de snelheid van mijn ppp connectie kan zien.

Ik hoop echt dat iemand weet wat er fout kan zijn. Deze snelheden zijn gewoon niet meer doenbaar.

Hartelijk dank,

phalkone

  • Gast
LAN snelheid
« Reactie #1 Gepost op: 2007/11/09, 21:16:16 »
Heb uiteindelijk een nieuwe netwerkkaart gekocht en nu loopt alles perfect. Er was dus duidelijk iets fout met de hardware en niet met ubuntu.