Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Spindown na 10 seconden  (gelezen 2087 keer)

stijnos

  • Gast
Spindown na 10 seconden
« Gepost op: 2007/11/07, 18:50:36 »
Beste,


Ik draai nu 3 dagen Ubuntu en ben dus redelijk nieuw hier.
Het is me gelukt om met Ndiswrapper een Atheros5007EG aan de praat te krijgen zonder hulp of wat dan ook te vragen, daar houd ik tenslotte helemaal niet van.

Helaas loop ik hier echt tegen de lamp aan.
Mijn Acer Aspire 5613_WLMI(met 2gb ram) laat de harddisk down-spinnen na ongeveer 10 seconden. Ik heb al de config van hdparm aangepast en daar de spindown time op 254 gezet. Helaas werkt dit niet.
Verder heb ik geen (duidelijke) oplossingen kunnen vinden met google.

Weet iemand misschien hoe ik óf spindown helemaal uit zet, óf de tijd verander?

Tnx already,
Stijn

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Spindown na 10 seconden
« Reactie #1 Gepost op: 2007/11/07, 20:52:04 »
Kan je de regel van spindown niet commenten, dus een # er voorzetten? Misschien iets te simpel gedacht.
En staat er nog iets in je BIOS wat je in of uit kan schakelen?
Ik heb nl. geen laptop en mijn BIOS is ook niet een van de nieuwste, dus dat weet ik niet.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

stijnos

  • Gast
Spindown na 10 seconden
« Reactie #2 Gepost op: 2007/11/08, 18:44:21 »
Sorry voor de late reactie.

Hier is de regel uit hdparm.config

# -S standby (spindown) timeout for the drive
#spindown_time = 254

In de Bios is trouwens niks te vinden. Ik had dit probleem ook met Windows Vista en daar loste ik het op door wat "Performance"tooltjes van Acer te installeren. Jammer genoeg had ik nog wat meer problemen met Vista en ben ik over gestapt op XP/Ubuntu.
Op XP heb ik nergens last van.

Offline llevering

  • Lid
    • http://www.levering.eu
  • Steunpunt: Nee
Spindown na 10 seconden
« Reactie #3 Gepost op: 2007/11/08, 19:28:10 »
In jou geval lijkt het erop dat je het hekje juist moet weghalen voor de regel met 'spindown_time', dan zou het opgelost moeten zijn. Aangezien nu de opdracht juist uitgecomment staat.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Spindown na 10 seconden
« Reactie #4 Gepost op: 2007/11/08, 19:30:51 »
Helpt het ook niet om de # weg te halen het lijkt mij dat je de door jouw ingestelde tijd krijgt. interval =5sec dus met jouw instelling zou je dan een tijd van 254*5=1270 sec=21,16 minuten moeten krijgen.
echter man hdparm zegt hierover:
     -S     Set the standby (spindown) timeout for the drive.  This value is
              used  by  the  drive to determine how long to wait (with no disk
              activity) before turning off the spindle motor  to  save  power.
              Under  such circumstances, the drive may take as long as 30 sec�
              onds to respond to a subsequent disk access, though most  drives
              are much quicker.  The encoding of the timeout value is somewhat
              peculiar.  A value of zero means "timeouts  are  disabled":  the
              device will not automatically enter standby mode.  Values from 1
              to 240 specify multiples of 5 seconds, yielding timeouts from  5
              seconds to 20 minutes.  Values from 241 to 251 specify from 1 to
              11 units of 30 minutes, yielding timeouts from 30 minutes to 5.5
              hours.   A  value  of  252  signifies a timeout of 21 minutes. A
Dus als je hdparm de optie -S met de waarde zero geeft zou de spindown uitgeschakeld moeten zijn.
Ik zou zeggen probeer het uit. Dus hdparm -S 0 of het woord zero i.p.v de 0 moet je maar even kijken.

Met vriendelijke groet,

Gijs

Edit: De hoofdletter S gebruiken niet de kleine s die optie wordt afgeraden.
In der Beschränkung zeigt sich der Meister.

Offline jespdj

  • Lid
  • Steunpunt: Nee
Spindown na 10 seconden
« Reactie #5 Gepost op: 2007/11/08, 23:48:51 »
Citaat van: stijnos
Sorry voor de late reactie.

Hier is de regel uit hdparm.config
Let op dat alleen maar /etc/hdparm.conf aanpassen niet voldoende is. Je moet ook nog een commando uitvoeren om de settings actief te maken:

sudo update-rc.d hdparm defaults

Zie voor meer info over het harddisk spindown probleem deze bugmelding:
https://launchpad.net/bug59695.html
Dell XPS M1530 | Core 2 Duo T9300 (2,5 GHz) | 4 GB RAM | nVidia 8600M GT | Ubuntu 8.04

stijnos

  • Gast
Spindown na 10 seconden
« Reactie #6 Gepost op: 2007/11/09, 08:00:26 »
Citaat van: jespdj
Citaat van: stijnos
Sorry voor de late reactie.

Hier is de regel uit hdparm.config
Let op dat alleen maar /etc/hdparm.conf aanpassen niet voldoende is. Je moet ook nog een commando uitvoeren om de settings actief te maken:

sudo update-rc.d hdparm defaults

Zie voor meer info over het harddisk spindown probleem deze bugmelding:
https://launchpad.net/bug59695.html
Shit, ik wilde net zeggen dat het niet de oplossing was met hdparm, maar zodra ik thuis kom ga ik het even proberen!
Trouwens, ik heb Western Digital ook even gemaild met het probleem, misschien dat hun een tool hebben om APM uit te schakelen op mijn schijf.(Hiren's boot CD haalde ook niet veel uit)

stijnos

  • Gast
Spindown na 10 seconden
« Reactie #7 Gepost op: 2007/11/09, 17:13:42 »
YES!!!! opgelost!!!

Doormiddel van DEZE tutorial! / howto : http://ubuntudemon.wordpress.com/2007/10/26/laptop-hardrive-killer-bug/#comment-31234

Heel erg bedankt allemaal voor alle hulp!
Ik kan nu eindelijk met een goed gevoel met Ubuntu gaan spelen!